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User Interface

Welcome to SketchUp dialog box

The Welcome to SketchUp dialog box appears when you first run SketchUp. This dialog box is primarily used to choose a template for use in SketchUp (templates
have predefined settings, such as units of measurement), license a copy of SketchUp Pro, and learn more about SketchUp.

@ Licensing Status Field

The Licensing Status field displays current information about your license status. SketchUp can either be Licensed, Not Licensed (during an 8-hour evaluation of
SketchUp Pro), or Not Licensed - Expired (the 8-hour evaluation period is over).

Default Template Field

The Default Template field displays the name of the currently used template. You must choose a template to use SketchUp.
Add License Button

Click the 'Add License' button to add a license. The Add License dialog box appears.

Choose Template Button

Click the 'Choose Template' button to select a default template. Refer to Selecting a Template for more information.
Learn Tab

Click on the arrow next to the Learn tab to display several options for learning SketchUp.

License Tab

Click on the arrow next to the License tab to display the currently active licenses.

Template Tab

Click on the arrow next to the Template tab to display a list of available templates.

Always Show on Startup Checkbox

Check the 'Always Show on Startup' button to display the Welcome to SketchUp dialog box when you launch SketchUp. Uncheck the 'Always Show on Startup’
button to never show the Welcome to Sketchup dialog box when you launch SketchUp. Use the Welcome to SketchUp menu item on the Help menu to display the
Welcome to SketchUp dialog box.

Start Using SketchUp Button

Click the 'Start using SketchUp' button to close the Welcome to SketchUp dialog box and start using SketchUp.

Deleting 2D person component

SketchUp opens with a 2D person standing at the origin of the axes. To delete this 2D person component:

1. Click on the Select tool. The icon turns to an arrow.
2. Click on the 2D person component. The component is highlighted.
3. Press the Delete key on your keyboard. The 2D person component is deleted.

Creating models to scale

You can create models that are not based on any scale, useful for drafting quick concepts, or are based on some scale, useful for creating a final produced
product. Models that are not created based on some scale can be rescaled when accuracy becomes important.

e Use the Tape Measure tool to rescale an entire model to a specific scale. See Scaling an Entire Model for further information.
e Use the Measurements toolbar to provide specific dimensions as you draw. The values accepted by Measurements toolbar depend on the tool you are
using. See the Measurements toolbar for further information.

Sharing files between versions

You can save SketchUp 8 files as SketchUp 7, 6, 5, 4, or 3 files. To save a SketchUp file in a format compatible with earlier SketchUp versions:

. Open the file in SketchUp 8. The file appears in the drawing area.
Select File > Save As. The Save As dialog box appears.

. Navigate to the directory where you want to save your file.

. Select the file type from the 'Save as type' drop-down list.

. Click on the Save button. The file is saved.
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Toolbars (Windows) and Tool Palettes (OS X)
Detaching toolbars (PC)

These Toolbars can be detached by clicking and dragging the move handle (thin line at the top) of the Toolbar, resized by dragging the corners, and reattached
or docked to the edge of the drawing area to suit your preferences.

Customizing the toolbar (Mac)

You can modify the Toolbar by adding, removing, and repositioning controls within the Toolbar. To customize your Toolbar:

1. Select View > Customize Toolbar, or Context-click on the Toolbar and select Customize Toolbar from the context menu, to customize the controls that
are visible in the Toolbar. The Customize Toolbar dialog box appears.
2. Perform one of the following Toolbar customizations:
o Drag the controls from the Customize Toolbar dialog box, to the desired position in the Toolbar, to add a control to the Toolbar.
o Drag a control from the Toolbar and drop it anywhere outside of the Toolbar to delete a control. A smoke cloud will appear indicating that the
control has been removed.
o Drag a control left or right, within the Toolbar, to reposition the control.
3. Click the Done button in the Customize Toolbar dialog box when you have finished customizing your Toolbar.

Note: Remove all of the controls from your Toolbar and drag the default set of controls to your Toolbar to reset the Toolbar controls to its original state.

Using the layers toolbar (PC)

The Layers Toolbar provides quick access to several often used layer operations.

Display the current layer
When nothing is selected, the current layer name is displayed in the Toolbar and has a check mark next to it. Any new entities you draw will be assigned to the
current layer.

Change the current layer
Select a layer from the Layers Toolbar, when nothing is selected, to change the current layer.

View entity's layer
Select an entity. The layer for the entity will be displayed, with a check mark, in the Layers Toolbar.

Change the layer assignment of entities
Select an entity and then a layer from the Layer Toolbar to change the layer of an entity.

Display the Layers Manager
The button on the right hand side displays the Layers Manager allowing you to create new layers, control their visibility, and more.

Showing or hiding tool palettes (Mac OS X)

SketchUp displays the Getting Started tool palettes by default. To show or hide other tool palettes:

1. Select View > Tool Palettes. The Tool Palettes sub-menu displays.
2. Select any tool palette to show or hide. Tool palettes with a check mark are currently displayed. Tool palettes without a check mark are not currently
displayed.

Viewing tool palette help tips

Hover the mouse cursor over a tool to display the name of the tool. A longer help tip will appear in the Status Bar when you activate a tool.

Toolbars (Microsoft Windows)

The Toolbars appear below the menus and along the left side of the application contain a user-defined set of tools and controls. Toolbar visibility is toggled
under the View > Toolbars menu item.

Note: Only the Getting Started and Google Toolbars appear when you first run SketchUp. You can turn on other Toolbars using the Toolbars submenu in the View
menu.

Getting Started

The Getting Started Toolbar contains all of the tools and menu items necessary for a new user to become acquainted with SketchUp. These tools and menu items
are: Select tool, Line tool, Rectangle tool, Circle tool, Arc tool, Make Component, Eraser tool, Tape Measure tool, Paint Bucket tool, Push/Pull tool, Move tool,
Rotate tool, Offset tool, Orbit tool, Pan tool, Zoom tool, Zoom Extents tool, Get Current View button, Toggle Terrain button, Place Model button, Get Models
button, and Share Models button.
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Large Tool Set

The Large Tool Set contains the most-used tools and menu items for experienced users. These tools and menu items are: Select tool, Make Component, Paint
Bucket tool, Eraser tool, Rectangle tool, Line tool, Circle tool, Arc tool, Polygon tool, Freehand tool, Move tool, Push/Pull tool, Rotate tool, Follow Me tool, Scale
tool, Offset tool, Tape Measure tool, Dimension tool, Protractor tool, Text tool, Axes tool, 3D Text tool, Orbit tool, Pan tool, Zoom tool, Zoom Extents tool,
Previous, Next, Position Camera tool, Look Around tool, Walk tool, Section Plane tool.
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Camera Toolbar

The buttons on the Camera Toolbar activate the Orbit tool, Pan tool, Zoom tool, Zoom Window tool, Previous, Next, and Zoom Extents tool camera tools.
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Construction Toolbar

The buttons on the Construction Toolbar activate the Tape Measure tool, Dimensions tool, Protractor tool, Text tool, Axes tool, and 3D Text tool.
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@ Solid Tools Toolbar

The buttons on the Solid Tools Toolbar activate the Outer Shell tool, Intersect tool, Union tool, Subtract tool, Trim tool, and Split tool.
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Outer Shell Toolbar
The Outer Shell toolbar contains one button for the Outer Shell Tool. This toolbar only appears in the free version of SketchUp.
Drawing Toolbar

The buttons on the Drawing Toolbar activate the Rectangle tool, Line tool, Circle tool, Arc tool, Polygon tool, and Freehand tool.
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Styles Toolbar

The buttons on the Styles Toolbar activate SketchUp's face rendering styles (x-ray transparency, wireframe, hidden line, shaded, shaded with textures, and
monochrome).
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Google Toolbar

The buttons on the Google Toolbar are used to collaborate between SketchUp and other Google products. The Toolbar contains the Add New Building, Add
Location, Show Terrain, Photo Textures, Preview Model in Google Earth, Get Models, Share Model, and Upload Components buttons.
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Layers Toolbar

The Layers Toolbar provides quick access to several often used layer operations.
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Measurements Toolbar

The Measurements Toolbar contains a field where you can type values corresponding to the currently activated tool. For example, you can type in the specific
length of a line while you are in the Line tool. The Measurement Toolbar is used to create accurate geometry.

Measurements

Modification Toolbar

The Modification Toolbar contains geometry modification tools. The tools on this Toolbar are the Move tool, Push/Pull tool, Rotate tool, Follow Me tool, Scale
tool, and Offset tool.
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Principal Toolbar

The buttons on the Principal Toolbar activate the Select tool, Make Component, Paint Bucket tool, and Eraser tool.
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Sections Toolbar

The Sections Toolbar allows you to conveniently execute common section operations. The controls on this Toolbar include buttons for toggling the section cut
effect and toggling the display of section planes.

09

Shadows Toolbar
The Shadows Toolbar is used to control shadows. This Toolbar contains buttons to launch the Shadow Settings dialog box (left-most icon) and enable/disable

shadows (second icon). This Toolbar also contains slider bars to control settings related to the time of year (left—-most slider bar) and time of day (right-most
slider bar).

S S —
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Standard Toolbar

The Standard Toolbar contains a variety of menu items which help with file and drawing management and shortcuts to printing and help operations. These menu
items are New, Open, Save, Cut, Copy, Paste, Erase, Undo, Redo, Print, and Model Info.

DR dEEXONG O
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Walkthrough Toolbar

The buttons on the Walkthrough Toolbar activate the Position Camera tool, Walk tool, and Look Around tool.
e
Views Toolbar

The buttons on the Views Toolbar activate SketchUp's standard views (iso, top, front, right, back, and left). The bottom view is not included, but is available from
the Camera menu.

FEGEN ™

@Dynamic Components Toolbar

The buttons on the Dynamic Components toolbar activate the Interaction tool, Component Options dialog box, and Component Attributes dialog box.

QIR

Sandbox Toolbar

The buttons on the Sandbox Toolbar activate SketchUp's Sandbox tools (Sandbox From Contours, Sandbox From Scratch, Smoove tool, Stamp tool, Drape tool,
Add Detail tool, and Flip Edge tool).

G2 ¥eo KN

Large buttons

The Toolbar can be displayed using large and small tool buttons. Check the Use Large Tool buttons checkbox in the General panel of the Preferences dialog box
to switch between large and small tool buttons.

Google tool palette (Mac)

SketchUp contains a Google tool palette containing all of the options to interact with other Google applications. Display the Google tool palette by clicking on the
View > Tool Palettes > Google menu item.

The buttons on the Google Toolbar are used to collaborate between SketchUp and other Google products. The Toolbar contains the Get Current View, Toggle
Terrain, Place Model, Get Models, and Share Model buttons.

ORO ¢¥

Tool bar context menu (Mac)

The Toolbar context menu is activated by context-clicking on the Toolbar. This menu contains options for manipulating the appearance of your Toolbar.
Icon & Text

The Icon & Text option allow you to display both icons and names of controls in the Toolbar. The Toolbar shows both controls and their labels as a default.
Icon Only

The Icon Only option allows you to only display icons for controls in the Toolbar.

Text Only

The Text Only option allows you to only display the names of controls in the Toolbar.

Use Small Size

The Use Small Size option provides additional space in the Toolbar by shrinking the size of individual icons. This option does not change the size of textual
names or icon groups, such as the Display Style group of controls.

Remove Item

The Remove Item option removes the control that you have selected.

Keep Item Visible

The Keep Item Visible option keeps the toolbar item always visible when the window is resized.
Customize Toolbar...

The Customize Toolbar... menu item displays the Customize Toolbar dialog box containing all of the controls that can be placed in the Toolbar.

Toolbar control types (Mac)

SketchUp contains a variety of controls you can place into your Toolbar for easy access. The following section covers each of these controls.
Note: Many of the controls on the Customize Toolbar dialog box are tools listed in the Large Tool Pallet section of the documentation.
Standard Views

Al Tnll=l<Ia)

The Standard Views control gives you quick access to SketchUp's Standard Views (not including a bottom view).

Face Style

| ARSARSAR A5 SR
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The Face Style control allows you to quickly switch between SketchUp's Face Rendering Styles. You can also use the View menu or the Styles dialog box to switch
between these styles.

Undo/Redo

f]

Undo/Redo

The Undo command will undo the last drawing or editing command performed. The Redo Command cancels Undo operations, stepping forward in the
modification history.

Shadows (sliders)

L
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The Shadows sliders give you quick access to the most frequently used shadow settings. You can turn shadow casting on and off with the checkbox, and adjust
date and time with the sliders.

You can also use the Shadow Settings dialog box to access more detailed shadow settings.
Shadows (icon)
The Shadows icon control toggles shadows on and off.

Layers
LayerQ I

The Layers Toolbar provides quick access to several often used layer operations.
Display the Current Layer: The Layers Toolbar displays the current layer name. Any new entities you draw will be assigned to the current layer.

Add a Layer: Click in the text field of the drop-down list and type a new layer name to add a new layer to the model.

Slideshow [ | p|

The Slideshow control is used to start and stop slide shows.

Model Info @

The Model Info control is used to display the Model Info dialog box.

. . e
Section Display ‘\."

The Section Display control toggles the display of Section Planes.

Section Cuts @

The Section Cuts control toggles the display of the Section Cut Effect.

X-Ray Mode $

The X-Ray Mode control toggles the X-Ray display mode.

Component Maker @.

The Component Maker creates a Component entity from the selected geometry. You will be prompted to set a few characteristics for the Component entity upon
clicking this Toolbar control.

Separator

The Separator is used to add a vertical line to separate controls in your Toolbar.
Space

The Space is used to add a space between controls.

Flexible Space

The Flexible Space is used to add an adjustable space between controls. A Flexible Space automatically adjusts spacing between Toolbar controls depending on
the number and size of controls in the Toolbar.

The Print control activates the Print dialog box, enabling you to print the current view of your model.

Colors \)

The Colors control launches the Color Picker.

Fonts A

The Fonts control launches the Font dialog box.

Customize
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The Customize control invokes the Customize Toolbar dialog box.
Measurements

The Measurements control contains a field where you can type values corresponding to the currently activated tool. For example, you can type in the specific
length of a line while you are in the Line tool. The Measurement Toolbar is used to create accurate geometry.

Sandbox Tool Palette

The buttons on the Sandbox toolbar activate SketchUp's Sandbox tools (Sandbox From Contours, Sandbox From Scratch, Smoove tool, Stamp tool, Drape tool,
Add Detail tool, Flip Edge tool.

Large tool palette (Mac)

SketchUp contains a large tool palette containing all of the tools in the program. Display the large tool palette by clicking on the View > Tool Palettes > Large
Tool Set menu item. The tools in the large tool palette are split into seven categories: Principal Tools, Drawing Tools, Modification Tools, Guide Tools, Camera
Tools, and Walkthrough Tools.

Principal Tools
The buttons on the principal tools section of the tool palette activate the Select tool, Make Component, Paint Bucket tool, and Eraser tool.

r QB G

Drawing Tools
The buttons on the drawing tools section of the tool palette activate the Rectangle tool, Line tool, Circle tool, Arc tool, Polygon tool, and Freehand tool.

BZ@(C Vw®

Modification Tools
The modification tools section of the tool palette contains geometry modification tools. The tools on this Toolbar are the Move tool, Push/Pull tool, Rotate tool,
Follow Me tool, Scale tool, and Offset tool.

IIDE

Guide Tools
The buttons on the construction tools section of the tool palette activate the Tape Measure tool, Dimensions tool, Protractor tool, Text tool, Axes tool, and 3D
Text tool.

BXRTEXRAE

Camera Tools
The buttons on the camera tools section of the tool palette activate the Orbit tool, Pan tool, Zoom tool, Zoom Window tool, Previous, Next, and the Zoom Extents
tool.

YLZARRF A

Walkthrough Tools
The buttons on the walkthrough tools section of the tool palette activate the Position Camera tool, Walk tool, and Look Around tool.

Qe

Google tool palette

SketchUp contains a Google tool palette containing all of the options to interact with other Google applications. Display the Google tool palette by clicking on the
View > Tool Palettes > Google menu item.

The buttons on the Google toolbar are used to collaborate between SketchUp and other Google products. The toolbar contains the Get Current View, Toggle
Terrain, Place Model, Get Models, and Share Model buttons.

QPLQPLH
Showing and hiding toolbars (Microsoft Windows)

SketchUp displays the Getting Started toolbar by default. To show or hide other tool toolbars:

1. Select View > Toolbars. The toolbars sub-menu displays.
2. Select any toolbar to show or hide. Toolbars with a check mark are currently displayed. Toolbars without a check mark are not currently displayed.

16



Drawing Axes

Aligning the point of view to the current view

You can align SketchUp's point of view to be perfectly aligned with the current view. To align the point of view to the current view:

1. Context-click on the drawing axes. The drawing axes context menu is displayed.
2. Select Align View from the context menu.

Determining which way is up, down, east, west, north, and south

Each axis has a solid line on one side of the origin and a dotted line on the other side of the origin. Following is an explanation for each line that make up the
origin:

The solid blue line leads up from the origin.

The dotted blue line leads down from the origin.
The solid red line leads east from the origin.

The dotted red line leads west from the origin.
The solid green line leads north from the origin.
The dotted green line leads south from the origin.

A Real-World 3D understanding of the axis is important when you placing models in Google Earth or casting realistic shadows.
Hiding the drawing axes

You can display or hide the drawing axes from the View menu. You can also hide the drawing axes from the drawing axes Context menu (when the drawing axes
are visible).

Moving and rotating the drawing axes relative to current position

You can quickly and accurately move and rotate the drawing axes relative to their current position using the Move Sketching Context dialog box. To move and
rotate the drawing axes:

1. Context-click on the drawing axes. The drawing axes context menu is displayed.

2. Select Move from the context menu. The Move Sketching Context (Microsoft Windows) or Move Axes (Mac OS X) dialog box is displayed. The following
image shows the Move Sketching Context dialog box on Microsoft Windows:

Move Sketching Context ' X|

Move Rotate

¥ [red) |EI X [red) |U
Y (areen) IU Y [green) IIJ
Z (blue) |U Z (blue) |U

oK I Cancel I

The following image shows the Move Axes dialog box on Mac OS X:

(&) Move Axes

Move
X(red) O
Y (green) 0
Z (blue) [0 ]
Rotate
Xired) 0
Y (green) "0

Z (blue) [0

3. Specify displacement and rotation values in the units specified under the Units panel of the Model Info dialog box.
4. Click the OK button.

Drawing axes
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SketchUp's drawing axes consist of three colored lines (red, green, blue), perpendicular to each other, displayed in the drawing area. These axes are helpful in
providing a sense of direction in 3D space while you work.

The plane where the red and green axes lines lie is called the ground plane. The term origin, is used to define the place where all of axes lines start or originate.

Note: The Drawing Axes will be automatically hidden in any images exported from SketchUp.

The drawing axes context menu

All of the context menu items for the drawing axes context menu follow.

Place
Use the Place menu item to move the drawing axes.

Move
Select the Move menu item to move and rotate the drawing axes relative to their current position.

Reset
Select the Reset menu item to place the axes at the original origin. Reset menu item highlight only if the axes have been moved.

Align View
Select the Align View menu item to align SketchUp's point of view with the current view.

Hide
Select the Hide menu item to hide the drawing axes.



Drawing window

Measurements toolbar options

Following is a list of options that can be used in the Measurements toolbar.
Units

Use the following characters to indicate a specific unit of measurement when entering a value in the Measurements toolbar. If you do not indicate a unit of
measurement, your default units are used (as indicated by the template you are using in SketchUp).

e number + " (inches). Example: 10"

e number + ' (feet). Example: 10'

e number + mm (millimeters). Example: 10mm
.

L]

.

number + c¢cm (centimeters). Example: 10cm
number + m (meters). E64xample: 10m

Arrays
An array is an arrangement of geometry in a line (linear array) or around an point (radial array).

e number + x (external array). Type this number after making a manual copy of geometry to duplicate that copy an additional x-1 times. So, 3x creates 2
additional copies plus the original copy. The copies are made in the same direction as the first copy (either in a line or radially around a point). Example: 3x

e number + * (external array) Type this number after making a manual copy of geometry to duplicate that copy an additional x-1 times. So, 3* creates 2
additional copies plus the original copy. The copies are made in the same direction as the first copy (either in a line or radially around a point). Example: 3*

e / (internal array). Type this number after making a manual copy of geometry to duplicate copy an additional x-1 times (between the original and manual
copy). So, 3/ creates 2 additional copies between the original and manual copy. The copies are made moving backward from the first, manual, copy (either
in a line or radially around a point). Example: 3/

Measurements field commands with SketchUp tools
You can enter values in the Measurements toolbar when you use specific tools to specify precise values, such as a specific number of sides in a circle.
Arc tool

number (chord length). Enter this value right after setting the starting point of the arc. Example: 10

number (bulge). Enter this value right after setting the ending point of the arc. Example: 5.

number+ r (radius). Enter this value right after setting the ending point of the arc (in place of bulge). Example: 10r
number + s (segments). Enter this value right after setting the ending point of the arc. Example: 20s

e o o o

Refer to Creating Precise Arcs for further information.
Circle tool

e number + s (sides/segments). Enter this value right after setting the center point of the circle. Example: 10s
e number + r (radius). Enter this value right after setting the center point of the circle. Example: 5r

Refer to Creating Precise Circles for further information.

Field of View tool
number + deg (field of view). Enter this value right after selecting the Field of View tool. Example: 110deg

Refer to Changing Field of View and Focal Length for further information.
Line tool

e number (length). Enter this value right after setting the starting point of the line. Example: 4' 2 5/8"

e [number, number, number] (@absolute coordinate). Enter three numbers right after setting the starting point of the line to identify an ending point at an
absolute coordinate relative to the axis. For example: [3',4',7']

e <number, number, number> (relative coordinate). Enter three numbers right after setting the starting point of the line to identify an ending point at
relative coordinate to the start point. For example: <1.5m, 4m, 2.75m>

Note: The exact format for Measurements toolbar entries will vary depending on your computer's Regional Settings. For European users, the list separator symbol
may be a semi-colon instead of a comma, so the format would be [x;y;z].

Refer to Creating Precise Lines for further information.

Look Around tool
number (eye height). Enter this value right after selecting the Look Around tool to set your eye height as your tour through a model. For example: 6'

Move tool

e number (distance). Enter this value as you begin to move geometry in a specific direction. For example: 10’

e [number, number, number] (global coordinate). Enter three numbers right after selecting geometry to identify a global coordinate for the ending of the
move relative to the axis. For example: [3',4',7']

e <number, number, number> (relative coordinate). Enter three numbers right after selecting geometry identify a relative coordinate for the ending of the
move. For example: <1.5m, 4m, 2.75m>

Refer to Moving Precisely for further information.

Offset tool
number (length). Enter this value right after you click on the lines or face you want to offset. Example: 20’

Refer to offsetting precisely for further information.

Push/Pull tool
number (distance). Enter this value right after you select a face to push or pull. Example: 10

Refer to Offsetting Precisely for further information.
Polygon tool

e number + s (sides). Enter this value right after setting the center point of the polygon. Example: 10s
e number + r (radius). Enter this value right after setting the center point of the polygon. Example: 5r



Refer to Creating Precise Polygons for further information.
Protractor tool

e number (degrees). Enter this value right after setting the start of the angle to set the angle of a guide line. Example: 15
e number:number (slope). Enter these values (rise:run) right after setting the start of the angle to set the slope of the guide line. Example: 14:7

Refer to Creating Precise Angles for further information.
Rotate tool

e number (angle). Enter this value right after setting the start of the rotation. Example: 15
e number:number (slope). Enter these values (rise:run) right after setting the start of the rotation. Example: 14:7

Refer to Rotating Precisely for further information.
Scale tool

e number (scale multiplier). Enter this value right after you begin to scale geometry. Example: 10
e number + units (length). Enter this value right after you begin to scale geometry. Example: 10’

Refer to Scaling Precisely for further information.
Tape Measure tool

e number (distance for guide line or guide point). Enter this value as you start to create a guide line or guide point. Example: 10"
e number (resize model). Enter this value right after you measure the length of a line segment to resize the entire model. Example: 20'

Refer to Placing Precise Guide Lines and Guide Points for further information.
Refer to Scaling an Entire Model for further information.
Rectangle tool

e number, number (length and width). Enter these values after setting the starting point of the rectangle. Example: 10',5
e number (length value only; use existing width value). Enter this value after setting the starting point of the rectangle. Example: 10'
e , number (width value only; use existing length value). Enter this value after setting the starting point of the rectangle. Example: , 5'

Refer to Creating Precise Rectangles for further information.
Zoom tool

e number + mm (focal length). Enter this number right after selecting the Zoom tool. Example: 300mm
e number + deg (field of view). Enter this value right after selecting the Zoom tool. Example: 110deg

Refer to Changing Field of View and Focal Length for further information.

Refer to Changing Focal Length with the Zoom Tool for further information.

Menus

Menus appear below the title bar. The majority of SketchUp tools, commands, and settings are available within these menus. The menus that appear by default
are: SketchUp (Mac OS X-only), File, Edit, View, Camera, Draw, Tools, Window, and Help.

Application window

The SketchUp user interface is designed to be simple and easy to use. The main parts of the SketchUp user interface are the title bar, menus, toolbars and tool
palettes, drawing area, status bar, and the Measurements Toolbar.

Mac OS X
Following is an image of the SketchUp user interface on Mac OS X:

@ SketchUp File Edit View Camera Draw Tools Window Help
eno Untitled - SketchUp Pro =)

Ml Z700C 2¢gPB LXOEF $ ZAR BLusd 8§F 9

O @ ©)|(@ select objects. shift to extend select. Drag mouse to select multiple. Measurements

Microsoft Windows
Following is an image of the SketchUp user interface on Microsoft Windows:
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Note: The previous images contain screenshots of the SketchUp Pro application. The SketchUp (free) application looks the same.

Drawing window area

The drawing area is where you create your model. The 3D space of the drawing area is identified visually by the drawing axes.

Status bar

The status bar is the long gray rectangular area at the bottom of the drawing area.
Microsoft Windows

Following is an image of the status bar on Microsoft Windows:

O @ @ @ Select objects. Shift to extend select. Drag mouse to select multiple. Measurements

Geolocation button
Hover over the Geolocation button to display location information for the current model.

Click the Geolocation button to display the Location panel of the Model Info dialog box. The Georeferencing portion of the Location panel allows you to manually
establish the geographic location for the current model. A model can have three states, as indicated by the icon next to the Use georeferencing checkbox: Not
georeferenced (faded exclamation point), Manually georeferenced using location in SketchUp (bright exclamation point), and georeferenced with data from
Google Earth (Google Earth logo with exclamation point).

Note: Altering the fields in the Location panel of the Model Info dialog box while using georeferenced data from Google Earth yields a warning that Google Earth
terrain and layers will be erased.

Attribution button
Click the Attribution button to display the Credits panel of the Model Info dialog box. The Credits panel allows you to view contributors toward the current model.
This panel also allows the current users to claim credit toward the current model.

Google Login button
Click the Google Login button to log in to your Google account.

Instructor button
Click on the Instructor button to display the Instructor dialog box.

Measurements Toolbar
The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently
selected entities, such as creating elements of a specific dimension.

Mac OS X

Following is an image of the status bar on Mac OS X:
O @ @ @ Select objects. Shift to extend select. Drag mouse to select multiple.

Geolocation button
Hover over the Geolocation button to display location information for the current model.

Click the Geolocation button to display the Location panel of the Model Info dialog box. The Georeferencing portion of the Location panel allows you to manually
establish the geographic location for the current model. A model can have three states, as indicated by the icon next to the Use georeferencing checkbox: Not
georeferenced, Manually georeferenced (using location in SketchUp), and georeferenced with data from Google Earth.

Attribution button
Click the Attribution button to display the Credits panel of the Model Info dialog box. The Credits panel allows you to view contributors toward the current model.
This panel also allows the current users to claim credit toward the current model.

Google Login button
Click the Google Login button to log in to your Google account.

Instructor button
Click on the Instructor button to display the Instructor dialog box.

Measurements Toolbar
The Measurements Toolbar displays dimensional information while you draw. You can also enter values into the Measurements Toolbar to manipulate currently
selected entities, such as creating elements of a specific dimension.

Note: Use the resize handle to make the drawing area larger so you can see the entire message in the status bar.
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Toolbars and Tool Palettes (Mac OS X)

The toolbar, appearing below the menus, contains a set of user-defined controls. By default, the toolbar contains the basic set of SketchUp tools, referred to as
the 'getting started' tools.

Additional tool palettes are found in the View > Tool Palettes submenu.

Scene tabs

Scene tabs are created when a scene is created using the Scene Manager. Click on a scene tab to switch between the scenes in your file.

Note: Scene tabs are not part of the default application user interface. Scene tabs are only displayed when you create a scenes using the Scene Manager. Refer to
Adding a scene for further information.

Microsoft Windows

Following is an image of the scene tabs on Microsoft Windows:
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Mac OS X

Following is an image of the scene tabs on Mac OS X:
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Scene tab context menu items

Scene Tabs contain their own context menus. Context-click on a scene tab to access its context menu.

Move Left/Move Right
The Move Left and Move Right menu items are used to reposition a scene in the series of scenes.

Add
The Add menu item is used to add a new scene to the current file.

Update
The Update menu item is used to update a scene if you have made changes to the scene.

Delete
The Delete menu item is used to delete the currently selected scene.

Play Animation (Microsoft Windows-Only)
The Play Animation menu item starts an animation.

Scene Manager
The Scene Manager menu item invokes the Scene Manager dialog box.

Toolbars (Microsoft Windows)

The toolbars, appearing below the menus and along the left side of the application contain a user-defined set of tools and controls. By default, SketchUp displays
one toolbar, referred to as the 'getting started toolbar' below the menus. Additional toolbars are found in the View > Toolbars submenu.

Title bar

Mac OS X

The title bar (at the top of SketchUp) contains the standard Macintosh OS X window controls (close, minimize, and maximize) on the left, and a title bar
collapse/expand button on the right. In the middle of the title bar is the name of the currently opened file. A blank drawing area appears when you start
SketchUp and the name of the currently opened file is 'Untitled' in the title bar, indicating that you have not yet saved your work.

Microsoft Windows

The title bar (at the top of SketchUp) contains the standard Microsoft Windows controls (close, minimize, and maximize) on the right, and the name of the

currently opened file. A blank drawing area appears when you start SketchUp and the name of the currently opened file is 'Untitled’ in the title bar, indicating that
you have not yet saved your work.

Measurements toolbar

By default, the Measurements toolbar is located on the right side of the status bar. The Measurements toolbar displays dimensional information while you draw.
You can also enter values into the Measurements toolbar to manipulate currently selected entities, such as creating elements of a specific dimension. Other
behaviors of the Measurements Toolbar are as follows:

e You can type a value in the Measurements toolbar before or after an operation is complete as long as the value is entered prior to the start of a new
operation. Detailed information on the Measurements toolbar values accepted for each tool appears in the Drawing Tools and Modification Tools sections
of this user's guide.

e You must press the Enter (Microsoft Windows) or Return (Mac OS X) key to accept a typed value.

e You can change the value of the geometry as many times as you like before you start a new operation.

e The Measurements toolbar cannot be used again to enter values for a tool once you have exited the tool.

e SketchUp will display a tilde (~) before the number to indicate that a number is not precise (not within precision settings as set in the Units panel of the
Model Info dialog box).
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e It is not necessary to click in the Measurements toolbar before typing. The Measurements toolbar is always awaiting input from your keyboard.

e You can type values in the Measurements toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the
default system. For example, you can type in 3' 6" even if you are using metric system as your default. Units are set within the Units panel of the Model Info

dialog box.

e You must use the appropriate list separator for your region in the Measurements Toolbar. The separator you use depends on your regional settings:
English and Spanish language regions (US, United Kingdom, South America, Central America) use a comma and European countries use a semicolon.
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Inference

Encouraging an inference

At times, the inference you need may not come up immediately or SketchUp might choose alignments with the wrong geometry. In these cases, you can increase the
chances of a particular alignment by pausing your mouse cursor over the particular location that you want SketchUp to infer from. When the visual cue appears, SketchUp
will briefly prioritize that alignment as you continue drawing.

To encourage SketchUp to create a parallel line to match the length of another, parallel, line (such as when drawing the third line of a rectangle):

1. Create the first two edges of a rectangle with the first edge being parallel to the red axes.
2. Click on the start point of the third edge and move the line tool as though you were creating the third line parallel to first line. As you begin to move the Line tool, the

line should appear in red.

3. Mid-line creation, move the Line tool over the start point of the first line you created for the rectangle. Your line will extend diagonally to this point.
4. Leave the tool over this point until the Endpoint visual cue displays.

5. Move the Line tool to the approximate location where the end of the third line should appear. A dotted line, with the color of the corresponding axes (green) will
follow the Line tool to indicate you are directly inline with the start point of the first line.

6. Click when the line you are drawing is indicated by an axes color (red) and is directly perpendicular to the green dotted line.

Z
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Note: Hover over any line to create a line parallel to that line. Refer to Inference Types for further information.

Locking an inference

Locking an inference

At times, geometry might interfere with your ability to infer points from other points, making it difficult to draw accurately. Use an inference lock, which tells
SketchUp not to waver from the direction it is currently inferring from, to solve this problem. To use the inference lock, press hold the Shift key when SketchUp
infers the desired alignment (the inference line will bold). The alignment will remain locked, even as you move the mouse and/or pick a secondary inference
point. The following image shows the inference locked in the blue direction to ensure that a new line is exactly perpendicular to the face.

On Blue Axis

Any of the inference conditions may be locked; along an axis direction, along an edge direction, on a face, from a point, parallel or perpendicular to an edge, and
so on.

Forcing an Inference Direction
You can force SketchUp to infer parallel to a specific axis by pressing one of the following keys while using the Line tool, Move tool, or Tape Measure tool:

e Right arrow key = red axis
e Left arrow key = green axis
e Up or down arrow keys = blue axis

Inference
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Inference types
There are three main types of inferences: point, linear, and planar. SketchUp often combines inferences together to form a complex inference.
Point inference

A point inference is based on the exact point of your cursor in your model. Following is a list of point inference types:
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Endpoint: The Endpoint inference indicates the end of a Line or Arc entity. The Endpoint inference is represented by a green circle. Following is an image of an
Endpoint inference.

Midpoint:The Midpoint inference indicates the middle point on a line or edge. The Midpoint inference is represented by a cyan circle. Following is an image of a
Midpoint inference.

Intersection: The Intersection inference indicates an exact point where a line intersects another line or face. The Intersection inference is represented by a red x.
Following is an image of an Intersection inference.

On Face: The On Face inference indicates a point which lies on a Face entity. The On Face inference is represented by a blue diamond.

On Edge:The On Edge inference indicates a point that lies along an edge. The On Edge inference is represented by a red square. Following is an image of an On
Edge inference.

Linear Inference

A linear inference snaps along a line or direction in space. In addition to a tooltip, a linear inference sometimes displays a temporary dotted line while you draw.
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On Red Axis: The On Red Axis inference indicates a linear alignment to the red drawing axis. The On Red Axis inference is represented by a red line.

On Green Axis: The On Green Axis inference indicates a linear alignment to green drawing axis. The On Green Axis inference is represented by a green line.
On Blue Axis: The On Blue Axis inference indicates a linear alignment to the blue drawing axis. The On Blue Axis inference is represented by a blue line.

From Point: The From Point inference indicates a linear alignment from a point along the drawing axes directions. The From Point inference is represented by a
dotted line whose color corresponds to the axis direction (red, green, or blue).

Perpendicular: The Perpendicular inference indicates perpendicular alignment to an edge. The Perpendicular inference is represented by a magenta line.
Parallel: The Parallel inference indicates a parallel alignment to an edge. The Parallel inference is represented by a magenta line.

Tangent at Vertex: The Tangent at Vertex inference indicates an arc whose vertex is tangent to a previously drawn arc's vertex. The Tangent at Vertex inference
is represented by a cyan arc

Shape Inferences

SketchUp indicates half circles, squares, and golden sections, using unique inference indicators. These indicators follow.

Golden Section

Half Circle: The Half Circle inference indicates an arc that is exactly one half of a circle.

Square: The Square inference indicates a rectangle whose sides are all the same size.

Golden Section: The Golden Section inference indicates a rectangle whose properties match the Golden Ratio as found in mathematics and the arts.
Drawing Plane Inference

SketchUp will snap to the planes defined by the Drawing Axes or your view when it cannot snap to geometry in the drawing area. For example, SketchUp will draw
on the ground plane when the point of view is that of the ground plane.

Component and Group Inferences

All inferences apply on geometry inside Component entities or Group entities. Group and Component inference indicators are the same shape, but are magenta
color. Group and component tooltips also indicate that the inference is in a Group or Component entity by appending the phrase 'in group' or 'in component' to
the end of an inference tooltip.

Inference
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Inference introduction
SketchUp features a geometric analysis engine, called the inference engine, allowing you to work in 3D space using a 2D screen and input device. This engine

helps you draw very accurately by inferring points from other points as you draw while also providing you with visual cues.

Inference cues

The inference engine uses visual cues, appearing automatically while working on the model, to identify significant points or geometric conditions. These cues
make complex inference combinations clear to you as you draw.

Additionally, the inference engine uses specific colors to indicate its type of inference (covered further in Inference Types).
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Dialog boxes
Manipulating dialog boxes in a dialog box stack in LayOut (Mac OS X)

A dialog box stack refers to a series of dialog boxes snapped together at their bottom and top edges such that they form a stack. The following image contains a
dialog box stack with Layers dialog box opened in the middle.
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You can manipulate the dialog boxes in a dialog box stack in the following ways:

Move the entire dialog box stack by clicking and dragging the top-most dialog box's title bar.

Click on any dialog box's title bar to minimize or maximize a dialog box within the stack.

Move a dialog box to the right, left, or down to break it from the stack.

Reinsert the dialog box at the end of the stack by snapping the dialog box to the bottom edge of the stack.
Reinsert the dialog box in the middle of the stack by moving sideways into a middle position.

Snap the entire dialog box stack to the screen by moving it to the outer edge of the screen.

e o o o o o

Minimizing dialog boxes
Click on any dialog box's title bar to minimize or maximize the dialog box (even those that can not be placed in a dialog box stack).

Resizing dialog boxes

Some SketchUp dialog boxes, such as the Components Browser dialog box, can be resized. Move the cursor around the dialog box's edges to display a resize
cursor (two arrows). Click on the edge and move the edge to resize the dialog box.

Snapping dialog boxes to other user interface components

Some dialog boxes, such as the Styles Browser dialog box, automatically snap to the outside edges of the application window, the outer edge of the screen, with
the top and bottom of other dialog boxes to create a dialog stack. To snap a dialog box to another user interface component:

1. Display a dialog box, such as the Window > Styles dialog box.

2. Click and hold on the dialog box's title bar.

3. Move the dialog box to the outside edge of the application window, outside edge of the screen, or top or bottom edge of another dialog box (such as the
Shadow Settings dialog box). The dialog box will snap to and align with the edge.

Note: Dialog boxes that have been snapped to the application window do not move when the application window is moved (they are not stuck to the window).

Tip: Snap several dialog boxes together at their top and bottom edges to form a dialog box stack. Dialog boxes in a dialog box stack move with the stack when
the top-most dialog box's title bar is moved.

Dialog boxes
Most dialog boxes in SketchUp are modeless, meaning they do not limit your interaction with the rest of the application by requiring user input before continuing

with your work. Instead, these dialog boxes can be displayed while you work allowing you to make dynamic settings changes to your model while you are
sketching. Dialog boxes in SketchUp can be snapped to other user interface components on your screen, resized, and minimized (with some exceptions).
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Menus
Edit menu (Mac OS X)

The Edit menu contains items allowing you to perform editing functions on SketchUp geometry. These menu items include those for creating and editing groups
and components, visibility operations, and standard cut, copy, paste commands.

Undo

Use the Undo menu item to undo the last drawing or editing commands performed. SketchUp allows you to undo all operations you have performed, one at a
time, to the state at which you saved your file. The number of possible sequential Undo commands is limited to 100 steps.

Keyboard Shortcut: Command+2Z

Note: Undo will undo any operation that creates or modifies geometry, but it does not undo changes to your point of view. Use the Previous menu item under the
Camera menu to undo a point of view change.

Redo

The Redo menu item returns the last undo to its previous state.
Keyboard Shortcut: Shift+ Command+Z

Cut

The Cut menu item removes the selected elements from your model and places them in the clipboard. The contents of the clipboard can then be inserted back
into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy command.

Keyboard Shortcut: Command+X
Copy

The Copy menu item copies the selected items to the clipboard without deleting the items from the model. The contents of the clipboard can then be inserted
back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Command+C
Paste

Use the Paste menu item to paste the contents of the clipboard into the current SketchUp document. The pasted geometry will be attached to and placed by the
point of the cursor, allowing you to position the new geometry when it is pasted.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Command+V

Paste in Place

Use the Paste in Place menu item to paste an item at the same location where it was cut or copied.
Delete

Use the Delete menu item to remove the currently selected entities from your model.

Delete Guides

Use the Delete Guides menu item to delete all of the guides that are in the drawing area.

Select All

Use the Select All menu item to select all selectable entities in the model. Hidden entities, any items on a hidden layer, or geometry that is clipped away using a
section plane cannot be selected with the Select All menu item.

Keyboard Shortcut: Command+A

Select None

The Select None menu item clears the selection set, deselecting any currently selected items in the model.

Keyboard Shortcut: Shift+Command+A

Hide

Use the Hide menu item to hide any selected object. Hiding geometry can help simplify your current view, or enable viewing and working inside tight areas.
Keyboard Shortcut: Command+E

Unhide

The Unhide submenu contains options for unhiding hidden entities.

Selected
The Selected menu item unhides any selected hidden object. Ensure Show Hidden Geometry is enabled under the View menu to view and select hidden geometry.

Last
The Last menu item unhides the last entities hidden with the Hide command.

All
The All menu item unhides all hidden entities in your current document.
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Keyboard Shortcut: Shift+ Command+E

Lock

The Lock menu item is used to lock any component or group that you do not want to be able to be moved or edited.
Unlock

The Unlock submenu contains options for unlocking components and groups.

Selected
Use the Selected menu item to unlock all components and groups in a selection set.

All
Use the All menu item to unlock all components and groups in your drawing area.

Make Component

Use the Make Component menu item to create a component entity from the selected entities.
Keyboard Shortcut: Shift+ Command+G

Make Group

The Make Group menu item creates a Group entity from the selected entities.

Keyboard Shortcut: Command+G

Close Group/Component

Use the Close Group/Component menu item to exit from a group or component's context or editing session.
Keyboard Shortcut: Control-Shift+Command+G

Intersect Faces

The Intersect Faces sub-menu contains menu items for intersecting geometry with other geometry.

With Model
Complex geometry in SketchUp can be easily created using the With Model menu item (also called the 'Intersector’). Use the With Model menu item to intersect all
entities overlapping with the currently selected entity (such as a box component and a tube component).

With Selected
Select the With Selection to intersect only those items that are selected.

With Context
Select the With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

Entity Commands Sub-Menu

The Entity Commands sub-menu contains all of the commands available to manipulate the currently selected entity (which are the same as the commands found
in the entity's context menu). The sub-menu's name and contents will change depending on the entity that you have selected.

Special Characters (Mac OS X)

The Special Characters menu item opens the Mac OS X Character Palette allowing you to insert special characters, such as mathematical symbols, letters with
accent marks, arrows, and other 'dingbats," into your model. The Mac OS X help system contains additional help on this feature.

Window menu (Mac OS X)

The Window menu contains model settings and managers for your models. Model settings are dialog boxes with settings that affect the model, such as shadows,
display settings, and model information. Managers are dialog boxes that manage certain aspects of your model such as scenes, layers, materials, and
components.

Minimize

The Minimize menu item minimizes the current document window and places it in the dock. Click on the minimized view in the doc to re-activate a minimized
window.
Keyboard Shortcut: Command+M

Zoom

The Zoom menu item toggles between shrinking and expanding the main document window. This item works similarly to clicking the plus icon at the top of the
document window.

Model Info

Use the Model Info menu item to display the Model Info dialog box used to set settings for your entire model.
Keyboard Shortcut: Shift+ Command+1

Entity Info

The Entity Info menu item displays the Entity Info dialog box used to view and set settings for the currently selected entity (or entities).
Keyboard Shortcut: Command+I

Materials

The Materials menu item invokes the Color Picker used for selecting and applying colors and materials to your models.
Keyboard Shortcut: Shift+Command+C

Components
The Components menu item displays the Component Browser used for managing your components.
Styles

The Styles menu item invokes the Styles dialog box containing options related to styles, such as edge and face rendering styles.
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Layers

Use the Layers menu item to display the Layers Manager used to manage your SketchUp layers.

Outliner

The Outliner menu item invokes the Component Outliner used to display components and groups in a hierarchy.

Scenes

The Scenes menu item invokes the Scene Manager used to manage scenes for an animation. The Scene Manger will display with the current scene highlighted.
Show Fonts

The Show Fonts sub-menu includes options for toggling the display of the Fonts Panel allowing you to choose a font face and type. The Font Panel also allows
you to select bold and italic versions of your fonts.
Keyboard Shortcut: Command+T

Shadows

The Shadows menu item invokes Shadow Settings dialog box for manipulating shadows in your model.
Fog

The Fog menu item invokes the Fog dialog box used to add a fog effect to your model.

Match Photo

The Match Photo menu item invokes the Match Photo dialog box used to help you create accurate 3D models from photos and to accurately place models in a
photo's context.

Soften Edges

The Soften Edges menu item invokes the Soften Edges dialog box used to soften and smooth edges in your model.
Instructor

The Instructor menu item invokes the Instructor used to display information about the currently activated tool.
Hide/Show Dialogs

Use the Hide/Show Dialogs menu item to hide and show all currently active dialog boxes.

Ruby Console

The Ruby Console menu item displays the Ruby Console where you can type Ruby script.

Component Options

The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

G:!DComponent Attributes

The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component.

Photo Textures

Photo Textures menu item is displays the Photo Textures dialog box used to capture a texture from Street View and apply it to the currently selected face.
Bring All To Front

Use the Bring All To Front menu item to bring all of your open SketchUp windows to the foreground of Mac OS X. All open document windows and active panels
and palettes are brought to front.

Arrange in Front

Use the Arrange in Front menu item to bring all of your open SketchUp windows to the foreground of Mac OS X and arrange them from the center outward toward
the edge of the screen.

(Open Documents)

The (Open Documents) menu items represent a dynamically generated list of all your open SketchUp files . Select the file you want to activate from this menu to
switch between files.

Help menu (Windows)

The Help menu contains items relating to receiving help with the product. These items include the SketchUp on-line user's guide, a quick reference card, and
video tutorials.

Welcome to SketchUp
The Welcome to SketchUp menu item launches the Welcome to SketchUp dialog box.
Help Center

The Online Help Center menu item launches the SketchUp Help Center in your default web browser. This web site contains a list of Frequently Asked Questions
(FAQs) and a knowledge base of technical support issues and solutions.

Contact Us

Select the Contact Us menu for contact options.
GmLicense

The License submenu includes several options allowing you to view and manage your SketchUp license.

License Info
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The License Info menu item displays information about your SketchUp license, including the type of license and serial number.

Authorize
Use the Authorize menu item to authorize your SketchUp license to extend the use of SketchUp beyond the 8 hour trial period. Click on this menu item to display
the SketchUp Authorization Screen. Type in the authorization number, provided when you buy SketchUp, to authorize SketchUp.

Unauthorize
Use the UnAuthorize menu item to unauthorize your SketchUp license. This menu item is used primarily when switching from a single-user license to a multiuser
network license.

Warning: SketchUp will not run after you unauthorize your license. You must authorize a new single-user or network license to use SketchUp again.

Set Network License File
Use the Set Network License File menu item to relocate the network license file on the network.

Unset Network License File
Use the Unset Network License File menu item to delete the location of the network license file on the network.

Lan License Monitor
The Lan License Monitor menu item displays the LAN License Monitor dialog box. This dialog box displays single user licenses on the network.

Check for Update...

The Check For Update menu item checks to see if you have the most current version of SketchUp. You will be prompted to download the current version if your
version is out-of-date. An Internet connection is required to use this feature.

About SketchUp...

The About SketchUp menu item activates the About SketchUp dialog box. This dialog box provides information about your SketchUp version and license.

SketchUp menu (Mac OS X)

The SketchUp menu contains menu items that control the SketchUp application, including items to show and hide SketchUp, application preferences, and the
SketchUp license manager.

About SketchUp

The About SketchUp menu item activates the About SketchUp dialog box, containing the SketchUp version number, contact information, and a link to the
SketchUp web site.

About Plugins
The About Plugins submenu contains information about each SketchUp plugin, such as the 3DS exporter.
Preferences

The Preferences menu item opens SketchUp's application preferences for setting various global settings for the program.
@License

The License menu item displays SketchUp's licensing dialog box used to enter a new license, determine which licenses are currently in use, and view a list of all
available licenses. Directions for entering a new license should accompany any new license.

Check for Update

The Check for Update menu item checks to see if you have the most current version of SketchUp. You will be prompted to download the current version if your
version is out-of-date. An Internet connection is required to use this feature.

Services

The Services menu item provides access to Mac OS X's system-wide services, which might vary on different computers depending on additional functionality of
your other applications.

Hide SketchUp

The Hide SketchUp menu item hides SketchUp and all of its open drawing windows, allowing you access to other programs running in Mac OS X. Clicking on the
SketchUp icon in your Dock returns SketchUp to view.
Mac OS X Keyboard Shortcut: Command+H

Hide Others

The Hide Others menu item hides all visible applications except SketchUp allowing you to focus on SketchUp alone. Clicking on any icon in the doc will return
that application to view.

Show All
The Show All menu item unhides all running programs in Mac OS X.
Quit SketchUp

The Quit SketchUp menu item quits SketchUp and closes all open documents. You will be prompted to save any unsaved work before SketchUp exits.
Mac OS X Keyboard Shortcut: Command+Q

@ _ Functionality only available in SketchUp Pro

File menu (Windows)

The File menu contains items that relate to SketchUp model files, including commands to create, open, save, print, import, and export model files.
New

The New menu item is used to close the current document and create a blank drawing area to begin a new SketchUp model. You will be prompted to save your
changes if you have not saved changes to the current model before selecting the New menu item. Sketchup will use the settings in the template file to define the
initial model state if you have selected a template file in the template panel under Window > Preferences.

Keyboard Shortcut: Ctrl+N
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Open*

Use the Open menu item to launch the Open dialog box, allowing you to open a previously saved SketchUp file. You will be prompted to save your changes if an
unsaved model is already open because only one file can be open at a time.
Keyboard Shortcut: Ctrl+0

Save*

Use the Save menu item to save the currently active SketchUp model to your file system. When you close an unsaved document, or attempt to quit SketchUp with
unsaved open documents, SketchUp will prompt you to save your work before continuing.
Keyboard Shortcut: Ctrl+S

Tip: If Create Backup is enabled within the General panel of the preferences dialog box, the existing file will be converted to a backup file (.skb), and the new
drawing will be saved in place of that currently existing file (.skp). The Create Backup option can help preserve your data in the event of an accidental removal of
a .skp file. Backup files are saved in the My Documents (Microsoft Windows) or Library/Application Support/Google Sketchup 6/SketchUp/Autosave (Mac OS X)
folder, by default.

Tip: It is good to save often. You can have SketchUp automatically save for you at a specific time increment by enabling the Auto-save option within the General
panel of the Preferences dialog box.

Save As*

Use the Save As menu item to open the Save As dialog box which defaults to the current document's folder. You can use this dialog box to save the current
drawing as a new document. This file can be assigned a new name, a new location, and a previous version of SketchUp. The new file will become the current file
in the drawing window.

Save A Copy As*

Use the Save A Copy As menu item to save a new file based on your current model. This menu item does not overwrite or close the current file and is useful for
saving incremental copies or tentative schemes of your work.

Save As Template

Use the Save As Template menu item to save the current SketchUp file as a template. This menu item launches a dialog box where you can name the template
and set the template as the default template (to be loaded every time you launch SketchUp).

Revert

Use the Revert menu item to revert your current document to its last saved state.

GESend to LayOut

Use the Send to LayOut menu item to send the current model to LayOut.

Preview in Google Earth

Use the Preview in Google Earth menu item to quickly view your model in Google Earth while working on the model.
Geo-location

The Geo-location submenu contains menu items for Geo-locating your models.

Add Location...
Use the Add Location menu item to display the Add Location dialog box for selecting a location for your model. This menu item is only available when a location
has not been added.

Clear Location
Use the Clear Location menu item to remove the location from your model.

Show Terrain
Use the Show Terrain menu item to toggle the Google Earth snapshot image between a 2D and 3D image.

Building Maker
The Building Maker submenu contains menu items for working with Building Maker.

Add New Building
Use the Add New Building menu item to launch Building Maker from SketchUp. Refer to the Building Maker Getting Started Guide for further information on using
Building Maker.

3D Warehouse
The 3D Warehouse submenu contains menu items for accessing the 3D Warehouse repository of models.

Get Models
Use the Get Models menu item to download a model from the Trimble 3D Warehouse.

Share Model
Use the Share Model menu item to post your SketchUp model file and corresponding KML file to the Trimble 3D Warehouse. The Trimble 3D Warehouse is a
repository where models can be shared with other Google Earth or SketchUp users.

Upload Component
Use the Upload Model button to post the currently selected component to the 3D Warehouse.

Export

Use the Export submenu to access SketchUp's export functionality, which is useful for sharing your work with other people or exporting your drawings for use in
other applications. You can export your SketchUp model as a 3D model, a 2D graphic, section slice, or animation.

3D Model
Use the 3D Model menu item to export you SketchUp file to 3D formats, such as KMZ files.

GEAdditional file formats are available for export using SketchUp Pro.

2D Graphic
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Use the 2D Graphic menu item to export 2D bitmap and dimensionally accurate, resolution independent, 2D vector drawings. Pixel-based images can be
exported in JPEG, PNG, Epix, BMP, TGA, and TIFF file formats.

G::DVector images can be exported in PDF, EPS, DWG, and DXF file formats. This option makes it easy to send your SketchUp files to a plotter, quickly integrate
them into construction documentation, or further modify your models using vector-based illustration software. Note that vector output formats may not support
certain display options, such as shadows, transparency, and textures.

@Section Slice
Use the Export 2D Section Slice menu item to output dimensionally accurate 2D section slices in standard vector formats.

Animation
Use the Animation menu item to export a pre-rendered animation file containing the scene sequence you have created. This option makes it easy to archive your
animations to CD or DVD and to create smooth animations of complex models.

Import

Use the Import menu to import information from other files into your SketchUp drawings.

Print Setup

Use the Print Setup menu item to access to the print setup dialog box. This dialog box is used to select and configure printer and scene properties for printing.
Print Preview

Use the Print Preview menu item to preview your model as it will appear on paper (using the print setup settings).

Print

The Print menu item opens the standard Print dialog box. This dialog box enables you to print the current model in SketchUp's drawing area to the currently
selected printer.
Keyboard Shortcut: Ctrl+P

Generate Report

The Generate Report menu item is used to generate a report of all attributes contained in a dynamic component.
(Recently Opened File List)

The (Recently Opened File List) menu item lists recently opened SketchUp files. Select a file from this list to open the file.
Exit

The Exit menu item closes the current file and the SketchUp application window. SketchUp will notify you to save your file if it has not been saved since the last
change.

@ - Functionality only available in SketchUp Pro
* Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different
in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel
of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my
models, Fix it now, and Fix it later. We recommend you click on the Always fix my models button in this dialog box to fix the problem. This button also checks
the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to
automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during Open, Save, Save As, and Save A Copy As, preventing the overwriting of a good auto-save file.
Sketchup will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and
send a report. We recommend you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file.
This report contains valuable information regarding the unrecoverable errors.

View (Mac OS X)

The View menu contains menu items that alter the display of entities within your model.
Note: Items in the View menu alter the display of entities. Items in the Camera menu alter your point of view.

Tool Palettes

The Tool Palettes submenu contains all of the tool palettes. There are three tool palettes: Large tool Set, Google, and Dynamic Components. The Large tool Set
palette contains all tools needed by advanced SketchUp users. The Google palette has tools for using SketchUp with Google Earth and the Trimble 3D Warehouse.
The Dynamic Components palette has one tool for activating animated dynamic components. The Sandbox palette has tools for creating terrain and organic
shapes.

Scene Tabs
The Scene Tabs command toggles the display of scene tabs. See the Scene Manager topic for further information.
Hidden Geometry

Use the Hidden Geometry menu item to display hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden
Geometry menu item displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected,
hidden geometry can be made visible with the Unhide and Unhide All menu items.

Section Planes

The Section Planes menu item toggles the display section plane entities.
Section Cuts

The Section Cuts menu item toggles the display of any section cut effects.

Axes
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The Axes menu item toggles the display of the drawing axes.

Guides

The Guides menu item toggles the display of guide line entities and guide point entities.

Shadows

The Shadows menu item activates shadows.

Fog

The Fog menu item activates fog. Refer to the Fog dialog box for information on configuring fog settings.
Edge Style

The Edge Style submenu contains options to activate edges, back edges, and edge styles. The edge styles are Profiles, Depth Cue, and Extension. Refer to the
Styles Browser Edge panel for further information.

Face Style

The Face Style submenu contains options to activate face styles. The face styles are X-ray, Wireframe, Hidden Line, Shaded, Shaded with Textures, and
Monochrome. See the The Styles Browser Face panel for further information.

Component Edit

The Component Edit submenu contains commands to alter the display of other entities when editing components.
Hide Rest of Model

Use the Hide Rest of Model menu item to toggle the display of the model when editing a component.

Hide Similar Components

Use the Hide Similar Components menu item to toggle the display of similar components when editing a component.
Animation

The Animation submenu contains several menu items related to scenes and animations. See the Scenes and Animations topic for further information.
Add Scene

Use the Add Scene menu item to add a new scene to the current file.

Update Scene

Use the Update Scene menu item to update a scene if you have made changes to the scene

Delete Scene

Use the Delete Scene menu item to delete a scene from the current model.

Previous Scene

Use the Previous Scene menu item to transition to the previous scene.

Next Scene

The Next Scene menu item is used to transition to the next scene.

Play

The Play menu item starts an animation. See the Scenes and Animations topic for further information.

Settings

The Settings item invokes the Animation panel of the Model Info dialog box.

Hide/Show toolbar

The Hide/Show toolbar menu item controls the visibility of the toolbar. You can also modify the visibility of the toolbar by clicking on the toolbar collapse/expand
button at the top right corner of the title bar.

Customize Toolbar

The Customize Toolbar menu item launches the Customize Toolbar dialog box allowing you to place command buttons on the toolbar.

Help menu (Mac OS X)

The Help menu contains items relating to receiving help with the product. These items include the SketchUp on-line user's guide, a quick reference card, and
video tutorials.

Welcome to SketchUp
The Welcome to SketchUp menu item launches the Welcome to SketchUp dialog box.
Online Help Center

The Online Help Center menu item launches the SketchUp Help Center in your default web browser. This web site contains a list of Frequently Asked Questions
(FAQs) and a knowledge base of technical support issues and solutions.

Contact Us

Select the Contact Us menu for contact options.

View Menu (Windows)

The View menu contains menu items that alter the display of entities within your model.
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Note: Items in the View menu alter the display of entities. Items in the Camera menu alter your point of view.
Toolbars

The Toolbars submenu contains all of the toolbars. These toolbars are: Getting Started, Large tool Set, Camera, Construction, Drawing, Styles, Google, Layers,
Measurements, Modification, Principal, Sections, Shadows, Standard,Views, Walkthrough, Dynamic Components, and Sandbox.

The Large Buttons menu item toggles large toolbar buttons on and off. This option can enhance usability on tablets or low-resolution displays.
Scene Tabs

The Scene Tabs command toggles the display of scene tabs. See the Scene Manager topic for further information.

Hidden Geometry

Use the Hidden Geometry menu item to display hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden
Geometry menu item displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected,
hidden geometry can be made visible with the Unhide and Unhide All menu items.

Section Planes

The Section Planes menu item toggles the display section plane entities.

Section Cuts

The Section Cuts menu item toggles the display of any section cut effects.

Axes

The Axes menu item toggles the display of the drawing axes.

Guides

The Guides menu item toggles the display of guide line entities and guide point entities.
Shadows

The Shadows menu item activates shadows.

Fog

The Fog menu item activates fog. Refer to the Fog dialog box for information on configuring fog settings.
Edge Style

The Edge Style submenu contains options to activate edges, back edges, and edge styles. The edge styles are Profiles, Depth Cue, and Extension. Refer to the
Styles Browser Edge panel for further information.

Face Style

The Face Style submenu contains options to activate face styles. The face styles are X-ray, Wireframe, Hidden Line, Shaded, Shaded with Textures, and
Monochrome. See the The Styles Browser Face panel for further information.

Component Edit

The Component Edit submenu contains commands to alter the display of other entities when editing components.
Hide Rest of Model

Use the Hide Rest of Model menu item to toggle the display of the model when editing a component.

Hide Similar Components

Use the Hide Similar Components menu item to toggle the display of similar components when editing a component.
Animation

The Animation submenu contains several menu items related to scenes and animations. See the Scenes and Animations topic for further information.
Add Scene

Use the Add Scene menu item to add a new scene to the current file.

Update Scene

Use the Update Scene menu item to update a scene if you have made changes to the scene

Delete Scene

Use the Delete Scene menu item to delete a scene from the current model.

Previous Scene

Use the Previous Scene menu item to transition to the previous scene.

Next Scene

The Next Scene menu item is used to transition to the next scene.

Play

The Play menu item starts an animation. See the Scenes and Animations topic for further information.

Settings

The Settings item invokes the Animation panel of the Model Info dialog box.

Tools menu (Mac OS X)
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The Tools menu provides access to all of the modification tools in Sketchup. This menu represents one of three mechanisms for accessing these tools (additional
mechanisms are the tool palette and keyboard shortcuts).

Select

The Select menu item invokes a Select tool allowing you to select one or more entities to modify.

Keyboard Shortcut: Spacebar

Eraser

Use the Eraser menu item to invoke the Eraser tool allowing you to erase entities from the drawing area. This tool also allows you to hide and soften edges.
Keyboard Shortcut: E

Paint Bucket

The Paint Bucket menu item invokes the Paint Bucket tool used to assign materials to entities in your model. Use the Paint Bucket tool to paint individual
elements, fill a number of connected faces, or replace a material in your model.

Note: The Paint Bucket tool is different than the Apple Color Picker used to select colors and materials.

Keyboard Shortcut: B

Move

The Move menu item invokes the Move tool allowing you to move, manipulate, and copy geometry. This tool can also be used to rotate component entities.
Keyboard Shortcut: M

Rotate

Use the Rotate menu item to invoke the Rotate tool used to rotate drawing elements and single or multiple objects within a single rotation plane. The Rotate tool
can also be used to stretch and distort geometry by selecting only a portion of a model.

Keyboard Shortcut: Q

Scale

The Scale menu item invokes the Scale tool allowing you to resize and stretch selected geometry relative to other elements in your SketchUp model.
Keyboard Shortcut: S

Push/Pull

The Push/Pull menu item invokes the Push/Pull tool used to manipulate faces of your model. This tool can be used to displace, extrude, re-attach, or subtract
faces, depending on the context of selected geometry.

Keyboard Shortcut: P
Follow Me

Use the Follow Me menu item to invoke the Follow Me tool used to extrude faces along a path such as an edge or line drawn with the Freehand tool. This tool is
useful when adding details to a model because it allows you to draw the detail at one end of a path on the model and then repeat that detail along the path.

Offset

The Offset menu item invokes the Offset tool used to create copies of co-planar lines and faces that are a uniform distance from original lines and faces. Lines
and faces can be offset either inside or outside the original face. Offsetting a face will always create a new face.

Keyboard Shortcut: F
Tape Measure

Use the Tape Measure menu item to invoke the Tape Measure tool used to perform a number of dimension-related operations. These operations include
measuring the distance between two points, creating guide line entities, and re-scaling an entire model to an exact dimension.

Keyboard Shortcut: T

Protractor

The Protractor menu item invokes the Protractor tool allowing you to measure angles and create guide line entities (usually at some angle).
Axes

The Axes menu item invokes the Axes tool allowing you to move the drawing axes. This tool is often used when constructing rectangular objects that are skewed
relative to one another, or to allow for more accurate scaling of entities that are not oriented along the default coordinate planes.

Dimensions
Use the Dimensions menu item to invoke a Dimension tool used to place Dimension entities in your model.
Text
The Text menu item launches a Text tool used to insert Text entities into your model.
3D Text
The 3D Text menu item launches a 3D Text tool used to create modeled 3 dimensional text.
Section Plane
The Section Plane menu item invokes a Section plane tool used to make section cuts in your model.
Interact
Use the Interact menu item to interact with a dynamic component that has click regions, such as a door that, when clicked, animates.
Utilities
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The Utilities submenu contains various utilities and macros created using the Sketchup Ruby API. This menu item only appears after enabling the utilities tools
using the Extensions panel of the Preferences dialog box.

Note: Ruby scripts are contained in the Plugins directory under the installation directory.
Create Face

The Create Face menu item invokes the Create Face utility allowing you to troubleshoot face creation and, in most cases, create a face for three or more
intersecting edges. Specifically, the Create Face utility is useful when:

e A model has two edges that have a common end point geometrically (the coordinates of the end point are the same), but the edges are not connected
topologically. In this case, the Create Face utility will properly connect edges and create a face.

e A face cannot be created because edges are not exactly planer, or appear to be connected when there is actually a small gap between the ends of the
edges. In these instances, Create Face will not create a face, but displays a message indicating why SketchUp cannot create a face. This message can be
used to troubleshoot face creation.

Query tool
The Query tool menu item invokes a Query tool utility that displays the current mouse position in the Measurements toolbar.
Sandbox

The Sandbox submenu contains options for modifying terrain. This menu item only appears after enabling the terrain modeling tools using the Extensions panel
of the Preferences dialog box. See the Sandbox tools topic for further information.

Tools Menu (Windows)

The Tools menu provides access to all of the modification tools in Sketchup. This menu represents one of three mechanisms for accessing these tools (additional
mechanisms are the toolbars and keyboard shortcuts).

Select

The Select menu item invokes a Select tool allowing you to select one or more entities to modify.

Keyboard Shortcut: Spacebar

Eraser

Use the Eraser menu item to invoke the Eraser tool allowing you to erase entities from the drawing area. This tool also allows you to hide and soften edges.
Keyboard Shortcut: E

Paint Bucket

The Paint Bucket menu item invokes the Paint Bucket tool used to assign materials to entities in your model. Use the Paint Bucket tool to paint individual
elements, fill a number of connected faces, or replace a material in your model.

Keyboard Shortcut: B

Move

The Move menu item invokes the Move tool allowing you to move, manipulate, and copy geometry. This tool can also be used to rotate Component entities.
Keyboard Shortcut: M

Rotate

Use the Rotate menu item to invoke the Rotate tool used to rotate drawing elements and single or multiple objects within a single rotation plane. The Rotate tool
can also be used to stretch and distort geometry by selecting only a portion of a model.

Keyboard Shortcut: Q

Scale

The Scale menu item invokes the Scale tool allowing you to resize and stretch selected geometry relative to other elements in your SketchUp model.
Keyboard Shortcut: S

Push/Pull

The Push/Pull menu item invokes the Push/Pull tool used to manipulate faces of your model. This tool can be used to displace, extrude, re-attach, or subtract
faces, depending on the context of selected geometry.

Keyboard Shortcut: P
Follow Me

Use the Follow Me menu item to invoke the Follow Me tool used to extrude faces along a path such as an edge or line drawn with the Freehand tool. This tool is
useful when adding details to a model because it allows you to draw the detail at one end of a path on the model and then repeat that detail along the path.

Offset

The Offset menu item invokes the Offset tool used to create copies of co-planar lines and faces that are a uniform distance from original lines and faces. Lines
and faces can be offset either inside or outside the original face. Offsetting a face will always create a new face.

Keyboard Shortcut: F
Tape Measure

Use the Tape Measure menu item to invoke the Tape Measure tool used to perform a number of dimension-related operations. These operations include
measuring the distance between two points, creating guide line entities, and re-scaling an entire model to an exact dimension.

Keyboard Shortcut: T
Protractor

The Protractor menu item invokes the Protractor tool allowing you to measure angles and create guide line entities (usually at some angle).
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Axes

The Axes menu item invokes the Axes tool allowing you to move the drawing axes. This tool is often used when constructing rectangular objects that are skewed
relative to one another, or to allow for more accurate scaling of entities that are not oriented along the default coordinate planes.

Dimensions

Use the Dimensions menu item to invoke a Dimension tool used to place Dimension entities in your model.
Text

The Text menu item launches a Text tool used to insert Text entities into your model.

3D Text

The 3D Text menu item launches a 3D Text tool used to create modeled 3 dimensional text.

Section Plane

The Section Plane menu item invokes a Section plane tool used to make section cuts in your model.
Utilities

The Utilities submenu contains various utilities and macros created using the Sketchup Ruby API. This menu item only appears after enabling the utilities tools
using the Extensions panel of the Preferences dialog box.

Note: Ruby scripts are contained in the Plugins directory under the installation directory.

Create Face
The Create Face menu item invokes the Create Face utility allowing you to troubleshoot face creation and, in most cases, create a face for three or more
intersecting edges. Specifically, the Create Face utility is useful when:

e A model has two edges that have a common end point geometrically (the coordinates of the end point are the same), but the edges are not connected
topologically. In this case, the Create Face utility will properly connect edges and create a face.

e A face cannot be created because edges are not exactly planer, or appear to be connected when there is actually a small gap between the ends of the
edges. In these instances, Create Face will not create a face, but displays a message indicating why SketchUp cannot create a face. This message can be
used to troubleshoot face creation.

Query tool
The Query tool menu item invokes a Query tool utility that displays the current mouse position in the Measurements toolbar.

Interact
Use the Interact menu item to interact with a dynamic component that has click regions, such as a door that, when clicked, animates.
Sandbox

The Sandbox submenu contains options for modifying terrain. This menu item only appears after enabling the terrain modeling tools using the Extensions panel
of the Preferences dialog box. See the Sandbox tools topic for further information.

File menu (Mac OS X)

The File menu contains items that relate to SketchUp model files, including commands to create, open, save, print, import, and export model files.
New

The New menu item is used to create a blank drawing area and begin a new SketchUp model. SketchUp will use the settings in the template file to define the
initial model state if you have selected a template file in template panel under SketchUp > Preferences.

Tip: Open another instance of SketchUp if you want multiple drawing areas open simultaneously.
Keyboard Shortcut: Command+N
Open*

Use the Open menu item to launch the Open dialog box, allowing you to open a previously saved SketchUp file.
Keyboard Shortcut: Command+0O

Open Recent

Use the Open Recent submenu to quickly access recently opened SketchUp files. You can clear the list of recent files by selecting the Clear menu item from the
end of the recent files list.

Close

The Close menu item closes the active drawing window. This action is the same as clicking on the close button in your drawing's title bar. You will be prompted
to save your changes if the model in the active drawing window has not been saved recently.

Keyboard Shortcut: Command+W

Save*

Use the Save menu item to save the currently active SketchUp model to your file system. When you close an unsaved document, or attempt to quit SketchUp with

unsaved open documents, SketchUp will prompt you to save your work before continuing.
Keyboard Shortcut: Command+S

Tip: If Create Backup is enabled within the General panel of the preferences dialog box, the existing file will be converted to a backup file (.skb), and the new
drawing will be saved in place of that currently existing file (.skp). The Create Backup option can help preserve your data in the event of an accidental removal of
a .skp file.

Tip: It is good to save often. You can have SketchUp automatically save for you at a specific time increment by enabling the Auto-save option within the General
panel of the Preferences dialog box.

Save As*

Use the Save As menu item to open the Save As dialog box which defaults to the current document's folder. You can use this dialog box to save the CLgéent



drawing as a new document. This file can be assigned a new name, a new location, and a previous version of SketchUp. The new file will become the current file
in the drawing window.
Keyboard Shortcut: Shift+ Command+S

Save A Copy As*

Use the Save A Copy As menu item to save a new file based on your current model. This menu item does not overwrite or close the current file and is useful for
saving incremental copies or tentative schemes of your work.

Save As Template

Use the Save As Template menu item to save the current SketchUp file as a template. This menu item launches a dialog box where you can name the template
and set the template as the default template (to be loaded every time you launch SketchUp).

Revert

Use the Revert menu item to revert your current document to its last saved state.

GESend to LayOut

Use the Send to LayOut menu item to send the current model to LayOut.

Preview in Google Earth

Use the Preview in Google Earth menu item to quickly view your model in Google Earth while working on the model.
Geo-location

The Geo-location submenu contains menu items for Geo-locating your models.

Add Location...
Use the Add Location menu item to display the Add Location dialog box for selecting a location for your model. This menu item is only available when a location
has not been added.

Clear Location
Use the Clear Location menu item to remove the location from your model.

Show Terrain
Use the Show Terrain menu item to toggle the Google Earth snapshot image between a 2D and 3D image.

Building Maker
The Building Maker submenu contains menu items for working with Building Maker.

Add New Building
Use the Add New Building menu item to launch Building Maker from SketchUp. Refer to the Building Maker Getting Started Guide for further information on using
Building Maker.

3D Warehouse
The 3D Warehouse submenu contains menu items for accessing the 3D Warehouse repository of models.

Get Models
Use the Get Models menu item to download a model from the Trimble 3D Warehouse.

Share Model
Use the Share Model menu item to post your SketchUp model file and corresponding KML file to the Trimble 3D Warehouse. The Trimble 3D Warehouse is a
repository where models can be shared with other Google Earth or SketchUp users.

Upload Component
Use the Upload Model button to post the currently selected component to the 3D Warehouse.

Export

Use the Export submenu to access SketchUp's export functionality, which is useful for sharing your work with other people or exporting your drawings for use in
other applications. You can export your SketchUp model as a 3D model, a 2D graphic, a section slice, or an animation.

3D Model
Use the 3D Model menu item to export you SketchUp file to 3D formats, such as KMZ files.

@ Additional file formats are available for export using SketchUp Pro.

2D Graphic
Use the 2D Graphic menu item to export 2D bitmap and dimensionally accurate, resolution independent, 2D vector drawings. Pixel-based images can be
exported in JPEG, PNG, Epix, and TIFF file formats.

@ Vector images can be exported in PDF, EPS, DWG, and DXF file formats. This option makes it easy to send your SketchUp files to a plotter, quickly integrate
them into construction documentation, or further modify your models using vector-based illustration software. Note that vector output formats may not support
certain display options, such as shadows, transparency, and textures.

@Section Slice
Use the Export 2D Section Slice menu item to output dimensionally accurate 2D section slices in standard vector formats.

Animation
Use the Animation menu item to export a pre-rendered animation file containing the scene sequence you have created. This option makes it easy to archive your
animations to CD or DVD and to create smooth animations of complex models.

Import
Use the Import menu to import information from other files into your SketchUp drawings.
Page Setup

Use the Page Setup menu item to access the Mac OS X page setup dialog box. This dialog box is used to select and configure printer and page properties to use
for printing. Consult the Mac OS X system help for more information about Page Setup.

Keyboard Shortcut: Shift+Command+P 39



Document Setup
Use the Document Setup menu item to access to the Document Setup dialog box. This dialog box is used to configure the document properties prior to printing.
Print

The Print menu item opens the standard Print dialog box. This dialog box enables you to print the current model in SketchUp's drawing area to the currently
selected printer. Consult the Mac OS X system help for more information about printing.
Keyboard Shortcut: Command+P

Generate Report

The Generate Report menu item is used to generate a report of all attributes contained in a dynamic component.

@ - Functionality only available in SketchUp Pro
* Problem Detection

Minor problems can occur with your model given the infinite flexibility that SketchUp provides when designing in 3D. You likely will not notice anything different
in your model, except that it will perform better, after these problems are fixed.

SketchUp checks all files for problems when they are opened and saved if the Automatically check models for problems check box is checked in the General Panel
of the Application Preferences. SketchUp displays a dialog box allowing you to fix problems if they are found. This dialog box has three options: Always fix my
models, Fix it now, and Fix it later. We recommend you click on the Always fix my models button in this dialog box to fix the problem. This button also checks
the Automatically fix problems when they are found checkbox in the General Panel of the Application Preferences. This preferences option causes SketchUp to
automatically fix problems without user intervention. Refer to the Automatically fix problems when they are found option for further information.

SketchUp will check your model for unrecoverable errors during Open, Save, Save As, and Save A Copy As, preventing the overwriting of a good auto-save file.
Sketchup will display a dialog box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and
send a report. We recommend you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file.
This report contains valuable information regarding the unrecoverable errors.

Edit Menu (Windows)

The Edit menu contains items allowing you to perform editing functions on SketchUp geometry. These menu items include those for creating and editing groups
and components, visibility operations, and standard cut, copy, paste commands.

Undo

Use the Undo menu item to undo the last drawing or editing commands performed. SketchUp allows you to undo all operations you have performed, one at a
time, to the state at which you saved your file. The number of possible sequential Undo commands is limited to 100 steps.

Keyboard Shortcut: Alt+Backspace or Ctrl+Z

Note: Undo will undo any operation that creates or modifies geometry, but it does not undo changes to your point of view. Use the Previous menu item under the
Camera menu to undo a point of view change.

Redo

The Redo menu item returns the last undo to its previous state.
Keyboard Shortcut: Ctrl+Y

Cut

The Cut menu item removes the selected elements from your model and places them in the clipboard. The contents of the clipboard can then be inserted back
into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy command.

Keyboard Shortcut: Shift+Delete or Ctrl+X
Copy

The Copy menu item copies the selected items to the clipboard without deleting the items from the model. The contents of the clipboard can then be inserted
back into any open SketchUp document by using the Paste menu item.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Ctrl+C or Ctrl+Insert
Paste

Use the Paste menu item to paste the contents of the clipboard into the current SketchUp document. The pasted geometry will be attached to and placed by the
point of the cursor, allowing you to position the new geometry when it is pasted.

You can use cut, copy and paste to move geometry between open SketchUp windows. Contents of the clipboard will remain on the clipboard until replaced with
other content using an additional Cut or a Copy operation.

Keyboard Shortcut: Ctrl+V or Shift+Insert

Paste in Place

Use the Paste in Place menu item to paste an item at the same location where it was cut or copied.
Delete

Use the Delete menu item to remove the currently selected entities from your model.

Keyboard Shortcut: Delete

Delete Guides

Use the Delete Guides menu item to delete all of the guides that are in the drawing area.
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Select All

Use the Select All menu item to select all selectable entities in the model. Hidden entities, any items on a hidden layer, or geometry that is clipped away using a
section plane cannot be selected with the Select All menu item.

Keyboard Shortcut: Ctrl+A

Select None

The Select None menu item clears the selection set, deselecting any currently selected items in the model.

Keyboard Shortcut: Ctrl+T

Hide

Use the Hide menu item to hide any selected object. Hiding geometry can help simplify your current view, or enable viewing and working inside tight areas.
Unhide

The Unhide submenu contains options for unhiding hidden entities.

Selected
The Selected menu item unhides any selected hidden object. Ensure Show Hidden Geometry is enabled under the View menu to view and select hidden geometry.

Last
The Last menu item unhides the last entities hidden with the Hide command.

All
The All menu item unhides all hidden entities in your current document.

Lock

The Lock menu item is used to lock any component or group that you do not want to be able to be moved or edited.
Unlock

The Unlock submenu contains options for unlocking components and groups.

Selected
Use the Selected menu item to unlock all components and groups in a selection set.

All
Use the All menu item to unlock all components and groups in your drawing area.

Make Component

Use the Make Component menu item to create a component entity from the selected entities.

Keyboard Shortcut: G

Make Group

The Make Group menu item creates a Group entity from the selected entities.

Close Group/Component

Use the Close Group/Component menu item to exit from a group or component's context or editing session.
Intersect Faces

The Intersect Faces sub-menu contains menu items for intersecting geometry with other geometry.

With Model
Complex geometry in SketchUp can be easily created using the With Model menu item (also called the 'Intersector’). Use the With Model menu item to intersect all
entities overlapping with the currently selected entity (such as a box component and a tube component).

With Selected
Select the With Selection to intersect only those items that are selected.

With Context
Select the With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

Entity Commands Sub-Menu

The Entity Commands sub-menu contains all of the commands available to manipulate the currently selected entity (which are the same as the commands found
in the entity's context menu). The sub-menu's name and contents will change depending on the entity that you have selected.

Window menu (Windows)

The Window menu contains model settings and managers for your models. Model settings are dialog boxes with settings that affect the model, such as shadows,
display settings, and model information. Managers are dialog boxes that manage certain aspects of your model such as scenes, layers, materials, and
components.

Model Info

Use the Model Info menu item to display the Model Info dialog box used to set settings for your entire model.

Entity Info

The Entity Info menu item displays the Entity Info dialog box used to view and set settings for the currently selected entity (or entities).
Materials

The Materials menu item invokes Material Browser and Editor used for managing your materials.

Components

The Components menu item displays Components Browser used for managing your components. 41



Styles

The Styles menu item invokes the Styles dialog box containing options related to styles, such as edge and face rendering styles.
Layers

Use the Layers menu item to display the Layers Manager used to manage your SketchUp layers.

Outliner

The Outliner menu item invokes the Component Outliner used to display components and groups in a hierarchy.

Scenes

The Scenes menu item invokes the Scene Manager used to manage scenes for an animation. The Scene Manger will display with the current scene highlighted.
Shadows

The Shadows menu item invokes Shadow Settings dialog box for manipulating shadows in your model.

Fog

The Fog menu item invokes the Fog dialog box used to add a fog effect to your model.

Match Photo

The Match Photo menu item invokes the Match Photo dialog box used to help you create accurate 3D models from photos and to accurately place models in a
photo's context.

Soften Edges

The Soften Edges menu item invokes the Soften Edges dialog box used to soften and smooth edges in your model.
Instructor

The Instructor menu item invokes the Instructor used to display information about the currently activated tool.
Preferences

The Preferences menu item invokes the Application Preferences dialog box where you can set various global settings for the program.
Welcome

The Welcome menu item invokes the Welcome to SketchUp dialog box.

Hide/Show Dialogs

Use the Hide/Show Dialog menu item to hide and show all currently active dialog boxes.

Ruby Console

The Ruby Console menu item displays the Ruby Console where you can type Ruby script.

Component Options

The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

GmComponent Attributes
The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic component.
Photo Textures

The Photo Textures menu item is displays the Photo Textures dialog box used to capture a texture from Street View and apply it to the currently selected face.

Draw menu (Windows)

The Draw menu contains all of the SketchUp drawing tools and provides an alternative to using the, toolbars or keyboard shortcuts.
Line

The Line menu item invokes a Line tool used to draw Line entities, or edges, within the drawing area.

Keyboard Shortcut: L

Arc

The Arc menu item invokes an Arc tool used to draw Arc entities, comprised of multiple connected straight line segments (editable as a single curve).
Keyboard Shortcut: A

Freehand

Use the Freehand menu item to invoke a Freehand tool used to draw irregular, coplanar connected lines in the form of Curve entities.
Rectangle

The Rectangle menu item invokes a Rectangle tool used to draw four coplanar intersecting edges and a subsequent Face entity.
Keyboard Shortcut: R

Circle

The Circle menu item invokes a Circle tool used to draw Circle entities.

Keyboard Shortcut: C

Polygon
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The Polygon menu item invokes a Polygon tool used to draw regular Polygon entities, inscribed within a circle, consisting of 3 to 100 sides.

Draw Menu (Mac OS X)

The Draw menu contains all of the SketchUp drawing tools and provides an alternative to using the tool palette or keyboard shortcuts.
Line

The Line menu item invokes a Line tool used to draw Line entities, or edges, within the drawing area.

Keyboard Shortcut: Apple+L

Arc

The Arc menu item invokes an Arc tool used to draw Arc entities, comprised of multiple connected straight line segments (editable as a single curve).
Keyboard Shortcut: Apple+)

Freehand

Use the Freehand menu item to invoke a Freehand tool used to draw irregular, coplanar connected lines in the form of Curve entities.
Keyboard Shortcut: Apple+F

Rectangle

The Rectangle menu item invokes a Rectangle tool used to draw four coplanar intersecting edges and a subsequent Face entity.

Keyboard Shortcut: Apple+K

Circle

The Circle menu item invokes a Circle tool used to draw Circle entities.

Polygon

The Polygon menu item invokes a Polygon tool used to draw regular Polygon entities, inscribed within a circle, consisting of 3 to 100 sides.

Keyboard Shortcut: Apple+;

Camera Menu (Windows)

The Camera menu contains items for altering your point of view of the model.

Previous

Use the Previous menu item to back up to the previous saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.
Next

Use the Next menu item to advance to the next saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.
Standard Views

The Standard Views submenu provides access to standard views: Top, Bottom, Front, Right, Back, Left, and Isometric. Selecting any of these model views will
immediately set your active drawing window to that view.

Parallel Projection
Select the Parallel Projection menu item to enter a paraline projection.

Note: SketchUp must be in paraline mode to print to scale. Be aware that faces and edges that are parallel to the view plane will be measurable.

Perspective
Select the Perspective menu item to enter a perspective projection.
Two-Point Perspective

A two-point perspective is a common drawing technique in which all vertical lines in the model will appear straight. Use the Two-Point Perspective menu item to
achieve a 2-point perspective view of your model. You will be placed in the Pan tool to pan around your model.

Warning: Orbiting will move a model out of 2-point perspective.

Match New Photo...

Select the Match New Photo menu item to start a match new photo session.
Edit Matched Photo

Select the Edit Matched Photo menu item to edit a previously matched photo.
Orbit

The Orbit menu item invokes the Orbit tool.

Keyboard Shortcut: O

Pan

The Pan menu item invokes the Pan tool.

Keyboard Shortcut: H

Zoom
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The Zoom menu item launches the Zoom tool.

Keyboard Shortcut: Z

Field of View

Use the Field of View menu item to invoke the Zoom tool in Field of View mode allowing you to widen or narrow your field of view.
Zoom Window

The Zoom Window menu item launches the Zoom Window tool.

Note: The Zoom Window tool is not in the SketchUp (free) toolbar, but is available to use from the Camera menu.
Zoom Extents

The Zoom Extents menu item launches the Zoom Extents tool.

Keyboard Shortcut: Shift+Z

Zoom to Photo

Select the Zoom to Photo menu item, while using matching, to zoom such that the photo fills the entire drawing area.
Position Camera

The Position Camera menu item launches the Position Camera tool allowing you to investigate fixed views of your model (such as an eye-level view of a house).
This option is often used with the Walk tool to take an eye-level tour of a structure.

Walk

The Walk menu item invokes the Walk tool for maneuvering through your SketchUp model as though you taking a virtual tour of the model.
Look Around

The Look Around menu item invokes the Look Around tool which pivots the camera around a stationary point at the point of view.

Image Igloo

The Image Igloo menu item is used with Match Photo sketching mode to add detail to a model. This option is only available for models that have 2 or more
scenes, each scene containing a photo (such as a model created with Building Maker). Image Igloo creates an "igloo" of these photos over the model allowing for
easy navigation and selection of photos to use in Match Photo's sketching mode. Refer to Creating an image igloo and Creating a 3D model to match a photo for
further information.

Camera Menu (Mac OS X)

The Camera menu contains items for altering your point of view of the model.

Previous

Use the Previous menu item to back up to the previous saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.
Next

Use the Next menu item to advance to the next saved point of view. Points of view are saved automatically when the camera is moved in SketchUp.
Standard Views

The Standard Views submenu provides access to standard views: Top, Bottom, Front, Right, Back, Left, and Isometric. Selecting any of these model views will
immediately set your active drawing window to that view.

Parallel Projection

Select the Parallel Projection menu item to enter a paraline projection.

Note: SketchUp must be in paraline mode to print to scale. Be aware that faces and edges that are parallel to the view plane will be measurable.
Perspective

Select the Perspective menu item to enter a perspective projection.

Two-Point Perspective

A two-point perspective is a common drawing technique in which all verticals lines in the model will appear straight. Use the Two-Point Perspective menu item to
achieve a 2-point perspective view of your model. You will be placed in the Pan tool to pan around your model.

Warning: Orbiting will move a model out of 2-point perspective.

Match New Photo...

Select the Match New Photo menu item to start a match new photo session.
Edit Matched Photo

Select the Edit Matched Photo menu item to edit a previously matched photo.
Orbit

The Orbit menu item invokes the Orbit tool.

Pan

The Pan menu item invokes the Pan tool.

Zoom

The Zoom menu item launches the Zoom tool.
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Field of View

Use the Field of View menu item to invoke the Zoom tool in Field of View mode allowing you to widen or narrow your field of view.
Zoom Window

The Zoom Window menu item launches the Zoom Window tool.

Note: The Zoom Window tool is not in the SketchUp (free) toolbar, but is available to use from the Camera menu.

Zoom Extents

The Zoom Extents menu item launches the Zoom Extents tool.

Zoom to Photo

Select the Zoom to Photo menu item, while using matching, to zoom such that the photo fills the entire drawing area.

Position Camera

The Position Camera menu item launches the Position Camera tool allowing you to investigate fixed views of your model (such as an eye-level view of a house).
This option is often used with the Walk tool to take an eye-level tour of a structure.

Walk

The Walk menu item invokes the Walk tool for maneuvering through your SketchUp model as though you taking a virtual tour of the model.
Look Around

The Look Around menu item invokes the Look Around tool which pivots the camera around a stationary point at the point of view.

Image Igloo

The Image Igloo menu item is used with Match Photo sketching mode to add detail to a model. This option is only available for models that have 2 or more
scenes, each scene containing a photo (such as a model created with Building Maker). Image Igloo creates an "igloo" of these photos over the model allowing for
easy navigation and selection of photos to use in Match Photo's sketching mode. Refer to Creating an image igloo and Creating a 3D model to match a photo for
further information.

Invoking a context menu

Context menus are invoked on entities by selecting one or more entities, holding down the Control key, and clicking the mouse button (single button mouse).
Users with three-button or scroll-wheel mice can select one or more entities and click the right mouse button to invoke a context menu. This operation is
referred to as a context-click.

Context menus are invoked on user interface components, such as a dialog box, by clicking the right mouse button while the cursor is on the component (three
button mouse) or holding down the Control key and clicking the mouse button (single button mouse).

45



Context Menus

Context menu items for entities

All of the context menu items for all entities in SketchUp follow.

Active Cut
The Active Cut menu item is used to activate and de-activate the Section Plane Object, as indicated by the check mark. Activating a Section Plane will
automatically de-activate all other planes in that context.

This menu item is available for the Section Plane entity.

Align View
The Align View menu item is used to align the SketchUp Camera to the currently selected face.

This menu item is available for Face, Section Plane, and Surface entities.

Align Axes
The Align Axes menu item is used to align the Drawing Axes to the currently selected face.

This menu item is available for the Face and Surface entities.

Area
The Area sub-menu of the Face context menu is used to calculate the surface area in your SketchUp model. The results of the calculation are displayed in a Area
dialog box.

This menu item is available for the Face and Surface entities.
Selection: The Selection menu item is used to calculate the total surface area of the currently selected face.
Layer: The Layer menu item is used to calculate the total area for all faces in the layer of the currently selected face.

Materials: The Materials menu item is used to calculate the total area of the faces in the entire model, hidden or unhidden, with the material of the currently
selected face.

This menu item is available for the Face and Surface entities.

Arrow
Click on the Arrow sub-menu menu to select the end point type for the leader line. Choose between None, Dot, Closed Arrow, and Open Arrow.

Change Axes
The Change Axes menu item is used to redefine the origin axes of the selected component. This option is similar to changing the local coordinate system in
other 3D applications.

This menu item is available for the Component entity.

Close Component
The Close Component menu item is used to end an editing session and close the component. You can also click outside of the component with the Select tool, or
press the Esc key to close the component.

This menu item is available for the Component entity.

Close Group
The Close Group menu item is used to end an editing session and close the group. You can also click outside of the group with the Select tool, or press the Esc
key to close the group.

This menu item is available for the Group entity.

Combine Textures
The Combine Textures menu item is used to create a texture which is unique to the set of parallel Face entities. This menu item is primarily used to stitch
together photographs.

This menu item is available for a selection set of parallel Face entities (where at least one face has a texture).

Convert to Polygon
The Convert to Polygon menu item is used to convert the entity into a polygon arc, which will remain editable yet generate standard facets when extruded.

This menu item is available for the 3D Polyline, Circle, and Curve entities.

Create Group from Slice
Generates new edges, encapsulated within a Group, wherever the section intersects with a face.

This menu item is available for the Section Plane entity.

Divide
The Divide menu item is used to divide an entity into any number of equal segments. This menu item is not available when an arc bounds a curved surface.

Dynamic Components
The Dynamic Components submenu contains menu items for configuring and creating dynamic components.

Component Options: The Component Options menu item is used to display the Component Options dialog box used to configure a dynamic component.

@Component Attributes: The Component Attributes menu item is used to display the Component Attributes dialog box used to develop a dynamic
component.

This menu item is available for any Component entity.

Swap Component: Use the Swap Component menu item to swap the currently selected component with another component. For example, use this option to
swap all windows of a specific type or manufacturer with windows of another type or manufacturer.

Note: Components that have attributes with the same name and value will retain their settings when swapped. For example, a window with a color attribute set to
green will remain green when swapped with another component containing a color attribute set to green.

This menu item is available for any Component entity.
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@Generate Report: The Generate Report menu item is used to display the Generate Report dialog box used to generate various dynamic components reports.

Edit Component
The Edit Component menu item is used to edit the currently selected component. You can also use the Select tool to double-click on the component, or select the
component and press Enter (Microsoft Windows) or Return (Mac OS X) key to edit a component.

This menu item is available for the Component entity.

Edit Group
The Edit Group menu item is used to edit the currently selected group. You can also use the Select tool to double-click on the group, or select the group and
press the Enter (Microsoft Windows) or Return (Mac OS X) key to edit a group.

This menu item is available for the Group entity.

Edit Text
The Edit Text menu item is used to edit the dimension text. Type in the new text and press the Enter (Microsoft Windows) or Return (Mac OS X) key to accept
your changes.

This menu item is available for the Dimension and Text entities.

Entity Info
The Entity Info menu item is used to display the Entity Info dialog box for viewing and changing the entity's attributes.

This menu item is available for all entities.

Erase
The Erase menu item is used to delete the selected entity from your model.

This menu item is available for the all entities.

Export
The Export menu item is used to save the image entity to a file that can be edited in an image editor.

This menu item is available for the Image entity.

Explode
The Explode menu item is used to break the entity into the separate entities. An exploded entity will appear the same, but it can no longer be edited, and will no
longer respond to tool operations as a single entity.

This menu item is available for the 3D Polyline, Component, Group, and Image entities.

Explode Curve
The Explode Curve menu item is used to break the entity into regular edges. An exploded entity will appear the same, but it can no longer be edited, and will no
longer respond to tool operations as a single entity.

This menu item is available for the 3D Polyline, Circle, Curve, and Polygon entities.

Flip Along
The Flip Along menu item is used to mirror the selected geometry along an axis. You can use the Axis tool to reposition the drawing axes, allowing you to flip in
virtually any direction.

This menu item is available for the Component and Group entities.

Group
This creates a Group entity out of the selected geometry.

Hide/Unhide
The Hide/Unhide menu item hides or unhides the select entity. All hidden entities are displayed in a ghosted pattern, allowing you to select them, if View >
Show Hidden Geometry is enabled. This menu item changes to Unhide when selected geometry is hidden. Select Unhide to restore visibility for the entity.

This menu item is available for all entities.
Intersect Faces

The Intersect Faces menu item is used to intersect two elements, such as a box and a tube, and automatically create new faces where the elements intersect.
These faces can then be pushed, pulled or deleted to create new geometry.

With Model
Complex geometry in SketchUp can be easily created using the Intersect Faces menu item (also called the 'Intersector’). Use the With Model menu item to
intersect all entities overlapping with the currently selected entity (such as a box component and a tube component).

With Selected
Select the With Selection to intersect only those items that are selected.

With Context
Select the With Context menu item to intersect two entities within the current context (excluding all entities outside of the context).

These menu items are available for the Component, Face, Group, and Surface entities.

Leader
Click on the Leader sub-menu to select between View Based, Pushpin, and Hidden leader types. A View Based leader will always retain its 2D screen orientation. A
Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

Lock/Unlock
The Lock menu item is used to lock the component so that it cannot be moved or edited. Additional copies of the component can be dragged into the work area
from the Components Browser, however.

The Unlock menu item is used to unlock the component so it can be edited.

Make Component
The Make Component menu item converts the entities into a new Component entity (component definition).

This menu item is available for the Group entity.

Make Unique
The Make Unique menu item converts the currently selected component into a unique component, with a new definition. The original component definition and
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all other instances will not be affected when you edit the component after using the Make Unique menu item.
This menu item is available for the Component entity.

Make Unique Texture
The Make Unique Texture menu item is used to create a texture which is unique to that face. This menu item is not available if SketchUp already considers the
texture to be 'unique' and applies to the side of the face which is visible at the time you select the menu.

The Make Unique Texture menu item is also available for a face which doesn't already have a texture applied. The Texture Size dialog box is displayed when you
select a face without a texture and then select the Make Unique Texture menu item. This dialog box prompts you to enter a texture size.

This menu item is available for the Face entity.

Note: The Make Unique Texture menu item will not be available again for a face unless you change the size of the face, edit the material size, or reposition the
texture on the face.

Orient Faces
The Orient Faces menu item is used to automatically orient all the connected faces of your model to the orientation of the currently selected face. This option
could lead to unexpected results when an edge of a face bounds three or more other faces.

This menu item is available for the Face and Surface entities.

Photo Textures

The Photo Textures menu item is displays the Photo Textures dialog box used to capture a texture from Street View and apply it to the currently selected face.
This menu item is available for the Face entity.

Point at Center
The Point at Center menu item is used to place a point at the center of your arc or circle entity. This menu item is generated by a Ruby script.

This menu item is available for the 3D Polyline, Circle, and Polygon entities.

Reload
The Reload menu item is used to update the currently selected component with a new revision from the file system.

This menu item is available for the Component and Image entities.

Reverse
The Reverse menu item is used to reverse the direction of a Section Plane entity.

This menu item is available for the Section Plane entity.

Reverse Faces
The Reverse Faces menu item is used to flip the front and back sides of the currently selected face. However, when exporting SketchUp geometry to a file format
that only supports single-sided faced polygons (like DXF, DWG, and 3DS), it becomes important to know which side of the face will be exported.

This menu item is available for the Face, Section, and Surface entities.

Reset Scale
The Reset Scale menu item is used to remove any scaling operations applied to the component.

This menu item is available for the Component and Group entities.

Reset Skew
The Reset Skew menu item is used to remove any skewing applied to the component.

This menu item is available for the Component and Group entities.

Save As
The Save As menu item is used to save the selected component to a separate SketchUp file, with a new name and location in your file system. This menu item is
commonly used to create component files that can be included in the component collection or reused in other models.

This menu item is available for the Component entity.

Scale Definition
The Scale Definition menu item applies any scaling operation, to the currently selected component, to the component definition in the Components Browser.

This menu item is available for the Component entity.

Select
The Select submenu contains several options for selecting geometry related to the entity.

Bounding Edges: The Bounding Edges menu item is used to select all of the edges currently bounding the selected entity.
Connected Faces: The Connected Faces menu item is used to select all of the faces currently connected to the selected entity.
All Connected: The All Connected menu item is used to select all of the elements currently connected to the selected arc.

All on same Layer: The All on same Layer menu item is used to select all of the elements on the current layer.

This menu item is available for the 3D Polyline, Circle, Curve, Face, Line, Polygon, and Surface entities.

Shadows
The Shadows submenu contains cast and receive shadow options for the Image entity.

Cast: The Cast Shadows menu item allows the face of the entity to cast a shadow.
Receive: The Receive Shadows menu item allows the face of the entity to receive a shadows cast by other entities.
This menu item is available for the Image entity

Soften
The Soften menu item is used to soften a faceted surface. Softened edges are not visible unless displayed in profile.

This menu item is available for the 3D Polyline, Circle, Curve, Line, and Polygon entities.
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Texture
The Texture submenu contains several options for repositioning textures on a face. This menu item only appears when a texture is painted on the face. See
Position Texture tool for additional information.

Position: The Position menu item is used to manipulate textures (reposition, stretch, skew, and so on) directly on a face.
Reset Position: The Reset Position menu item is used to reset the texture to its previous state.

Projected: The Projected menu item is used to wrap images and textures over forms as though projected onto the form.
This menu item is available for the Face and Surface entities.

Text Position
The Text Position menu item is used to position text either at the start of the dimension line (Outside Start), center (Centered), our end of the dimension line
(Outside End).

This menu item is available for the Dimension entity.

Unglue
The Unglue menu item is used to free a component from a face (if you've attached a hole-cutting component to a face).

This menu item is available for the Component, Group,and Image entities.

Upload Component

Select the Upload Component menu item to upload the currently selected component to the Trimble 3D Warehouse.
This menu item is available for Component entities, including Dynamic Components.

Use As Material (Microsoft Windows)
The Use As Material menu item is used to create a material, in the In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.

Use As Material (Mac OS X)
The Use As Material menu item is used to create a material, in the Colors In Model section of the Material Browser, from the image.

This menu item is available for the Image entity.

With Model
The With Model menu item is used to intersect two elements, such as a box and a tube, and automatically create new faces where the elements intersect. These
faces can then be pushed, pulled or deleted to create new geometry.

Zoom Extents
The Zoom Extents menu item is used to zoom your view to a distance where the whole entity is visible and centered in the drawing window.

This menu item is available for the 3D Polyline, Circle, Component, Curve, Face, Group, Image, Line, Polygon, and Surface entities.

Context menus

Menu items also appear in special context menu: menus whose contents vary depending on the context in which they are invoked (usually on one or more
entities in the drawing area or on a user interface component, such as a dialog box). The following image shows a context menu for a Face entity.

Entity Info
Erase Delete
Hide

Select >
Area »
Intersect with Model

Align View

Align Axes

Reverse

Orient Faces

Zoom Extents
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User Interface

Selecting a template

You must select a template before you can use SketchUp.
Selecting a template using the Welcome to SketchUp dialog box
To select a template using the Welcome to SketchUp dialog box, please follow these steps:

1. Click on the Choose Template button. The Template panel is displayed.

2. Select a template that best fits your design projects. For example, choose the 'Product Design and Woodworking - Inches' template if you are a woodworker
who works in inches. The template name appears in the 'Default Template' field.

3. Click on the Start using SketchUp button to start using SketchUp. SketchUp will load with the newly selected default template.

Selecting a template using the Template panel in the Preferences dialog box
To select a template using the template panel in Preferences dialog box:

1. Select Window > Preferences (Microsoft Window) or SketchUp > Preferences (Mac OS X). The Preferences dialog box is displayed.
2. Click on the Template item in the list on the left-hand side of the Preferences dialog box. The Template panel appears.
3. Click on a template in the 'Drawing Template' drop-down list. The template is selected as the default template.
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Select Tool

SketchUp Select Tool: Introduction
L3

Select tool introduction

Use the Select tool to specify the entities you will modify when using other tools or commands. The entities that are included in a selection are referred to as the
selection set. Activate the Select tool from the Getting Started, Large Tool Set, and Principal Toolbars (Microsoft Windows), the Tool Palette (Mac OS X) or from the
Tools menu.

Keyboard Shortcut: Spacebar
SketchUp Select Tool: Selecting a single entity
L3

Selecting a single entity

SketchUp allows you to make both single-entity and multiple-entity selections. To select a single entity:

1. Select the Select tool ( k ). The cursor changes to an arrow.
2. Click on an entity. The selected entity is highlighted in yellow.

Tip: To select or unselect all geometry, choose Edit > Deselect All, press Ctrl+T (Microsoft Windows) or Shift+ Command+A (Mac OS X). Alternatively, click on
any empty space in the drawing area to de-select all currently selected entities.

SketchUp Select Tool: Selecting multiple entities
L3

Selecting multiple entities
There are multiple ways to select multiple entities in SketchUp. These ways are:

e Selecting multiple entities with a selection box.
e Selecting connected entities using rapid mouse clicking.
e Selecting connected entities using the Select context-menu item.

Selecting multiple entities with a Selection box
A selection box is an expandable temporary box used to select multiple entities. Selection box selections are useful when you want to perform a single operation
on several connected or disconnected entities (the selection set). To select multiple entities:

1. Choose the Select tool. The cursor will change to an arrow.
2. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.
3. Drag the mouse to expand the selection box over the elements you want to select.
o Clicking to the right-side and dragging to the left, called a crossing selection, selects any elements within the selection rectangle, including those
that are only partially contained in the rectangle. The following images show a right-to-left selection selecting two components, though none are
completely within the bounds of the selection box.

i U

o Clicking to the left-side of the entities and dragging right, called a window selection, selects only those elements completely within the selection
rectangle. The following image shows a left-to-right selection selecting one component because only one component (the left speaker) is completely
within the bounds of the selection box.
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4. Release the mouse button when all of the elements are either partially included (right-to-left selection) or fully included (left-to-right selection) in the
selection box.

Selecting connected entities using rapid mouse clicking
Rapidly clicking the mouse button will select one or more additional connected entities. To Select a face and its bounding edges:

1. Choose the Select tool. The cursor will change to an arrow.
2. Double-click on a face to select the face and all of its bounding edges. The selected entities are highlighted.

To select just a face and an edge:

1. Choose the Select tool. The cursor will change to an arrow.
2. Double-click on an edge to select the connected face. The selected entities are highlighted.

To select all entities connected to a single entity:

1. Choose the Select tool. The cursor will change to an arrow.
2. Triple-click rapidly on any entity, in a set of connected entities, to select all of the connected entities. For example, if you triple-click a face in a cube, the
entire cube is selected. Selected entities are highlighted.

Selecting connected entities using the Select context-menu item
Use the Select context-menu item to select entities based on their specific relationship to the currently selected entity. To use the Select men item:

. Select the Select tool ( 3 ). The cursor will change to an arrow.
. Context-click on a single entity, such as an edge or face. The entity's context-menu appears.
. Select the Select menu item. A sub-menu appears.
. Select one of the Select sub-menu items:
o Select Bounding Edges if you want to select all the bounding edges of a selected face.
o Select Connected Faces to select all of the faces connected to the selected entity.
o Select All Connected to select all entities connected to the selected entity (this is identical to performing a triple-click on the entity).
o
o

HAWN R

Select All on same Layer to select all the entities on the same layer as the selected entity.
Select All with same Material to select all the entities on with the same material as the selected entity.

SketchUp Select Tool: Expanding the selection set
L3

Expanding the selection set using the mouse

You can automatically add to a selection set by clicking the mouse button (while in the Select tool) multiple times in rapid succession. Click once on an entity to
select that entity. Click rapidly twice (double-click) on an entity, namely an edge or face, to select corresponding faces or edges respectively. Click three times
(triple-click) on an entity, namely an edge or face, to select the edge or face and all entities physically connected to that edge or face. The following image shows
this click/selection sequence.

ok 5
%

Tip: Use a context-click to invoke the context menu for an entity. Many context menus have a Select submenu allowing you to expand a selection using one of
the following commands: Bounding Edges, Connected Faces, All Connected, All on same layer, and All with same material.

SketchUp Select Tool: Adding and subtracting from a selection set

LY

Adding and subtracting from a selection set
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The Select tool can be used with one or more keyboard modifiers to add or remove entities from a selection set.

Adding to the selection set

Press and hold the Ctrl (Microsoft Windows) or Option (Mac OS X) key (the cursor will change to an arrow with a plus sign) while clicking on additional entities to
add entities, one-by-one, to the selection set. Or, press and hold the Shift key (the cursor will change to an arrow with a plus and minus signs) while clicking on
additional entities to add entities, one-by-one, to the selection set.

Changing selection status for an entity (Shift)
Press and hold the Shift key (The cursor will change to an arrow with plus and minus signs) while clicking on entities to invert the selection status of the entity
(currently selected entities will become unselected, unselected entities will be come selected).

Subtracting from the selection set

Press and hold the Shift and Ctrl (Microsoft Windows) or Option (Mac OS X)keys simultaneously (the cursor will change to an arrow with a minus sign) while
clicking on currently selected entities to remove entities from the selection set. Or, press and hold the Shift key (the cursor will change to a plus sign and minus
sign) while clicking on currently selected entities to remove the entities, one-by-one, from the selection set.

Tip: Use the Group entity to group items within a selection set as a temporary way of quickly reselecting the same group of items. See the Group entity for
additional information.

SketchUp Select Tool: Selecting or deselecting all geometry
Select All

Select Edit > Select All, or press Ctrl+A (Microsoft Windows) or Command+A (Mac OS X) to Select all currently selected entities.

Deselect All

Select Edit > Deselect All, press Ctrl+T (Microsoft Windows) or Shift+Command+A (Mac OS X) or click on any empty space in the drawing area to de-select all
currently selected entities.
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Eraser Tool
SketchUp Eraser Tool: Introduction

Ve /
'\/Eraser tool introduction

Use the Eraser tool to delete entities. The Eraser tool can also be used to hide and soften edges. Activate the Eraser tool from the Principal Toolbar(Microsoft
Windows), the Tool Palette (Mac OS X), or by selecting Eraser from the Tools menu.

Keyboard Shortcut: E

SketchUp Eraser Tool: Erasing

,é] . .
“# Erasing entities

As mentioned previously, the Eraser tool is used to erase entities in the drawing area. Note, the Eraser tool does not allow you to erase faces (faces are erased
after their bounding edges are erased). To erase entities:

Ve /
1. Select the Eraser tool ( '\/ ). The cursor changes to an eraser with a small box.

2. Click on an entity to erase it. Alternatively, erase several entities at once by holding down the mouse button and dragging it over several entities to be
erased. All selected geometry will be erased once you release the mouse button.

If you accidentally select geometry you do not wish to delete, press the Esc key to cancel the erase operation before it deletes your selection.
Tip: Try erasing entities slowly if you continuously skip over entities you want to erase.

Tip: It is usually faster to erase a large number of entities by selecting the entities with the Select tool and pressing the Delete key on your keyboard. You can also
delete selected items by selecting Erase from the Edit menu.

Hiding lines
Press and hold the Shift key and use the Eraser tool to hide lines (instead of erasing lines).

SketchUp Eraser Tool: Soften edges
,47 . .
4 Softening or unsoftening edges

Press and hold the Ctrl (Microsoft Windows) or Option key (Mac OS X) key to soften/smooth edges (instead of erasing entities). Press and hold the Shift and Ctrl
(Microsoft Windows) or Option (Mac OS X) keys simultaneously to unsoften/unsmooth edges.
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Paint Bucket tool
Paint Bucket Tool: Introduction

‘GPaint Bucket tool introduction

Use the Paint Bucket tool to assign materials and colors to entities in your model. You can use it to paint individual entities, fill a number of connected faces, or
replace a material with another throughout your model. Activate the Paint Bucket tool from the Principal Toolbar (Microsoft Windows), the Tool Palette(Mac OS X),
or by choosing Paint Bucket from the Tools menu.

The Paint Bucket tool is separate from the Apple Color Picker used to select colors and materials (Mac OS X).

Keyboard Shortcut: B

Paint Bucket Tool: Applying materials

‘6 Applying materials and color

Ensure you are using either the Shaded or Shaded with Textures style so that you can see materials as they are applied to your model. To apply materials
(Microsoft Windows):

1. Select the Paint Bucket tool. The cursor will change to a paint bucket and the Material Browser is activated. The Materials Browser contains libraries of
materials you can paint on faces in your model.

2. Select a materials library using the drop down list in the Materials Browser. SketchUp contains several default materials libraries, including landscape,
roofing, and transparent materials.

3. Select a material from the materials library.

4. Click on the faces to paint. The material is assigned to the face.

To apply materials from the Apple Color Picker (Mac OS X):

1. Select the Paint Bucket tool and then select the material you want to use from the Apple Color Picker. To select a materials library first click the Brick icon
at the top of the Color Picker and then select a materials library using the drop down list. Click the Paint Bucket tool's cursor over the entity or selection set
you wish to color.

2. Alternatively, click and drag a material swatch from the Texture Pallet picker and drop it on the a single entity or selection you want to color.

Paint Bucket Tool: Fill options

‘6 Fill options

The Paint Bucket tool can be used with one or more keyboard modifiers to perform various painting operations.

Element fill
The Paint Bucket tool normally operates by filling in faces as you click on them. As mentioned previously, entities selected with the Select tool can be painted with
a single click of the Paint Bucket tool.

Note: Selecting a number of entities with the Select tool and painting causes just the entities within the selection set to be painted.
Adjacent fill

Press and hold the Ctrl (Microsoft Windows) or the Option (Mac OS X) key while clicking on a face with the Paint Bucket tool to fill that face and any adjacent
(connected) face with the same material. The face you click on and the adjacent face must have the same material prior to performing this operation.

Note: Selecting a number of entities with the Select tool and painting using the Ctrl (Microsoft Windows) or the Option (Mac OS X) modifier key causes just the
entities within the selection set to be painted.

Replace
Press and hold the Shift key prior to clicking on a face with the Paint Bucket tool to apply a material to every face, with the same material in the current context,
with the new material.

Note: Selecting a number of entities with the Select tool and painting using the Shift modifier key causes just the entities within the selection set to be painted.

Adjacent replace
Press and hold both the Shift and the Ctrl (Microsoft Windows) or the Option (Mac OS X) keys simultaneously while painting to only replace the material on the
face within the confines of geometry that is physically connected to that face.
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Paint Bucket Tool: Groups and components

‘6Painting groups and components

Materials can be painted on entire Group entities or Component entities or to the individual entities within the group or component. To assign materials to an
entire group or component:

1. Select the Paint Bucket tool. The cursor will change to a paint bucket and the Material Browser is activated. The Materials Browser contains libraries of
materials you can paint on faces in your model.

2. Select a materials library using the drop down list box. SketchUp contains several default materials libraries, including landscape, roofing, and transparent
materials.

3. Select a material from the library of materials.

4. Click on the group or component you want to paint. The faces will receive the material.

5. If you select multiple groups or components using the Select tool, clicking on the selection with the Paint tool will paint all of them with a single click.

Note: If a face within a group or component is already painted with a material (other than the default material), before applying a material to the entire group or
component, the face will not adopt the new material. For example, the windshields, bumpers, and tires in the following image were already painted before a
material was applied to these components. Therefore, the windshields, bumpers, and tires maintained their original material.

Note: Exploding a group or component assigns the object materials to any elements assigned the default material, thus making the material override permanent.

Paint Bucket Tool: Face Rules

‘6 Face painting rules
There are several face painting rules that apply when painting multiple faces or edges at the same time. These rules follow:

e The side of the faces that will be painted depends on the side initially painted when more than one face is selected. For example, if all faces are selected
and you paint the front of one face, the front of all faces will be painted. Conversely, if all faces are selected and you paint the back of one face, all back
faces will be painted.

e All selected edges will be painted when you select a face and all edges and paint the front of the face. No edges are painted when you select a face and all
edges and paint the back of one face. In order to see the painted effect applied to edges, you'll need to display the edge color by material. To do so, open
the Styles Browser (under the Window menu), choose the Edit tab, and select the Edge Settings button. Finally, choose By material from the Color menu.

Paint Bucket Tool: Sampling

‘8 Sampling a material

Press and hold the Alt (Microsoft Windows) or Command (Mac OS X) key to change from the Paint Bucket tool to a Sample tool for sampling materials within your
model. The cursor will change to an eye dropper. Click on the face whose material you want to sample. Release the Alt (Microsoft Windows) or Command (Mac OS
X) key to return to the Paint Bucket tool. Paint the sampled material on a face.

Note: The sampled material is placed in the Active Color Well of the Color Picker, where it can be painted on new entities, modified, or used as the basis of a new
material (Mac OS X).
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Line Tool
SketchUp Line Tool: Introduction

/Line tool introduction

Use the Line tool to draw edges or Line entities. Line entities can be joined to form a face. The Line tool can also be used to divide faces or heal deleted faces.
Activate the Line tool from the Toolbar / Tool Palette or from the Draw menu.

Keyboard Shortcut: L

SketchUp Line Tool: Drawing a line

/ Drawing a line

Lines can be placed on existing faces or separate from existing geometry. To draw a Line: /

. Select the Line tool (/). The cursor changes to a pencil.
2. Click to set the starting point of your line.

-

Note: Press the Esc key at any point during the operation to start over.

3. Move the cursor to the ending point of your line. As you draw a line, the length is displayed dynamically in the Measurements Toolbar.
4. Click to draw your line. This ending point can also be the starting point of another line.

The line length can be specified precisely using the Measurements Toolbar either before clicking the second point or immediately after the line has been drawn.
See Creating Precise Lines for further information on using the Measurements Toolbar with Line entities.

Tip: Alternately, you can click and hold the mouse button to set the starting point of the line, and drag outward without releasing the button to set the length.
Release the mouse button to complete the line. See the Drawing panel of the Preferences dialog box for further information on setting drawing behavior.

SketchUp Line Tool: Creating precise lines

/ Creating precise lines
The Measurements Toolbar displays the length of your line while you are drawing lines. You can also specify a line length value using the Measurements Toolbar.
Entering a length value

The Measurements Toolbar label indicates 'Length’ after you place the starting point of a line. The following image shows the length value in the Measurements
Toolbar.

Length 4' 2 5/8"

Type the length into the Measurements Toolbar, after placing the starting point of the line, and press the Enter (Microsoft Windows) or Return (Mac OSX) key.
SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at
any time, regardless the model units setting.

Note: The Line tool will snap to any previously entered length within the Measurements Toolbar.

Entering a 3D coordinate
The Measurements Toolbar can also be used to place the end of the line at an exact coordinate in space.

Length [3',5',7'] 4

Entering an Absolute Coordinate
Type in the coordinates of a point in 3D space enclosed by brackets, such as [x, y, z], to get absolute coordinates relative to the current axes.

Length |<1.5m,4m,2.75m> ¢|

Entering a Relative Coordinate
Type the coordinate points enclosed by angle brackets, in the format , where X, y, and z values are relative distances from the starting point of your line.

Note: The exact format for Measurements Toolbar entries will vary depending on your computer's Regional Settings. For European users, the list separator
symbol may be a semi-colon instead of a comma, so the format would be [x;y;z].

SketchUp Line Tool: Creating a face

/ Creating a face

Face entities are flat plane-like entities that combine to form the 3D geometry in a SketchUp model. Faces are automatically created when any three or more
intersecting lines or edges are in the same plane (an infinite flat 2D space), or coplanar. To create a face using the Pencil tool:

. Select the Line tool (/). The cursor changes to a pencil.

. Click to set the starting point of your line.

. Move the cursor to the ending point of your line. As you draw a line, the length is displayed dynamically in the Measurements Toolbar.
. Click to draw your line. This ending point can also be the starting point of another line.
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5. Move the cursor to an ending point for the second line.
57



6. Click to draw your line. This ending point can also be the starting point of another line.

'

7. Move the cursor to the starting point of the first line. The tip of the Pencil cursor changes to a green circle and says "Endpoint."

"

Endpoint

8. Click to draw your line. A face is created.

Tip: Set the display settings (View > Face Style > Shaded) to the "Shaded" or "Shaded With Textures" rendering style to clearly show new faces as they are
created.

SketchUp Line Tool: Editing a line entity

/ Editing a line entity
You can edit the length the of a Line entity, that does not yet bound a face, by using the Move tool. To edit an Line entity:

. Select the move tool. The cursor will change to a four-way arrow.
. Move over the Line entity to locate an endpoint of the Line entity.
. Click and hold on the endpoint of the Line entity.

. Move the cursor to adjust the length of the Line entity.
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You can also adjust the length using the Line entity's Entity Info dialog box.

SketchUp Line Tool: Drawing lines by inference

/Drawing lines by inference

The Line tool uses SketchUp's sophisticated geometric inference engine to help you place your lines in 3D space. The inference decisions, made by the inference
engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the line you are
drawing and the geometry of your model. Refer to the inference engine topic for additional information.

Locking a line to the current inference direction

Press and hold the Shift key, while the line you are drawing is the specific color of an axis, to lock drawing operation to that axis. 58



Locking a line to a specific inference direction
Press and hold either the up arrow, left arrow, or right arrow keys, where the up arrow equals blue, left arrow equals green, right arrow equals red, while drawing
a line to lock the line to a specific axis.

SketchUp Line Tool: Dividing lines into equal segments

/ Dividing a line into equal segments
Line segments can be divided into any number of equal line segments. To divide a line into equal segments:
1. Context-click on a line.
2. Select Divide from the context menu. SketchUp will place points on the line to show where the line will be divided.
3. Move the cursor toward the center of the line to reduce the number of segments. Move cursor toward either end of the line to increase the number of

segments.
4. Click on the line when the number of segments you would like is shown. The line will be divided into an equal number of joined line segments.

SketchUp Line Tool: Splitting a line

/ Splitting a line

SketchUp automatically splits line segments when new lines are drawn perpendicular to \f
a line. For example, draw a new line to the midpoint (identified by a cyan square) of / Midpoint
another line to split a line in half. The following example shows one line being . : - ﬁ\
intersected at the midpoint, resulting in two lines. B :

Select the original line to verify that the line has been split into two equal segments.

Dividing a line into equal segments
Line segments can be divided into any number of equal line segments. To divide a line into equal segments:

1. Context-click on a line.

2. Select Divide from the context menu. SketchUp will place points on the line to show where the line will be divided.

3. Move the cursor toward the center of the line to reduce the number of segments. Move cursor toward either end of the line to increase the number of
segments.

4. Click on the line when the number of segments you would like is shown. The line will be divided into an equal number of joined line segments.

SketchUp Line Tool: Splitting a face

/ Splitting a face

Draw a line with starting and ending points on the face's edges to split a face. The following image shows a rectangle being split when a line is drawn from one
edge of a face to another opposite edge.

SketchUp Line Tool: Line entities

/Line entities

Lines, also referred to as edges, form the structural foundation of all models. Draw lines with the Line tool.
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Arc Tool
SketchUp Arc Tool: Introduction

( Arc tool introduction

Use the Arc tool to draw Arc entities: arcs comprised of multiple connected line segments (which can be edited as a single arc). Activate the Arc tool from the
Toolbar / Tool Palette or from the Draw menu.

Keyboard Shortcut: A

SketchUp Arc Tool: Drawing an arc

( Drawing an arc

Arc entities consist of three parts: the starting point, the ending point and the bulge distance. The distance between the starting point and the ending point is
also known as the chord length. To draw an arc:

. Select the Arc tool ((\). The cursor changes to a pencil with an arc.

. Click to place the starting point of your arc.

Move the cursor to the ending point of your chord.

. Click to place the ending point of your arc. A straight line is created.

. Move your cursor perpendicular to the straight line to adjust the bulge distance. A straight line will extend
perpendicular from the straight line.
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Note: Press the ESC key at any point during the operation to start over.

6. Click to set the bulge distance.

Chord length can be specified after you place the ending point of your arc. Bulge distance, radius, and number of segments can be specified using the
Measurements Toolbar immediately after a arc is drawn. See Creating Precise Arcs for more information on manipulating arcs using the Measurements Toolbar.

SketchUp Arc Tool: Creating precise arcs

( Creating precise arcs

The Measurements Toolbar displays the chord length of the arc (after setting the starting point), then the bulge distance (after setting the ending point). Use the
Measurements Toolbar to enter exact lengths for the chord length, bulge distance, radius value, and number of segments.

Note: SketchUp will use the current file units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at
any time, regardless the file's units setting. Units are set within the Units panel of the Model Info dialog box.

Entering a chord length

The Measurements Toolbar's label indicates 'Length' after you place the starting point of an arc. Type the chord length into the Measurements Toolbar, after
placing the starting point of the arc, and press the Enter (Microsoft Windows) or Return (Mac OSX) key. Specify a negative value, such as -6.5" to indicate that
you want the length to apply in an opposite direction to the current drawing direction.

Specifying a bulge distance

The Measurements Toolbar's label indicates 'Bulge’ after you place the ending point of an arc. Type the bulge length in the Measurements Toolbar, after placing
an ending point, and press the Enter (Microsoft Windows) or Return (Mac OS X) key. You can also enter the bulge distance after the creation of the arc as long as
'Bulge' is displayed as the Measurements Toolbar label. Negative bulge values can also be used to create an arc in an opposite direction to the current drawing
direction.

Specifying a radius

You can specify an arc radius instead of a bulge distance. Type the desired radius in the Measurements Toolbar, followed by the letter r and press the Enter
(Microsoft Windows) or Return (Mac OS X) Key. You can perform this action either during or immediately following the creation of the arc. For example: 24r or
3'6"r or 5mr.

Specifying the number of segments
You can also specify the number of segments in an arc. Type the number of segments in the Measurements Toolbar, followed by the letter s, and press the Enter
(Microsoft Windows) or Return (Mac OS X) key. You can perform this action either during or immediately following the creation of the arc. For example: 20s.

SketchUp Arc Tool: Editing an arc entity

(\ Editing an arc entity

You can edit the radius of an Arc entity by using the Move tool. To edit an Arc entity:

. Select the Move tool (a). The cursor will change to an four-way arrow.
Move over the Arc entity to locate the midpoint of the Arc entity.
. Click and hold on the midpoint of the Arc entity.
Move the cursor to adjust the bulge of the Arc entity. R
. Click and hold on the starting or ending point of the Arc. ;\_’//
Move the mouse to adjust the radius and length of the arc entity. The radius attempts to stay

proportional to the base chord length.

oOuhwNE

You can also adjust the radius and number of segments using the Arc entity's Entity Info dialog box.

SketchUp Arc Tool: Editing an extruded arc

60



r Editing an extruded arc

When you use the Push/Pull tool to extrude a 2D face that includes an arc, it extrudes a special arc Surface
entity which can also have its radius edited. Use the Move tool to reposition the midpoint edge, and the
arc curved face set (as well as the midpoints of the two arc entities that define it) will move accordingly.

SketchUp Arc Tool: Drawing a half-circle

C Drawing a half-circle

The arc temporarily snaps to a half-circle as you pull out a bulge distance. Watch for the half-circle inference tool tip indicating when your arc is a half-circle.

i

SketchUp Arc Tool: Drawing tangent arcs

( Drawing tangent arcs

The Arc tool displays a cyan tangent arc while you are drawing from an unconnected end or start point of an existing arc.

ol
Tangent at vertex

SketchUp Arc Tool: Arc entities

( Arc entities

Arc entities are a combination of multiple line segments connected together to approximate the curvature of the arc. These entities act as a single line in that
they can define the edge of a face and also divide a face. Additionally, selecting one segment of the arc selects the entire Arc entity. However, all inference
techniques will operate on the Arc as though it were comprised of segments. For example, every point on the arc is inferred as an endpoint of the segment. Draw
Arcs with the Arc tool.

Note: You can explode a arc into regular edge segments using the Explode Curve context menu item (see the Arc Context Menu Items section later in this topic).
Arc entities are comprised of a length (also called the base chord), bulge, radius, and number of segments. The following image shows an Arc entity.
Note: Arc and Circle entities are special in that they automatically produce softened edges when extruded using the Push/Pull tool.

Arc segmentation

Arcs with more line segments appear to have smoother curvature than arcs with fewer line segments. However, more line segments increases the size of your
model and degrades performance. You can often achieve acceptable results by indicating small segmentation and using smoothing and edge softening to create
the impression of smoothness.

Arc deformation
If an Arc is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric Curve entity.
Polyline Curves can no longer be edited as arcs.
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Freehand Tool

SketchUp Freehand Tool: Introduction

@ Freehand tool introduction

Use the Freehand tool to draw irregular hand-drawn lines in the form of Curve entities and 3D Polyline entities. Curve entities are comprised of multiple line
segments that are connected together. These curves behave as a single line in that they can define and divide faces. They are also connected such that selecting
one segment selects the entire entity. Curve entities can be useful for representing contours in a contour map or other organic shapes. Activate the Freehand tool
from the Toolbar / Tool Palette or from the Draw menu.

SketchUp Freehand Tool: Drawing curves

@ Drawing curves
Curves can be placed on existing faces or separate from existing geometry (aligned to an axes plane). To draw a curve:

1. Select the Freehand tool. The cursor will change to a pencil with a curve.
2. Click and hold to place the starting point of your curve.
3. Drag the cursor to draw.

¥

4. Release the mouse button to stop drawing.
5. (optional) End your curve at point where you started drawing to draw a closed shape.

SketchUp Freehand Tool: Drawing 3D polylines

@ Drawing 3D polyline entities
3D polylines do not generate inference snaps or affect geometry in any way. 3D polylines are usually used for tracing imported drawings, 2D sketching, or for

decorating your model. Press and hold the Shift key, before you begin drawing, to draw a 3D polyline.

Note: Select Explode from the 3D polyline's context menu to convert a Freehand Sketch into regular edge geometry.

SketchUp Freehand Tool: Editing a curve entity

@ Editing a curve entity
You can change the length of a Curve entity, that does not yet bound a face, by using the Move tool. To edit a curve:

. Select the Move tool. The cursor will change to an four-way arrow.

. Move over the Curve entity to locate an endpoint of the Curve entity.
. Click and hold on the endpoint of the Curve entity.

. Move the cursor to adjust the length of the Curve entity.

D wWN

SketchUp Freehand Tool: Curve entities

@ Curve entities

SketchUp's Curve entities are a combination of multiple line segments that are connected together. These entities act as a
single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the curve
selects the entire Curve entity.

Draw curves with the Freehand tool.

Note: You can explode a curve into regular edge segments using the Explode Curve context menu item (see the Curve
Context Menu Items section later in this topic).

The following image contains a Curve entity. Curves can begin and end at the same point (as in the following image) or start
and end at different points.

Note: The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Curve entity (the continuous edge). 62



SketchUp Freehand Tool: 3D polyline entities

@ 3D polyline entities

SketchUp's 3d Polyline entities are curve-like entities that do not generate inference snaps or affect geometry in any way. Freehand sketches are usually used for
tracing imported drawings, 2D sketching, or for decorating your model.

Draw 3D Polyline entities with the Freehand tool.

Note: You can explode a freehand sketch into regular edge segments using the Explode context menu item (see the 3D Polyline Context Menu Items section later
in this topic).

Note: A 3D Polyline looks just like a Curve entity, but is thinner.
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Rectangle Tool

SketchUp Rectangle Tool: Introduction

@Rectangle tool introduction

Use the Rectangle tool to draw rectangular Face entities, specified by clicking at two opposite corners of the desired shape. Activate the Rectangle tool from the
Toolbar / Tool Palette or from the Draw menu.

SketchUp Rectangle Tool: Drawing a rectangle

@Drawing a rectangle
Rectangles can be placed on existing faces or separate from existing geometry (aligned to an axes plane). To draw a rectangle:
. Select the Rectangle tool (@). The cursor changes to a pencil with a rectangle.

. Click to set the first corner point of the rectangle.
. Move the cursor diagonally.
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Note: Press the ESC key at any point during the operation to start over.

4. Click again to set the second corner point of the rectangle.

SketchUp Rectangle Tool: Drawing a square

@ Drawing a square

Squares are created with the rectangle tool in conjunction with the Square tool tip. To draw a Square:

. Select the Rectangle tool (@). The cursor changes to a pencil with a rectangle.

. Click to set the first corner point of the rectangle.

. Move your mouse to the opposite corner. A diagonal dotted line will appear, along with a Square tool tip, when you are in a position that will create a
square.
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Note: Press the Esc key at any point during the operation to start over.

4. Click to finish.
Tip: A dotted line and Golden Section tool tip appears when you are in a position to create a Golden Section.
Alternately, you can press your mouse button on the first corner of your rectangle, drag to the opposite corner, and release the mouse button.

Tip: Use the Axes tool to re-align the axes, prior to drawing your rectangle, if you want to draw a rectangle that is not aligned with the default drawing axes
orientation.

SketchUp Rectangle Tool: Creating precise rectangles

@ Creating precise rectangles

A rectangle's dimensions dynamically appear in the Measurements Toolbar as you draw. Specify exact length and width dimensions by typing them in the
Measurements Toolbar, and pressing Enter (Microsoft Windows) or Return (Mac OS X) either after the first corner is clicked or immediately after the rectangle is
drawn.

Dimensions W %

SketchUp will use the current document units setting if you only type in a numerical value. You can also specify either Imperial (such as 1'6") or Metric (such as
3.652m) units at any time, regardless the document units setting.

You can also type one dimension at a time in the Measurements Toolbar. If you enter a value and a comma (3',), the new value will be applied to the first
dimension, and the second dimension will be retained from before. Similarly, if you type a comma and then a value (,3"), only the second dimension will be
changed.

Note: if you're using a non-English keyboard, you'll want to use a comma to indicate the decimal place and a semi-colon to separate the dimensions. For
example, you might enter two sides of a rectangle as: 7,6m;4,3m

Tip: If you enter a negative value (-24, -24), SketchUp will apply that value in a direction opposite to the one you indicated while drawing and accept any new
values in the new direction.

SketchUp Rectangle Tool: Drawing rectangles by inference

m Drawing rectangles by inference

The Rectangle tool uses SketchUp's geometric inference engine to help you place your rectangles in 3D space. The inference decisions, made by the inference
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engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the rectangle you are
drawing and the geometry of your model.

For example, if you move your mouse over an endpoint of an existing edge and then move away in the direction of an axis, a dotted inference line with a From
Point tool tip will appear.

From Point

This tool tip indicates that you are aligned to that end point. You can also use a From Point inference to draw rectangles vertically or at non-orthogonal planes.

SketchUp Rectangle Tool: Locking a rectangle to the current inference direction

l Locking a rectangle to the current inference direction

Press and hold the Shift key, while the rectangle you are drawing is the specific color of an axis, to lock drawing operation to that axis.

SketchUp Rectangle Tool: Face entities

‘ Face entities

Face entities are flat plane-like entities that combine to form the 3D geometry in a SketchUp model. Faces are automatically created when any three or more
intersecting lines or edges are in the same plane (an infinite flat 2D space), or coplanar.

The edges that bound a face remain when you delete a face. However, a face is erased automatically when you delete one of its bounding edges. SketchUp will
create new edges and faces using the Auto-fold feature if you alter one of the edges of a face so that it is no longer co-planar with that face.

Draw faces with the Line Tool, Arc Tool, Freehand Tool, Rectangle Tool, Circle Tool, or Polygon tool. The following image was created simply by joining arcs and
lines to form the edges and subsequent faces.
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Circle Tool

SketchUp Circle Tool: Introduction
O Circle tool introduction
Use the Circle tool to draw Circle entities. Activate the Circle tool from the Toolbar / Tool Palette or from the Draw menu.

Keyboard Shortcut: C

SketchUp Circle Tool: Drawing a circle

O Drawing a circle
Circles can be placed on existing faces or separate from existing geometry. To draw a circle:
1. Select the Circle tool (O). The cursor changes to a pencil with a circle.
2. Click to place the center point of the circle.
3. Move the cursor out from the center point to define the radius of your circle. As you move the cursor, the radius value is displayed dynamically in the

Measurements Toolbar and can be specified by typing in a length value followed by the Enter (Microsoft Windows) or Return (Mac OS X) key. You can also
specify the segmentation for the circle in the Measurements Toolbar.

Note: Press the ESC key at any point during the operation to start over.
4. Click to finish the circle.

Tip: You can also click and hold the mouse button to set the center of the circle, and drag outward without releasing the button to set the radius. Release
the mouse button to complete the circle.

Radius and segment values can be specified using the Measurements Toolbar immediately after a circle is drawn. See Specifying Precise Circle Values for more
information on setting the radius and segment values with the Measurements Toolbar.

SketchUp Circle Tool: Creating precise circles

O Creating Precise Circles

The Measurements Toolbar displays the radius after setting the center point of a circle. Use the Measurements Toolbar to enter an exact radius and number of
segments.

Specifying a Radius

The Measurements Toolbar's label indicates "Radius" after you place the center point of the circle. Type the radius size in the Measurements Toolbar, after
placing the center point, and press the Enter (Mac OS X) or Return (Mac OS X) key. You can perform this action either during or immediately following the
creation of the circle. For example: 24r or 3'6"r or 5mr.

Note: The Circle Tool will snap to any previously entered radius within the Measurements Toolbar.
Specifying the Number of Sides
The Measurements Toolbar's label indicates "Sides" when the Circle Tool is initially activated. Specify the number of sides in the Measurements Toolbar, and press

the Enter (Microsoft Windows) or Return (Mac OS X) key, before clicking to set the center point of the circle. For example: 100.

You can also specify the number of sides in a circle immediately after the creation of the circle. Type the number of sides in the Measurements Toolbar, followed
by the letter s, and press the Enter (Microsoft Windows) or Return (Mac OS X) key. For example: 20s. This number will be applied to any future circles.

Note: The default number of segments for a circle is 24.

SketchUp Circle Tool: Editing a circle entity

O Editing a Circle Entity
You can edit the radius of an Circle entity that does not yet bound a face by using the Move Tool. To edit an Circle entity:

. Select the Move Tool. The cursor will change to an four-way arrow.

. Move over the Circle entity to locate one of the four cardinal points of the Circle entity.
. Click and hold on the cardinal point of the Circle entity.

. Move the cursor to adjust the radius of the Circle entity.
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You can also adjust the radius and number of segments using the Circle entity's Entity Info

The inference engine sometimes can get distracted, preventing it from snapping to the center of a circle. You can encourage a center point inference by hovering
the mouse cursor over the edges of the circle and then moving it towards the center point.

SketchUp Circle Tool: Editing an extruded circle

O Editing an extruded circle

When you use the Push/Pull Tool to extrude a 2D circle, a special cylindrical Surface entity is created. To change the size of the extruded
circle:

1. Select the Move tool (:{). The cursor will change to a four-way arrow.
2. Click on one of the four cardinal points (indicated by a vertical dashed line) on the side of the extruded circle.
3. Move the cursor inward to decrease the size of the extruded circle or outward to increase the size of the extruded circle.

Circle segmentation

Circles with more line segments appear to have smoother curvature than circles with fewer line segments. However, more line segments increases the size of
your model and degrades performance. You can often achieve acceptable results by indicating small segmentation and using smoothing and edge softening to
create the impression of smoothness. 66



Circle deformation
If an Arc is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric Curve entity.
Polyline curves can no longer be edited as arcs.

SketchUp Circle Tool: Locking a circle to its current orientation
O Locking a circle to its current orientation
Press and hold the Shift key, before you begin drawing a circle, to lock drawing operation to that orientation.

SketchUp Circle Tool: Circle entities

O Circle entities

Circle entities are a combination of multiple line segments that are connected together to form a circle. These entities act as a
single line in that they can define the edge of a face and also divide a face. Additionally, selecting one segment of the arc selects
the entire Circle entity. However, all inference techniques will operate on the Circle as though it were comprised of segments. For
example, every point on the circle is inferred as an endpoint of the segment. Draw circles with the Circle tool.

Note: You can explode an Circle into regular edge segments using the Explode Curve context menu item (see the Circle Context
Menu Items for more information).

Circle entities are comprised of a radius and number of segments. The following image shows a Circle entity with 24 segments.

Note: The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Circle entity (the circular edge).

Note: Arc and Circle entities are special in that they automatically produce softened edges when extruded using the Push/Pull tool.
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Polygon Tool

SketchUp Polygon Tool: Introduction

g Polygon tool introduction

Use the Polygon tool to draw regular Polygon entities. Activate the Polygon tool from the Toolbar / Tool Palette or from the Draw menu.

SketchUp Polygon Tool: Drawing a polygon

V Drawing a polygon

Polygons can be placed on existing faces or separate from existing geometry. To draw a polygon: 9}7 O

. Select the Polygon tool (v). The cursor changes to a pencil with a polygon.

. Click to place the center point of the polygon.

3. Move the cursor out from the center point to define the radius of your polygon. As you move the cursor, the radius value is displayed dynamically in the
Measurements Toolbar and can be specified by typing in a length value followed by the Enter (Microsoft Windows) or Return (Mac OS X) key.
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Note: Press the ESC key at any point during the operation to start over.

4. Click a second time to finish the polygon. (Alternately, you can click once to set the center of the polygon, and drag outward without releasing the button
to set the radius. Release the mouse button to complete the polygon.)

Radius and segment values can be specified using the Measurements Toolbar immediately after a polygon is drawn. See Creating Precise Polygons for more
information on setting the radius and segment values with the Measurements Toolbar.

SketchUp Polygon Tool: Drawing precise polygons

v Drawing precise polygons

The Measurements Toolbar displays the radius after setting the center point of a polygon. Use the Measurements Toolbar to enter an exact radius and number of
segments.

Specifying a Radius

The Measurements Toolbar's label indicates 'Radius' after you place the center point of the polygon. Type the radius size in the Measurements Toolbar, after
placing the center point, and press the Enter (Microsoft Windows) or Return (Mac OS X) key. You can perform this action either during or immediately following
the creation of the polygon. For example: 24r or 3'6"r or 5mr.

Note: The Polygon tool will snap to any previously entered radius within the Measurements Toolbar.

Specifying the Number of Sides
The Measurements Toolbar's label indicates 'Sides' when the Polygon tool is initially activated. Specify the number of sides in the Measurements Toolbar, and
press the Enter (Microsoft Windows) or Return (Mac OS X) key, before clicking to set the center point of the polygon. For example: 10.

You can also specify the number of sides in a polygon immediately after the creation of the polygon. Type the number of sides in the Measurements Toolbar,
followed by the letter s, and press the Enter (Microsoft Windows) or Return (Mac OS X) key. For example: 6s. This number will be applied to any future polygons.

SketchUp Polygon Tool: Editing a polygon entity

v Editing a polygon entity

You can edit the radius of a circle in which the polygon is inscribed, that does not yet bound a face, by using the move tool. To edit a Polygon entity:

. Select the Move tool (V). The cursor will change to a four-way arrow.

. Move over the Polygon entity to locate the midpoint of a side. At least one midpoint of the polygon will allow you to resize the entity.

. Click and hold on the midpoint of the Polygon entity.

. Move the cursor to adjust the radius of the Polygon entity. Click and hold on another midpoint if the polygon does not resize. Try each midpoint until you
find the midpoint that will resize the entity.
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You can also adjust the radius and number of segments using the Polygon entity's Entity Info dialog box.

SketchUp Polygon Tool: Editing an extruded polygon

v Editing an extruded polygon

When you use the Push/Pull tool to extrude a 2D face that includes a polygon, it extrudes a special polygonal curved face set which can also have its radius
edited. Use the Move tool to reposition one of the control edges, and the polygonal curved face set radius (as well as the radii of the two polygon entities that
define it) will be adjusted accordingly.

Polygon Deformation

If a polygon is deformed in a way that destroys its radial definition, such as with a non-uniform scale operation, it will become a non-parametric polyline curve.
Polyline curves can no longer be edited as polygons.

SketchUp Polygon Tool: Locking a polygon to its current orientation
V Locking a polygon to its current orientation
Press and hold the Shift key, before you begin drawing a polygon, to lock drawing operation to that orientation.

SketchUp Polygon Tool: Polygon entities o



' Polygon entities

SketchUp's Polygon entities are similar to Faces entities, but can have 3 or more sides. These entities act as a single line in that
they can define the edge of a face and also divide a face. Additionally, selecting one segment of the polygon selects the entire
Polygon entity. However, all inference techniques will operate on the Polygon as though it were comprised of segments. Draw
polygons with the Polygon tool.

Note: You can explode a polygon into regular edge segments using the Explode Curve context menu item (see the Polygon
Context Menu Items section later in this topic).

Polygon entities are comprised of a radius and number of segments. The following image shows a six-sided polygon.

Note: The model in the previous image contains two entities: a Face entity (in the middle) surrounded by a Polygon entity (the six-sided edge).
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Move Tool
Move Tool: Introduction

k Move tool introduction

Use the Move tool to move, stretch and copy geometry. This tool can also be used to rotate components and groups. Activate the Move tool using the
Modification Toolbar (Microsoft Windows), the tool Palette (Mac OS X)or the Tools menu.

Keyboard Shortcut: M

Move Tool: Moving a single entity

k Moving a single entity

You can activate the Move tool when nothing is selected to select a single entity to move. The selection click point becomes the base point for the move
operation. To select and move a single entity:

. Select the Move tool (k). The cursor will change to a four-way arrow.

. Click on an entity to begin the move operation.

. Move the cursor to move the entity. The selected entity will follow as you move the cursor.
. Click at the destination point to finish your move operation.
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Note: If the entity you are moving is connected to other entities, the other entities will be moved or modified accordingly. See the Stretching Geometry section for
further information on this behavior.

Move Tool: Moving several entities

}: Moving several entities

You can preselect several entities to move prior to performing a move operation. To preselect and move entities:

. Select the Select tool ( 3 ). The cursor will change to an arrow.
. Select the entities to be moved.

. Select the Move tool (). The cursor will change to a four-way arrow.

. Click once on an entity to begin the move operation. The point where you click on the entity is called the move point.

. Move your mouse to move the entities. The selected entities will follow as you move your mouse. Also, an inference line will appear between the start and
ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar. You can also type in a specific distance as
described below. The following image shows a component being moved:
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Tip: Follow inference lines to easily align items in 3D space. Select corners of components as your move point and align to corners of other components
when aligning components side-by-side (such as when aligning kitchen cabinet components).

6. Click at the destination point to finish your move operation.

Note: Press the Esc key at any point during the operation to start over.

Move Tool: Moving by inference

k Moving by inference

The Move tool uses SketchUp's sophisticated geometric inference engine to help you place entities in 3D space. The inference decisions, made by the inference
engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between the move operation and
the geometry of your model. Refer to the inference engine topic for additional information.

Locking a move to the current inference direction
Press and hold the Shift key, while the move you are performing is the specific color of an axis, to lock move operation to that axis.

Locking a line to a specific inference direction
Press and hold either the up arrow, left arrow, or right arrow keys, where up arrow equals blue, left arrow equals green, and right arrow equals red, while moving
to lock the move to a specific axis.

Move Tool: Moving precisely

k Moving precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the length of the move operation (displacement) in the default units, as
specified under the Units panel of the Model Info dialog box, while moving, copying, or stretching entities. In addition to creating arrays, you can also specify an
exact displacement or a relative or absolute 3D coordinate for the finishing point during, or immediately after, a move operation.

Entering a Displacement Value
You can specify a new displacement length during or directly following a move operation. To enter a displacement value during a move operation:
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. Select the Select tool (™ ). The cursor will change to an arrow.
. Select the entities to be moved.

. Select the Move tool (*¥). The cursor will change to a four-way arrow.

. Click once to select the start point of the move operation.

. Move your mouse to begin moving the entities in the correct direction. The selected entities will follow as you move your mouse. Also, an inference line will
appear between the start and ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar.

. Type the positive or negative displacement value (such as 20' or -35mm) in the Measurements Toolbar and press the Enter (Microsoft Windows) or Return
(Mac OS X) key.
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Note: You can type values in the Measurements Toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the
default system. For example, you can type in 3' 6" even if you are using metric system as your default.

Entering a 3D Coordinate
SketchUp can move your entities to exact (using [ ]) or relative (using < >) coordinates in 3D space. To enter a 3D coordinate during a move operation:

1. Select the Select tool ( k ). The cursor will change to an arrow.

2. Select the entities to be moved.

3. Select the Move tool (). The cursor will change to a four-way arrow.

4. Click once to select the start point of the move operation.

5. Move your mouse to begin moving the entities in the correct direction. The selected entities will follow as you move your mouse. Also, an inference line will
appear between the start and ending points of the move, and the distance of the move is displayed dynamically in the Measurements Toolbar.

6. Type the exact or relative coordinate.

Global Coordinates: [x, y, z] of the current Sketch Axes:
Length i 35,71 y/

Relative Coordinates: relative to the start point:

Length |<1.5m,4m,2.75m> 7

Note: You can define only one or two values as part of your 3D coordinate. For example, to move geometry to 2 feet in the z or blue direction enter the following
in the Measurements Toolbar: [, ,2"']

Note: The exact format for values typed in the Measurements Toolbar will vary depending on your computer's regional settings. For some European users, the list
separator symbol is a semi-colon instead of a comma. For example, [x; y; z]

Move Tool: Stretching geometry

k Stretching geometry

When you move an element that is interconnected with others, SketchUp will stretch geometry as necessary. You can move points, edges, and faces in this
manner. For example, the following Face entity can be moved back in the negative red direction or up in the positive blue direction:

You can also move single line segments to stretch an object. In the following example, a line is selected and moved up in the blue direction to form a sloped roof.

Move Tool: Moving or stretching with Autofold
k Moving or stretching with Autofold

SketchUp will Autofold faces automatically when a move or stretch operation will create non-planar faces. For example, clicking on the corner of a box with the
Move tool and move down in the blue direction causes SketchUp to create a fold line along the box's top face.
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Forcing Autofold Behavior
There are times when SketchUp constrains an operation in favor of keeping all faces planar and not creating additional fold lines. For example, clicking on the
edge of a box with the Move tool only allows you to move the edge in a horizontal direction (red and green), but not vertically (blue).

You can override this behavior by pressing and releasing the Alt (Microsoft Windows) or Command (Mac OS X) key before performing the move operation. This
key sequence enables Autofold allowing geometry to move freely in any direction.

Move Tool: Making copies

}: Making copies

As mentioned previously, the Move tool can be used to make copies of entities within your model. To make copies of an entity using the move tool:

. Select the Select tool ( k ). The cursor will change to an arrow.
. Select the entities to be copied.

. Select the Move tool (*%). The cursor will change to a four-way arrow.

. Press and release the Ctrl (Microsoft Windows) or Option (Mac OS X) key on your keyboard. The cursor will change to a four-way arrow with a plus sign.
This action informs Sketchup that you want to duplicate the selected entities.

. Click on the selected entities to copy.

. Move the cursor to copy the entities. A copy of the selected entities will follow as you move your mouse.

. Click at the destination point to finish your copy operation. The copied entities are now selected and the original entities are deselected.
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Note: You can press and release the Command (Microsoft Windows) or Option (Mac OS X) key on your keyboard at any time during a move operation to perform
a copy (not just at the start).

Move Tool: Creating multiple copies (linear arrays)

k Creating multiple copies (linear arrays)

The Move tool can also be used to create arrays, or a series of copies of geometry. To create multiple copies of one or more entities:

. Select the Select tool ( 3 ). The cursor will change to an arrow.
. Select the entities to be copied.

. Select the Move tool ( ). The cursor will change to a four-way arrow.

. Press and release the Ctrl (Microsoft Windows) or Option (Mac OS X) key on your keyboard. The cursor will change to an arrow with a plus sign. This action
informs SketchUp that you want to duplicate the selected entities.

. Click on the selected entities to copy.

. Move your mouse to copy the entities. A copy of the selected entities will follow as you move your mouse.

. Click at the destination point to finish your copy operation. The copied entities are now selected and the original entities are deselected.

. Type a multiplier value to create additional multiple copies. For example, typing in 2x (or *2) will create one additional copy (or 2 copies total, the one you
manually copied plus one you automatically copied using this step) instead of just one.
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Creating Copies at an Equal Distance Apart

You can divide the distance between the copy and the original by typing in a divisor value. For example, typing 5/ (or /5) will create five copies evenly distributed
between the original and the first copy. You can keep typing in distances and multipliers until you perform another operation.

This feature is particularly useful in creating models of items such as fences, bridges, and decks, where you might want several posts or beams an equal distance
apart.

Move Tool: Moving groups and components

}: Moving groups and components 72



If a component is glued to a face, the component will stay in the plane of that face when moved unless it is unglued. Copies of a glued component will also be
glued to the originating plane.
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Rotate Tool

Rotate Tool: Introduction

A . .
%/ Rotate tool introduction

Use the Rotate tool to rotate, stretch, distort, or copy entities along a rounded path. Activate the Rotate tool from the Modification Toolbar (Microsoft Windows),
the Tool Palette (Mac OS X) or the Tools menu.

Keyboard Shortcut: Q
Rotate Tool: Rotating geometry

~
%/ Rotating geometry
You can rotate geometry in three different planes in a 3D environment. To rotate geometry using the Rotate Tool:
~
1. Select the Rotate tool (%#). The cursor will change to a protractor with a circular arrow.

2. Click on the entity to rotate.
3. Move the cursor in a circle until it is at the starting point of the rotation.

4. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.

5. Move the cursor until it as at the ending point of the rotation. If the 'Enable angle snapping' checkbox is checked in the Units Panel of the Model Info dialog
box, movements close to the protractor result in angle snaps, while those further away from the protractor allow free rotation.
Note: Press the Esc key at any point during the operation to start over.

6. Click to complete the rotation.
Rotational stretching with Autofold

The Rotate tool can also be used to stretch geometry by selecting and rotating a portion of the geometry. Any rotational movement that would cause a face to
twist in on itself or otherwise become non-planar will activate SketchUp's Auto-Fold feature.

Rotate Tools: Making rotated copies

~A
W/ Making rotated copies

The Rotate tool can be used to make rotated copies of entities within your model. To make copies of an entity using the Rotate Tool:

~
. Select the Rotate tool (%e#). The cursor will change to a protractor with a circular arrow.
. Click on the entity to rotate.
3. Press and release the Ctrl (Microsoft Windows) or Option (Mac OS X) key on your keyboard. The cursor will change to a protractor with a plus sign. This
action informs Sketchup that you want to duplicate the entity.
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. Move the cursor in a circle until it is at the starting point of the rotation.
. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.
. Move the cursor until it as at the ending point of the rotation. A copy of the entity appears and is rotated about the starting point. If the 'Enable angle

snapping' checkbox is checked in the Units Panel of the Model Info dialog box, movements close to the protractor result in angle snaps, while those further
away from the protractor allow free rotation.

. Click to complete the rotation.

Note: Press and hold the Ctrl (Microsoft Windows) or Option (Mac OS X) key at any time during a move operation to perform a copy (not just at the start).

Rotate Tool: Creating multiple rotated copies (radial arrays)

W/ Creating multiple rotated copies (radial arrays)

The Rotate tool can also be used to create radial arrays, or a series of copies around a rotate point. To create a radial array.
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. Select the Rotate tool (%#). The cursor will change to a protractor with a circular arrow.
. Click on the entity to rotate.
. Press and release the Ctrl (Microsoft Windows) or Option (Mac OS X) key on your keyboard. The cursor will change to a protractor with a plus sign. This

action informs Sketchup that you want to duplicate the entity.

. Move the cursor in a circle until it is at the starting point of the rotation.
. Click to set the starting point of the rotation. Use the inference tool tips to help you to find the center of the rotation.
. Move the cursor until it as at the ending point of the rotation. A copy of the entity appears and is rotated about the starting point. If the 'Enable angle

snapping' checkbox is checked in the Units Panel of the Model Info dialog box, movements close to the protractor result in angle snaps, while those further
away from the protractor allow free rotation.

. Click to complete the rotation.
. Type a multiplier value to create additional multiple copies. For example, typing in 2x (or *2) will create one additional copy (or 2 copies total, the one you

manually copied plus one you automatically copied using this step) instead of just one.

Note: Press and hold the Ctrl (Microsoft Windows) or Option (Mac OS X) key at any time during a rotate operation to perform a copy (not just at the start).

Creating copies at an equal distance apart

You can divide the distance between the copy and the original by typing in a divisor value in the Measurements Toolbar. For example, typing 5/ (or /5) will create
five copies evenly distributed between the original and the first copy. You can enter distances and multipliers until you perform another operation.

Rotate Tool: Folding along an axis of rotation

~
%/ Folding along an axis of rotation

You can fold geometry by setting the protractor along an edge that will act like a fold line and then folding geometry at that line. To fold geometry along an axis
of rotation:

1.
2.

3.
4.
5.

6.
7.

Select the Select tool ( k ). The cursor will change to an arrow.
Select the geometry to rotate. The bottom of the triangle will act as a fold line.

~A
Select the Rotate tool (%#). The cursor will change to a protractor with a circular arrow.
Click and hold on one end of the fold line or edge where the fold will appear in your geometry.
Drag the cursor along the fold line to align the protractor to the fold line (the bottom of the triangle).

Release the mouse button to set the rotation point or the point upon which the geometry will rotate.
Click the mouse again to set the starting point of the rotation.
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8. Move the mouse to rotate. If angle snaps are active under preferences, you'll notice that as you move the mouse, movements close to the protractor will
result in angle snaps, while those further away from the protractor will allow free rotation.

9. Click a third time at the ending point of the rotation (to complete the rotation).

Rotate Tool: Rotating precisely

~
W/ Rotating precisely

The degree of rotation you have indicated appears in angular degrees in the Measurements Toolbar while rotating. You can also manually enter in angular
rotation or slope values directly into the Measurements Toolbar while rotating geometry.

Entering an angular rotation value

To specify an exact angle in degrees, type a decimal value into the Measurements Toolbar while rotating the cursor around the protractor. For example, typing in
34.1 will give you an exact 34.1 degree angle. Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either
during or immediately after your rotation operation.

Entering a slope value
To specify a new angle as a slope, type in the two values separated by a colon in the Measurements Toolbar, such as 8:12. Negative values will move angle in a
counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.

Rotate Tool: Locking the rotate tool to its current orientation

~
W’ Locking the rotate tool to its current orientation

Press and hold the Shift key, before you click on an entity, to lock the operation to that orientation.
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Scale Tool

Scale Tool: Introduction

‘) Scale tool introduction

Use the Scale tool to resize and stretch portions of geometry relative to other entities in your model. Activate the Scale tool from the Modification Toolbar, the
Tool Palette or the Tools menu.

Keyboard Shortcut: S
Note: A Global Scale is an operation whereby the entire model is scaled simultaneously by applying a desired dimension to the distance between two points. The

Scale tool is only intended to perform scaling operations on portions of your model (not the entire model). Use the Tape Measure Tool's global re-scale
functionality to perform global scaling operations.

Scale Tool: Scale grip types

‘) Scale grip types

Upon activation, the Scale tool displays all the grips you may use. Any grips hidden behind geometry will become visible whenever touched by the mouse cursor,
and remain fully operable. Turn on X-ray Transparency mode to reveal any hidden grips.

The Scale tool allows you to perform both uniform scaling and non-uniform scaling (stretching operations). The scaling grip that is used dictates the type of
scaling you perform.

Corner grips
Corner grips scale the selected geometry from the opposite corner. The default behavior is a uniform scale such that the proportions remain intact and a single
scale factor or dimension is displayed in the Measurements Toolbar.

Edge grips

Edge grips scale the selected geometry from the opposite edge by two dimensions simultaneously. The default behavior is a non-uniform scale, meaning that the
proportions of the object will change. The Measurements Toolbar displays two values separated by a comma.

Face grips

Face grips scale the selected geometry from the opposite face in only one dimension. The default behavior is a non-uniform scale, meaning that the proportions
of the object will change. The Measurements Toolbar displays and accepts a single value.

Scale Tool: Scaling geometry

“)Scaling geometry

To scale geometry:

1. Select the Scale tool (“)). The cursor will change to a box within another box.
2. Click on the entity. Scaling grips will appear around the selected geometry.
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3. Click on a scaling grip. The selected grip and the opposite scaling grip will highlight in red. Each scaling grip provides a different scaling operation. See
Scaling Options section for further information.

4. Move the cursor to scale the entity. The Measurements Toolbar displays relative size of the item as you scale the item. You can enter the desired scale
dimensions after the scale operation is complete.

Note: Press the Esc key at any point during the operation to start over.

5. Click to finish scale operation.

Scaling Auto-Folding geometry
SketchUp's Auto-fold feature works automatically with all Scale operations. SketchUp will create folding lines as necessary to maintain planar faces.
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Scale Tool: Scaling 3D surface or image entities

‘) Scaling 2D surface or image entities

Two-dimensional surfaces and Image entities can be scaled just as easily as three-dimensional geometry. The scale tool's bounding box contains nine scaling
grips when scaling a 2D face. These operate in a similar manner to the grips in a 3D bounding box, and also work with the Command (Microsoft Windows) or
Option (Mac OS X) and Shift modifiers.

The bounding box is a 2D rectangle when scaling a single 2D surface that lies in the red-green plane. The bounding box will be a 3D volume if the surface to be
scaled is out of plane with the current red-green plane. You can ensure a 2D scale by aligning the Drawing Axes to a surface prior to scaling.

Scale Tool: Scaling components

‘) Scaling components

Scaling a Component entity scales the individual instance. All other instances of the component will retain their individual scales. This feature allows you to have
many differently scaled versions of the same component in your model.

Scale operations within a component's context (such as scaling a Line entity within a component) affects the component definition and, therefore, all instances of
the component are scaled to match (all instances of the same Line entity in all component instances).

Scale Tool: Scaling about the geometry center

‘) Scaling about the geometry center

The Scale tool allows you to scale outward from geometry's center point. Press and hold the Control (Microsoft Windows) or Option (Mac OS X) key at any time
during a scale operation to display the geometry's center point, click on any of the other scaling grips, and drag outward or inward to scale accordingly.

Scale Tool: Scaling uniformly

‘) Scaling uniformly

You might need to maintain the uniformity of geometry as it is being scaled, despite performing nonuniform scaling. The Shift key toggles to uniform scaling
operation (from a nonuniform scaling operation) and to nonuniform scaling operation (from a uniform scaling operation).

Note: The Ctrl (Microsoft Windows) or Option (Mac OS X) and 'Shift' keys to allow uniform and non-uniform scaling from the center of the selected geometry.
Scale Tool: Controlling scaling direction with the Axis tool

‘) Controlling scaling direction with the Axis tool

You can precisely control the direction of scaling by first repositioning the drawing axes with the Axes tool. The Scale tool will use the new red, green, and blue
directions to orient itself, and control grip direction, after the axes are repositioned.

Scale Tool: Scaling precisely

‘) Scaling precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the axis dimensions that are being scaled, and the value of the scale
itself, in the default units (as specified under the Units panel of the Model Info dialog box) during a scaling operation. Type a scale value into the Measurements
Toolbar to directly scale geometry during or immediately after a scaling operation.

Entering a scale multiplier value
You can specify a new dimensional length value during or directly following a scaling operation. To enter a dimensional length value during a scaling operation:

. Select the Select tool ( k ). The cursor will change to an arrow.
. Select the geometry to scale.

. Select the Scale tool (‘)). The cursor will change to a box within another box. Scaling grips will appear around the selected geometry.
. Click on a scaling grip to select the grip. The selected grip and the opposite scaling grip will highlight in red. Each scaling grip provides a different scaling
operation. See Scaling Options section for further information.
5. Move the mouse to scale the geometry. The Measurements Toolbar displays relative size of the item as you scale the item. You can enter the desired scale
dimensions after the scale operation is complete.
6. Type the dimensional length value (such as 2' 6" for two feet and six inches or 2m for two meters) in the Measurements Toolbar and press the Enter
(Microsoft Windows) or Return (Mac OS X) key.
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Mirroring geometry using the Scale tool

The Scale tool can also be used to mirror geometry by pulling a grip towards and then beyond the point about which you are scaling. This operation allows you to
pull geometry inside out. Note that the grips snap to certain negative values (such as -1, -1.5, and -2) just as they do in the positive direction. You can force a
mirror by typing in a negative value or dimension.

Entering multiple scale values
The Measurements Toolbar always indicates the scaling factors associated with a particular operation. A 1D scaling operation requires one value. A 2D scaling
operation requires two values, separated by a comma. A Uniform 3D scaling operation requires only one value whereas a Non Uniform 3D scaling operation
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requires three values, each separated by a comma.

You'll notice that during the scale operation, a dashed line appears between the scaling point and the grip you've selected. Entering a single value or distance in
the Measurements Toolbar tells SketchUp adjust the anchor to grip distance to be that scale value or distance, regardless of which mode (1D, 2D, 3D) is active.

When scaling in multiple directions, typing in multiple values separated by commas will resize the object(s) based on the entire bounding box dimension(s), not
the objects individually. (To scale objects based on a particular edge or known distance, you can use the Tape Measure tool.)
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Push/Pull Tool

Push/Pull Tool: Introduction

4
" Push/Pull tool introduction

Use the Push/Pull tool to push and pull Face entities to add volume to or subtract volume from your models. You can use push/pull to create volume out of any
face type, including circular, rectangular, and abstract faces. Activate the Push/Pull tool from the Tool Palette (Mac OS X), the Modification Toolbar (Microsoft
Windows) or the Tools menu.

Keyboard Shortcut: P

Note: Push/Pull works only on faces, and therefore does not work when SketchUp is set to a Wireframe rendering style.

Push/Pull Tool: Creating a volume

4
¥ Creating a volume

Push/Pull tool is used to expand or decrease the volume of geometry in your models. To push or pull faces:

4
1. Select the Push/Pull tool (*). The cursor will change to a 3D rectangle with an up arrow.
2. Click on the face that you want to expand or decrease.

3. Move the cursor to create (or decrease) volume.

Note: Press the Esc key at any point during the operation to start over.

4. Click when the volume has reached the desired size.
Note: You can also press and hold the mouse button, drag the mouse, and release the mouse button to create a volume.
Note: You can also press and hold the mouse button, drag the mouse, and release the mouse button to create a volume.
Note: When you create a single face, as shown previously in step 4, on the ground plane (the red/green plane), SketchUp assumes you are going to be
using that face as the floor of a structure. The front of the face (gray) points down and the back of the face (purple) points up. When you use the Push/Pull
tool on this single face (in the blue direction), you are really pulling up from the back of the face. The positive blue direction temporarily acts as the 'below
ground' or negative blue direction. A double-click, after performing the initial push/pull, applies a positive amount and returns the entity to the single face
you started with.

Note: By default, you can select a face with the Select tool, orbit the model (even so that the pre-selected face is hidden), click on the Push/Pull tool and
push/pull anywhere on the screen to push/pull the pre-selected face. This feature allows you to push/pull faces that are normally hard to select.

Push/Pull Tool: Repeating a Push/Pull operation

4
" Repeating a Push/Pull operation

Double-clicking on another face immediately after a push/pull operation will automatically apply another push/pull operation, of the same amount, to the other
face.

Note: The side of the face that you double-click on affects the direction of the repeated push/pull operation. If your last push/pull was on a front face, and you
double-click on the back side face, the push/pull will occur in the opposite direction.

Push/Pull Tool: Creating voids
¢ Creating voids

Push/pull will implode the shape into the volume and toward the back face of the volume when you use push/pull on a shape that is part of another volume.
SketchUp will subtract the shape and create a 3D void if the shape is pushed completely out of the back of the volume as in the following example.
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Note: This operation only works when the front and back faces are parallel. Such as when you have two parallel walls in a house and you want to create a void for
a door or window.

Push/Pull Tool: Creating a new Push/Pull starting face

4
" Creating a new Push/Pull starting face

Push/pull a face (click on the face, move, and then click again) and then press and release Control (Microsoft Windows) or Option (Mac OS X) (the cursor will
contain a plus sign) and push/pull again. The lines that represent the edges of the top-most face will remain as the starting point for a new push/pull operation.
This mechanism is useful for creating quick multilevel buildings. The following image shows a face that was pulled up (left), then the user pressed and released
Ctrl (Microsoft Windows) or Option (Mac OS X)and pulled again (middle) and then the user pressed and released Ctrl (Microsoft Windows) or Option (Mac OS X)
and pulled again (right).

This operation is particularly useful for creating quick space planning diagrams (such as for an office building). Simply use a combination of push/pull and
push/pull with Ctrl to create offices, halls, break rooms, meeting rooms and so on (with walls created when Ctrl is pressed).

Push/Pull Tool: Pushing and pulling a curved face

4
% Pushing and pulling a curved face

You can use the Push/Pull tool on faces that have an arc as an edge similarly to using the Push/Pull tool on regular faces. The curved face that results from the
push/pull operation is called a Surface entity. Surfaces can be adjusted as a whole, but are comprised of a number of faces or a curved face set.

Tip: Select View > Hidden Geometry to view and manipulate the individual faces in the surface.
Push/Pull Tool: Pushing and pulling precisely

4 . ) .
" Pushing and pulling precisely

The displacement of a push/pull operation is displayed in the Measurements Toolbar. You can specify an exact push/pull value either during or immediately after
your push/pull operation. Negative values will perform the push/pull in the opposite direction.
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Offset Tool

Offset Tool: Introduction

( Offset tool introduction

Use the Offset tool to create copies of lines and faces at a uniform distance from the originals. You can offset edges of faces either inside or outside of the
original face. Offsetting a face will always create a new face. Activate the Offset tool from the tool Palette (Mac OS X), the Modification Toolbar (Microsoft
Windows) or from the Tools menu.

Keyboard Shortcut: F
Offset Tool: Offsetting a face
&\\ Offsetting a face

1. Select the Offset tool (6‘\). The cursor will change to two offset corners.
2. Click on the face to be offset.

3. Move the mouse cursor to define the offset dimension. The offset distance is displayed in the Measurements Toolbar. You can offset either inside or
outside of the edges; on rectangular face or circular face.

Note: Press the Esc key at any point during the operation to start over.

4. Click to finish the offset operation.

Offset Tool: Offsetting lines

(F\ Offsetting lines

You can also select and offset connected, co-planar, lines (and arcs) for an offset. To offset lines:

1. Select the Select tool ( k ). The cursor will change to an arrow.
2. Select the lines to be offset. You must select two or more connected lines, and all your lines must be coplanar.

3. Select the Offset tool (Ci ). The cursor will change to two offset corners.
4. Click on one of your selected line segments. The cursor will automatically snap to the nearest line segment.
5. Move the cursor to define the offset dimension.

6. Click to finish the offset operation.

Tip: You can click once on the selected line segments, drag to set the offset while holding down the mouse button, and release the button to accept.

Note: Offsetting an Arc entity will create a Curve entity that cannot be edited. The original Arc, however, can still be edited after this operation.
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Offset Tool: Repeating an offset operation

@\\Repeating an offset operation

Double-clicking on another face immediately after a offset operation will automatically apply another offset operation, of the same amount, to the face.

Offset Tool: Offsetting precisely

6\\ Offsetting precisely

The Measurements Toolbar at the bottom right corner of the SketchUp window displays the length of the offset in the units as specified under the Units panel of
the Model Info dialog box, while offsetting entities. You can also specify an exact offset during, or immediately after, an offset operation.

Note: You can type values in the Measurements Toolbar using an alternate measuring system than the default system. SketchUp will convert the value to the
default system. For example, you can type in 3' 6" even if you are using metric system as your default.

Entering an Offset Value
You can specify a new offset length during or directly following an offset operation. To enter an offset value during an offset operation:
. Select the Select tool ( k ). The cursor will change to an arrow.

. Select the lines to be offset. You must select two or more connected lines, and all your lines must be coplanar. Use the Command (Microsoft Windows) or
Option (Mac OS X) and/or Shift key to change your selection.

N =

. Select the Offset tool (\" ). The cursor will change to two offset corners.

. Click on one of your selected line segments. The cursor will automatically snap to the nearest line segment.

. Move the mouse to define the offset dimension.

. Click your mouse to accept the offset lines.

. Type the positive or negative offset value (such as 20" or -35mm) in the Measurements Toolbar and press the Enter (Microsoft Windows) or Return (Mac OS
X).

NOoO v~ w
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Follow Me Tool

Follow Me Tool: Introduction

-'3 Follow Me introduction

Use the Follow Me tool to duplicate the profile of a face along a path. This tool is especially useful when trying to add details to a model, such as a crown
molding, because you can draw the profile of the molding at one end of a path on the model and using the Follow Me tool continue that detail along the path.
You can manually and automatically extrude a face along a path using the Follow Me tool. Activate the Follow Me tool from the Tools menu, the Modification
Toolbar (Microsoft Windows), or the tool Palette (Mac OS X).

Note: The path and the face must be in the same context.

Follow Me Tool: Manually extruding a face along a path

g Manually extruding a face along a path

The manual method for extruding a face along a path allows you to control the direction the face will travel while performing the extrude. To manually extrude a
face along a path using the Follow Me Tool:

1. Identify the edge of the geometry you want to modify. This edge will be your path.
2. Draw a face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.

. Select the Follow Me tool (E). The cursor will change to a slanted cylinder with an arrow.

. Click on the face that you created.

. Drag the cursor along the path. SketchUp will highlight the path, in red, you are following as you drag your cursor around the model. You must touch the
segment of the path immediately adjacent to the profile for the Follow Me to start in the correct location. If you select an edge, as your starting edge, that
is not touching the profile, Follow Me will start extruding at that edge, not from the profile to that edge.
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Note: Press the ESC key at any point during the operation to start over.

6. Click to complete the Follow Me operation when you reach the end of the path.
"/

Follow Me Tool: Preselecting the path

-‘3 Preselecting the path

You can preselect the path using the Select tool to help the Follow Me tool follow the correct path. To extrude a face along a pre-selected path:

. Draw a profile of the face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.
. Select the continuous set of edges that represent the path.

. Select the Follow Me tool (‘ ) (the edges should still be selected). The cursor will change to a slanted box with an arrow.
. Click on the profile that you created. The surface will be extruded continuously along your pre-selected path.

Aw N

Follow Me Tool: Automatically extruding a face along a single surface path
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% Automatically extruding a face along a single surface path

The simplest and most accurate way to extrude a face along a path is to have the Follow Me tool automatically select and follow a path on a single coplanar
surface. To automatically extrude a face along a path on an single surface using the Follow Me Tool:

1. Identify the edge of the geometry you want to modify. This edge will be your path.
2. Draw a profile of the face that you want to follow the path. Make sure that this profile is approximately perpendicular to the path.

. Select the Tools > Follow Me.

. Press and hold the Alt (Microsoft Windows) or Command (Mac OS X) Key.

. Click on the profile that you created.

. Move the cursor off the profile surface onto the surface around which you wish to sweep. The path will automatically close.

(o) IV B N OV}
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Note: If your path consists of the edges around a single surface, you can select the surface and then the Follow Me tool to automatically follow the edges
around the surface.

7. Click to commit the follow-me operation.

)

Follow Me Tool: Creating a lathed shape

E Creating a lathed shape
You can use the Follow Me tool to create full lathed shapes using circular paths. To create a lathed shape:

1. Draw a circle whose edge will represent the path.
2. Draw a face perpendicular to the circle. The face does not have to be on or even touch the circle's path.

3. Select Follow Me tool (E). The cursor will change to a slanted box with an arrow.
4. Follow the edge of the circle with the face using one of the methods above.
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Position Texture Tool

Position Texture Tool: Introduction

lﬁ Position Texture tool introduction

Materials within SketchUp are applied as tiled images meaning that the pattern or image will repeat both vertically and horizontally across any entities you paint.
Use the Position Texture tool to adjust a material on a surface in a number of ways, including repositioning, resizing, and distorting. Additionally, this tool allows
you to perform unique actions on images such as painting a picture around a corner or projecting it on a model. Activate the Position Texture tool from the
context menu for a Face entity.

Note: The Position Texture tool can only be used to modify textures applied to flat surfaces. You cannot edit a texture applied to a curved surface as a whole
though you can use the View > Hidden Geometry menu item view and edit the texture on the individual faces that make up the curve's face set.

Note: Normally a texture is a subset of a material. However, the terms material and texture are used interchangeably in this topic.
Position Texture Tool: Repositioning a material

.ﬂ Repositioning a material
Repositioning the material is the easiest of position texture operations. To reposition a material:

1. Context-click on the material to display its context menu.

2. Select Texture > Position. A matrix of dotted lines is displayed on the material to indicate the material's individual tiles. The cursor also changes to a hand
and four pins are displayed.

3. Drag the cursor on the surface to reposition the texture on that surface. If you want to rotate the tiled image, context-click on the surface again and select
Rotate or Flip.

4. When you are finished modifying the texture, context-click and select Done, or just click outside the texture to exit the Position Texture tool.

Tip: Press the Esc key anytime during editing to reset the material's position to its previous position. Press Esc twice to cancel the entire texture positioning
operation. While positioning a texture, you can back up a step at anytime by context-clicking and selecting Undo from the context menu.

Position Texture Tool: Material positioning pins

'ﬁ Material positioning pins

The Position Texture tool uses pins to manipulate a material. Pins can be moved or dragged. A move operation simply moves the pin to another location on the
material. A drag operation performs some manipulation of the material, such as a resize or skew.

The Position Texture tool has two modes: Fixed Pin Mode and Free Pin Mode.
Position Texture Tool: Manipulating a material using Fixed Pin mode

lﬁ Manipulating a material using Fixed Pin mode

Fixed pin mode allows you to scale, skew, shear and distort a texture, while constraining or 'fixing' one or more pins. Fixed pin mode is best for materials that
tile like brick or roofing textures. To manipulate a material using Fixed Pin Mode:

1. Context-click on the material to display its context menu.

2. Select Texture > Position. A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand
and four pins are displayed.

3. Context-click on the material.

4. Select the Fixed Pins menu item if there is not a check mark next to the item. Colored icons appear next to each pin, each icon representing a specific
position texture operation.

5. Manipulate the material by clicking, holding, and dragging on one of the pins. See Fixed Pin Mode Options in this topic for additional information.

Note: Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point
for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.

6. When you are finished modifying the texture, context-click and select Done, or just click outside the texture to exit the Position Texture tool.
Fixed Pin Mode Options

.ﬂ Move Icon and Pin: Drag (click and hold) the Move icon or pin to reposition the texture. When you are finished modifying the texture, context-click and
select Done, or just click outside the texture to close it. Or you can simply press the Enter (Microsoft Windows) or Return (Mac OS X) key when finished.

0@ scale / Rotate Icon and Pin: Drag (click and hold) the Move icon or pin to reposition the texture. When you are finished modifying the texture, context-
click and select Done, or just click outside the texture to close it. Or you can simply press the Enter (Microsoft Windows) or Return (Mac OS X) key when finished.
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Notice that the dots along the dashed lines and arcs show you the current size and the original size of the texture for reference. You can change back to the
original size by moving the cursor to the original arc and line. Or you can select Reset from the Context menu. Be forewarned that selecting Reset also resets the
rotation as well as the scale.

Eﬁ Scale / Shear Icon and Pin: The Scale/Shear icon or pin is used to simultaneously slant or shear and resize the material. Notice that the two bottom pins
are fixed during this operation.

D.;D Distort Icon and Pin: The Distort icon or pin is used to perform a perspective correction on the material. This feature is useful for applying image photos to
geometry.

Position Texture Tool: Manipulating a material using Free Pin mode

) Manipulating a material using Free Pin mode

Pins are not constrained to other pins in Free Pin Mode allowing you to drag pins anywhere to distort the material just as you might distort a material as you
stretch it over a drum. Free pin mode is best for positioning and removing the distortion from photographs. To manipulate a material using Free Pin Mode:

1. Context-click on the material to display its context menu.

2. Select Texture > Position. A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand
and four pins are displayed.

3. Context-click on the material.

4. Select the Fixed Pins menu item if there is a check mark next to the item. Four pins appear.

e

e

5. Manipulate the material by clicking, holding, and dragging on one of the pins.

Note: Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point
for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.

6. When you are finished modifying the texture, context-click and select Done, or just click outside the texture to exit the Position Texture tool.
Position Texture Tool: Manipulating an image as material using Free Pin mode

.ﬁ Manipulating an image as material using Free Pin mode

Free pin mode is especially useful when using an image as the foundation for geometry. For example, you can use a picture containing a door as the foundation
for a photo-realistic door in a SketchUp model. To manipulate an image using Free Pin Mode:

1. Create a rectangular face.
2. Select the File > Import to insert an image, such as the image of a real door. The Open dialog box is displayed.
3. Select an image format from the Files of type drop-down list.
4. Click on the 'Use as texture' radio button.
5. Select the image file.
6. Click on the Open button. The cursor changes to the Paint Bucket tool with the image.
7. Click on one corner of the face to place the starting point of the texture.
8. Drag the cursor away from the starting point so that the texture is resized over the rectangular face.
9. Click again to place the texture on the rectangular face.
10. Context-click on the material to display its context menu.
11. Select Texture > Position. A matrix of dotted lines is displayed on the material to indicate the materials individual tiles. The cursor also changes to a hand
and four pins are displayed.
12. Context-click on the texture.
13. Select the Fixed Pins menu item if there is a check mark next to the item.
14. Manipulate the material by clicking, holding, and dragging on one of the pins.

Note: Single-clicking on a pin grabs the pin allowing you to move the pin to a different location on the texture. This new position will be the starting point
for any of the fixed pin mode operations. This action works in both Fixed Pin and Free Pin modes.

15. When you are finished modifying the texture, context-click and select Done, or just click outside the texture to exit the Position Texture tool.
Position Texture Tool: Wrapping material around corners

e Wrapping material around corners The texture can be wrapped around a corner, just as you might wrap a package with wrapping paper. To wrap textures
around corners:

1. Create a three-dimensional cube.
2. Select File > Import to insert an image.
3. Select an image format from the Files of type drop-down list.
4. Select the image file.
5. Click the Open button. The cursor changes to the Select tool with the image.
6. Click in the drawing area to place the starting point of the image.
7. Drag the cursor away from the starting point so that the image is resized.
8. Click again to place the image.
9. Context-click on the image. The Image entity's context menu appears.
10. Select 'Use as Material. The image appears in the In Model (Microsoft Windows) or Colors in Model (Mac OS X)materials library within the Materials
Browser.
11. Select the Paint Bucket tool ('6). The cursor will change to a paint bucket and the Materials Browser is activated.
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12. Click and hold the Alt (Microsoft Windows) or Command (Mac OS X) key while using the Paint Bucket tool to change to the eye dropper.
13. Click on the thumbnail of your image in the In Model (Microsoft Windows) or Colors in Model (Mac OS X) material library within the Materials Browser.
14. Release the Alt (Microsoft Windows) or Command (Mac OS X) key.

15. Click on a face of your model and paint the material.

16. Context-click on the material to display its context menu.

17. Select Texture > Position. Don't position anything!

18. Context-click again.

19. Select Position Texture tool > Done.

20. Click and hold the Alt (Microsoft Windows) or Command (Mac OS X) key while using the Paint Bucket tool to change to the eye dropper.
21. Click on the painted material using the eye dropper to sample the material.

22. Release the Alt (Microsoft Windows) or Command (Mac OS X) key.

23. Paint the sampled texture on the remainder of the model. The texture is wrapped around corners.

Position Texture Tool: Wrapping material around a cylinder

e Wrapping material around a cylinder
A texture can also be wrapped around a cylinder. To wrap a texture, such as an image texture, around a cylinder:

. Create a cylinder.

. Select File > Import to insert an image.

Select an image format from the Files of type drop-down list.

. Select the image file.

. Click the Open button. The cursor changes to the Select tool with the image.

. Click in the drawing area to place the starting point of the image.

Drag the cursor away from the starting point so that the image is resized.

. Click again to place the image.

. Context-click on the image. The Image entity's context menu appears.

10. Select Use as Material. The image appears in the In Model (Microsoft Windows) or Colors in Model (Mac OS X) material library within the Materials Browser.
11. Click on the material in the Materials Browser. The cursor changes to the Paint Bucket tool.

12. Paint the Material on the cylinder. The material will automatically wrap around the cylinder, repeating itself as necessary to wrap the entire model.

Position Texture Tool: Repositioning a material on hidden geometry

.ﬁ Repositioning a material on hidden geometry

You can adjust textures on a face, such as the faces of a cylinder, and then repaint the adjust texture across the entire curved surface of the cylinder. For
example, to adjust a texture on a cylinder:

. Create a cylinder.

. Select the File > Import menu item to insert an image.

. Select an image format from the Files of type drop-down list.

. Select the image file.

. Click the Open button. The cursor changes to the Select tool with the image.

. Click in the drawing area to place the starting point of the image.

Drag the cursor away from the starting point so that the image is resized.

. Click again to place the image.

. Context-click on the image. The Image entity's context menu appears.

10. Select Use as Material. The image appears in the Colors In Model material library within the Materials Browser.

11. Click on the material in the Materials Browser. The cursor changes to the Paint Bucket tool.

12. Paint the Material on the cylinder. The material will automatically wrap around the cylinder, repeating itself as necessary to wrap the entire model.
13. Select the Display > Hidden Geometry menu item.

14. Select one of the faces of the cylinder.

15. Context-click on the selected face. The Face entity's context menu appears.

16. Select the Texture > Position menu item.

17. Reposition the texture on the face.

18. Sample the repositioned texture using the eyedropper button on the material browser, or using the Alt key with the Paint Bucket tool.
19. Click on Display > Hidden Geometry to turn off Hidden Geometry.

20. Paint the sampled, repositioned, texture on the remainder of the cylinder. Your texture now appears as though it has been repositioned on the entire
cylinder.

Position Texture Tool: Projecting a material

) Projecting a material SketchUp's Texturing Positioning feature also lets you project materials or images onto faces as though projected using a slide
projector. This feature is particularly useful if you wish to project a topographic image over a site model, or an image of a building onto a model representing the
building. To project an image over a model:

. Create a model, such as a cone, topography, or building front. This model will receive the projected image.
Select File > Import. The cursor changes to the Select tool with the image.

. Place the image in front of the model that will receive the projection.

. Size the image so it is large enough to cover the entire model.

. Context-click on the image and select 'Explode’ to turn the image into a projected texture.

U WN =

Note: Turn on x-ray display mode for the image to ensure the image is positioned such that it will cover the entire model.
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6. Select the 'Sample Paint Tool' from the Materials Browser. Notice, when you drag the Sample Paint tool over the image, a square appears on the tip of the
tool. This square indicates that you are in projected texture mode (Microsoft Windows).

7. Sample the projected texture with the Sample Paint tool.

8. Paint the texture onto the faces of the model. The image will appear as though it were projected directly on the faces, adjusting to the contours of model.

Position Texture Tool: Reorienting materials

.ﬁReorienting materials

You can reorient materials (skew, rotate, resize, and so on) using the Position Texture tool. See Position Texture tool for more information.
Position Texture Tool: Fixed pin and free pin mode context commands

I Fixed pin and free pin mode context commands

Context-click while using the Position Texture tool to display the position texture context menu.

Done

The Done menu item is used to exit the Position Texture tool and save the current texture position.

Reset

The Reset menu item is used to reset the position of the texture to the position prior to using the Position Texture tool.
Flip

The Flip menu item is used to flip the texture horizontally (Left/Right) or vertically (Up/Down).

Rotate

The Rotate menu item is used to rotate the texture one of three predefined increments: 90, 180, and 270 degrees.
Fixed Pins

The Fixed Pins menu item is used to toggle between Fixed Pin and Free Pin modes.

Undo

The Undo menu item will undo the last position texture command. Unlike the Undo command in the Edit menu, this undo command will only keep track of a
single operation at a time.

Redo
The Redo menu item cancels Undo operations, returning you to the texture positioning state previous to using the Undo command.

The Edit > Undo command and Undo button will Undo everything you did during your texture positioning session. The Edit > Redo operation cancels the Undo
Edit > Undo operation, returning you to the last texture positioning command that you performed.
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Intersect With Model Tool

Intersect With Model Tool: Introduction

Intersect Faces introduction

Use Intersect Faces to create complex geometry. This option allows you intersect two elements, such as a box and a tube, to automatically create new edges and
faces where the elements intersect. These faces can then be pushed, pulled or deleted to create new geometry. Activate Intersect Faces from either context menu
or the Edit menu.

Intersect With Model Tool: Creating complex geometry

Creating complex geometry
To create complex geometry using the Intersect With Model Tool:

1. Create two distinct geometries, such as a box and a tube.

LY

. Select the Select tool (™ ). The cursor changes to an arrow.
. Triple-click on the tube to select all of the entities of the tube.

. Select the Move tool (*%). The cursor will change to a four-way arrow.
. Move the tube such that it intersects the box completely in any way you like. Notice that no edges exist where the tube meets the faces of the box on the
box's top face. The tube should remain selected although it is within the box.
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6. Context-click on the selected tube.
7. Select Intersect Faces > With Model from the context commands menu. The tool creates edges where the tube intersects the box.

8. Delete or move the portions of the tube that you do not want to keep. Notice that SketchUp will have created new subdivided faces where the tube
intersected the box.

Intersect With Model Tool: Using Intersect With Model with groups and components

Using Intersect With Model with groups and components

Edges created by the Intersect With Model tool are drawn in the current context. For example, if one of your intersecting entities is a group, and you perform the
Intersect with Model while editing that group (such as while editing the tube), the intersection lines will be applied within the group (right-most image below).
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Tape Measure Tool
Tape Measure Tool: Introduction

v; Tape Measure tool introduction

Use the Tape Measure tool to measure distances, create guide lines or points, or scale a model. Activate the Tape Measure tool from the Construction toolbar
(Microsoft Windows), the tool palette (Mac OS X) or the Tools menu.

Keyboard Shortcut: T

Tape Measure Tool: Measuring distance

vp Measuring distance

The Tape Measure tool is primarily used to measure distances between two points. To measure a distance between two points:

. Select the Tape Measure tool (vp). The cursor changes to a tape measure.

. Click at the starting point of your measurement. Use the inference tool tip to make sure you click on the exact point.

3. Move the cursor in the direction you want to measure. A temporary measuring tape line, with arrows at each end, will stretch out from your starting point
as you move the mouse. The Tape Measure tool's measuring tape line functions like an inference line and will change color to match axes colors when it is
parallel to any axes. The Measurements toolbar dynamically displays the length of your measuring tape as you move the mouse around your model.
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Note: Press the ESC key at any point during the operation to start over.
4. Click at the ending point of your measurement. The final distance is displayed.

Tip: You can also click and hold on the starting point of the distance you wish to measure, drag the mouse to the endpoint of the measurement, and release the
mouse to obtain a measurement.

Tape Measure Tool: Creating guide lines and guide points

vp Creating Guide Lines and Guide Points
Guide Line entities and Guide Point entities are useful for drawing precisely. To create an infinite parallel guide line using the Tape Measure tool:
. Select the Tape Measure tool (vp). The cursor changes to a tape measure.

2. Click on a line that will be parallel to the guide line, to set the starting point of your measurement. You must click on an On Edge or Midpoint point
between the start and end points in the line segment.

—

Note: Start from an 'On Edge' point inference and move across a face to generate an infinite parallel guide line. Start from an 'Endpoint’ to create a finite
guide line with a guide point at the end.

3. Press and release the Ctrl (Microsoft Windows) or Option (Mac OS X) key.
4. Move the cursor in the direction you want to measure. A temporary measuring tape line and a guide line will stretch out from your starting point.

5. Click again at the point where you want to set your guide line. The final distance is displayed in the Measurements toolbar.

Tip: Starting from an endpoint or midpoint results in a Guide Point.

TR

Tape Measure Tool: Scaling an entire model
92



vI Scaling an entire model

You can rescale your model to a more precise dimension during the modeling process by specifying the desired dimension between two points using the Tape
Measure tool. This line is referred to as the reference line. To scale an entire model:

. Select the Tape Measure tool (vp). The cursor changes to a tape measure.
2. Measure the distance between two points on your model:
a. Click one end of a line segment to set the starting point of a measurement. Use the inference tool tip to make sure you click on the exact point.
b. Move the mouse to the end point of the same line segment. A temporary measuring tape line, with arrows at each end, will stretch out from your
starting point as you move the mouse.
c. Click again at the other end of the line segment. The final distance is displayed in the Measurements toolbar.
3. Enter a new size for the line in the Measurements toolbar and press the Enter (Microsoft Windows) or Return (Mac OS X) key. This size will be used as the
basis for a proportional rescale of your model. The following dialog box appears.

-

SketchUp

"

%) ?
- / Do you want to resize the model?

4. Click the Yes button. The model will be rescaled proportionally.

Note: Only components that are created within the current model (not dragged from the Components browser and loaded from an external component file) can
be resized.

Tape Measure Tool: Scaling entities

vp Scaling entities

You can rescale one or more entities using the Tape Measure tool. To scale an one or more entities:

. Select the Select tool ( 3 ). The cursor changes to an arrow.
. Select the entities you want to scale.
. Context-click while the cursor is over one of the selected entities. The selection set context menu is displayed.
. Select Make Group. The entities are grouped.
Note: This process also works with components.
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. Double-click on the group to enter the group's context.

. Select the Tape Measure tool (¥"). The cursor changes to a tape measure.
. Click one end of a line segment to set the starting point of a measurement. Use the inference tool tip to make sure you click on the exact point.
. Move the mouse to the end point of the same line segment. A temporary measuring tape line, with arrows at each end, will stretch out from your starting
point as you move the mouse.
9. Click again at the other end of the line segment. The final distance is displayed in the Measurements toolbar.
10. Enter a new size for the line in the Measurements toolbar and press the Enter (Microsoft Windows) or Return (Mac OS X) key. This size will be used as the
basis for a proportional rescale of your model. The following dialog box appears.

:\.’/ Do you want to resize the active group or component?

coONO wuv

11. Click the Yes button. The model will be rescaled proportionally.
Note: Only components that are created within the current model (not dragged from the Components Browser and loaded from an external component file)
can be resized.

Tape Measure Tool: Locking a line to a specific inference direction

vi Locking a line to a specific inference direction
Press and hold a directional button while measuring to lock an axis, each arrow corresponds to a specific axis:
e Up arrow = blue

e Left arrow = green
« Right arrow = red

Tape Measure Tool: Placing precise guide lines and guide points

vp Placing precise guide lines and guide points

The Measurements toolbar displays the distance that a guide line is from the starting point. Specify a different distance simply by typing it in the Measurements
toolbar. Specify a negative length to draw the line in the direction opposite the one indicated.

Tape Measure Tool: Tape Measure tool entities

vj Tape Measure tool entities

There are two types of entities when making guides. Click on the links below to find out more about each type:
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e Guide Line Entities
e Guide Point Entities

Tape Measure Tool: Guide line entities

»p Guide Line entities

Guide Line entities are infinite dashed lines used as guides to draw precisely. Guide lines do not interfere with regular geometry. Guide lines can also be hidden
and erased independent of regular geometry. Draw guide lines with the Tape Measure tool.

You can use the Move, Rotate, and Erase tools to reorient a guide line. But, you cannot resize a guide line because guide lines are infinite in length.
Hiding/erasing all guide lines

Guide lines are usually created as a temporary means to build a portion of your model. Keeping too many guide lines in your model can decrease SketchUp's
inference accuracy and display performance, so you might want to hide guide lines as you work or delete all guide lines at once when you have finished your

model.

Use Edit > Hide to hide the currently selected guide line. Use Edit > Erase Guides to erase all guides in the current context.

Tape Measure Tool: Guide Point entities

vp Guide Point entities

Guide point entities are finite dashed lines with end points as guides to draw precisely. Guide points do not interfere with regular geometry. Guide points can also
be hidden and erased independent of regular geometry. Draw guide points with the Tape Measure tool.

You can use the Move, Rotate, and Erase tools to reorient a guide point.

Hiding/erasing all guide points

Guide points are usually created as a temporary means to build a portion of your model. Keeping too many guide points in your model can decrease SketchUp's
inference accuracy and display performance, so you might want to hide guide points as you work or delete all guide points at once when you have finished your

model.

Use Edit > Hide to hide the currently selected guide line. Use Edit > Erase Guides to erase all guides in the current context.
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Protractor Tool
Protractor Tool: Introduction

p 4
@ . .
‘\/ Protractor tool introduction

Use the Protractor tool to measure angles and create angled guide lines. Activate the Protractor tool from the Guide Toolbar (Microsoft Windows), the Tool Palette
(Mac OS X) or the Tools menu.

Protractor Tool: Measuring an angle
& Measuring an angle
Measure an angle when you want to duplicate that angle elsewhere in your model or create plans, such as for a woodworking project. To measure and an angle:

1. Select the Protractor tool (&/ )- The cursor will change to a protractor, aligned to the red/green plane and with its center point fixed to the cursor.
2. Place protractor's center at a vertex of the angle (where two lines meet).
3. Click to set the vertex of the angle you will measure. The following image shows the protractor being placed at the angle's vertex.

4. Move the cursor in a circle until it is touching the start of the angle (one of the lines). The following image shows the first line in the angle (from the vertex
out along to the red square).

%
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. Click to set the start of the angle.

6. Move the cursor in a circle until it is touching the end of the angle (other line). Notice that the protractor has marks, indicating 15 degree increments, on
its edge. The angle will snap to these tick marks when the cursor is close to the protractor while moving around the protractor. Conversely, angle will move
in more precise (smaller) increments when your cursor is farther from the center of the protractor while moving around the protractor.

Note: Press the Esc key at any point during the operation to start over.

7. Click to measure angle. The angle's measurement will appear in the Measurements Toolbar. The value displayed in the Measurements Toolbar is referred to

as the angular rotation value. The following image shows the second line in the angle (from the vertex out along to the red square). The angle measures
120 degrees.

Note: Set the angle manually by entering a value in the Measurements Toolbar, and pressing Enter (Microsoft Windows) or Return (Mac OS X). The value can
either be in decimal degrees, such as 34.1, or slope, such as 1:6. This value can be changed any number of times before proceeding to the next command.

Protractor Tool: Creating angled guide lines

& Creating angled guide lines

Angled guide lines are useful to draw angled geometry such as a roof slope. To create an angled guide line:

1. Select the Protractor tool (Ea/ ). The cursor will change to a protractor, aligned to the red/green plane and with its center point fixed to the cursor.
2. Place protractor's center at a vertex of the angle.

3. Click to set the vertex of the angle you will measure. The following image shows the protractor being placed at the angle's vertex.
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4. Move the cursor in a circle until it is touching the start of the angle (one of the lines). The following image shows the first line in the angle (from the vertex
out along to the red square).

o

. Click to set the start of the angle.

. Press and release the Command (Microsoft Windows) or Option (Mac OS X) key.

. Move the cursor in a circle until the guide line is at the desired angle. Notice that the protractor has marks, indicating 15 degree increments, on its edge.
The angle will snap to these tick marks when the cursor is close to the protractor while moving around the protractor. Conversely, angle will move in more
precise (smaller) increments when your cursor is farther from the center of the protractor while moving around the protractor.

N o wv

Note: Press the Esc key at any point during the operation to start over.

8. Click to create the guide line. The following image shows a guide line created at a 45 degree angle so that a profile of a roof can be drawn.

Protractor Tool: Creating precise angles

V7 4
‘&/ Creating precise angles

The degree of rotation you have indicated appears in angular degrees in the Measurements Toolbar while creating guide lines using the Protractor tool. You can
also manually enter in angular rotation or slope values directly into the Measurements Toolbar while measuring an angle and setting a guide line.

Entering an angular rotation value

To specify an exact angle in degrees, type a decimal value into the Measurements Toolbar while rotating the cursor around the protractor. For example, typing in
34.1 will give you an exact 34.1 degree angle. Negative values will move angle in a counter-clockwise direction. You can specify an exact angular value either

during or immediately after your rotation operation.

Entering a slope value
To specify a new angle as a slope, type in the two values separated by a colon in the Measurements Toolbar, such as 8:12. Negative values will move angle in a

counter-clockwise direction. You can specify an exact angular value either during or immediately after your rotation operation.

Note: SketchUp can handle up to 0.1 of a degree of angular precision.

Protractor Tool: Locking the Protractor tool to its current orientation

7 4
& Locking the Protractor tool to its current orientation

Press and hold the Shift key, before you click on an entity, to lock the operation to that orientation.
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Axes Tool

Axes Tool: Introduction

* Axes tool introduction

Use the Axes tool to move, or reorient, the drawing axes within your model. For example, you might want to move the axes when you are constructing
rectangular objects that are skewed relative to one another. Or, you might use this tool to allow for more accurate scaling of objects that are not oriented along
the default coordinate planes. Activate the Axes tool from either the Construction Toolbar (Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

Axes Tool: Moving the drawing axes

* Moving the drawing axes
To move the Drawing Axes:

1.
2.

wv

7.

. Click to establish the origin.
. Move cursor away from the origin to set the direction for the red axis. Use the inference tool tips to make sure you

Select the Axes tool. The cursor changes to a collection of axes.

Move your cursor to a point in your model that you want to be the new origin. You will see the axes snap to
inferred alignments and points as you move near them around your model. Use the inference tool tips to make sure
your cursor is located exactly where you want it to be.

are aligned precisely.

. Click to accept the direction.
. Move your cursor away from the origin to set the direction of the green axis. Use inference tool tips again to make sure you are aligned precisely.

Note: Press the Esc key at any point during the operation to start over.

Click again to accept the direction.

You have moved your axes. The blue axis will appear perpendicular to the new red/green plane.

Note: Moving the drawing axes does not change the true ground plane for shadows and ground/sky display.

Axes Tool: Resetting the drawing axes

* Resetting the drawing axes

Context-click on the drawing axes and select 'Reset' from the context menu to restore the axes to the default position

Note: When context-clicking on the axes, there must be empty model space behind the axes. If there are entities behind the axes, the context menu for the
entities will appear.
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Dimension Tool

SketchUp Dimension Tool: Introduction

)
’(\ Dimension tool introduction

Use the Dimension tool to place Dimension entities in your model. Activate the Dimensions tool from the Guide Toolbar (Microsoft Windows), the Tool Palette
(Mac OS X) or the Tools menu.

SketchUp Dimension Tool: Placing linear dimensions

%,
‘(\ Placing linear dimensions

Dimensions in SketchUp are based on a 3D model. Edges and points can be used to take dimensions. Suitable points include: end points, midpoints, on edge
points, intersections, and arc and circle centers. Dimension leaders can be adjusted to span between non-linear points in a model so that your dimensions are as
useful as possible in 3D. To take a dimension between two points in your model:

)
1. Select the Dimension tool (’(\). The cursor changes to an arrow.
2. Click at starting point of your dimension.
3. Move the cursor toward the endpoint of your dimension.

4. Click on the endpoint of your dimension.
5. Move the cursor perpendicular to create a dimension string.

Note: Press the Esc key at any point during the operation to start over.
6. Click the mouse to fix the position of the dimension string.
Tip: You can take a dimension of a single line simply by clicking on the line and moving the cursor.
Tip: You might need to occasionally rotate your model, as you dimension, to position the dimension to the proper plane.
Warning: Type \n followed by a space to start a new line of text (Microsoft Windows).

The appearance of all Dimensions are set and controlled from the Dimension panel of the Model Info dialog box. These settings affect all dimensions already in
the model.

Dimension plane

You can take dimensions in one of several planes. These include the current axial planes (red/green, red/blue, red/green) or the plane aligned to the edge you
are measuring. Radius and Diameter dimensions are limited to the plane defined by the arc or circle. Once a dimension is taken and placed within a plane, it can
only be moved within that plane.

SketchUp Dimension Tool: Placing radius dimensions

%,
‘(\ Placing radius dimensions

To place a radius dimension on an Arc entity:

b,
. Activate the Dimension tool (’(\). The cursor changes to an arrow.
. Click on an Arc entity.
. Move the cursor to pull a dimension string out from the model.
. Click the mouse again to fix the position the dimension string.

HAWN R

SketchUp Dimension Tool: Placing diameter dimensions
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)
’{\ Placing diameter dimensions

To place a diameter dimension on a Circle entity:

)
. Activate the Dimension tool (’(\). The cursor changes to an arrow.
. Click on a Circle entity.
. Move the cursor to pull a dimension string out from the model.
. Click the mouse again to fix the position of the dimension string.

DAWN R

SketchUp Dimension Tool: Toggling dimension types

)
‘(\ Toggling dimension type

Context-click on the dimension and choose Type > Radius or Diameter, to change a radius dimension to a diameter dimension (or a diameter dimension to a
radius dimension).

SketchUp Dimension Tools: Dimension entities

%,
’(\ Dimension entities

Dimension entities are finite lines with length information allowing you to quickly and effectively communicate key dimensions of your model. Dimensions can
move and update automatically as you make changes to your model. Draw dimensions with the Dimension tool.

Each Dimension Object lies in its own plane, which is determined by the entity from which it is drawn and the direction used when it was created.
Dimension display properties, for all dimension entities in your model, can be adjusted using the Dimension panel of the Model Info dialog box.
Changing dimension text

A Dimension entities text displays the dimension by default. You can, however, change the dimension text to include additional information, such as text. Include
the symbols <> anywhere in your text to insert the dimension. For example, The length of this line is <>.

Warning: Dimensions that have lost their direct link to geometry or that have had their text edited might not show accurate measurements. Select the Highlight
non-associated dimensions option in the Dimension panel of the Model Info dialog box to highlight these dimensions in a specified color.
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Text Tool
SketchUp Text Tool: Introduction

Text tool introduction

Use the Text tool to insert text entities into your model. Activate the Text tool from either the Construction toolbar (Microsoft Windows), the tool palette (Mac OS
X), or the Draw menu.

There are two types of text in SketchUp: Leader text and Screen text.
SketchUp Text Tool: Creating and placing leader text

[REC]
F Creating and placing leader text

Leader text contains characters and a leader line that points (refers) to an = Guest Bedroom
entity. To create and place leader text: 7

[REC]

1. Select the Text tool (F). The cursor changes to an arrow with a text

prompt.

2. Click on any entity to indicate the ending point of the leader line (the

location where the leader should point).

3. Move the cursor to position the text. The leader line will grow and

shrink as you move the cursor around the screen.

4. Click to position the text. A text entry box appears with default text,
such as the name of a component (if the ending point of the leader
line is attached to a component), or the square footage of a square (if
the ending point of the leader line is attached to the face of a square).

. (optional) Click in the text box.

6. (optional) Enter text in the text box.

v

Note: Press the ESC key at any point during the operation to start over.

7. Click outside of the text box, or press the Enter (Microsoft Windows) or Return (Mac OS X) key twice, to complete text entry.

Tip: Press the Esc key at any time to cancel creation of the text entity.

Note: There are two styles of leaders: View Based and Pushpin. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D
space, and rotates with your model as you change your view. You can specify which type of leader is used from the Text panel of the Model Info dialog box.

Tip: Double-click on any face, while in the Text tool, to display the area of the face as a Text entity.

Tip: Type \n followed by a space to start a new line of text (Microsoft Windows)

SketchUp Text Tool: Creating and placing screen text

F
Creating and placing screen text

Screen text contains characters and is not associated with an entity and is fixed to the screen regardless of how you manipulate or orbit the model. To create and
place screen text:

[REC]
. Select the Text tool (F). The cursor changes to an arrow with a text prompt.
. Move your mouse to a blank area on the screen where you want the screen text to appear.
. Click to position the text. A text entry box appears.
. Enter text in the text entry box.
. Click outside of the text box, or press the Enter (Microsoft Windows) or Return (Mac OS X) key twice, to complete text entry. Screen text will stay fixed on
the screen regardless of how you manipulate and orbit the model.
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Tip: Type \n followed by a space to start a new line of text (Microsoft Windows).

SketchUp Text Tool: Editing text

Editing text

Double-click on text, with the Text tool or Select tool active, to edit the text. You can also context-click on a text entity and select the Edit Text menu item from
the text entity's context menu.

SketchUp Text Tool: Attaching text directly to a face
Attaching text directly to a face

Double-click on a face with the Text tool to attach text, without leader, to the face.

SketchUp Text Tool: Configuring text settings
Configuring text settings

Text entities are created using the settings found in the Text panel of the Model Info dialog box. Refer to the Text entity topic for further information.

Note: Text entities can have different attributes (font, size, and so on) while dimension settings are global.
SketchUp Text Tool:Text entities
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Text entities

Text entities allow you to annotate your SketchUp model in several ways. There are two types of Text entities: Leader text, which has leader lines and can be
attached to a face, or Screen text, which remains fixed to a point on your screen.

Text

[

Text entities can have their own font, color, and size settings. Use the Text tool to place text objects in your model.
Text leaders

Text objects can have one of four leader arrow styles: None, Dot, Closed arrow, and Open arrow. This can be changed using the context menu or its Entity Info
dialog box.

Text leaders are tied to the model, so as you rotate the model, the text information continues to be valid. As you move and adjust surfaces, the notes attached to
those surfaces adjust with them. Once a leader arrow is obscured the text will be hidden.

All text interacts with the model in three dimensions, but there are two ways for it to look on the screen. Thus, there are two main styles of leaders: View Based
and Pushpin. A View Based leader will always retain its 2D screen orientation. A Pushpin leader is aligned in 3D space, and rotates with your model as you change
your view.

View Based

2D view based leaders do not change as the model view is changed. There appearance remains the same based on the screen layout and viewing direction
present when they were placed. As you rotate the model, the actual text tries to stay oriented on the screen the same way, and the entire entity will follow
whatever it is attached to. When the leader arrow becomes obscured, the whole text entity disappears. This method works well for presentation of still images
from a particular vantage point.

Pushpin
3D pushpin leaders do change appearance as your view changes because they are drawn in 3D space just like model geometry. As you rotate the model, the

leader foreshortens, rotates and hides just like any edge geometry. 3D text can be repositioned in 3D space just like any other edge entity. This method works
well for planning studies and models that will be examined using fly-bys.
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3D Text Tool

3D Text Tool: Introduction

vl
4 3D Text tool introduction

Use the 3D Text tool to create 3 dimensional geometry from text. Activate the 3D Text tool from either the Construction Toolbar (Microsoft Windows), the Tool
Palette (Mac OS X) or the Tools menu.

This image shows the Place 3D Text dialog box on Mac OS X:
© 06O  Place3DText

Enter text

Font: Tahoma : 10"
Align: = Left 5 “ Fonts )

™ Filled ™ Extruded 1

{ Cancel )

This image shows the Place 3D Text dialog box on Microsoft Windows:

Place 3D Text X]

Font ITahoma :J IRegular L]
Align |Left w Height | 10”
Form [V Filled v Extruded |17

Place | Cancel I

3D Text Tool: Creating 3D text

& Creating 3D text
3D text is text is composed of regular SketchUp geometry (edges and surfaces). To create 3D text:

. Select the 3D Text tool. The 3D Text dialog box appears.

. Type text in the text field.

. Optionally, modify settings in the Place 3D Text dialog box. See The 3D Text dialog box for further information.
. Click on the Place button. You are placed in a move operation with the 3D text and the move tool.

. Move the 3D text to the desired location. Refer to the Move tool for further information.
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Note: Press the Esc key at any point during the operation to start over.

3D Text Tool: Place 3D Text dialog box

Aj Place 3D Text dialog box
Use the options in the Place 3D Text dialog box to enter and configure 3D text.

Font
Select a Font from the drop-down list to change font. Select Regular or Bold from the drop-down menu to create regular (non-bold) or bold text, respectively.

Height
Type the height, in current modeling units, in the Height text entry box.

Align
Select Left, Center, or Right, from the drop-down list to align two or more lines text to the left, center, or right respectively.

Filled

The 3D Text dialog box allows you to create 2D text with just outlines (edges) or faces, or 3D extruded text. Check the Filled checkbox to create faces for 3D
text. Uncheck the Filled checkbox to create 2D text outlines (just edges).

Note: The Filled checkbox must be checked to create 3D text.

Extruded

Check the Extruded checkbox to create extruded (push/pull) 3D text. Uncheck the Extruded checkbox to create 2D text.

The extruded checkbox must be checked to create 3D text.
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Section Plane Tool

Section Plane Tool: Introduction

/N
Section Plane tool introduction

Use the Section Plane tool to create section cuts enabling you to view geometry within your model. Activate the Section Plane tool from the Guide Toolbar
(Microsoft Windows), the Tool Palette (Mac OS X) or the Tools menu.

Section Plane Tool: Creating section cut effects

72N
Creating section cut effects

To add a section plane entity:

1. Select the Section Plane tool (@). The cursor changes to a pointer with a section plane.
Note: Press the Esc key at any point during the operation to start over.
2. Click on a face to create a Section Plane entity and resulting section cut effect.

Note: A section plane will not work on a selection set (you cannot preselect only those items you want to slice). Instead, the section plane will create a
section slice in all entities in the current context and, therefore, the slice will expand to cover all entities in the context.

Section Plane Tool: Manipulating section planes

72
Manipulating section planes

You can use the Move tool and Rotate tool to reposition section planes just as you reposition other entities. Additional methods for manipulating section planes
follows.

Reverse cutting direction
The direction of a section plane can be reversed by context-clicking on the section plane and selecting reverse from context menu.

Changing the active section plane
Newly placed section planes are active until another entity, such as another section plane, is selected.

There are two ways to activate a section plane: double-click on the section plane while in the Select tool or context-click on the section plane and select 'Activate
from the context menu.

Note: One section plane can be active for each context in your model. Therefore a section plane within a group or component can be active at the same time,
because they are in separate contexts, as a section plane outside of any group or component. A model that has a group that also contains two other groups has
four different contexts (one context outside of any group, one context inside the top level group, and one context each for the groups contained within the top-
level group), and can have four active sections at once.

Section Plane Tool: Creating grouped section slices

72N
Creating grouped section slices

To create grouped section slices, context-click on a Section Plane entity, then select 'Create Group from Slice' from the context menu. new edges, encapsulated
within a group, are generated (wherever the section plane intersects with faces).

This group may be moved off to the side as a section outline, or it may be immediately exploded, making the edges merge with the geometry from which they
were generated. This technique allows you to quickly make slices through any complex shape.

Section Plane Tool: Using sections with scenes

72N
Using sections with scenes

Active Section Plane may be saved to a scene. Section cut effects will animate during animations.

Section Plane Tool: Aligning your view

&7 Aligning your view

Use the 'Align View' command from the Section Plane Context menu to re-orient the model view to a view perpendicular to the section plane. Use this command,
in conjunction with Paraline mode, to quickly generate sectional elevation or 1-point perspective views of your model.

Section Plane Tool: Animating section cut effects

72N
Animating section cut effects

SketchUp allows you to animate section cut effects such that transitions are automatically inserted when you move between active section cuts. To animate a
section cut effect:

. Add two or more section slices to your model.

. Create two or more scenes.

. Activate one section cut in the first scene. The section cut effect is displayed.

. Activate the second section cut in the second scene. The section cut effect is displayed.

Context-click on the second scene. The scene context menu is displayed.

. Select the Update menu item.

. Context-click on the first scene. The scene context menu is displayed.

. Select the Play Animation menu item. SketchUp will cycle through each scene transitioning seamlessly between section cut effects.

103



Section Plane Tool: Section Plane entities

@ Section Plane entities

Section Planes are special entities that control the SketchUp section cutting effect. Their position in space and in relation to groups and components determine
the nature of the section cut effect. The following image shows a rectangular section plane creating a section cut effect in a model of a cup.

Section Plane Tool: Simultaneously activating multiple section planes

72
Simultaneously activating multiple section planes

SketchUp only allows you to have one section plane active per context. That means, you must place additional section planes within a group or component to
have simultaneous multiple section planes active.

Section Plane Tool: Exporting sections

@ Exporting sections
Sketchup allows you to export section cut effects (your model with a section slice) and section slices themselves.
Exporting models with section cut effects

Exporting models with section cut effects is the equivalent of exporting any model as a bitmap image file. Section planes and section cuts will appear in the
exported file depending on the visibility of the section plane and section cut.

Section slice

SketchUp can also export section slices using the Section Slice export feature. 2D vector sections can be accurately scaled and measured similarly to other 2D
vector exports.

Section Plane Tool: Hiding Section Plane entities and section cuts

72N
Hiding Section Plane Entities and Section Cuts

Use the Toggle Section Cuts toolbar item in the Section Planes toolbar (Microsoft Windows) or Customize toolbar screen (Mac OS X) to hide and unhide section
cuts. Additionally, you can use the Toggle Section Plane Display in the Section Planes toolbar (Microsoft Windows) or Customize Toolbar screen (Mac OS X) to hide
and unhide Section Plane entities. These controls are helpful in keeping your model uncluttered.
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Standard Views

Standard Views: Introduction

Standard views introduction
SketchUp provides several pre-defined standard point of views for your convenience. These point of views are (from left-to-right in the image below):

Isometric (Shift+1),

Top (Shift+2),

Front (Shift+4),

Right (Shift+6),

Back (Shift+5),

Left (Shift+7), and

Bottom (Shift + 3, not pictured).

e o6 o o o o o

Select a Standard View from Views Toolbar (Microsoft Windows), Standard Views Toolbar (Mac OS X) or the Camera menu.

L)

Tip: The standard views can be used with a parallel projection to produce elevation, plan, and section drawings.

Standard Views; Printing standard views in Perspective mode

Printing standard views in Perspective mode
Traditional rules of perspective apply when you are in Perspective mode and want to print or export your model as a 2D vector drawing, (the 2D output will not

be to scale as it is in SketchUp's 3D drawing area). For example, the Top and Isometric views will reorient your view in a similar way, but cannot create a true plan
or isometric drawing unless SketchUp is in Parallel Projection mode.

Standard Views: Using the Isometric (Iso) view

Using the Isometric (Iso) view
SketchUp will move your view to the true Isometric view closest to your current view angle when you activate the Isometric View. Use the Orbit tool to orient the

camera approximately where you want the view to be to change to a different Isometric view. Finally, activate the Isometric view to lock into an actual Isometric
view. (Remember that true Isometric views require Paraline mode.)
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Matching Photos and Models

Match Photo: Introduction

Match Photo introduction

Use the Match New Photo and Edit Matched Photo menu items to create a 3D model to match a photo or to match an existing 3D model to a photo's context.
Activate the Match New Photo and Edit Matched Photo menu items from the Camera menu.

SketchUp is commonly used to create designs of buildings or structures. SketchUp allows you to create these designs using the actual, real-world scale (a scale of
1:1 where a unit of measurement in SketchUp represents that actual unit of measurement in the real world). However, digital pictures are not at a 1:1 scale.
Therefore, to create a 3D model that matches a photo (or to match an existing SketchUp model to a scale in a photo), you must calibrate SketchUp's camera to
match the position and focal length of the digital camera used to take the picture.

High-level steps for creating a model from photos
Creating a model from photos consists of 4 high-level steps:
1. Take digital pictures of a building or structure. Refer to Taking Digital Photos for Use When Matching for further information.

2. Start matching. Matching involves loading a digital picture and calibrating SketchUp's camera to the position and focal length of the camera used to take
the actual photo (you are setting up the exact criteria used to take your picture so you can draw on the picture). You can also set the scale of the actual
building or structure while matching, or just resize the entire model after it has been drawn. Refer to Creating a 3D Model to Match a Photo for further
information.

3. Start sketching. Once you have duplicated the position and focal length of the camera used to take the picture, you can draw over the image in SketchUp.
SketchUp moves into a 2D sketching mode from matching (it is 2D because you are drawing on a 2D photo that needs to be oriented at a specific camera
angle to you). Refer to Creating a 3D Model to Match a Photo for further information.

4. Repeat Step 2 and 3 with any photos representing other views of the building or structure.

Note: You can also use the Match Photo feature to set a model within the context of one or more photos. For example, set a model of a new building in the
context of an empty lot. Refer to Matching an Existing 3D Model to a Photo's Context for further information.

Match Photo: Taking photos

Taking digital photos for use when matching

Your success with matching depends highly on the quality of photographs taken of your building or structure. Following are a few tips regarding taking
photographs:

e Take photos at a roughly 45 degree angle to each corner of the structure. Match Photo works best on pictures of structures composed of predominantly
right angles and taken at a roughly a 45 degree angle from a corner. Following is an example of a photo taken at a 45 degree angle to a corner:

e Do not crop photos. Match Photo currently requires that the point you aimed the camera at is located in the center of the image (also called the center of
projection). Although it may seem possible to use a cropped image, typically vertical lines will not align well across a cropped image and the results will be
unsatisfactory.

e Do not warp photos. Images which have been manually warped using an image processing program, or specialized camera, are not supported by Match
Photo.

e Remove barrel distortion or issues where straight lines are bent away from the center of the image. Barrel distortion typically occurs on wide angle lens
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cameras. Use a third-party product to eliminate barrel distortion from images prior to using them within Match Photo. All cameras have a little bit of this
distortion and it is typically worse around the edges of the image.

* Avoid stitched images (panoramic images). Stitched images are typically excessively warped and will have multiple vanishing points for each axis.

e Avoid excessive foreground features. If there are trees and other foreground objects blocking the view of the building, it may be difficult to Sketch Over
top of the image.

« Avoid vanishing points at infinity. Images where you are only adjusting one vanishing point bar, such as an image of a hallway or down a long train track,
are hard to use with Match Photo. Images taken with a very long telephoto lens (or a satellite or aerial image) as vanishing point bars will be hard to adjust.

Match Photo: Modeling from photos

Creating a 3D model to match a photo

Use the matching process to create a 3D model to match one or more photos of a building or structure. This process is best suited for making models of images
of structures containing features representing parallel lines, such as the top and bottom of a square window.

Note: There are several You Tube videos on the Match Photo feature, including two videos that use the same example found in this article. These videos might
use an different version of SketchUp, but the process and Match Photo tools are exactly the same.

To create a 3D model to match photos of a building or structure:

. Take digital pictures of the building or structure. See 'Taking Digital Photos for Use When Matching' for further information.

. Select the Camera > Match New Photo. The Select background image file dialog box is displayed.

. Navigate to the first photo in the series of photos for your building or structure.

. Click on the first photo in the series of photos for your building or structure. The photo is selected.

. Click the Open button. The photo will appear in the drawing area on its own scene in SketchUp. You are also placed in a matching mode where you will
calibrate SketchUp's camera to duplicate the position and focal length of the camera used to take the actual photo. The words 'Match Photo' appear in the
upper-left of the drawing area. Finally, the Match Photo dialog box appears. Refer to Matching Controls and Context-Menu Items for further information.
Following is a picture of match photo mode with a photo of a barn:
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6. Click and hold the cursor on the origin (“Ié: ). The cursor changes to a hand.
7. Move the cursor to a distinct origin-like point on photo (where three axes might intersect, such as bottom corner of building). Following is a picture of the

origin adjusted to the lower corner of the image:
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10.

Note: The origin you use depends on the photo:

o For photos that are usually taken indoors where walls, ceiling, and floor of a room meet at a corner, the origin is usually at the bottom corner where
the walls, ceiling, and floor meet.

o For photos that are taken from a vantage point where you are looking down on the building or structure, the origin would be at the top corner of the
building where roof and walls meet.

o For photos that are taken from a vantage point where you are standing on the ground, the origin would be the bottom corner where the walls and
ground meet.

. Release the mouse button. The origin is established.

There are four vanishing point bars in matching mode, two red bars and two green bars. Each bar is represented as a dashed line with square bar grips at
the end. Click on a red vanishing point bar grip ). The cursor changes to a hand.

Move the cursor to the starting point of a position on the photo representing a line parallel to the red axis, such as the track for the barn door. Zoom in, if
necessary, to ensure that the grip is over the upper-right corner of the barn door track.
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13.
14.

15.

. Release the mouse button.

. Click on the other red vanishing point bar grip. The cursor changes to a hand.

Move the cursor to the ending point of a position on the photo representing a line parallel to the red axis.

Release the mouse button. The first axis bar is aligned to the red axis, such as the track for the barn door. Zoom in, if necessary, to ensure that the grip is
over the upper-left corner of the barn door track.

Repeat steps 14 through 19 for the remaining three (one red and two green) vanishing point bars. Following is an image of the matching mode after all of
the vanishing point bars have been aligned to axis:

Note: Axis bars should be aligned to features that are parallel to their corresponding axis, such as window frames, roof lines, or door frames. Also, try to
pick the longest features as this will increase precision.
16. Click on the blue axis bar (Z axis). A two-way arrow appears.
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17. Drag the cursor up to adjust the scale larger or down to adjust the scale smaller. Use the model of the 2D person as a guide (the person appears in all new
SketchUp files). For example, if the model of the person is larger than a door, move the cursor down to adjust him to be smaller than the door - the size of
an average person. Following is an image showing the adjusted scale (the model of the person is now the correct scale to the photo):

18. Context-click to invoke the matching context-menu.

19. Click the Done button. You are placed in a sketching mode. This mode, unlike normal SketchUp drawing mode, is a 2D drawing mode. The words 'Sketch
Over' appear in the upper-left of the drawing area. The Pencil tool is active. Refer to Sketch-Over-Image Controls and Context-Menu Items for further
information.

20. Sketch on photo using the SketchUp drawing tools.

1. Use the Pencil tool to trace over the edges that make up the left-most side of the barn in the photo. Following is an image showing the traced photo.

Following is an image showing the resulting face:
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Following is an image showing the resulting model:

111



3. (optional) Add detail as necessary, such as roof overhangs.
4. (optional) Project the photo on the model of the building by selecting faces and clicking on the Project textures from photo button. The message
"Trip partially visible faces?" appears.
= Press the Yes button if you only want textures applied to the portion of faces that are shown in the image.
= Press the No button if you want textures applied to the entire face, even if the face is only partially shown.
The photo are projected on the faces of your model. Following is an image with a textured model:

Warning: Tools that manipulate your point of view force you out of Sketch-Over-Image mode into normal SketchUp drawing mode. These POV tools
are the Orbit Tool, Position Camera Tool, Walk Tool, and Look Around tool. Click on the scene tab to return to Sketch Over mode.

Match Photo: Re-entering matching mode
Re-entering matching mode
There are two options to re-enter matching mode. These options are:

e Select the photo you were matching from the Camera > Edit Matched Photo sub-menu.
e Context-click on the Scene tab for the photo you were matching and select Edit Matched Photo.

Match Photo: Re-entering sketching mode

Click on the scene tab that represents the photo to return to sketching mode.
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Match Photo: Deleting matched photo

Deleting a matched photo
To delete a matched photo:

. Select the Window > Scenes. The Scenes Manager is displayed.

. Click on the scene with the same name of the matched photo. The photo is selected.

. Click on the Remove Scene button. A dialog box appears asking if you want to delete the scene.
. Click the Yes button. The scene and its matched photo are removed.

D wWN =

Note: Alternatively, context-click on a Scene tab and select Delete to delete the matched photo.

Match Photo: Matching models to photos

Matching an existing 3D model to a photo's context

Use the matching process to match an existing 3D model to a photo's context. For example, you might have a model of a house that contains an addition and
want to place that within a photo to show the change. To match an existing 3D model to a photo's context:

1. Take a digital picture of the location where you will place your building. This photo might or might not have an existing building where the model will be
located.

. Select File > Open. The Open dialog box appears.

. Navigate to your model.

. Select the model.

. Click the Open button. The model appears in the drawing area. The following image shows a model of a simple schoolhouse.
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. Select Camera > Match New Photo. The Select background image file dialog box is displayed.

. Navigate to the photo where you want to place your building or structure.

. Click on the photo. The photo is selected.

. Click the Open button. The photo will appear in the drawing area on its own scene in SketchUp. You are also placed in a matching mode where you will
calibrate SketchUp's camera to duplicate the position and focal length of the camera used to take the actual photo. The words 'Match Photo' appear in the
upper-left of the drawing area. Finally, the Match Photo dialog box appears. Refer to Matching Controls and Context-Menu Items for further information.
Following is a picture of match photo mode with a photo of a schoolhouse:

O o NO
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10. Click and hold the cursor on the origin (”Iﬁ: ). The cursor changes to a hand.
11. Move the cursor to a distinct origin-like point on photo (where three axes might intersect, such as bottom corner of building). Following is a picture of the

origin adjusted to the lower corner of the image:

Note: The origin you use depends on the photo:

For photos that are usually taken indoors where walls, ceiling, and floor of a room meet at a corner, the origin is usually at the bottom corner where
the walls, ceiling, and floor meet.

For photos that are taken from a vantage point where you are looking down on the building or structure, the origin would be at the top corner of the
building where roof and walls meet.

For photos that are taken from a vantage point where you are standing on the ground, the origin would be the bottom corner where the walls and
ground meet.

o

. Release the mouse button. The origin is established.
. Uncheck the Model checkbox in the Match Photo dialog box. The model will be hidden.

. There are four vanishing point bars in matching mode, two red bars and two green bars. Each bar is represented as a dashed line with square bar grips at

the end. Click on a green vanishing point bar grip ). The cursor changes to a hand.

Move the cursor to the starting point of a position on the photo representing a line parallel to the green axis, such as the top of the school entrance. Zoom
in, if necessary, to ensure that the grip is over the upper-right corner of the school entrance.
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16. Release the mouse button.

17. Click on the other green vanishing point bar grip. The cursor changes to a hand.

18. Move the cursor to the ending point of a position on the photo representing a line parallel to the green axis.

19. Release the mouse button. The first axis bar is aligned to the green axis, such as the entrance to the school. Zoom in, if necessary, to ensure that the grip
is over the upper-left corner of the school entrance.

20. Repeat steps 14 through 19 for the remaining three (one red and two green) vanishing point bars. Following is an image of the matching mode after all of
the vanishing point bars have been aligned to axis:

Note: Axis bars should be aligned to features that are parallel to their corresponding axis, such as window frames, roof lines, or door frames. Also, try to
pick the longest features as this will increase precision.
21. Check the Model checkbox in the Match Photo dialog box. The model will reappear, oriented correctly to the photo (but likely not-to-scale with the photo).
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22. Click on the blue axis bar (Z axis). A two-way arrow appears.
23. Move the cursor up or down the axis to scale your model. Your model will scale to fit the photo. Following is an image showing the adjusted scale (the
model to the correct scale of the photo):

24. (optional) If your photo contains an existing building that is now represented by your model, click the Project textures from photo button in the Match
Photo dialog box to project the photo on the model. The message "Trip partially visible faces?" appears.
o Press the Yes button if you only want textures applied to the portion of faces that are shown in the image.
o Press the No button if you want textures applied to the entire face, even if the face is only partially shown.
The photo are projected on the faces of your model. Following is an image with a textured model:

25. Context-click to invoke the matching context-menu.

26. Click the Done button. You are placed in a sketching mode. This mode, unlike normal SketchUp drawing mode, is a 2D drawing mode. The words 'Sketch
Over' appear in the upper-left of the drawing area. The Pencil tool is active. Refer to Sketch-Over-Image Controls and Context-Menu Items for further
information.
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27. (optional) Add new features to your model such as a room addition or fence.

Warning: Tools that manipulate your point of view force you out of Sketch-Over-Image mode into normal SketchUp drawing mode. These POV tools are the
Orbit Tool, Position Camera Tool, Walk Tool, and Look Around tool. Click on the scene tab to return to Sketch Over mode.

Match Photo: Matching controls and context menu items

There are three sets of controls that are accessible during matching mode. These controls are: The matching controls that appear over the photo, the controls
that appear in the Match Photo dialog box, and the matching context-menu items.

Matching controls appearing over the photo
Matching controls appear over your photo during matching mode. A description of these controls follows:

Origin
The origin appearing in matching mode is used to identify where the three axis meet and is used to help you create geometry aligned to the photo. The location
of the origin depends on the type of photo:

e For photos that are usually taken indoors where walls, ceiling, and floor of a room meet at a corner, the origin is usually at the bottom corner where the
walls, ceiling, and floor meet.

e For photos that are taken from a vantage point where you are looking down on the building or structure, the origin would be at the top corner of the
building where roof and walls meet.

e For photos that are taken from a vantage point where you are standing on the ground, the origin would be the bottom corner where the walls and ground
meet.

Axis lines extend out from the origin. You can click on an axis line and move the cursor along the axis line to increase or decrease the size of the geometry that
you have drawn. Following is an image of the origin and axis lines:

Vanishing Point Bars
There are four vanishing point bars in matching mode, two red bars and two green bars. Each bar is represented as a dashed line with square bar grips at the
end. These bars are further used to align the axis to the photo. Following is an image of the vanishing point bars:

a

D
Match Photo dialog box controls

Refer to the Match Photo dialog box for an explanation of each of the controls in the Match Photo dialog box.
Matching context-menu items

Context-click during matching to display the matching context-menu.

Done
Select the done menu item to end your matching.

Start Over
Select the Start Over menu item to restart matching.

Cancel Match
Select the Cancel Match menu item to cancel and exit your matching.

Zoom Matched Photo
Select the Zoom matched photo menu item to fit the entire drawing area.

Zoom Vanishing Points
Select the Zoom vanishing points menu item to zoom to fit all vanishing points in the drawing area.

Rotate 90 Left
Select the Rotate 90 left menu item to rotate the red and green axes 90 degrees left. Use this menu item primarily when creating a model to match several photos
(to rotate the model as you draw the model's sides to match the different sides of the structure in different photos).

Rotate 90 Right
Select the Rotate 90 right menu item to rotate the red and green axes 90 degrees right. Use this menu item primarily when creating a model to match several
photos (to rotate the model as you draw the model's sides to match the different sides of the structure in different photos).

Undo
Use the Undo menu item to undo the last matching command.

Redo

Use the Redo menu item return the last undo to its previous state.

Match Photo: Sketching controls and context-menu items

There are three sets of controls that are accessible during sketching mode. These controls are: The SketchUp drawing and modification tools, a few of the Match
Photo dialog box controls, and the sketching context-menu items.
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The SketchUp drawing and modification tools

All of the SketchUp drawing and modification tools are available during sketching mode.

Match Photo dialog box controls

Refer to the Match Photo dialog box for an explanation of each of the controls in the Match Photo dialog box.
Styles Browser Modeling panel controls

There are two sets of controls at the bottom of the Styles Browser Modeling panel used during sketching mode. Refer to the Styles Browser Modeling panel for an
explanation of these controls.

Sketching context-menu items
Context-click during a Sketch-Over-Image session to display the Sketch-Over-Image session context-menu.

Edit Photo Match
Select the Edit Photo Match menu item to resume the Photo Match session.

Project Photo
Select the Project Photo menu item to project the photo's texture on your model.

Zoom Matched Photo
Select the Zoom matched photo menu item to fit the entire drawing area.
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Orbit Tool

Orbit Tool: Introduction

#’ Orbit tool introduction

Use the Orbit tool to rotate the camera about the model. The Orbit tool is useful when viewing geometry from the outside. Activate the Orbit tool from either the
Camera Toolbar (Microsoft Windows), Tool Palette (Mac OS X), or the Camera menu.

Keyboard Shortcut: O

Orbit Tool: Orbiting the view

#’ Orbiting the view

The Orbit tool performs a 3D orbit. To orbit using the Orbit Tool:

1. Select the Orbit tool (@). The cursor changes to two interconnected perpendicular ovals.
2. Click anywhere in the drawing area.
3. Move your cursor in any direction to rotate around the center of the drawing area.

Note: Double-click the left mouse button on your model to center to the model in the drawing area.

Orbit Tool: Suspending the gravity setting

# Suspending the gravity setting

The Orbit tool is designed to maintain a sense of gravity by keeping vertical edges pointed up and down. Press and hold the Ctrl (Mac = Opt) key during orbit to
suspend this gravity setting and to roll the camera on its side.

Orbit Tool: Orbiting with a three-button mouse

#’ Orbiting with a three button mouse

The Orbit tool is used heavily when creating and editing models. SketchUp contains a few mouse enhancements and modifier keys to allow easy access to the
Orbit tool.

Activating the Orbit tool while in another tool

Click and hold middle mouse button (scroll wheel) on a three-button mouse to temporarily activate the Orbit tool while in any other tool (except the Walk tool).
Note: Click and hold the Control and Command keys simultaneously while clicking and holding the left mouse button to temporarily activate the Orbit tool (if you
have only one mouse button) (OS X).

Note: You will also be put in pan temporarily if you click on the middle-mouse wheel and then click and hold the left mouse button or press and hold the Shift
key.
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Pan Tool

Pan Tool: Introduction

777
/.~ Pan tool introduction

Use the Pan tool to move the camera (your view) vertically and horizontally. Activate the Pan tool from either the Camera Toolbar (Microsoft Windows), or Tool
Palette (Mac OS X) or the Camera menu.

Keyboard Shortcut: H

Pan Tool: Panning the view

777
/.~ Panning the view

The Pan tool performs a pan operation. To pan using the Pan Tool:

177
1. Select the Pan tool (/7). The cursor changes to a hand.
2. Click and hold the left mouse button anywhere in the drawing area.
3. Move the cursor in any direction to pan.

Pan Tool: Panning while in other tools (one-button mouse - Mac OS X)

177
)} Panning while in other tools (One button mouse - Mac OS X)

Click and hold the Control, Command, and Shift keys simultaneously while clicking and holding the mouse button to temporarily activate the Pan tool (if you have
only one mouse button or are using the track pad).

Pan Tool: Panning while in the Orbit tool (three-button mouse)
1177
)} Panning while in the Orbit tool (Three button mouse)

Press and hold the Shift key while in the Orbit tool to temporarily activate the Pan tool. Or, press and hold the left mouse button while pressing and holding the
middle mouse button (scroll wheel) to activate the Pan tool.
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Zoom Tool

Zoom to Photo Tool

Zoom to Photo tool

Use the Zoom to Photo tool to move the camera (your view) in such that the entire photo fills the drawing area. This menu item is active while matching a photo.
Activate the Zoom to Photo tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X), or the Camera menu.

Zoom Extents Tool

L~
£ " Zoom Extents tool

Use the Zoom Extents tool to zoom your view to a distance which makes the whole model visible and centered in the drawing area. Activate the Zoom Extents
tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X), or the Camera menu.

Keyboard Shortcut: Shift+Z

Zoom Tool: Introduction

q Zoom tool introduction

Use the Zoom tool to move the camera (your view) in or out. Activate the Zoom tool from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS
X), or the Camera menu.

Keyboard Shortcut: Z

Zoom Tool: Zooming in and zooming out of your model

q Zooming in and zooming out of your model
To zoom in and out using the Zoom Tool:
1. Select the Zoom tool. The cursor changes to a magnifying glass.

2. Click and hold anywhere in the drawing area.
3. Move the cursor up to zoom in (closer to the model) and down to zoom out (farther from the model).

Zoom Tool: Zooming with a scroll wheel mouse

’\ Zooming with a scroll wheel mouse

Rolling wheel forward on a scroll wheel mouse zooms in on your model. Rolling the wheel backward on a scroll wheel mouse zooms out from your model.

Note: The cursor position determines the center of zoom when using the scroll wheel whereas the center of the screen determines the center of zoom when
zooming using the left mouse button.

Zoom Tool: Centering the point of view

q Centering the point of view

Double-click the left mouse button on your model to center the model in the drawing area.

Zoom Tool: Changing focal length with the Zoom tool

q Changing focal length with the Zoom tool

Focal length, expressed in millimeters, affects the amount you can see of a model. A shorter focal length allows you to see a larger (wide) portion of a model,
while a longer focal length allows you to see a smaller portion of a model. To change the focal length:

1. Select the Zoom tool (q). The cursor changes to a magnifying glass.
2. Type a focal length in millimeters, such as 30@mm. The value appears in the VCB and the focal length changes to 300mm.

Note: Focal length can range from 10 to 2063 millimeters.

Zoom Tool: Changing field of view

q Changing field of view

Field of view, expressed in degrees, refers to the amount you can see of a model. A narrow field of view only allows you to see a small portion of a model, while a
wider field of view allows you to see more of a model. Wider fields of view are useful when working inside a room where you might want to see more of the room
while you draw. To change field of view:

1. Select the Zoom tool. The cursor changes to a magnifying glass.
2. Hold the shift key while moving the cursor up or down. The field of view increases when the cursor goes up. The field of view decreases when the cursor
goes down.

Note: The Measurements Toolbar will display field of view in degrees when using the Zoom tool in the field of view mode.

Note: Alternatively, you can select Camera > Field Of View to change field of view.
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Zoom Tool: Adjusting perspective (field of view)

q Adjusting perspective (Field of view)

Adjust the screen to an exact perspective or camera lens by typing an exact value in the Measurements Toolbar while the Zoom tool is active. For example, 45
deg sets a 45 degree field of view and 35 mm sets the equivalent focal length of a 35mm camera. Press and hold the Shift key while in the Zoom tool to visually
adjust the camera lens or field of view. Remember, changing the FOV keeps the camera in the same location in 3D space.

Zoom Window Tool: Introduction

‘\
g‘ Zoom Window tool introduction

Use the Zoom Window tool to zoom in on a specific portion of your model. Activate the Zoom Window tool from either the Camera Toolbar (Microsoft Windows),
or Tool Palette (Mac OS X), or the Camera menu.

Zoom Window Tool: Zooming In on a portion of your model

‘\
R‘ Zooming in on a portion of your model

The Zoom Window tool allows you to draw a rectangular zoom window around a portion of your model. The Zoom Window tool will then zoom in on the content
within the zoom window. To zoom in on a portion of your model:

\
. Select the Zoom Window tool (g‘). The cursor changes to a magnifying glass with small square.
. Click and hold a short distance away from the entities you want to appear in the zoom window. This is the zoom window starting point.
. Move cursor diagonally.
. Release the mouse button when all of the entities are enclosed within the zoom window. These entities will fill the screen.

HWN R
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Camera tools

Next

w Next

Use the Next option to advance to the next view of your model. Next can be used after using the Orbit Tool, Pan Tool, Position Camera Tool, Look Around Tool,
or any of the Zoom tools. Activate the Next option from the Camera menu.

Previous

]! Previous

Use the Previous option to return to the last view of your model. Previous can be used after using the Orbit Tool, Pan Tool, Position Camera Tool, Look Around
Tool, or any of the Zoom tools. Activate the Previous option from either the Camera Toolbar (Microsoft Windows), or Tool Palette (Mac OS X), or the Camera
menu.
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Walk Tool

Walk Tool: introduction

o . .
«" Walk tool introduction

Use the Walk tool to maneuver through your SketchUp model as though you were walking through your model. Specifically, the Walk tool fixes the camera to a
particular height, and then allows you to maneuver the camera around your model. The Walk tool is available only in Perspective mode. Activate the Walk tool
from the Walkthrough toolbar (Microsoft Windows), Tool Palette (Mac OS X) or the Camera menu.

Walk Tool: Touring your model

ot
«* Touring your model
The Walk tool is primarily used to take an interactive walk through or around your model. To use the Walk tool to tour your model:

1. Select the Walk tool. The icon changes to a pair of shoes. Notice that the Measurements toolbar indicates that the eye height above the ground plane is set
to 2 feet, 10 1/2 inches. You can override this height at this time by typing in a desired value.

2. Click and hold anywhere in the drawing area. A small plus sign (cross hair) is placed at the location where you clicked.

3. Move the cursor up (forward), down (backward), left (to go left) or right (to go right) to walk through or around your model. The further you are from the
cross hair, the faster you walk.

Note: Press and hold the Shift key while moving the cursor up and down allows you to move up or down instead of forward or backward. Press and hold the Ctrl
(Microsoft Windows) or Option (Mac OS X) key to run instead of walk. Press and hold the Alt key to avoid collision detection (walk through walls).

Tip: It is often desirable to tour a model with a wide field of view. Activate the Zoom tool, press and hold the Shift key, and press and drag up and down to widen
your field of view prior to walking through a model.

Walk Tool: Looking around while in the Walk tool
'

«" Looking around while in the Walk tool
Click and hold the middle mouse button, while using the Walk tool, to use the Look Around tool.
Walk Tool: Ascending and descending

'Y
«" Ascending and descending

The Walk tool automatically walks up and down inclines or steps while maintaining eye height.
Walk Tool: Toggling collision detection

o i isi ;

«" Toggling collision detection

Press the Alt (Microsoft Windows) or Command (Mac OS X) key while walking around to temporarily turn off collision detection. This option is useful when
examining models such as mechanical devices or furniture (anything other than the interior of a building).
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Look Around Tool

Look Around Tool: Introduction

&

Use the Look Around tool to pivot the camera (your view) around a stationary point. The Look Around tool behaves similarly to a person standing still while
turning their head to up, down (¢ilt), and side to side (pan). The Look Around tool is particularly useful for viewing the inside of spaces, or to evaluate visibility
after using the Position Camera tool. Activate the Look Around tool from either the Walkthrough toolbar (Microsoft Windows, Tool Palette (Mac OS X) or the
Camera menu.

Look Around tool introduction

Look Around Tool: Looking around
&

Looking around

The Look Around tool performs tilt and pan operations. To tilt and pan using the Look Around tool:

&

1. Select the Look Around tool (™ ). The cursor changes to a pair of eyes.

2. Click to start pivot.
3. Move the cursor up or down to tilt; right or left to pan.

Look Around Tool: Specifying an eye height
&

Type the eye height for the camera in the Measurements toolbar and press the Enter (Microsoft Windows) or Return (Mac OS X) key to change the height above
the ground plane for the camera.

Specifying an eye height

Look Around Tool: Activating the Look Around tool while in the Walk tool
&

Click the middle mouse button to activate the Look Around tool while in the Walk tool.

Activating the Look Around tool while in the Walk tool
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Walkthrough tools

Position Camera Tool: Introduction

Q Position Camera tool introduction

Use the Position Camera tool to position the camera (your view) at a specific eye height so that you can check the line of sight of a model or walk through a
model. Activate the Position Camera tool from either the Walkthrough toolbar (Microsoft Windows), Tool Palette (Mac OS X) or the Camera menu.

Position Camera Tool: Positioning the camera

Q Positioning the camera

The camera is positioned using one of two methods. The first method places the camera at eye-level above a specific point (5' 6" above that point by default).
The second method placing the camera at a specific point, facing a specific direction.

Positioning the camera at an eye-level view

The first position camera method allows you to position the camera at a specific eye-height above a specific point that you choose. The camera does not point at
anything in particular. However, you are placed in the Look Around tool allowing you to move the camera around the point to look at items in your model.

1. Select the Position Camera tool ( ;Q ). The cursor changes to a small person with a red X. Notice that the Measurements toolbar indicates that the eye
height above the ground plane is set to 5 feet, 6 inches. You can override this height at this time by typing in a desired value.

2. Click on a point in your model. SketchUp places the camera's point of view at an average eye-height over the point you click on. You are also placed in the
Look Around tool. The following image shows a point in the middle of a room. The camera will be positioned directly above this point (5' 6") facing the
television set if you click at this point.

Note: The viewing direction defaults to the top of screen, which is due north, if you place the camera from a plan view.

Positioning the Camera Using Specific Target Points

The second position camera method allows you to position the camera at a specific point, facing a specific direction.

1. Select the Position Camera tool ( ;Q ). The cursor changes to a small person with a red X. Notice that the Measurements toolbar indicates that the eye
height above the ground plane is set to 5 feet, 6 inches. You can override this height at this time by typing in a desired value.

Tip: Use the Tape Measure tool and the Measurements toolbar to drag parallel construction lines off of edges as a method to provide accurate camera
placements.

2. Click and hold mouse button on a point in your model.

3. Drag the cursor to the portion of the model that you want to look at. A dotted line is extended from the point selected in step 2 to the portion of the model
you want to look at.

4. Release the mouse button. The camera is repositioned at a height of 0 at the point selected in step 2. The camera faces the item you dragged the cursor to
in step 3. The following image shows a point in the middle of a room with a dotted line to the window on the left wall of the room. The camera will be
positioned directly at the first point (at 0 height) facing up at the window if you release the mouse button on the window.
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5. (optional) Type a new eye height into the Measurements toolbar to reposition the camera at eye height above the point selected in step 2.
Tip: Position the camera directly horizontal to the model to achieve a 2 Point Perspective.

Tip: Hold the Shift key while clicking on a surface to position the camera directly on the surface.
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Sandbox From Scratch Tool

Sandbox From Scratch Tool: Introduction

2 sandbox From Scratch tool introduction

Use the Sandbox From Scratch tool to generate a flat triangulated TIN that can be sculpted into other forms using other sandbox tools. The Sandbox From
Scratch tool generates the TIN in the red/green or ground plane. This tool is useful in creating terrain when no other terrain model or data is available. Activate
the Sandbox From Scratch tool from the Draw menu.

Note: You must enable the Sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Sandbox From Scratch Tool: Creating a new TIN

720
ﬁ‘i Creating a New TIN
To create a new TIN:

1. Select the Sandbox From Scratch tool. The cursor changes to a pencil with a grid.

Note: The Sandbox From Scratch tool defaults to 10" square grid sizes. You might want to zoom out or change the grid size (Grid Spacing) in the
Measurements toolbar before creating your sandbox.

Tip: You can optionally enter a value in the Measurements toolbar for the size of each square in your grid at this time (Grid Spacing).

2. Click to set the starting point of your TIN.

3. Move the mouse in the direction you want to be the length of the TIN. As you move your mouse a line appears with tick marks at a specific spacing. The
length value is displayed dynamically in the Measurements toolbar.

4. Click a second time to establish the length of your TIN.

5. Drag the mouse perpendicular to the length line to establish the width of your TIN.

6. Click a third time to establish the width of your TIN. The following image shows the flat TIN created with the Sandbox From Scratch tool.

Note: The terrain will be placed inside of a Group entity. You must edit or explode the group to perform other operations, such as smoothing with the Smoove
tool, on the TIN.

Sandbox From Scratch Tool: Creating precise TINS

70
@ Creating precise TINs

The Measurements toolbar displays the length and width of your TIN while you are drawing a flat TIN. You can also specify a line length and width value using the
Measurements toolbar.

Entering length and width values

Specify a length and width in the Measurements toolbar by typing in the desired length after placing the starting point of the flat TIN. SketchUp will use the
current document units setting if you only type in a numerical value. You can also specify either Imperial (1'6") or Metric (3.652m) units at any time, regardless
the model units setting.

Sandbox From Scratch Tool: Drawing a flat TIN by inference

i
@ Drawing a flat TIN by inference

The Sandbox From Scratch tool uses SketchUp's sophisticated geometric inference engine to help you place your terrain in 3D space. The inference decisions,
made by the inference engine, are displayed in the drawing area as inference lines and inference points. These lines and points show precise alignment between
the line you are drawing and the geometry of your model. Refer to the inference engine topic for additional information.
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Smoove Tool
Smoove Tool: Introduction

E Smoove tool introduction

Use the Smoove tool to sculpt an existing TIN by allowing vertical movement of a selection of points, edges, or faces and their immediately adjacent geometry.
The result is a smooth deformation of a triangulated surface. Activate the Smoove tool from the Tools menu.

Note: You must enable the sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Smoove Tool: Sculpting a terrain

E Sculpting a terrain

To sculpt a terrain:

1. Create a TIN, such as with the Sandbox From Scratch tool, or import a TIN. The following image shows a flat terrain created with the Sandbox From Scratch
tool.

2. Select the Smoove tool. The cursor changes to an arrow.
Tip: Alternatively, you can preselect a series of points, edges, and faces and then click on the Smoove tool to begin a smoove operation.

3. Click on a point, edge, or face within the TIN. SketchUp highlights all neighboring vertices to be included in the sculpting operation within the radius
specified in the Measurements toolbar. The following image shows the point that was selected (the largest square in the middle) and neighboring vertices.

Note: Remember to ungroup a terrain created with the Sandbox From Scratch tool prior to using the Smoove tool.

4. Move the mouse up or down in the vertical (blue) direction to sculpt the TIN. The TIN will expand or contract accordingly. You can also type offset value in
the Measurements toolbar, such as 1@'. The following image shows the terrain resulting from moving the point and neighboring vertices up.

Note: You can sculpt in a direction other than vertical by holding down the Shift key while moving the mouse. However, this operation can result in a non-
functional terrain or terrain that can no longer be manipulated in a known way. This operation can only be performed while in active selection (not after
preselection).

5. Smooth and soften the TIN to get your final model.

Tip: Double-click to repeat the last smoove operation.

Smoove Tool: Specifying sculpting radius values

E Specifying sculpting radius values

SketchUp determines the number of vertices included in the sculpting operation based on a radius value. The larger the radius the more vertices included in the
sculpt. The Measurements toolbar displays this radius while you are sculpting a TIN. You can also specify a radius value while sculpting, such as 1@'r, using the
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Measurements toolbar.

Tip: Preselect a series of points, faces, and edges within your TIN to sculpt more specific shapes such as ridges and berms.

Smoove Tools: Specifying an offset value

m Specifying an offset value

The Measurements toolbar also specifies an offset while you are sculpting. You can also specify an offset value, such as 10", using the Measurements toolbar.
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Drape Tool

Drape Tool: Introduction

@ Drape tool introduction
Use the Drape tool to project edges, such as the edges in a road, onto a terrain. Activate the Drape tool from the Tools menu.

Note: You must enable the Sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Drape Tool: Draping edges onto a TIN

@ Draping edges onto a TIN
Note: The Drape tool will only drape the edges surrounding a face if you attempt to drape a face or series of faces over the TIN.
1. Create a TIN, such as with the Sandbox From Scratch tool, or import a terrain.

2. Create the edges you want to drape over the TIN. The edges can be in a single plane (flat) and must be positioned above a TIN. The following image shows
a 2D road positioned above a terrain.

3. Select the edges that you want to drape over the TIN.
4. Select the Drape tool. The cursor changes to an arrow.
5. Click on the TIN to drape the selected edges on the TIN. The following image shows the edges draped over the terrain.

Note: The draped edges will be outside of a group or component context if the TIN is encapsulated within a group or component.

Tip: This tool also works in active selection mode to select the drape edges if nothing is preselected.

Drape Tool: Painting draped terrain

=

\—@ Painting draped terrain

Terrain is typically contained within a group. Paint the draped section without editing the group will paint the entire terrain instead of just a section of the terrain.
You must edit the group to paint individual sections of the terrain.
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Add Detail Tool

Add Detail Tool: Introduction

E Add Detail tool introduction

TINs do not have to consist of triangles of the same size. Use the Add Detail tool to split triangles into additional, smaller triangles, and make small detailed
modifications to your TIN. Any click on your TIN creates new triangles centered around a new vertex that you can manipulate. Activate the Add Detail tool from
the Tools menu.

Note: You must enable the sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Smaller triangles equate to a smoother final TIN. However, having an abundance of small triangles in your TIN can also decrease performance. The Add Detail tool
can help strike a balance between detail and performance by allowing you to add detail only to areas of the TIN where it is needed.

Add Detail Tool: Detailing a TIN

E Detailing a TIN

To detail a terrain:

1. Create a TIN. The image (slide 1) shows a flat TIN or sandbox created with the Sandbox From Scratch tool.

2. Select the Add Detail tool. The cursor changes to an arrow.

3. Click on a point, edge, or face within the TIN. SketchUp creates a new vertex where you clicked with new triangles spanning out from the new vertex. The
image (slide 2) shows two additional triangles created when the midpoint of a line was selected.

4. Move your mouse up or down to adjust the height of the vertex and surrounding triangles. The image (slide 3) shows the resulting TIN when the new
vertex was lifted.

Note: You can also type in an offset distance to adjust the height of the vertex after clicking on a point, edge, or face within the terrain. For example, 10"
will raise the new vertex 10' above the starting terrain.

Note: You can sculpt in a direction other than vertical by holding down the Shift key while moving the mouse. However, this operation can result in non-
functional terrain or terrain that can no longer be manipulated in a known way.

5. Continue clicking on points, edges, or faces (either on the TIN you created in step 3, or on other portions of the TIN) to create additional triangles for

manipulation.
6. Smooth and soften the TIN to get your final surface.

Add Detail Tool: Specifying an offset value

E Specifying an offset value

The Measurements toolbar also specifies an offset while you are detailing a TIN. You can also specify an offset value, such as 10", using the Measurements
toolbar.

Add Detail Tool :Creating smooth areas

% Creating smooth areas

You can preselect a series of triangles in your model using the Select tool and then use the detailer to divide those triangles to create a smoother area. The
following image shows a flat TIN with a selection set that was detailed two times (creating several tiny triangles). This area of the model will appear very smooth
when sculpted, using a tool such as the Smoove tool.
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Sandbox tools

Enabling the Sandbox tools

To enable the sandbox tools:

e Open the Extensions Manager (Window > Preferences > Extensions on Microsoft Windows or SketchUp > Preferences > Extensions on Mac OS X).
e Select the checkbox next to the extension that you want to enable.
e Click OK.

Improving Sandbox tool performance

The more complex your model (the more faces), the slower SketchUp. Some Sandbox tools are capable of creating a lot of faces, thus slowing performance.
Following are some tips for improving performance using the Sandbox tools.

Depending on the complexity of the model, it can take SketchUp several minutes to several hours to calculate the geometry created by the Sandbox tools.
SketchUp may even appear to have stopped responding. Once you have started a Sandbox operation, you should not make any more changes to the model until
after SketchUp has finished the operation. If you make any changes before that, you'll interrupt the calculations.

Sandbox From Contours tool

Simplify contours so that they have fewer lines and end points (when the complexity of the contours is not important for your overall model). Use the Simplify
Contours script to reduce the number of line segments and endpoints. This script evaluates each pair of segments in a contour. If a pair forms an angle that is
less than the simplify angle, which defaults to 10 degrees, they are merged into one segment, eliminating one endpoint. You can change the simplify angle when
running the script.

You can reduce the endpoints by 50% or more when using the 10 degree setting, while maintaining contours that are smooth enough for modeling. To use the
Simplify Contours Ruby script:

1. Download the Simplify Contours script from the SketchUp web site .
2. Uncompress the Simplify Contours script to create a SimplifyContours.rb file.
3. Place the Simplify Contours script into your Plugin The Plugins folder on Microsoft Windows is at:s folder.

C:\Program Files\Google\Google SketchUp #\Plugins
The Plugins folder on Mac OS X is at:
/Library/Application Support/Google SketchUp #/SketchUp/plugins

. Restart SketchUp.

. Open your model with the contoured terrain.

. Select all of the contours. The contours are highlighted.
. Select the Plugins > Simplify Contours.

. (optional) Set the Simplify Angle.

. Click the OK button. The contours are simplified.
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Sandbox From Scratch tool

Reduce grid complexity, by adjusting grid spacing to be larger, when creating a sandbox from scratch.

Stamp and Drape tool

The Stamp tool and Drape tool create additional faces from existing terrain. Simplify your existing terrain to yield simpler results with these tools by:

e Simplifying your contours if your existing terrain was created from contours.
e Adjusting grid spacing to be larger if your existing terrain was created from scratch.
e Crop existing terrain to essential area needed for your model (removing all unneeded geometry).

The following image shows the additional polygons created when using the Stamp tool on a complex terrain (rectangles that compose the house foundation):

The following image shows the additional polygons created when using the Stamp tool on a simple terrain (rectangles that compose the house foundation):
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http://sketchup.google.com/download/rubyscripts.html

The following image shows the additional polygons created when using the Drape tool on complex terrain (shaded below the house foundation):

The following image shows the additional polygons created when using the Drape tool on a simple terrain (shaded below the house foundation):

Add Details tool

Minimize use of this tool unless you truly need to add detail to your model because this tool adds additional faces to your terrain.

Flip Edge Tool: Introduction

. Flip Edge tool introduction

Use the Flip Edge tool to manually adjust the triangulation for any pair of adjacent triangles in a TIN. This tool is useful in removing flat spots or plateaus in a
terrain generated from contour lines. Activate the Flip Edge tool from the Tools menu.

Note: You must enable the Sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Image 1 contains a terrain with several opposing triangulations (triangles that point opposite to each other):

Triangulations whose sides run north and south create plateaus in the TIN. The Flip Edge tool can be used to flip these triangulations and remove these plateaus
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(creating slopes). Image 2 shows terrain with the triangulations flipped:

Tip: You can easily see triangles with opposing triangulation by displaying hidden geometry. Turn on hidden geometry (View > Hidden Geometry) to view the
triangles in the TIN.

Flip Edge Tool: Modifying TINs

E Modifying TIN triangulations
To modify TIN triangulations:

. Create a TIN using a tool such as the Sandbox From Contours tool.

. Select the Flip Edge tool.

. Move the mouse over the TIN to highlight edges that can be flipped.

. Click on any edge to flip the edge to an opposite triangulation. SketchUp analyzes the two adjacent triangles that share the edge, removes the selected
edge, and replaces it with a perpendicular edge.
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Stamp Tool: Introduction

@ Stamp tool introduction

Use the Stamp tool to create impressions in a TIN by pushing a duplicate of the base of geometry, such as a house, into a TIN. Activate the Stamp tool from the
Tools menu.

Note: You must enable the Sandbox tools before you can use them. See Enabling the Sandbox tools for further information.

Stamp Tool: Creating impressions of geometry in a TIN

@ Creating impressions of geometry in a TIN
To create an impression of geometry in a TIN:

1. Create your TIN, such as the terrain where a building might exist.
2. Create the faces to be used as the stamp, such as the bottom faces of the building.
3. Move the stamp over the location in the TIN where you want to create an impression.
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Note: The stamp can be an individual face, selection set of faces, a group, or a component.

4. Select the Stamp tool. The cursor changes to an arrow.
5. Click on the stamp. SketchUp will create an offset around the stamp.
6. (optionally) Adjust the offset size by typing in a new value in the Measurements toolbar.
7. Click on the TIN.
8. A copy of the stamp will be indented into the TIN. The cursor will be on the copy of the stamp allowing you to move the stamp, and connected TIN, up or
down.
9. Move the mouse to adjust the stamp within the TIN.
10. Click when you are done adjusting the stamp.
11. Smooth and soften the TIN to get your final model.

Note: The Stamp tool will not work on a group or component that is open for editing.

Sandbox From Contours Tool: Introduction

E Sandbox From Contours tool introduction

Use the Sandbox From Contours tool to create a TIN from contour lines. You must create or import contour lines that are offset in their height prior to using this
tool. Activate the Sandbox from Contours tool from the Draw menu.

Note: You must enable the Sandbox tools before you can use them. See Enabling the Sandbox tools for further information.
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The following image shows several contour lines offset in height from the ground plane.

The following image shows the resulting terrain created when the Sandbox From Contours tool is used on the selected contours.

Tip: In some cases the Sandbox From Contour tool might create triangulations in the TIN that result in flat spots or plateaus. These plateaus can be
retriangulated (to create a slope) using the Flip Edge tool.

Sandbox From Contours Tool: Creating a sandbox from contour lines

ﬂ Creating a Sandbox From Contour Lines
To create Sandbox From Contour lines:
1. Import or draw several contour lines. Ensure that the contour lines are offset in their height from the ground plane.

2. Select all of your contour lines.
3. Select Draw > Sandbox > From Contours. Terrain will be filled in using the contour lines as a guide.
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Solid Tools

Solid Tools Introduction

SketchUp's Solid tools work only on SketchUp solids. In SketchUp, a solid is any 3d model (component or group) that has a finite closed volume. A SketchUp solid
cannot have any leaks (missing faces or faces that do not meet at an edge).

You can select a component or group and visit the Entity Info dialog box to see if the selection is a solid. If there is a volume listed, the selection is a SketchUp
solid. If there is no volume listed, the selection is not a solid and likely has a leak.

The following image contains several solids:

U0

There are six Solid tools in SketchUp - all operate only on solid models:

L

The Intersect tool ( ) operates on two or more solids and results in only the overlapping parts.

The Subtraction tool ( ) operates on two solids and merges the intersecting geometry from the second selected solid with the first selected solid. The
first solid is then removed leaving only the second solid (minus its intersecting geometry).

Just like the Subtraction tool, The Trim tool ( ) operates only on two solids and merges the intersecting geometry from the second selected solid with
the first selected solid. Unlike the Subtraction tool, the Trim tool leaves the first solid in the result.

e The Split tool ( ) splits all of the parts of two solids into separate groups or components wherever the solids overlap.

&

e The Union tool ( ) merges all outer faces of two or more overlapping solids to create one larger SketchUp solid. The Union tool leaves all internal
geometry in the result.

e The Outer Shell tool ( ) works just like the Union tool, but removes all internal geometry from the result. Therefor, the Outer Shell tool is the preferred
tool for creating lightweight models, such as buildings for Google Earth, because only the outer faces of the model are needed to convey the design.

Outer Shell Tool: Creating an outer shell

@

The Outer Shell tool is used to remove and clean up geometry that is on the inside of overlapping groups or components (all outer faces remain). The Outer Shell
tool is often used, for example, to to remove unneeded geometry on the inside of a model of a structure to improve the model's performance in Google Earth. An
intersection can be performed on two or more intersecting groups or components.

Creating an outer shell

The result of an outer shell is similar to the result of a union. However, the result of an outer shell can only contain external faces while the result of a union can
also contain internal geometry.

The following image shows two square tubes on the left, a union of the tubes in the center, and an outer shell of the tubes on the right:

Activate the Outer Shell tool from the tool palette (Mac OS X), the Solid Tools toolbar (Microsoft Windows) or the Tools > Solid Tools menu.

The following image shows two groups:
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The following image shows these two groups when they overlap:

The following image shows the overlapping geometry of these two groups using X-Ray mode:

To create an outer shell:

@ A

). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow

1. Select the Outer Shell tool (

with the number 1 (k ) if you are over a group or component.

2. Click on the group or component. The first group or component is selected. The following image shows the right group selected: 138



3. Click on the second group or component. The outer faces remain.

Note: The Outer Shell tool will only operate on geometry that has watertight volume (no holes).

The Outer Shell works on nested components and groups (one level of nesting).

Creating an outer shell by preselecting groups or components

You can also preselect the groups or components before performing an outer shell. To preselect groups and components and perform an outer shell:
. Select the Select tool ( k ). The cursor changes to an arrow.

. Select all of the intersecting groups or components. The selected entities are highlighted in blue.

. Context-Click on one groups or components. The context-menu appears.
. Select Solid Tools > Outer Shell. The outer faces remain.

HAWN R
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Intersect Tool: Performing an intersection

@ This is a Pro only feature.

&

An intersection refers to the geometry of one group or component that intersects or overlaps with another group or component. An intersection can be
performed on two or more intersecting groups or components and results in only the intersecting geometry. Activate the Intersect tool from the tool palette (Mac
0OS X), the Solid Tools toolbar (Microsoft Windows) or the Tools > Solid Tools menu.

Performing an intersection

The following image shows two groups:

The following image shows these two groups when they overlap:

140



The following image shows the overlapping geometry of these two groups using X-Ray mode:

To perform an intersection:

@ re

). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow with

1. Select the Intersect tool (
LS
the number 1 ( ) if you are over a group or component.

2. Move the cursor over one of the groups or components. The cursor changes to an arrow with the number 1 ( ).
3. Click on the group or component. The first group or component is selected.
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4. Click on the remaining groups or components. The resulting intersecting geometry remains.

A

&

Note: Solid tools will only operate on geometry that has watertight volume (no holes).
Performing an intersection by preselecting groups or components

You can also preselect the groups or components before performing an intersection. To preselect groups and components and perform an intersection:

1. Select the Select tool ( g ).
2. Select all of the intersecting groups or components. The selected entities are highlighted in blue.

3. Context-Click on one groups or components. The context-menu appears.
4. Select Solid Tools > Intersect. The resulting intersecting geometry remains.

Union Tool: Performing a union

@ This is a Pro only feature. 142
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Performing a union

A union is the merging of two or more solid volumes into a single solid volume.

The result of a union is similar to the result of an outer shell. However, the result of a union can contain internal geometry whereas an outer shell can only
contain external faces.

The following image shows two square tubes on the left, a union of the tubes in the center, and an outer shell of the tubes on the right:

Activate the Union tool from the tool palette (Mac OS X), the Solid Tools toolbar (Microsoft Windows) or the Tools > Solid Tools menu
The following image shows two groups:

The following image shows these two groups when they overlap:

The following image shows the overlapping geometry of these two groups using X-Ray mode:
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To perform a union:

@ r?

1. Select the Union tool ( ). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow with the

L
number 1 ( ) if you are over a group or component.

N

L3
. Move the cursor over on of the groups or components. The cursor changes to an arrow with the number 1 ( ).
3. Click on the group or component. The first group or component is selected.

4. Click on the second group or component. The resulting union of the geometry remains.
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Note: Solid tools will only operate on geometry that has watertight volume (no holes).
Performing a union by preselecting groups or components

You can also preselect the groups or components before performing a union. To preselect groups and components and perform a union:

1. Select the Select tool ( k ). The cursor changes to an arrow.
2. Select all of the intersecting groups or components. The selected entities are highlighted in blue.

3. Context-Click on one groups or components. The context-menu appears.
4. Select Solid Tools > Union. The union of the components or groups remains.

Subtract Tool: Performing a subtraction
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@ This is a Pro only feature.

Performing a subtraction

A subtraction refers to the merging of overlapping geometry from one group or component with the geometry from a second group or component (the
overlapping geometry is merged with the first selected group or component). The first group or component is then removed from the result. A subtraction can
only be performed on two overlapping groups or components. The resulting subtraction also depends on the order the groups or components are selected.
Activate the Subtract tool from the tool palette (Mac OS X), the Solid Tools toolbar (Microsoft Windows) or the Tools > Solid Tools menu.

The following image shows two groups:

The following image shows these two groups when they overlap:

The following image shows the overlapping geometry of these two groups using X-Ray mode:
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To perform a subtraction:

@ A

1. Select the Subtract tool ( ). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow with
LS
the number 1 ( ) if you are over a group or component.

2. Move the cursor over one of the groups or components. The cursor changes to an arrow with the number 1 ( ).
3. Click on the group or component. The first group or component is selected. The following image shows the right group selected:

4. Click on the second group or component. The resulting geometry remains.
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Selecting the left group first would yield the following result:

Note: Solid tools will only operate on geometry that has watertight volume (no holes).
Performing a subtraction by preselecting groups or components

You can also preselect the groups or components before performing a subtraction. To preselect groups and components and perform a subtraction:

. Select the Select tool ( 3 ). The cursor changes to an arrow.

. Select two overlapping groups or components. The selected entities are highlighted in blue.

. Context-Click on one groups or components. The context-menu appears.

. Select Solid Tools > Subtract. The first group or component remains with the subtraction of the second merged. The following image shows the result

when the left group was selected first:
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Selecting the right group first would yield the following result:

Trim Tool: Performing a trim

@ This is a Pro only feature.

@

A trim refers to the merging of overlapping geometry from one group or component with the geometry from a second group or component (the overlapping
geometry is merged with the first selected group or component). Unlike a subtraction, the first group or component remains in the result of a trim operation. A
trim can only be performed on two overlapping groups or components. The resulting trim also depends on the order in which the groups or components are
selected. Activate the Trim tool from the tool palette (Mac OS X), the Solid Tools toolbar (Microsoft Windows) or the Tools > Solid Tools menu.

Performing a trim

The following image shows two groups:
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The following image shows these two groups when they overlap:

The following image shows the overlapping geometry of these two groups using X-Ray mode:

To perform a trim:

@ A

). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow with the

1. Select the Trim tool (

LS
number 1 ( ) if you are over a group or component.

150



2. Move the cursor over one of the groups or components. The cursor changes to an arrow with the number 1 ( ).
3. Click on the group or component. The first group or component is selected. The following image shows the right group selected:

4. Click on the second group or component. The resulting trimmed geometry remains.

Selecting the left group first would yield the following result:
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Note: Solid tools will only operate on geometry that has watertight volume (no holes).

Performing a trim by preselecting groups or components

You can also preselect the groups or components before performing a trim. To preselect groups and components and perform a trim:

. Select the Select tool ( 3 ). The cursor changes to an arrow.

. Select two overlapping groups or components. The selected entities are highlighted in blue.

. Context-Click on one groups or components. The context-menu appears.

. Select Solid Tools > Trim. The two groups or components remain with the difference of the second merged. The following image shows the result when

the left group was selected first:
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Selecting the right group first would yield the following result:
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Split Tool: Performing a split

@ This is a Pro only feature.

&

A split refers to the splitting of overlapping geometry into individual parts. Activate the Split tool from the tool palette (Mac OS X), the Solid Tools toolbar
(Microsoft Windows) or the Tools > Solid Tools menu.

Performing a split

The following image shows two groups:

O
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The following image shows these two groups when they overlap:

The following image shows the overlapping geometry of these two groups using X-Ray mode:
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To perform a split:

@ A

1. Select the Split tool ( ). The cursor changes to an arrow with a circle and a slash ( ) if you are not over a group or component or a arrow with the
1
number 1 ( ) if you are over a group or component.

2. Click on the group or component. The first group or component is selected. The following image shows one group selected:

3. Position the cursor over the second group or component. The group or component is selected.

4. Click on the second group or component. The resulting split geometry remains:

The groups or components are now split into additional groups or components where geometry overlaps:

Note: Solid tools will only operate on geometry that has watertight volume (no holes). 154



Performing a split by preselecting groups or components

You can also preselect the groups or components before performing a split. To preselect groups and components and perform a split:

1. Select the Select tool ( 3 ). The cursor changes to an arrow.
2. Select two overlapping groups or components. The selected entities are highlighted in blue.

3. Context-Click on one groups or components. The context-menu appears.
4. Select Solid Tools > Split. The resulting split geometry remains:

The groups or components are now split into additional groups or components where geometry overlaps:
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Google Toolbar

Toggle Terrain Button

% Toggle Terrain introduction

Use the Toggle Terrain button to toggle the Google Earth snapshot image between a 2D and 3D image.

Toggle Terrain

E Toggling terrain
To toggle a terrain:

1. Get the current view from Google Earth using the Get Current
View button. A 2D Google Earth image will appear by default.

2. Click on the Toggle Terrain button. The 2D Google Earth image
will toggle to a 3D Google Earth image (with terrain).

Note: The Get Current View button actually captures two images
from Google Earth, one with terrain and one without terrain. Each
image is assigned to a different layer in SketchUp whose visibility
is toggled using the Toggle Terrain button.

Tip: Develop your model on the 2D image then toggle to the 3D
image and adjust the model's location to the contours of the
terrain.

Hiding Google Earth terrain

SketchUp imports two terrain images, one 3D and one 2D, when the Add Location feature is used in SketchUp. Each image is locked on its own unique layer. The
3D image's layer is named Google Earth Snapshot. The 3D image's layer is Google Earth Terrain. Only one of these snapshots (layers) is visible at a time. To hide
all Google Earth terrain:

1. Select Window > Layers. The Layer Manager is displayed.
2. Deselect the checkboxes under the Visible column for the Google Earth Snapshot and Google Earth Terrain layers. All Google Earth terrain will be hidden.

Warning: You should not unlock the Google Earth terrain image layers, and you should never place any geometry on those layers. Geometry placed on those
layers won't be displayed when you place the model in Google Earth.

Uploading a component to 3D Warehouse

Use the Upload Component menu item to upload the currently selected component to the 3D Warehouse. To upload a component:

. Select the component to be uploaded to the Trimble 3D Warehouse. The component is selected.
. Context-click on the component. The context-menu appears.

. Select the Share Component menu item. The Sign In dialog box is displayed.

. Sign in to the Trimble 3D Warehouse. The Trimble 3D Warehouse appears.

. Fill in the fields on the "Update your model to 3D Warehouse" page.

. Press the Upload button. The component is uploaded.
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Tip: Use the upload component option when you have a single building component that you want to upload (among several buildings in your model). Remember
to set the component axes for the single building (right click on component > Change Axes) to match the intersection of the component and the terrain,
otherwise, your component will be floating after upload to the 3D Warehouse.

Finding and downloading models from the 3D Warehouse into SketchUp

The Trimble 3D Warehouse is an online collection of 3D models or components. There are several ways to find and download models or components from the
Trimble 3D Warehouse while working within SketchUp.

Downloading components using the Components Browser
SketchUp's Component Browser allows you to download models in the Trimble 3D Warehouse. To search and download models using the Component Browser:

1. (In SketchUp). Select Window > Components. The Components Browser is displayed.

2. Enter the type of component you're looking for in the "search” field to find related models from the 3D Warehouse and press the Enter (Microsoft Windows)
or Return (Mac OS X) key. A list of components appears.

3. Click on the thumbnail image of the component that you like to download the component into SketchUp. One of the following will occur:

o If the current model in SketchUp has location information (such as terrain downloaded from Google Earth or another building downloaded from the
Trimble 3D Warehouse), and the model you are downloading from the 3D Warehouse also has a location information, a dialog box appears. This
dialog box states "The model being imported is located at a specific place on Earth, which may be far away from the current model." Press Choose
new location if you want the model you are downloading to appear at its intended location (it might be accompanied by Google Earth terrain). Press
Preserve location if you want the model you are downloading to appear at the same location as the current model in SketchUp.

o If the current model in SketchUp doesn't have location information, but the model you are downloading from the 3D Warehouse has location
information, the downloaded model is placed on the ground plane at the axes origin. The solid green axis points north, the solid red axis points
west, and the solid blue axis points up.

o If the model you are downloading doesn't have a location information (for example, a model of a chair), the model is downloaded and attached to a
Move tool cursor. Refer to the Move Tool for further information.

Note: If the model contained Scenes (different views of the model) or screen text, they are not displayed.

Tip: Add "author:Google" to your search string to find components made by Google. For example, search for "tree author:Google" to to find trees created by
Google.

Downloading models using the Google toolbar
SketchUp's Google toolbar allows you to download models from the Trimble 3D Warehouse. To search and download models using the Google toolbar:

1. Click on the Get Models button to access the 3D Warehouse from within SketchUp.
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Enter the type of model you're looking for in the "search" field.

. Click on the Search button. Thumbnail icon representations of models are displayed.

. Click on the thumbnail image of the model that you like to view the model.

. Click on the Download Model button to download the model into SketchUp. The message "Load this directly into your SketchUp model" appears.

. Click Yes to download the model directly into SketchUp. One of the following will occur:

o If the current model in SketchUp has location information (such as terrain downloaded from Google Earth or another building downloaded from the
Trimble 3D Warehouse), and the model you are downloading from the 3D Warehouse also has a location information, a dialog box appears. This
dialog box states "The model being imported is located at a specific place on Earth, which may be far away from the current model." Press Choose
new location if you want the model you are downloading to appear at its intended location (it might be accompanied by Google Earth terrain). Press
Preserve location if you want the model you are downloading to appear at the same location as the current model in SketchUp.

o If the current model in SketchUp doesn't have location information, but the model you are downloading from the 3D Warehouse has location
information, the downloaded model is placed on the ground plane at the axes origin. The solid green axis points north, the solid red axis points
west, and the solid blue axis points up.

o If the model you are downloading doesn't have a location information (for example, a model of a chair), the model is downloaded and attached to a
Move tool cursor. Refer to the Move Tool for further information.

Note: Click No to download the model to your computer.

Note: If the 3D Trimble Warehouse model contained Scenes (different views of the model) or screen text, they are not displayed.

Downloading models using the Trimble 3D Warehouse separate from SketchUp
You can access the Trimble 3D Warehouse directly through your web browser to find pre-made models:

. Visit the 3D Warehouse using your Web browser. The 3D Warehouse is at http://sketchup.google.com/3dwarehouse

. Enter the type of model you're looking for in the "search” field.

. Click on the Search button. Thumbnail icon representations of models are displayed.

. Click on the thumbnail image of the model that you like to view the model .

. Click on the Download Model button. A list of SketchUp versions and other formats appear.

. Select the version of the file that is closest to the version of your copy SketchUp. A dialog box appears asking if you want to open the model with SketchUp
or save the file.

7. Select Open with SketchUp Application (default). SketchUp is run and the model is inserted in a new file.
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Note: A model that was created with an earlier version of SketchUp will download and work fine in a newer version of SketchUp.
Note: If the 3D Warehouse model contained Scenes (different views of the model) or screen text, they are not displayed.

Note: (SketchUp 6) Select File > 3D Warehouse > Get Models... to find additional models.

Launching Building Maker from Sketchup

Click on the Add New Building button ( \';’) from the or select File > Building Maker > Add New Building to launch Building Maker from SketchUp.

The Add New Building button is on the Large Tool Set toolbar and the Google toolbar on Microsoft Windows and on the Google tool palette on Mac OS X.

Creating Buildings with Building Maker and SketchUp

This article presents two workflows for using Google Building Maker and SketchUp together to create 3D Buildings. The first workflow (“From Building Maker to
SketchUp”) is a way for people to start in Building Maker to create their rough buildings and then bring them into SketchUp for further detailing.

The second workflow (“From SketchUp to Building Maker”) is a way for people to work entirely in SketchUp to create a Building Maker building and then enhance
that building with SketchUp.

From Building Maker to SketchUp

Building Maker is a terrific tool for creating low polygon count buildings for Google Earth. Building Maker models can be taken into SketchUp for further
modification. To create a Building Maker model in Building Maker and modify that model in SketchUp:

1. Launch Building Maker (http://sketchup.google.com/3dwarehouse/buildingmaker).

2. Create a Building Maker model. Align each block to at least 6 images to ensure all imagery appears in SketchUp. Refer to the Building Maker Getting Started
Guide for further information. The following image contains a simple two block building maker model:

. Save the Building Maker model.

. Select the My Models menu item in the My Warehouse menu.

. Click on the building you just created

. Click on the the Download Model button. A list of download file types is displayed.

. Click on the link next to “SketchUp 8 (.skp).” The "Generating SketchUp File" dialog box is displayed. The resulting SketchUp file (.skp) is saved to your
computer.

. Double-click on the resulting SketchUp file to load SketchUp. The building model appears in SketchUp with a tab for each image you used in Building
Maker. Each scene is a photo matching scene. The following image shows the model in SketchUp with corresponding Scene tabs:
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The following image shows the scene thumbnails in the Scene Manager (notice that the active scene has a pencil icon):

9. Make modifications to the model in SketchUp 8. The following image shows the building with air conditioning units and sign modeled in SketchUp using
the sketch over mode:

10. Click the Share Model button (‘) from SketchUp. The model is uploaded back into 3D Warehouse over the original Building Maker model.
From SketchUp to Building Maker
To create a Building Maker model in SketchUp and modify in SketchUp:
1. Click on the Add new building button (‘). Building Maker opens in a web dialog box.

2. Create a Building Maker model. Align each block to at least 6 images. Refer to the Building Maker Getting Started Guide for further information. The
following image contains a simple one block building maker model:
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. Click on the SketchUp Export button. The Save to the Trimble 3D Warehouse dialog box appears.

. Fill in the information for your model.

. Click the Save button. The "Generating SketchUp File" dialog box is displayed. The building model appears in SketchUp with a tab for each image you used
in Building Maker. Each scene is a photo matching scene. The following image shows the model in SketchUp with corresponding Scene tabs:
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The following image shows the scene thumbnails in the Scene Manager (notice that the active scene has a pencil icon):

6. Make modifications to the model in SketchUp 8. The following image shows the building with air conditioning units and additional walls modeled in
SketchUp using the sketch over mode:

7. Click the Share Model button (‘) from SketchUp. The model is uploaded back into 3D Warehouse over the original Building Maker model.

Share Model button

'i Share Model introduction
Use the Share Model button to post your model to the 3D Warehouse. Refer to the 3D Warehouse documentation for further information.

Note: The thumbnail of your model appearing in the 3D Warehouse will represent the view of the model in SketchUp at the time the model was shared.

Get Models button

g Get Models introduction

Use the Get Models button to download models from the 3D Warehouse. Refer to the 3D Warehouse documentation for further information.

Share Component button

Share component button

Use the Share Component button to post the currently selected component to the 3D Warehouse. Refer to the Uploading a component to the 3D warehouse for
further information.

Note: The thumbnail of your model appearing in the 3D Warehouse will represent the view of the model in SketchUp at the time the component was l‘fglgaded.



Tip: Use the upload component option when you have a single building component that you want to upload (among several buildings in your model) or for
dynamic components.
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Add Location

Add Location: Introduction

Use the Add Location button (@) to capture 2D and 3D snapshot images of the current view in Google Earth. These images are used as the context for your 3D
SketchUp models.

Add Location: Adding a location
To add a location:

i 000 Add Location ]
Enter an address or intersection...

iceland
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. Click on the Add Location button (@). The Add Location dialog box appears. This dialog box allows you to navigate a two-dimensional view of the world

and find a location for your model.

. Find the location where you want your 3D model to appear. There are two ways to find a location:

a. Manually navigate to the location. Refer to the Add Location Dialog Box for further information.
b. Type the address in the search field and click the Search button.

. Click on the Select Location button. A cropped image of the location appears with four pins, one on each corner.
. Click and hold the left mouse button on one of the pins, such as the upper-left pin.
. Move the mouse cursor (pin) to a position in the Add Location image such that your location is still in the image, but other unneeded location information

is cropped.

. Release the left mouse button. The following image shows the upper-left pin placed at the upper-left corner of the location:
. Repeat steps 4-6 for the remaining three pins. The following image shows all four pins placed to define the location. The size of the location or site is

subjective. However, the larger the site, the larger your SketchUp file.

. Click the Grab button to grab the selected portion of the Add Location image and place it in your model. A 2D image of the location is placed in SketchUp.

This image is locked so that you cannot mistakenly delete it.

Setting the location of your model

The easiest way to assign location information for a SketchUp model is to first add the location to your model using the Add Location dialog box and then
creating your model on that location. To set the location of your model:

1.

2.

[N

Click on the Add Location button. The Add Location dialog box appears. This dialog box allows you to navigate a two-dimensional view of the world and
find a location for your model.
Find the location where you want your 3D model to appear. There are two ways to find a location:

a. Manually navigate to the location. Refer to the Add Location Dialog Box for further information.

b. Type the address in the search field and click the Search button.

. Click on the Add Location button in the Add Location dialog box. A 2D image of the current view is placed in SketchUp. This image is locked so that you

cannot mistakenly delete it.

. Create your structure on top of the location. The structure will be associated with the geographic information of the current view.
. Click on the Preview Model in Google Earth button to view your SketchUp models in Google Earth. Google Earth is launched. SketchUp creates a

temporary file of your model and places the model in Google Earth at the proper location.

6. Click on the Share Model button in the Google toolbar. The 3D Warehouse appears.
7.
8. Follow the steps to post your model in the 3D Warehouse.

Log in to the 3D Warehouse. You will need a Google account if you do not have one.

Stitching locations together

You can often get better quality images by flying in close on a location in the Add Location dialog box, but this can prevent you from seeing the entire area you
want to use. However, you can easily stitch together multiple terrain images. To stitch together multiple terrain images:

. Click on the Add Location button (@). The Add Location dialog box appears. This dialog box allows you to navigate a two-dimensional view of the world

and find a location for your model.

. Find the location where you want your 3D model to appear. There are two ways to find a location:

a. Manually navigate to the location. Refer to the Add Location Dialog Box for further information.
b. Type the address in the search field and click the Search button.

. Click on the Add Location button in the Add Location dialog box. A 2D image of the current view is placed in SketchUp. This image is locked so that you
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cannot mistakenly delete it.

. Repeat steps 1 to 3 by selecting a location that is within 1000 meters and at the same elevation of the first location. Selecting locations at different
elevations or at a great distance apart might result in improperly aligned structures in Google Earth.

Note: The latitude and longitude found in the Model Info dialog box always refers to the center of the first added location.

163



SketchUp and Google Earth

Keeping or deleting a model that you placed in Google Earth

Keeping a model available in Google Earth that you placed from SketchUp.
There are two ways to keep a SketchUp model available in Google Earth.

Share it via the 3D Warehouse. The advantage of this method is that it makes it easy to share your model with others. If you choose "Google Earth Ready" when
you upload your model, it'll also be considered for inclusion in the 3D Buildings layer.

1. Open your model in SketchUp.
2. Click Share Model.
3. For more information about how to share a model via the 3D Warehouse, click here.

Save it in the My Places folder. This method keeps the model in your local copy of Google Earth. It can't be seen by other people using their own copy of Google
Earth, but it will be available to you at any time.

1. In the Places panel on the left side of Google Earth, find the model in the Temporary Places folder. Models placed in Google Earth from SketchUp are
named "SUPreview#," for example, "SUPreview?2. "

2. When you find the model you want to keep, right-click it (Ctrl+click on a Mac), and then click Move to My Places.

3. Optionally, you can also rename it: right-click it (Ctrl+click on a Mac), and then click Rename.

4. The next time you want to view the model, double-click its name in the My Places folder.

On a PC, if you want to keep multiple SketchUp models available in the Google Earth My Places folder, rather than using the Preview Model in Google Earth
command (which always overwrites the previous model you placed in Google Earth from SketchUp), you must export them from SketchUp:

1. Open the File menu.

2. Go to Export.

3. Click 3D Model...

4. Choose a folder in which to save the file.

5. Give the file a unique name.

6. Choose "Google Earth file (*kmz)" from the Format drop-down.

7. Click Export.

8. In Windows Explorer, open the folder in which you saved the file, and double-click it to open it in Google Earth.
9. In Google Earth, move the file to your "My Places" folder.

0. You can repeat this for as many models as you want.

Note: On a Mac, you can save multiple different files directly using the Preview Model in Google Earth command.
Delete a model from Google Earth that you placed from SketchUp

1. In the Places panel on the left side of Google Earth, find the model in the Temporary Places folder. Models placed in Google Earth from SketchUp are
name "SUPreview#," for example, "SUPreview?2," "SUPreview3," and so on.

2. If you have placed several models, you can find the model you need to delete by clearing the check mark in front of each. When a model's name is selected,
the model is displayed; when its check mark is cleared, it is not displayed.

3. When you find the model you want to delete, right-click it (Ctrl+click on a Mac), and then click Delete.

Preview Model: Introduction

N
@ Preview Model in Google Earth button

The Preview Model in Google Earth button (@)is used as a quick way to view your model in Google Earth while working on the model.

Use the Share Model button to save your model to the Trimble 3D Warehouse and submit it for inclusion in the Google Earth 3D Buildings Layer.

Preview Model: Previewing a model in Google Earth

N
@ Previewing a model in Google Earth
To preview your model in Google Earth:

N
Click on the Preview Model in Google Earth button (Q) to view your SketchUp models in Google Earth. Google Earth is launched. SketchUp creates a temporary
file of your model and places the model in Google Earth at the proper location.

Use the Share Model button (%) to save your model to the Trimble 3D Warehouse and submit it for inclusion in the Google Earth 3D Buildings Layer.

Storing models for use in Google Earth

You can store models either in your local version of Google Earth (so they are not available to others) or share them using the 3D Warehouse.
Storing a model locally in Google Earth
To store a model locally in Google Earth:

1. Locate the model in the Temporary Places folder within Places panel on the left-hand side of Google Earth. Models placed in Google Earth are named
SUPreview#, such as SUPreview2.

2. Context-click on the model name. A context menu appears.

3. Select the Move to My Places menu item. The model is moved to the My Places folder within the Places panel.
Note: Only one SketchUp model can exist in Temporary Places at one time. You must store your models in the My Places folder if you want to view more
than one of your models simultaneously in Google Earth.

Sharing a model using the 3D Warehouse
To share a model using the 3D Warehouse:

1. Open the model in SketchUp. The model appears in the drawing area.
2. Click on the Share Model button in the Google toolbar. The 3D Warehouse appears.
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3. Log in to the 3D Warehouse. You will need a Google account if you do not have one.
4. Follow the steps to post your model in the 3D Warehouse.

Optimizing Models for Google Earth

Complex models (models with a lot of faces) are rendered slowly in Google Earth. To optimize your models for Google Earth:

1. Take photographs of the structure you want to model, such as the Eiffel Tower.
2. Convert photographs into photo textures optimized for the web:
o Use PNG or JPG file formats.
o Use PNG if you need to see through the structure (PNG preserves transparency).
o Do not colorize your image if it contains transparency.
o Use a resolution of 720 pixels per inch. Image dimension should be 640x480 or smaller.
3. Create a model that represents the basic form of the structure with the correct dimensions. For example, instead of modeling all of the details of each side
of the Eiffel Tower, which could contain thousands of faces, model the general shape of each side. The following image shows a SketchUp model of the
Eiffel Tower with minimal faces:

4. Project the photo textures to each of faces of the structure.

. Select File > Import. The "Open" dialog box appears.

. Select the file type from the "Files of Type" (Microsoft Windows) or "Format" (Mac OS X) drop-down list JPG or PNG).

. Locate your image.

. Click the Use as Texture button (Microsoft Windows) or select the Use As Texture item from the drop-down list (Mac OS X).
. Click Open (Microsoft Windows) or Import (Mac OS X). The image appears attached to the cursor.

. Click on the lower-left corner of the structure to affix the photo texture to the structure.

. Move the cursor to the opposite corner to affix the photo texture to the face of the structure.

. Adjust the photo texture. Refer to Position Texture Tool for further information.

5. Project the remaining images on the faces of the model. The following image shows the Eiffel Tower with projected photo textures:
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Placing Models in the Ocean

SketchUp can be used to create three-dimensional models for Google Earth's Ocean layer.
The workflow for creating and placing SketchUp models in Google Earth Ocean layer follows:

1. Select the Extensions panel in the Preferences dialog box (Window > Preferences on Microsoft Windows or SketchUp > Preferences on Mac OS X). The
Extensions panel is displayed.

. Select Google Earth Ocean Modeling checkbox. The ocean modeling extension is enabled.

3. Add a location that is over the area in the ocean where you want to create your model (you can often see terrain under the ocean from the Add Location
dialog box). Refer to Adding a location for information on how to add a location to your model.

4. Create your model on or above the 2D image of the ocean. If you draw your model above the 2D image (so that it floats in the middle of the ocean), you
need to know the ocean depth. It is possible to place a model at a distance above the 2D image of the ocean floor such that it appears at or above sea level
if you place your model at a height above the 2D image that is more than the depth of the ocean.

N
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5. Click on the Toggle Terrain button to toggle to a 3D image of the ocean floor.

6. Reposition the model, adjusting for the terrain in the 3D image.
7. Click on the Preview Model in Google Earth button to view the model in Google Earth.

8. Click on the Share Model button to post the model to the Trimble 3D Warehouse.
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Materials Browser

Applying materials (Microsoft Windows)

There are multiple methods to apply a material to entities in your model. To apply materials using the Paint Bucket tool:

. Select the Paint Bucket tool. The cursor will change to a paint bucket. The Materials Browser will open.
. Click on the Select tab.

. Locate and click on a material collection within the drop-down list.

. Click on the material you want to use.

. Click on a entity to apply the color or material to the entity.
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Note: Ensure that the Shaded with Textures display style is selected to see materials containing textures that you have applied to entities.

Applying materials (Mac OS X)
There are multiple methods to apply a material to entities in your model. To apply materials using the Paint Bucket tool:

. Select the Paint Bucket tool. The cursor will change to a paint bucket. The Materials Browser will open.
. Click on the Materials picker.

. Locate and click on a material collection within the drop-down list.

. Click on the material you want to use.

. Click on a entity to apply the color or material to the entity.
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Note: Ensure that the Shaded with Textures display style is selected to see materials containing textures that you have applied to entities.

Editing materials (Microsoft Windows)

Changes made a material will automatically apply to the entities in the model painted with that material. This behavior allows you to interactively experiment with
color variations in your model. To edit a material:

. Select Window > Materials. The Materials Browser is displayed.

. Click on the Select tab.

. Click on the Collections drop-down list.

. Select a collection.

Click on one of the materials. The material appears in the material thumbnail.

. Context-click on the material. A context menu appears.

. Select Add to Model to add the material to the In-Model materials.

. Select In Model from the Collections drop-down list. The In-Model materials are displayed.

. Click on the material that you just added to the In-Model materials. The material is selected.

10. Click on the Edit tab.

11. Modify settings in any of the material. Refer the Edit Panel for further information.

12. (optional) Save your changes to the edited material:

. Click on the Select tab. The In-Model materials are displayed.

. Context-click on the edited material. The In-Model context-menu is displayed.

. Select the Save As menu item.

. Navigate to a directory (folder) where you want to save the material.

. Type a name in the File name field and click the Save button. The file is saved. Refer to the Open or create a collection context-menu item for
information on how to retrieve this material for use in other SketchUp files.
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Note: Select Edit > Undo to revert back to a previous material if you make a mistake while you are editing a material

Editing materials (Mac OS X)

Changes made a material will automatically apply to the entities in the model painted with that material. This behavior allows you to interactively experiment with
color variations in your model. To edit a material:

. Select Window > Materials. The Materials Browser is displayed.

. Click on the Materials picker icon. The Materials picker is displayed.

. Click on the Collections drop-down list. A list of collections is displayed.

Select a collection. Thumbnail images of the materials in the collection appear.

Click on one of the materials. The material appears in the Active Color Well.

. Select Edit from the Color drop-down menu. The Materials Browser Edit panel appears.

. Modify settings in any of the material. Refer to Materials Browser Edit Panel for further information.
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Deleting materials (Microsoft Windows)

Materials added to your model are stored within the model's .skp file. A material with only color information is very small, but materials with textures can get
fairly large, depending on the file size of your texture. Therefore, it is suggested you delete unused materials from the In Model tab to minimize the size of your
model file. To delete a material:

1. Select the In Model button of the Materials Browser. This button displays all materials used in your model. Materials that are used in your model have a
small triangle in the bottom right corner.
2. Right click on the material you want to delete to display the material's context menu.
3. Select Delete (Microsoft Windows) or Remove (Mac OS X) from the context menu. A dialog box will appear if you are deleting a material that is currently
used in your model.
a. Click Yes to delete the material and replace it with the default material.
b. Click No to retain the material.

Deleting materials (Mac OS X)

Materials added to your model are stored within the model's .skp file. A material with only color information is very small, but materials with textures can get
fairly large, depending on the file size of your texture. Therefore, it is suggested you delete unused materials from the Colors In Model collection to minimize the
size of your model file. To delete a material:

1. Select the Colors In Model collection from the drop-down list.
2. Right-click on the material you want to delete. The material's context menu is displayed.
3. Select Remove. A dialog box appears.

a. Click Replace to delete the material and replace it with the default material. 167



b. Click Cancel to retain the material.

Adding materials from image files (Mac OS X)

You can create realistic materials from image files (such as .jpg pictures taken with a digital camera) using the Materials Browser. To add materials from image
files:

1. Create a folder for your image files.
2. Place your image files into the new folder.

Note: You must create a new materials collection if you wish to add materials to SketchUp from image files. You cannot add materials to the materials collections
that are included with SketchUp.

3. Launch SketchUp.

4. Select Window > Materials. The Materials Browser is displayed.

5. Click on the Materials picker.

6. Click on the List drop-down menu.

7. Select New.

8. Enter a name for the new materials collection that will contain your image-based materials.
9. Click OK. A new materials collection is saved at ~/Library/Application Support/SketchUp/Materials/ < collectionname>.skm
10. Click on the Color drop-down menu.

11. Select New Texture.

12. Locate the image-based material to add to the collection.

13. Click Open. The image-based material will be added to your new materials collection.

Loading and selecting colors from images (Mac OS X)

The Image palettes picker allows you to load an image file into the Color Picker and select colors from anywhere in that image. The Image palettes Picker has a
spectrum image loaded as a default. To load and select a color from an image:

. Select New From File from the Palette drop-down menu above the Opacity slider. .

. Locate your image in the New Color Palette dialog box.

. Click Open. The image appears in the middle of the Materials Browser.

. Click and drag your cursor around the image until the color you want is in the Active Color Well.
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Note: You can have multiple images loaded in the Image Palettes picker. Use the pop-up list above the image to switch between images.

Note: You can also load an image you have copied to the OS X clipboard by selecting New From Pasteboard from the pop-up menu at the bottom of the image
well. Additionally, you can drag an image file from the Finder and drop it in the Image Palettes picker.

Selecting color with the screen picker tool (Mac OS X)

The Screen Picker tool, represented as a magnifying glass, is used to choose a color from any element currently visible on your Apple Mac screen. To select a
color using the Screen Picker tool:

1. Click on the Screen Picker tool to activate the Screen Picker tool. The cursor changes into a large magnifying glass.
2. Move the cursor around the screen until you are magnifying the color you want to use.
3. Click the mouse button to place the color in the Active Color Well.

Materials Browser context menu items (Mac OS X)

A number of useful Materials Browser-related commands are accessible using context menus. Context-click on any material's icon or name to access the
Materials Browser's context menus. The following options appear depending on whether you are clicking on icons in an established materials collections or in the
In Model materials.

Duplicate...

Use the Duplicate menu item to duplicate the material. The Color name dialog box appears. Enter a new name for the duplicated material in the Color Name field.
Click OK.

Edit...
Use the Edit menu item to place the current material in the Edit Panel.
Remove

Use the Remove menu item to remove a material from the In Model materials.

Materials Browser context menu items (Microsoft Windows)

A number of useful Materials Browser-related commands are accessible using context menus. Context-click on any material's icon or name to access the
Materials Browser's context menus. The following options appear depending on whether you are clicking on icons in an established materials collection or in the
In Model materials:

Add to Model
Use the Add to model menu item to add the currently selected material to the In Model materials.
Area

Use the Area menu item to calculate the amount of surface area, in current units, painted with the currently selected material. The material is not applied to any
faces when the Area menu item is grey.

Delete
Use the Delete menu item to delete a single material from a materials collection or the In Model materials.
Edit Texture Image

Use the Edit Texture Image to launch your default image editor, as defined in the Applications panel of the Preferences dialog box, to edit the currently selected
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texture. If you have not identified an editor in the Applications panel of the Preferences dialog box, SketchUp launches the default editor or image display
application.

Export Texture Image
Use the Export Texture Image menu item to save the texture-portion of the material as an image file
Save As

Use the Save As menu item to save the selected material to a separate file (.skm), with a new name and location. You can use this menu item to save materials
that have been modified or created during a drawing session.

Select

Use the Select menu item to select all faces in your model painted with the currently selected material.

Materials picker options (Mac OS X)

SketchUp contains collections of materials in the pop-up menu below the Active Color Well. Select the collection of materials to see several related materials. Or,
use the forward and backward arrows next to this pop-up to quickly step forward and backward through your previously selected material collections.

Colors In Model

The Materials picker includes a special material collection called Colors In Model containing all materials currently used in your model. The contents of this
collection are generated automatically as you add materials to your SketchUp model.

Select the Colors In Model from the materials collection drop-down menu, or simply click on the icon shaped like a house, to view all of the materials in your
model.

Color menu
The Color drop-down menu allows you to manage and create new materials.

Edit
Click on the Edit menu item to edit the currently selected material. Refer to Edit Material Panel for further information.

Remove
Click on the Remove menu item to remove the currently selected material. You will be prompted to replace the material with the default material if the material is
currently used within your model.

Duplicate...
Click on the Duplicate... menu item to duplicate the currently selected material. You will be prompted to provide a new name for the duplicate material.

New Texture...

Click on New Texture... menu item to import an image file containing new material. You will be prompted to select the image file from a file system to import as
a new texture. After you have selected the image file to import, type in the name for the new material followed by the dimension, in inches, that comprise the
size of the texture swatch that will be repeated when painted on your model.

SketchUp can place any image supported by Apple's QuickTime media layer as a texture. Supported Image file types include JPEG, PNG, PDF, PICT, PSD, EPS, SGl,
and TIFF files

Note: SketchUp for OS X supports the alpha channel in image files that support transparency, such as PNG, PSD and TIFF files.

List menu The List drop-down menu allows you to create, duplicate, remove, and purge unused materials libraries.

New...
Click on New... to create a new materials collection. You will be prompted to provide a name for the new collection.

Duplicate...
Click on Duplicate... to Duplicate the currently selected materials collection. You will be prompted to provide a name for the duplicate collection.

Remove
Click on Remove to remove a collection. You will be prompted to click Remove or Cancel to commit this action. Certain standard Apple color collections, such as
the Web Safe Colors collection, cannot be removed.

Purge Unused
Click on Purge Unused, from within the Colors In Model materials collection to remove any materials that appear in this collection, but are not being used in the
model. This option is useful when Colors In Model becomes cluttered with materials that are no longer used in your model.

Materials Browser controls (Mac OS X)

Use Materials Browser controls to select and edit colors and materials.

Note: The materials browser contains five color pickers, only one of which, called the materials picker, allows you to pick materials. The remaining four color
pickers are just for selecting color.

Toolbar

The toolbar at the top of the Materials Browser contains icons representing each of the available color pickers. Switch between these color pickers by clicking one
on of these icons. The controls available in the middle of the Materials Browser differ depending on the currently selected color picker. For example, clicking on
the Materials Picker displays several new controls for materials handling.

The following controls are available for all color pickers. Refer Color Picker Types in this article for further information on specific picker controls.

Screen Picker tool

The Screen Picker tool, represented as a magnifying glass, is used to choose a color from any element currently visible on the screen.

Active Color Well

The Active Color Well, below the toolbar, contains the current color selection. You can drag and drop color swatches from this color well into your model or into
any other visible color well.

The contents of the Active Color Well are maintained as you switch between color pickers, allowing you to use different pickers to create your colors.
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Note: Ensure that the Shaded or Shaded with Textures display style is selected to ensure applied colors and materials are displayed.

Color picker controls

The Color picker controls, below the active color well, differ for each color picker. See the Color Pickers section of this topic for additional information.
Opacity slider

SketchUp supports adjustable (by material) transparency. The Opacity slider, below the color picker controls, is used to adjust the opacity level. Type an opacity
value in the text field to the right of the slider if you prefer to set opacity levels more precisely.

Be sure to activate SketchUp's material transparency within the Edit tab of the Styles Browser before experimenting with the Opacity Slider.
User palette
The User Palette, at the bottom of the color pickers, is an expandable palette of small color wells. To use the User Palette:

e Drag and drop a color or texture swatch from any visible color well, including the Active Color Well, and drop it over a User pallet well to add a color to the
User Palette.

e Drag and drop a new swatch in the place of another color swatch to replace a swatch in the User Palette.

e Drag and drop an empty swatch onto a color to remove a color from the User Palette.

e Click and drag down on the size handle (a small circle) in the middle of the bottom edge of the palette to see more wells.

Note: The colors and materials in the User Palette are saved in SketchUp and can be used between multiple modeling sessions.

Note: Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

Materials Browser edit panel (Microsoft Windows)

Use the edit panel to edit the currently selected material.
Picker drop-down list

Use the Picker drop-down list to select between the HLS, (Hue,Light,Saturation), HSB (Hue, Saturation, and Brightness), RGB, (Red-Green-Blue), and Color Wheel
color Pickers. See The Choose Color dialog box for further information.

Undo Color Changes button
Use the Undo Color Changes button to drop all changes to the material during an edit session.
Match Color of object In Model button

Use the match color of object In Model button and click on an entity in the model to sample the color from that entity and apply it to the currently selected
material.

Note: The Match color of object In Model tool matches the color of a specific entity's material. This color can be disguised a bit when it is combined with a
texture. Use the Match color on screen button if you want to sample a , specific, on-screen, color.

Match color on screen button
Use the Match color on screen button and click anywhere on the screen to sample a color of a pixel and apply it to the currently selected material.
Use texture image checkbox

Selecting the Use texture image checkbox allows you to include an image file, representing a texture, as part of the current material. The Choose Image dialog
box appears. Locate and select the image file you want to use and click the Open button. The image file appears in the texture file field below the Use texture
image checkbox.

Deselecting the Use texture image checkbox allows you to indicate that you no longer want to use an image file in your material (the texture file is removed).

Note: Selecting the use texture checkbox again will not restore a previous image file setting. Instead, you will be promoted to select a new image file.

Texture file field

The texture file field contains the name of a image file (representing a texture), if any, associated with the current material. Drag image files into this field on
click on the file open icon to the right to locate and open a image file.

Browse button
Use the Browse button to display the Choose Image dialog box and browse for an image file.
Edit texture image in external editor button

Use the Edit texture image in external editor button to launch your default image editor, as defined in the Applications panel of the Preferences dialog box, to
edit the currently selected texture. If you have not identified an editor in the Applications panel of the Preferences dialog box, SketchUp launches the default
editor or image display application.

Colorize checkbox

Selecting the Colorize checkbox locks all colors throughout the image to the same hue. This option is useful for files that are not displaying proper colors.
Reset Color button

Use Reset Color button to reset the color of the material to the original color in the image file.

Dimensions fields

Textures repeat themselves similar to tiles when they are painted on surfaces. The Dimensions options allow you to specify the dimensions of each texture tile.
These options do not affect the original image file itself. Type a value in the height or width box to change the size of the texture tile. The corresponding
dimension will adjust automatically to maintain aspect ratio. For example, if you type 2 in the top dimension box (width), 2 will appear in the bottom box
(height).

Click on the chain icon if you do not want aspect ratio to be maintained.
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Click the horizontal and vertical arrow buttons to revert to the previous width and height settings.
Opacity slider

Sliding the opacity slider to the right increases the opacity of the texture. Sliding the opacity slider to the left increases the transparency of the texture.
Alternatively, type a number from 0 to 100 (0 being fully transparent and 100 being fully opaque) in the opacity field.

Materials Browser (Mac OS X)

SketchUp contains collections of predefined materials that you can apply to faces and edges in your model. The Materials Browser is used to organize materials
and colors into collections and to select and to apply materials to your model.

Activate the Materials Browser either by clicking on the Paint Bucket tool or by selecting Material Browser from the Window menu.

Note: The materials browser contains five color pickers, only one of which, called the materials picker, allows you to pick materials. The remaining four color
pickers are just for selecting color. Refer to Material Browser Controls for further information.

Materials Browser controls (Microsoft Windows)

Use Materials Browser controls to navigate among materials in your materials collections.
Material thumbnail

The material thumbnail displays the currently selected material.

Material name field

The material name field displays the name of the currently selected material.

Display Secondary Selection Pane button

The Display Secondary Selection Pane button displays a second select panel below the primary select panel. This feature allows you to display both your materials
collections and the In Model materials at the same time. This feature is useful when you want to drag materials between a collection and the In Model materials.

Create Material button
Use the Create Material button to create a copy of the currently active material in the In Model materials.
Set Material To Paint With To Default button

Use the Set Material To Paint With To Default to set the material to the default front and back face colors. Refer to the Face Panel section of the Styles Browser
topic for further information on setting the default front and back face colors.

Sample Paint button

Use the Sample Paint button, appearing as an eye dropper, to sample and repaint materials appearing in your model. See the Paint Bucket tool for additional
information.

Select tab

Click on the Select tab to display the select panel . Use the select tab to navigate between material collections.

Back arrow

Use the Back arrow to navigate to the previous location in the hierarchy of collections.

Forward arrow

Use the Forward arrow to navigate to the next location in the hierarchy of collections.

In Model button

Use the In Model button to navigate to the In Model materials. The In Model materials contains all of the materials currently included with your model file.
Edit tab

The Edit tab contains a panel of options for editing materials.

Materials Browser Edit panel (Mac OS X)

The Edit Material panel allows you to modify the following material properties:
Name

Enter a new name for a material to change the name of the material being edited.
Texture

The Texture drop-down menu allows you to load a materials image file, remove the texture portion of an image file that you are editing, or reset any colorization
applied to the material. A flat color approximation of the removed image appears when the texture image is removed.

Width and Height

Using the Width and Height text boxes, you can change the actual size of the texture material in your model. To maintain the proportions of the material you are
editing, ensure that the chain icon to the right of the fields is unbroken. Click on the chain icon to toggle aspect locking on and off.

Note: If you have a texture image assigned to the material you are editing, picking a color from any of the Color pickers will colorize the texture image instead of
replacing it with a flat color. This is a great way to quickly and loosely experiment with variations in material color.

Close button

Click the Close button to close the Edit Material panel.

SketchUp Material Libraries
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SketchUp stores materials in the cross-platform .SKM file format. Following are some details about materials files:

e .SKM files are also created every time you use the Texture Palette picker to create a new material collection.
e .SKM files are stored in the directory ~/Library/Application Support/SketchUp. Place a .SKM file in this directory to add a new materials collections to

SketchUp.
e .SKM files created on Mac OS X are identical to those created under Windows and can be shared transparently between platforms.

Materials Browser details menu (Microsoft Windows)

Click on the right arrow next to the materials collection drop-down list to open the details pop-up menu. This menu allows you to perform additional material-
related functions.

Open or create a collection
Use the Open or create a collection menu item to open an existing collection (or file) or create a new materials collection (folder).

Note: The open or create a collection menu item displays a Browse for Folder dialog box. This dialog box does not display files, only folders. Select the folder or
location containing the file and click the OK button.

Save collection as
Use the Save collection as menu item to save a copy of a collection with a new name.
Add collection to favorites

Use the Add collection to favorites menu item to add an existing collection to the list of favorite collections (appearing at the bottom of the collections drop-
down list).

Remove collection from favorites

Use the Remove collection from favorites menu item to remove a collection from your list of favorites (appearing at the bottom of the collections drop-down list).
Purge Unused

Use the Purge Unused menu item to remove all materials in the In Model materials that are not actually used in your model.

Small Thumbnails, Medium Thumbnails, Large Thumbnails, Extra Large Thumbnails

Use the Small Thumbnails, Medium Thumbnails, Large Thumbnails, or Extra Large Thumbnails menu item to change the size of the thumbnails in the Select
panel.

List View

Use the List View menu item to display the materials in list form.

Refresh

Use the Refresh menu item to update the materials appearing in the Materials Browser.
Get More

Use the Get More menu item to get more materials from the SketchUp web site.

Materials Browser (Microsoft Windows)

SketchUp contains collections of predefined materials that you can apply to faces and edges in your model. The Materials Browser is used to organize materials
and colors into collections and to select and to apply materials to your model.

Activate the Materials Browser either by clicking on the Paint Bucket tool or by selecting Material Browser from the Window menu.
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Color pickers (OS X)

The materials browser contains five color pickers, only one of which, called the Materials picker, allows you to pick materials. The remaining four color pickers
are just for selecting color.

Note: Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

A Color Wheel Picker

The Color Wheel picker allows you to select a color by hue, saturation, and brightness.

Select the color you want by clicking your mouse over that color in the color wheel. You can also click and drag the cursor around the color wheel to quickly
browse through many different colors. You will see a dynamic preview of the selected color in the active color well at the top of the color picker.

The color wheel arranges color hue radially around the wheel, with the highest saturation at the outer edge of the wheel. Slide the value slider, to the right of the
wheel, up or down, to change the brightness of the color.

The Color Wheel picker is the simplest and most versatile of the standard Apple color pickers, though it is also the least precise. You might want to use the Color
Wheel picker to make a rough color choice, and then use the Color Slider pickers to fine tune your choice.

il

= Color Slider Picker
The Color Slider picker contains four sliders: Gray Scale slider, RGB sliders, CMYK sliders, and HSB sliders. These color pickers differ only in the components they
use to mix colors. Select the Color Slider picker from the pop-up menu at the top of the picker control area.

Gray scale slider
The Gray Scale slider allows you to select colors from the grayscale color range (shades of gray).

Adjust the slider until you see the color you want in the Active Color Well. Alternatively, you can select a color by typing a percent gray value directly in the text
box to the right of the slider. Or, choose from one of the five preset gray values below the slider.

RGB sliders

The RGB sliders allow you to select colors from the RGB (Red, Green and Blue) color range. RGB colors are traditionally used when modeling color on a computer
screen and represent the closest approximation of the actual range of colors recognizable by the human eye. RGB has a wide color gamut and is one of the most
effective color spaces to use in SketchUp.

Drag the sliders left and right for each of the component colors (red, green and blue) to create the color that you want to use. The background color of each
slider changes as you modify values to help you predict how adjustments will change your color mix.

Alternatively, you can type in exact numerical values for red, green or blue in the value boxes to the right of the sliders to precisely match a color that you have
specified elsewhere.

CMYK sliders

The CMYK sliders allow you to select colors from the CMYK (Cyan, Magenta, Yellow and Black) color range. CMYK is traditionally used to select colors intended for
professional printing, where colors are usually specified in percentages of these four basic ink colors. RGB or HSB color pickers are generally sufficient for most
work in SketchUp.

Drag the sliders left and right for each of the component colors (cyan, magenta, yellow and black) until you have the color you want to use. To help you find an
exact color, the background color of each slider will change as you modify values to help you predict how adjustments will change your color mix.

HSB sliders
The HSB Color sliders allow you to pick colors from the HSB (Hue Saturation and Brightness) color range. HSB often gives you a more intuitive color model for
selecting desaturated colors.

Adjust the sliders for hue, saturation and brightness until you see the color you want in the Active Color Well.

Sometimes it is easier to mix de-saturated colors using the HSB picker in conjunction with one of the other pickers. Switch to another color picker to make your
rough color selection, then switch back to the HSB picker to fine tune or mix desaturated colors.

Image Palettes

The Image Palettes picker allows you to load an image file and select colors from anywhere in that image. The Image Palettes picker has a spectrum image loaded
as a default.

¢

The Materials picker is unique to SketchUp and is the picker that you use to create, modify and manage SketchUp-specific materials.

Materials Picker

Material Thumbnail Images
The middle of the Materials Picker contains thumbnail images for all available materials in the currently selected materials collection. Following are some tasks
you can perform on these thumbnail images:

Drag your mouse over a thumbnail image to see a tool tip with the material's name.

Click on a thumbnail image to load it in the Active Color Well for use in your model.

Double-click on a thumbnail image to open the material for editing. Refer to Material Picker Options for further information.

Drag and drop material thumbnails to re-sort the materials.

Drag and drop image files directly from the finder into the material thumbnail area. You will be prompted to supply a name and dimensions for the
material when you drag and drop an image file into this area.

e o o o o

Color and List Menus
The Color and List drop-down menus are below the material thumbnail images. Use the Color menu to manage and create new materials and the List menu to
manage and create new material lists. See Material Picker options for further information.

o
" Crayons Picker

The Crayons picker displays a graphic representation of a box of crayons with a small range of standard Apple colors. The Crayon picker is the simplest picker to
use and is fairly limited in the range of colors available.

Click on the crayon whose color you want to use to select a color with the Crayon picker. The crayon's color will be transferred to the Active Color Well.
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Components Browser

Creating a component

Components are useful for creating reusable models to be placed within other models. The most important issue to consider when creating components is how
you want them to be placed when inserted into the model from the Components browser. The component axes will dictate both component orientation on insert
and cutting plane (for components that are to automatically cut holes in faces, such as windows). To create a component:

1. Draw your component in the orientation where it will be used. For example, if you are creating a couch component, draw it on the ground plane. If you are
creating a window or door, draw it on a wall that is vertically aligned to the blue axis.

. Select the Select tool. The will change to an arrow.

. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.

. Drag the mouse to the opposite corner of the selection starting point.

. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the
selection box.
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6. Select Edit > Make Component. Alternatively, context-click on the currently selected entities and select Make Component from the context menu. The
Create Component dialog box is displayed. The following image shows the Create Component dialog box on Microsoft Windows:

Create Component H

General
Name: m
Description:
Alignment

Glue to: |None v | SetComponent Axes
r

[T Always face camera

-

[V Replace selection with component

Cancel | Create |

The following image shows the Create Component dialog box on Mac OS X:
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Glue to:  None m k Set Component Axes )
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7. Fill out the fields in the dialog box. Ensure you make all of the appropriate selections and check all of the appropriate boxes before continuing. Specifically,
decide whether the component should glue to faces in a specific orientation and cut openings.
8. Click the Create button. SketchUp adds the newly created component to the In Model components.

Warning: Components that are created in their appropriate 'glue to' orientation are created with the blue and green axis swapped. This is only of importance
when creating dynamic components as the LENZ will have a value for length along the green axis and the LENY will have a value for the length along the blue
axis.

Note: The Make Component operation disconnects any geometry that was connected to selected geometry prior to placing the selected geometry in the
component. The disconnected geometry is maintained outside of the component's context.
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Note: You can make component hierarchies by grouping other Component entities within a component. Additionally, you can mix your hierarchies by including
components and groups within other components and groups.

Tip: Create components that can be attached or glued to a surface in context (on a surface) to ensure that the cutting plane is established correctly.

Setting the gluing and cutting plane of a component

The Set gluing plane button is used to specify a different origin for the Component and to modify the orientation of the component when it is placed. To set the
origin and plane of a component:

1.

N

o v hw

8.
9.

10.

Select Show Component Axes in the Components panel of the Model Info dialog box to see the existing axes on a component before using the 'Set gluing
plane' button to move the axes.

. Draw your component in the orientation where it will be used. For example, if you are creating a couch component, draw it on the ground plane. If you are

creating a window or door, draw it on a wall that is vertically aligned to the blue axis.

. Select the Select tool. The will change to an arrow.

. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.

. Drag the mouse to the opposite corner of the selection starting point.

. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the

selection box.

R

. Select Edit > Make Component. Alternatively, context-click on the currently selected entities and select Make Component from the context menu. The

Create Component dialog box is displayed. The following image shows the Create Component dialog box on Microsoft Windows:
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The following image shows the Create Component dialog box on Mac OS X:
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Click on the Set gluing plane button. The cursor changes to an arrow with axes attached to it.

Click on a location of the component to set the origin of the component's axes. The origin and insertion point is now set to this location.

Note: When you change the axes you change the orientation of the component when dragged from the Components browser and also the component's
cutting plane. By default, the component's axes are placed as though the component will be inserted from the Components browser in the exact
orientation as the component is in while you create the component. Generally, you will not want to change this orientation unless, for example, you are
creating a window component independent of other geometry and in the vertical plane (blue). In this case, the bottom of the window will be on the
red/green plane. The red/green plane is the gluing and cutting plane. As such, this window's bottom will therefore want to align and cut into a face when
placed in the model from the Component browser. As mentioned previously, however, it is best to create window and door components within the context
of a surface type where they will ultimately be placed, such as a wall, so you do not have to reorient the axes. Follow the last two steps in this list if you
need to reorient the component axes.

(optional) Move the mouse around the origin to redefine the orientation of the component. The axes of the component will rotate suggesting a new
orientation for the component. The cut plane will also move to represent where the component will cut into a face when placed vertically or horizontally.
For example, if you rotate the axes such that red is up and green is to the left, the component will be inserted horizontally to its orientation when created.
The following image shows a window component during component creation. The component's axes have been reoriented such that the cutting plane is
now parallel to the front of the window.
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11. (optional) Click to set the new orientation.

Editing a component instance as a whole

You can edit the component as a whole or edit individual entities within a component. Editing or modifying the component instance as a whole affects only the
component instance, not the component definition or other instances.

Scaling a component

Scaling a component as a whole scales the individual component instance, not the component definition, allowing you to have many differently scaled instances
of the same component in your model.

A component can become skewed when you scale the component in multiple directions. You can reset both a components scale and skew using the 'Reset Scale'
and 'Reset Skew' context menu items.

Flipping a component

You can flip (or mirror) a component along its axes using the 'Flip Along component' context menu item. Choose component's red, component's blue, or
component's green depending on the direction to flip the component.

Rotating a component using the Move tool

Components can be rotated using either using the Move tool or Rotate tool. The first rotation method rotates the component about its center of mass and in the
planes of the component bounding box. The second rotation method allows you to specify precise rotate planes and center of rotation. See the Rotate tool for
further information on this second rotation method. To rotate a component using the Move tool:

. Select the Move tool. The cursor will change to a four-way arrow.

. Move the cursor over a face that is perpendicular to the desired axis of rotation. Four rotation handles and a protractor appear on the face.
. Click on a rotation handle.

. Rotate the component.
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Editing entities within a component instance

Editing the entities within a component requires you to enter the component's context. Editing or modifying the entities within a component instance affects the
component definition and other instances of the component. To edit the entities within a component:

1. Select the Edit > Component Instance > Edit Component to edit the component. Alternatively, context-click on the currently selected component and
select Edit Component from the context menu. An edit bounding box will surround the component and entities exterior to the component will turn grey.
Tip: Double-click on the component to edit the component.

2. Make changes to entities within the component. Any changes while in the context of the component affects each component instance and the component
definition. You can also perform inference alignments to geometry outside of the component while you are editing the component.

3. Select the Edit > Close Group / Component to end the edit session. Alternatively, context-click on the component's bounding box and select Close
component from the context menu.

Tip: Click outside of the component to close the component.

Exploding a component

You can explode a component entity to break it back into its original entities. To explode a component:

1. Select the Select tool. The will change to an arrow.

2. Select the component you want to explode.

3. Select Edit > Component Instance > Explode. Alternatively, context-click on the currently selected group and select Explode from the context menu. The
component will be split back into its entities.

Elements within components that were placed adjacent to other geometry might become joined to elements exterior to the component when the component is
exploded.

Inserting components

There are a variety of different ways to insert component instances in SketchUp.

Inserting components from Components browser

Pre-defined components are most often inserted from the Components browser into a model. See the 'Components browser' for further information.
Insert a component from an external SketchUp (.skp) file

You can also insert a component from an external SketchUp file. To insert a component from an external SketchUp file:

1. Select the File > Import menu item. The Open file dialog box appears.

2. Click the Open button. The cursor changes to the Move tool anchored to the component's insertion point.
Tip: The component axes origin is the default insertion point for a component. Change the location of the component's axes before you insert the
component to change the default insertion point.
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3. Move the mouse to the location in the drawing area where you want to place the component.
4. Click the mouse button again to release the component.

Insert a component from the File Explorer (Microsoft Windows) or the Finder (Mac OS X).
To insert a component from the File Explorer (Microsoft Windows) or the Finder (Mac OS X):

1. Locate the icon representing the file you want to insert.

2. Click and hold the mouse button on the icon.

3. Drag the icon into the drawing area. The cursor changes to the Move tool anchored to the component's insertion point.
Tip: The component axes origin is the default insertion point for a Component. Change the location of the component's axes before you insert the
component to change the default insertion point.

4. Release the mouse button to place the component into your model.

Applying materials to components

Any geometry inside a component that is painted with the default material will be painted when you paint the instance as a whole. Therefore, you can have
entities within a component painted individually while other elements painted using the material assigned to the entire component. The following image contains
four cars all enclosed in components. The tires, bumper, and windshield have been painted black when editing the component.

Each entire component instance was then painted after being edited, turning each of the faces with the default material to the color applied on the group (green,
blue, red, and yellow from left to right):

Moving the insertion point

The Components browser switches the insertion point from the origin of the component's axes to another point on the component when you use the Move tool to
select a component, that is already in your model, using a different (non-origin) point. For example, if you have a 3d rectangle component, the origin and
insertion point will be the lower left-hand corner. However, if you insert this component and then move it by a midpoint, the insertion point changes to the mid
point (while the origin remains at the lower left hand corner).

This feature is useful when aligning components, such as cabinet components in a kitchen. Consider the following:

1. Insert one kitchen cabinet component with the insertion point at the lower left corner of the component.

2. Insert a second instance of the same cabinet to the left of the previously inserted cabinet (so that the two cabinets touch). Notice that it is hard to
accurately place the second cabinet because the insertion point is at the origin at the lower left corner of the component (away from where the two
cabinets will touch).

. Reposition the second kitchen cabinet away from the first.

. Select the Move tool and click the lower-right corner of the second kitchen cabinet component.

. Now move the second kitchen cabinet such that it is aligned on the left-side of the first cabinet. This process should be easier now that the insertion point
has been moved to the lower-right corner of the component. If you drag a third instance of the same cabinet into the model, the insertion point will now
be at the lower-right corner (making it easier to place more cabinets to the left of each other).
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Resetting component axes

Context-click on the component in the Components browser and select Reset insert point to reset the insertion point to the origin of the component's axes.

Inserting a component

To insert a component in your drawing area:

1. Navigate to a component in the Components browser.

2. Click on the component.

3. Move the mouse to the location in the drawing area where you want to place the component. The cursor changes to the Move tool.
Note: The Move tool will usually be anchored to the origin of the component's axes (also called the insert point ). To see the origin of the component,
select Window > Model Info > Components > Show component axes.

Note: The component axes is the default insertion point (the point where the cursor grabs the component) for a component the first time you place the
component in the model from the Components browser. The insertion point will change to the point where the Move tool selects a component if you place
a component and then reposition the component using the Move tool.

4. Click the mouse button again to release the component.
Note: You can also insert components from an external SketchUp (.skp) file or by dragging and dropping a file from the Explorer (Microsoft Windows) or
the Finder (Mac OS X) into your model. See the 'Component entity' for further information.

Changing component thumbnail
Creating a component creates a thumbnail image of the component in the Component browser. This image is based on the view of the component unless the

component has a gluing plane. The following rules apply for components that have gluing planes:

e Thumbnails for components whose gluing plane is vertical, such as windows and doors, is of a front view of the component.
e Thumbnails for components whose gluing plane is horizontal,any, or sloped, is a top-down view of the component (which is appropriate for a rug
component, but not for a lamp, vehicle, or person, for example).
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You must save the individual component to a file to change its thumbnail. To change the component thumbnail:

. Context-click on the component. The component's context menu appears.

. Select the Save As menu item. The Save As dialog box appears.

. Navigate to the components directory. The components directory on Microsoft Windows is: C:\Program Files\Google\Google SketchUp
#\Components. The components directory on Mac OS X is: Macintosh HD/Library/Application Support/Google SketchUp #/Components.

. Type a file name in the 'File name' field.

. Click the Save button. The component is saved in the specified directory.

. (Microsoft Windows) Select Window > Model Info. The Model Info dialog box appears.

. (Microsoft Windows) Select the File item from the left-hand side of the dialog box. The File panel is displayed.

. (Microsoft Windows) Check the 'Redefine thumbnail on save' checkbox. This option ensures your thumbnail will be saved based on current view.

Open the component file. The component appears in the drawing area.

. Use the camera tools to find a view of the component acceptable for a thumbnail.

. Save the component file.
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Finding components near the current Google Earth view

The Components Browser contains an option to search for all models nearest the current imported Google Earth view. To find components that are near a Google
Earth view:

1. Get a current view from Google Earth. Refer to Getting the Current View from Google Earth for further information.
2. Select Window > Components. The Components Browser is displayed.

3. Click on the 'Collections and Searches' drop-down list.

4. Select Nearby Models. Models near the current view are listed.

Components browser controls

Use Components browser controls to navigate among components in your component libraries.
Component thumbnail

The component thumbnail displays the currently selected component.

Component name field

The component name field displays the name of the currently selected component.
Component description field

The component description field displays a description of the currently selected component.
Display secondary selection pane button

The Display secondary selection pane button displays a second select panel below the primary select panel. This feature allows you to display both your
component collections and the In Model components at the same time. This feature is useful when you want to drag components between collections and the In
Model components.

Select tab

Click on the Select tab to display the select panel . Use the select panel to navigate between component libraries, components in your model, and components in
the 3D Warehouse.

View options drop-down list
Click on the View options drop-down list to list several options for viewing your components in Components browser.

Small thumbnails: Click the Small thumbnails menu item to display small thumbnail representations of your components.
Large thumbnails: Click the Large thumbnails menu item to display large thumbnail representations of your components.

Details: Click on the Details menu item to display large thumbnails representations of your components along with the component name, author, and
description.

List: Click on the List menu item to display a list of all component names.
Refresh: Click on the Refresh menu item to refresh the current list of components.

In Model Button
Click on the In Model button to navigate to the In Model components. The In Model components contain all of the component currently included with your model
file.

Note: You can have components in your In Model components that are not being used by your model.

Collections and searches drop-down list

Click on the Collections and searches drop-down list to list all of the component collections in SketchUp. Click on a collection to select the collection. The
Collections and searches drop-down list is divided into three sections: Collections at the top, a list of the user's favorite collections or searches (local or in the
Trimble 3D Warehouse), and a list of the five most-recently viewed local collections and Trimble 3D Warehouse searches.

Search field
Type the name of any components you want to find in the search field. For example, to search for all plane components, type [ plane ].

Search button (Microsoft Windows)
Click the Search button to initiate a search of a component whose name you have typed in the Search field.

Search button (Mac OS X)
Click the Search button view a list of recent searches. Select the 'Clear' menu item to clear the list.

Note: SketchUp lists all individual models and collections with the search term.

Details menu
Click on the Details arrow to display the Details menu. The following lists all options found on the details menu in both Microsoft Windows and Mac OS X versions
of SketchUp.

Add to favorites: Select the Add to favorites menu item to add the current collection to a list of favorite collections in the Collections and Searches drop-down
list.
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Create a local collection (Mac OS X): Select the Create a local collection menu item to create a new collection folder.
Expand: Select the Expand menu item to see all sub-components within the components the In Model components.
Open a local collection: Select the Open a local collection menu item to open all the components in a collection folder.

Open or create a local collection (Microsoft Windows): Select the Open or create a local collection menu item to open all the components in a collection folder
or create a new collection folder.

Purge unused (In Model only): Select the Purge unused to remove all components in the In Model collection that are not currently used in your model.

Remove from favorites: Select the Remove from favorites menu item to remove the current collection from the list of favorite collections in the Collections and
Searches drop-down list.

Save as a local collection: Select the Save as a local collection menu item to save all components in the In Model collection as a collection on your local hard
drive.

View in 3D Warehouse: Select the View in 3D Warehouse menu item to view the search results in the 3D Warehouse.

3D Warehouse Terms of Service: Select the 3D Warehouse Terms of Service menu item to launch a Web browser and view the 3D Warehouse Terms of Service
document.

Component list
The component list contains a listing of all components in the model, in a favorite, resulting from a search, and so on. Individual components are indicated by a
single box around the component thumbnail. Collections are identified by a stack of 3 overlapping boxes around a component thumbnail.

Previous button
Click on the Previous button (displayed after performing a search) to view the previous twelve 3D Warehouse search results.

Next button
Click on the Next button (displayed after performing a search) to view the next twelve 3D Warehouse search results.

Edit tab

The Edit tab contains properties specific to the currently selected component. These properties can only be edited for components that are selected in the In
Model components. These are the same properties, whose values you define, when a component is created, for the exception of the Loaded From field. See the
'Create Component dialog box' for further information on these properties.

Glue to
Refer to The Create Component dialog box

Cut opening
Refer to The Create Component dialog box

Always face camera
Refer to The Create Component dialog box

Shadows face sun
Refer to The Create Component dialog box

Loaded from
The Loaded from field displays the location of the component on the file system.

Statistics tab

The Statistics reports quantities of various elements, such as faces, edges, construction lines, within the component. Select All geometry from the drop-down list
to see statistics for all geometry in the component or group. Alternatively, select Components from the drop-down list to see statistics for all components in the
component. Finally, click on Expand to see components and groups nested within the currently selected component or group.

Component entities

Components are entities that can hold other entities. Components are similar to group entities, but they are commonly used to combine several entities as a
single entity for the purposes of reuse in multiple models. Use the 'Make Component’' menu item from the Edit menu to create a component from the currently
selected entities.

Components browser context menus

A number of useful Component browser-related commands are accessible using context menus. Context-click on any component's icon or name to access the
Components browser's context menus. The following options appear depending on whether you are clicking on icons in an established component collection or
in the In Model components:

Delete
Select the Delete menu item to delete a single component from a component collection.
Properties

Select the Properties menu item to display the Properties dialog box. This dialog box contains the location for the component file, when the file was last opened,
the name of the component, and the number of component instances in the model.

Reload

Select the Reload menu item to reload a component from its original file in the event that the component's file has changed since being used in yourﬁgdel.



Replace selected

Select the Replace selected menu item to replace the currently selected components in the drawing area with the currently selected component in the
Components browser.

Reset insertion point
Select the Reset insertion point menu item to reset any changes made to a component definition's insertion point.
Save as

Select the Save as menu item to save the selected component to a separate SketchUp file with a new name and location. You can use this menu item to save
components that have been modified or created during a drawing session.

Select instances

Select the Select instances menu item to select all of the instances of a specific component in your model.

Component definitions and instances

A component definition and a component instance are created when a component is created using the Create Component dialog box. Components definitions
provide a blueprint for how all components of a specific type, called instances, appear and behave within the drawing area (whether they can be glued to faces,
where insertion points appear, and so on). Component definitions are represented by thumbnail images in the Components browser.

Component instances are components definitions that have been inserted in the drawing area (called instancing). Component instances all look like and have the

same default behavior as the component definition, but, once brought into the drawing area, can be rotated, scaled, and painted independently of other
instances.

The Create Component dialog box

The Create Component dialog box is displayed when you attempt to create a component using the Make Component menu item.

General
Name

The Name field can contain the name of the component definition. All component definitions must have a name.

Description

The Description field can contain a description of the component.

Alignment

Glue to

The Glue to drop-down list is used to identify the faces where your component can be placed when initially placed from the Components browser. For example, a
standard door might only be glued to faces in the vertical (blue) plane. A grey gluing plane guide will appear when a specific gluing plane is selected. This plane
represents exactly where the component will orient to a face and cut into a face. The following image shows a window component during component creation.

Notice that the gluing plane (the grey plane) is parallel to the red/green plane and bottom of the window). This window component was also set to glue to vertical
surfaces.

The following image shows what occurs when the previously mentioned window component is placed, from the Components browser, against a vertical surface.
Notice that the window meets the vertical face at the window's bottom because it was created with a gluing plane that is parallel to the bottom of the window.

Usually you want windows and doors to have a gluing plane that is parallel to the front or back of the window or door (not the bottom). You might need to
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reorient the component's axes at creation, using the 'Set Plane' button, to properly set the gluing or cutting plane.
Set component axis

The component axis defines how the component inserts and aligns to other geometry or to the camera. The component axis also defines the cutting plane by the
orientation of the red/green plane. The Set component axis button is used to specify a different origin for the component and to modify the orientation of the
component when it is placed.

Cut opening

The Cut opening option allows the component to create openings in the face onto which it is placed. For example, a door or window component might be set to
cut an opening in any wall where instances of the component are placed.

Note: There must be edges along the cutting plane of the component to cut a hole in a face.
Always face camera

The Always face camera option allows the component to take on billboard behavior by drawing the component as a 2D form. This option increases performance
by eliminating the need to render the component as a 3D model.

Note: Components with the 'Always face camera' option enabled cannot have gluing behavior.
Shadows face sun

This option is only available when the 'Always face camera' option is enabled. The shadows face sun option causes the shadow to be cast from the component's
current position as though the component were facing the sun. The shadow shape does not change as the component rotates to face the camera. This option
works best with components that have short bases (such as trees). This option does not work well with components that have wide bases (such as people in mid
stride).

Note: Ensure the component's axis is positioned at the bottom center of the component for best results.
Uncheck this option to cause the shadow to be cast from the component's current position. The size of the shadow changes based on view point.
Replace selection with component

The Replace selection with component option causes the currently selected entities to be turned into a component instance. Uncheck this option to create a
component definition in the Components browser without creating a component instance from selection set.

Components browser

The Components browser contains both user-created and pre-built Component entities that you can use in your models. Activate the Components browser from
the Window menu.
Note: See component definitions and instances for further information.

The following image contains a screen shot of the Components browser on Microsoft Windows.
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Styles Browser
Applying styles

Select one of many pre-defined styles from the Styles Browser and apply it to your model. Each pre-defined style represents a collection of specific settings that
can be applied to your model and the drawing area. To select and apply a pre-defined style:

. Select Window > Styles. The Styles Browser is displayed.

. Click on the Select tab.

. Click on the 'Styles Collections' drop-down list.

. Select a Styles collection or In Model styles. All of the pre-defined styles in the collection are displayed in thumbnail form.
. Click on one of the pre-defined styles. The style is applied to your model and the drawing area.
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Editing styles
Styles are comprised of several different settings found under the Edit tab. To Edit a style:

. Select Window > Styles. The Styles Browser is displayed.

. Click on the Select tab.

. Click on the 'Styles collections' drop-down list.

. Select a Styles collection or In Model styles. All of the pre-defined styles in the collection are displayed in thumbnail form.

Click on one of the pre-defined styles. The style is applied to your model and the drawing area. A copy of the style appears in the In Model styles.

. Click on the Edit tab. One of five panels is displayed (Edge, Face, Background, Watermark, and Modeling).

Modify settings in any of the edit panels. Refer to Edge Panel, Face Panel, Background Panel, Watermark Panel, or Modeling Panel for further information.

. Click on the Update Style button. The copy of the style in the In Model styles is updated with your changes.

. Type a name in the 'File name' field and click the Save button. The file is saved. Refer to the Open or create a collection context-menu item for information
on how to retrieve this style for use in other SketchUp files.

Aligning edges to axes

One method for aligning edges to axes is to enable an option to display all edges in the color of their respective axis direction. For example, edges drawn in the
up or down direction will be colored blue. To enable edge color by axis:

. Select Window > Styles. The Styles Browser is displayed.

. Select In Model from the drop-down list of edge types. Thumbnails of all of the current edge styles used are displayed.

. Click on the Edit tab. The Edit panel is displayed.

. Click on the Edge Settings icon (the first icon on the left). The Edge rendering panel is displayed.

. Select the By axis item from the Color drop-down list (at the bottom of the Edge rendering panel). All edges in your model will now be colored with the
color of their respective axis direction.
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Sharing styles

Styles are shared in .style files that can be opened by any copy of SketchUp 6 or above. You must create a .style file to share a style with others. To share a
style:

. Create a new folder/directory on your computer to contain your shared styles.

. Select Window > Styles. The Styles Browser is displayed.

. Select the In Model styles from the drop-down list. The In Model styles are displayed.

. Context-click on the style name you would like to share. The style context menu is displayed.
. Select the Save As menu item. The Save As dialog box appears.

. Navigate to the folder/directory you created in step 1.

. Type the name of the style in the 'File name' field.

. Click the Save button. The style file is saved to your newly created folder/directory.
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You can now share this style file with others.

Adding a watermark to the drawing area

To add a watermark to the drawing are:

. Select Window > Styles. The Styles Browser is displayed.
. Click on the Edit tab.
. Click on the Watermark panel button. The Watermark panel is displayed.
. Click on the Add button. The Choose Watermark dialog box is displayed.
. Navigate to an image you will use as a watermark.
. Click the Open button. The image will appear as a watermark in the background of the drawing area. The Create Watermark dialog box is displayed.
. Click either the Background button to have the image appear behind your model as a background watermark, or the Overlay button to have the image
appear in front of your model as an overlay.
8. Click on the Next button.
9. (optional)Select the 'Create Mask' checkbox. Refer to Watermark Settings for further information.
10. (optional) Move the Blend slider to the left to fade the watermark. Or, move the Blend slider to the right to fade the model.
11. Click on the Next button.
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. Select the button that reflects where you want the watermark to appear on the screen. Refer to Watermark Settings for further information.
. Click on the Finish button.

Styles Browser controls

Use the Styles Browser controls to navigate among styles in your styles collections.
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Style thumbnail

The style thumbnail displays the style currently applied to your model.

Style name field

The style name field displays the name of the currently active style.

Style description field

The style description field displays a description of the currently active style.
Display the secondary selection pane button

The Display the secondary selection pane button displays a second select panel below the primary select panel. This feature allows you to display both your styles
collections and the In Model materials at the same time. This feature is useful when you want to drag styles between collections and the In Model styles.

Note: You can only apply one style at a time, but you might want multiple styles in the In Model styles. For example, you might have one style that you apply
when you are working on the model (because performance is better when you use the style) and another style you use for presenting the model. Styles in the In
Model styles are also saved with your SketchUp file.

Create new style button

Use the Create new style button to create a copy of the currently active style in the In Model styles.

Update style button

Use the Update style button to update the copy of the currently active style in the In Model styles.

Select tab

Click on the Select tab to display the select panel. Use the select panel to navigate between style collections.

Back arrow
Use the Back arrow to navigate to the previous location in the hierarchy of collections.

Forward arrow
Use the Forward arrow to navigate to the next location in the hierarchy of collections.

In Model button
Use the In Model button to navigate to the In Model styles collection. The In Model styles collection contains all of the styles currently included with your model
file.

Note: You can have styles in your In Model style collection that are not being used by your model.

Collections drop-down list
Select the collections drop-down list to list all of the styles collections in SketchUp. Click on a collection to select the collection.

Details menu
Click on the Details arrow to display the Details menu. See Details menu for further information.

Edit Tab
The Edit tab contains five separate panels: The edge rendering panel, face rendering panel, drawing area styles panel, watermark panel, and other styles panel.
Mix tab

The Mix tab contains five wells corresponding to the five categories of styles in the styles browser (edge, face, background, watermark, and modeling styles).
Click on this tab to display the five wells and a secondary style pane. Select a style from the secondary style pane and click on one or more wells to sample the
corresponding settings from that style. For example, click on a style in the secondary style pane and click on the Edge Settings well to sample the edge settings
from that style. The style in the style thumbnail changes to reflect the newly sampled settings.

The Styles Browser Face panel

SketchUp contains a variety of face rendering styles allowing you to manipulate the amount of material and textures displayed on the screen.
Front color button

Use the Front color button to set the default color for all front sides of faces. Materials assigned to faces override this setting.

Back color button

Use the Back color button to set the default color for the back sides of faces. Materials assigned to faces override this setting.

Display in wireframe button

Use the Display in wireframe button to display the model as a collection of lines. Faces are not displayed in Wireframe mode.

Note: You cannot use face modification tools, such as the Push/Pull tool, on a wireframe rendered model
Display in hidden line mode button
Use the Display in hidden line mode button to display faces in the model without any shading or textures.

Use this face rendering style when creating black and white printouts which you might want to modify further with traditional media, or which you might use as
an underlay for hand drawings.
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Display in shaded mode button

Use the Display in shaded mode button to display faces in the model as shaded to reflect a light source. Any color that had been applied to a face will be
displayed. Remember that both sides of faces can have different colors. The default colors for front and back face are displayed when no color has been applied
to a face.

Display in shaded using textures button
Use the Display in shaded using textures button to display the faces In Model with the texture images that have been applied to a face.

Textures can slow down SketchUp's performance. Use other face rendering styles, such as the Shaded face renderings style, when performance slows
dramatically. Switch back to the Shaded with Textures face rendering mode to create your final output.

Display in shaded using all the same button
Use the Display in shaded using all the same button to display the faces with the default front and back face color.
Display X-Ray mode button

Use the Display in X-Ray mode button to display all faces in SketchUp with a global transparency. This option allows you to see through the model's faces and
edit edges behind faces and can be combined with any of the above face rendering styles.

You can easily visualize, select, and snap to points and edges that would otherwise be hidden behind faces when modeling with X-ray mode. Remember,
however, that it is not possible to select and infer faces that would otherwise be hidden.

Faces can not cast Shadows when using X-ray mode. Shadow display will default to ground plane shadows only when X-ray mode is enabled. X-ray mode is
different than material transparency.

Enable transparency checkbox
Selecting the Enable transparency checkbox enables or disable global material transparency.
Transparency quality

The Transparency quality options allow you to select the quality of transparency display between faster, medium, and nicer. Each option differs in its speed and
quality of transparency sorting. The Faster display sacrifices sorting accuracy to provide a faster rendering update rate. Conversely, the Nicer display performs
additional calculations to correctly sort transparent surfaces.

Because SketchUp's transparency system is designed for real-time feedback and display, it may sometimes display transparent faces in an unrealistic way: Faces
may appear as if they were in front of other surfaces when they are really behind, and vice-versa.

The Styles Browser Background panel

Styles also contain options for configuring the drawing area background, sky, and ground colors.

Background button

Use the Background button to select a background color for SketchUp's drawing area.

Sky checkbox

Use the Sky checkbox to have a sky color that is different from the background color. Use the Sky button to select a sky color.
Ground checkbox

Selecting the Ground checkbox selects a ground color that is different from the background color.
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Transparency slider

Slide the Transparency slider to adjust the level of transparency for the ground plane. Place the slider toward the left-most position to minimize below-ground
visibility. Place the slider toward the right-most position to maximize below-ground visibility.

Show ground from below checkbox

Selecting the Show ground from below checkbox toggles the display of the ground plane from viewpoints below the horizon.

The Styles Browser Watermark panel

Refer to the Watermark section of this reference guide for additional information on the watermark feature.

Styles Browser details menu

Selecting the right arrow next to the styles collections drop-down list opens the details pop-up menu. This menu allows you to perform additional styles-related
functions.

Create style

Use the Create style menu item to create a copy of the currently active style in the In Model styles.

Open or create a collection (Microsoft Windows)

Use the Open or create a collection menu item to open an existing collection (or file) or create a new styles collection (folder).

Note: The open or create a collection menu item displays a Browse for Folder dialog box. This dialog box does not display files, only folders. Select the folder or
location containing the file and click the OK button. Use the Make New Folder button to create a new collection folder.

Open an existing collection (Mac OS X)

Use the Open an existing collection menu item to open an existing collection.

Note: The Open an existing collection item displays a Open dialog box. This dialog box does not display files, only folders. Select the folder or location
containing the file and click the Open button.

Create a collection (Mac OS X)

Use the Create a collection menu item to create a new styles collection.

Save collection as

Use the Save collection as menu item to save a copy of a collection with a new name.

Add collection to favorites

Use the Add collection to favorites menu item to add an existing collection to the list of favorite collections (appearing at the bottom of the collections drop-
down list).

Remove collection from favorites

Use the Remove collection from favorites menu item to remove a collection from your list of favorites (appearing at the bottom of the collections drop-down list).
Purge unused

Use the Purge Unused menu item to remove all styles in the In Model styles that are not actually used in your model.

Small Thumbnails, Medium Thumbnails, Large Thumbnails, Extra Large Thumbnails

Use the Small Thumbnails, Medium Thumbnails, Large Thumbnails, or Extra Large Thumbnails menu item to change the size of the thumbnails in the Select
panel.

List View
Use the List View menu item to display the styles in list form.
Refresh

Use the Refresh menu item to update the styles appearing in the styles browser.

The Styles Browser Edge panel

SketchUp contains a variety of edge rendering styles allowing you to manipulate the edge appearance on the screen.

Note: Endpoints and Jitter edge rendering styles are not available for NPR Edges.

Models with perfectly straight digitally drawn lines are often perceived to be in a finished state. Edge Rendering Styles are useful in conveying that a model is still
in conceptual state and, therefore, is open for feedback.

Edges checkbox

Selecting the Edges checkbox activates the display of edges in your model. The following images shows a series of cubes without and then with edges.
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Back Edges checkbox

Selecting the Back Edges checkbox activates the display of edges obscured by other edges in your model. Obscured edges appear as dashed lines. The following
images show a cube without back edges and then a cube with back edges. Note that enabling back edges will disable the X-Ray face style.

e

Profiles checkbox

Selecting the Profiles checkbox emphasizes the outlines or profiles of major shapes in your model. This style is particularly useful in ensuring the 3D nature of
geometry is emphasized and borrows from a proven traditional media drawing technique. Enter a thickness, in pixels, for the profile lines in the pixels field. The
following image shows a series of cubes with edges and profile edges.

Depth cue checkbox

Selecting the Depth cue checkbox emphasizes the lines of geometry in the foreground over the lines of geometry in the background. The following image shows
a series of cubes with edges and depth cue edges on. Notice that the foreground edges on each cube get progressively thinner from front to back and top to
bottom. Enter a thickness, in pixels, for the depth cue lines in the pixels field. This thickness determines the thickness of the forward-most lines (such as for the
bottom middle cube in the following image) of your model.
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Extension checkbox

Selecting the Extension checkbox extends each line slightly past its endpoint, giving your model hand-drawn sketched appearance. This edge rendering style
does not affect inference behavior. Enter a length, in pixels, for the extension lines in the pixels field. The following image shows a series of cubes with edges
and extension edges.

Endpoints checkbox

Selecting the Endpoints checkbox places additional line thickness at the endpoints of lines. Enter a length, in pixels, for the length of the emphasized endpoints
in the pixels field. The following image shows a series of cubes with edges and endpoints edges.

Jitter checkbox

Selecting the Jitter checkbox renders each line multiple times at a slight offset, giving your model hand-drawn sketched appearance. This edge rendering style
does not affect inference behavior. The following image shows a series of cubes with edges and jitter edges.

SketchUp also allows you to manipulate the edge color on the screen.

Note: Edge colors are only available when using Shaded and Shaded with Textures face rendering styles. Inference alignments to edges are not available when
edges are hidden.

All same
Use the All same drop-down list item to display all edges using the Edges color as defined in color swatch. This option does not actually change any edge color
assignments you may have made, but preserves them if you choose to view them again.

By material
Use the By material drop-down list item to display edges using an assigned material color. The following image contains edges painted with a grey material.
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By axis

Use the By axis drop-down list item to display edges in colors corresponding to the color of the drawing axes to which they are parallel. This option is helpful in
determining when edges are not aligned to an axis. The following image has lines colored red, green, and blue corresponding to the axes to which they are
aligned.
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The Styles Browser Modeling panel

The Modeling panel contains styles for how a variety of entities are displayed on the screen.
Selected button

Use the Selected button to set the color of the highlight used to indicate a selection. Use a color that will contrast well with the other colors in your model when
selecting a selected color.

Locked button

Use the Locked button to set the color of any locked component.

Guides button

Use the Guides button to set the color of any Guide Line entities in your model.

Inactive section button

Use the Inactive section button to define the color for the currently inactive (not highlighted) Section Plane entities in your model.
Active section button

Use the Active section button to define the color for the currently active (highlighted) Section Plane entity.
Section Cuts button

Use the Section Cuts button to define the color for the active section plane's section slice line.

Section cut width field

Enter a Section cut width to define the thickness (in pixels) of all cut lines in the active section plane.
Hidden Geometry checkbox

Selecting the Hidden Geometry checkbox displays hidden geometry or entities that have been hidden using the Hide menu item or context command. The Hidden
Geometry checkbox displays hidden faces with a light cross-hatch pattern (edges are displayed dashed), enabling you to select the geometry. Once selected,
hidden geometry can be made visible with the Unhide> Selected, UnHide > Last, and Unhide > All menu items.

Color by Layer checkbox

Selecting the Color by Layer checkbox applies materials to geometry on a per layer basis using the color associated with the layer. Ensure shaded or shaded with
Textures display is turned on to view materials.

Guides checkbox

Selecting the Guides checkbox displays guide line entities and guide point entities.
Section Planes checkbox

Selecting the Section Planes checkbox displays Section Plane entities.

Section Cuts checkbox

Selecting the Section Cuts checkbox displays section cut effects.

Model Axes checkbox

Selecting the Axes checkbox displays the drawing axes.

Foreground Photo checkbox

Check the Foreground Photo checkbox to display the photo as an overlay image on the model faces. Uncheck the Foreground Photo checkbox to hide the overlay.
This option is only applicable during Match Photo Sketching mode.

Opacity slider

Move the Opacity slider to the left to make the photo overlay more transparent. Move the Opacity slider to the right to make the photo overlay more opaque. This
option is only applicable during Match Photo Sketching mode.

Background Photo checkbox

Check the Background Photo checkbox to display the photo as a background image to the model. Uncheck the Background Photo checkbox to hide the photo.
This option is only applicable during Match Photo Sketching mode.
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Opacity slider

Move the Opacity slider to the left to make the photo more transparent. Move the Opacity slider to the right to make the photo more opaque. This option is only
applicable during Match Photo Sketching mode.

Styles Browser

The Styles Browser contains options used to alter how your model and the drawing area is rendered (its edge type face type, background colors, watermarks, and
so on). Activate the Styles Browser from the Window menu. The following image contains a screen shot of the Styles Browser on Microsoft Windows:
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Watermark

Watermark panel

The watermark panel contains settings for all of the watermarks in a style.
Display watermarks checkbox

Selecting the Display watermarks checkbox displays all active watermarks (all watermarks whose Active checkbox is selected). Deselecting the Display
Watermarks checkbox hides all watermarks.

Watermark

Watermark is part of the Styles Browser. This feature allows you to add a watermark-like image to foreground or background of the drawing area.

Watermark settings

There are several settings that you can make when creating or editing a watermark. These settings follow.
Create Mask checkbox

The Create Mask checkbox uses brightness of the color to create a vignette-like mask. The white portion of the graphic will become transparent and the black
portions of the graphic will use the background color.

Blend slider

Sliding the Blend slider to the right increases the presence of the watermark while decreasing the presence of the model. Sliding the Blend slider to the left
increases the presence of the model while decreasing the presence of the watermark.

Position
There are three options for positioning your watermark. The positioning options are:

Stretched to fit the screen button

Use the Stretched to fit the screen button to stretch the watermark across the drawing area. Selecting the Lock Aspect Ratio checkbox to cause the aspect ratio
(height of image to width of image) to remain consistent such that the image is not distorted (the image might not fill the entire drawing area when aspect ratio
is locked).

Tiled across the screen button
Use the Tiled across the screen button to create copies, ortiles,of the watermark and tile them across the drawing area. Sliding the Scale slider to the left creates
progressively more, smaller, watermarks. Sliding the Scale slider to the right creates progressively fewer, larger, watermarks.

Positioned in the screen button

Use the Positioned in the screen button option to position the watermark at one of nine pre-defined screen locations. Select the button in the Position matrix that
best represents the location on the screen where you want your watermark. Sliding the Scale slider to the left decreases the size of the watermark. Sliding the
Scale slider to the right increases the size of the watermark.
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Model settings and managers

Moving geometry between layers in SketchUp

To move geometry from one layer to another:

. Select the Select tool. The cursor changes to an arrow.

. Select one or more entities. The selected entities are highlighted in yellow.
. Activate the context menu for the selected entities.

. Select the Entity Info menu item. The Entity Info dialog box appears.

. Select the layer for the entities from the 'Layers' drop-down list.
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Note: Assigning a different layer to a group or component doesn't affect the layer assignments of the individual entities within the group or component. If you
want to assign new layers to the entities within a group or component, you must edit the group or component, select specific entities within the group or
component, and then assign a different layer to the selected entities.
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Outliner

Filtering groups and components in the hierarchical view

The Outliner contains a Filter field for displaying only those groups or components containing a specific filter string. This feature helps you to locate only like
components or groups. To filter items within the Outliner:

1. Select Window > Outliner. The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-
most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy
exist (additional groups or components within the top-level groups or components).

2. Type a string in the 'Filter' field.

3. Click on the + icon to list groups or components within other groups or components. Or, optionally, click on the Details menu and select the Expand All
menu item to expand the hierarchy so all levels are displayed. Items containing the filter string will be listed, in red, in the hierarchical view.

Identifying entries in the outliner hierarchy

The Outliner uses a combination of icons and text to identify groups and component status in a hierarchy.

Component - Four black squares

Group - One solid square

Locked Component - Four grey squares with small lock in lower right corner
Locked Group - One grey square with small lock in lower right corner

Open Component - Four hollow squares

Open Group - One hollow square

Hidden Component or Group - Name of component or group is in italics
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Moving items within the outliner

Use the Outliner to reorganize groups and components in the hierarchy. For example, you can move a group, buried deep within the hierarchy, to the top of the
hierarchy for easy editing. To move items within the outline:

1. Select Window > Outliner. The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-
most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy
exist (additional groups or components within the top-level groups or components).

2. Click on the + icon to list groups or components within other groups or components. Or, optionally, click on the Details menu and select the Expand All
menu item to expand the hierarchy so all levels are displayed.

3. Click and hold on the group or component you want to move in the hierarchy.

4. Move the group or component to a new position in the hierarchy.

Naming groups and components within the outliner

The Outliner displays groups by their group names and components by a combination of the definition and specific instance name.
Naming a component definition

As mentioned in the previous paragraph, components are identified in the outliner by a combination of their instance and definition names (the definition name
is enclosed in less-than and greater-than symbols). For example, Jim's Office . Where you may have several Cubicle Style 1 components in your model, but only
one instance represents Jim's Office.

The component definition name generally refers to type of component, such as a certain type of cubicle (Cubicle Style 1) or certain type of video camera (VideoX
8mm camera). This name can either be established when the component is first created, or you can accept the default (Component#X, X being some number) and
rename the component definition using the outliner. To rename the component definition:

1. Context-click on the component in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the
context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).

. Click on the Entity Info menu item. The Entity Info dialog box is displayed.

. Click on the Definition tab to display information about this component's definition.

. Type a new name in the definition's name field.

. Click outside of the Entity Info dialog box to save your change.
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Naming a component instance

A component instance name is useful when you want to differentiate different component instances from each other in the Outliner (the default name for all
component instances is 'Component'). For example, you might want to have different instance names if several chairs are all from the same definition in your
model. To rename the component instance:

1. Context-click on the component in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the
context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).

2. Select the Rename menu item

3. Type the new component instance name in the Outliner.

4. Press the Enter (Microsoft Windows) or Return (Mac OS X) key to save your change.

Note: You can also use the Name field at the top of a component's Entity Info dialog box to rename component instances.

Use instance names to differentiate different instances of the same definition in your model. This tip is particularly useful if you want to easily locate a specific
component instance in the outliner.

Naming a group
You can also name your groups for easy identification in the Outliner. To rename a group:

1. Context-click on the group in the Outliner. The context menu for the Component entity is displayed. Notice that this is the same context menu as the
context menu displayed when you context-click on an entity in the drawing area (except this context menu has a Rename menu item).

2. Select the Rename menu item

3. Type the new component instance name in the Outliner.

4. Press the Enter (Microsoft Windows) or Return (Mac OS X) key to save your change.

Traversing component and group hierarchies

The outliner contains a hierarchy view that reflects your hierarchy of components and groups in your model. To navigate a component or group hierarchy using
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the hierarchical view:

1. Select Window > Component. The Outliner dialog box opens with a hierarchical view of your model. The Group and Component entities at the root (top-
most) level of the hierarchy are displayed. An icon with a plus sign will appear next to any components or groups when additional levels in the hierarchy
exist (additional groups or components within the top-level groups or components).

2. Click on the + icon to list groups or components within other groups or components. Or, optionally, click on the Outliner's Details menu and select the
Expand All menu item to expand the hierarchy so all levels are displayed.

3. Click on any group or component name in the hierarchical view to select the group or component in your model.

4. (optional) Double-click on the group or component name in the hierarchical view to edit the group or component in your model.

Outliner

The Outliner is used to view your Group and Component hierarchies as a hierarchical tree. This feature is great for navigating through large models, restructuring
the model hierarchy, locating instances of a particular component, or renaming groups and components. Activate the Outliner dialog box from the Window menu.
The following image shows a screenshot of the Outliner on Microsoft Windows:
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Identifying Entries in the Outliner Hierarchy
Moving Items Within the Outliner
Filtering Groups and Components in the Hierarchical View

Naming Groups and Components Within the Outliner

Details menu

Click on the right arrow next to the 'Filter' field to open the details pop-up menu. This menu allows you perform additional Outliner-related functions.
Expand All

Use the Expand All menu item to expand (open all branches) the entire hierarchical view in the Outliner.

Collapse All

Use the Collapse All menu item to collapse (close all branches) the entire hierarchical view in the Outliner.

Sort by Name

Use the Sort by name menu item to toggle the sorting of the groups and components alphabetically.
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Scenes Manager

Creating an animation

Animations are a series of scenes that are displayed in succession to give a hands-free tour of a model. To create an animation:

AwWN R

. Select Window > Scenes. The Scenes Manager displays.

. (optional) Type the name of the scene in the 'Name' field. For example, type "Front View" if the scene represents the front view of a building.

. (optional) Press the Tab key. The cursor advances to the Description field.

. (optional) Type a description of the scene in the 'Description’ field. The description could be the address of a building, some detail shown in the scene, and

SO on.

5. (optional) Deselect any of the Properties to save that you do not want saved with the scene. Refer to Scene Manager Options for further information.
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. Click the Add Scene button (@) to add the scene. A scene tab is added above the Drawing Window. The scene tab has the name of the scene you

assigned in step 2.

. Move to a new location of the model using either the Camera tools or Walkthrough tools.
. (optional) Repeat steps 2-7 to add additional scenes.

. Context-click on the first scene tab above the Drawing Window. A context menu appears.
10.

Select Play Animation. The animation cycles through each scene.

Refer to Running an Animation for further information.

Running an animation

SketchUp contains controls for starting, stopping, and pausing an animation. To run an animation:

1.
2.
3.

Select the View > Animation > Play menu item. The animation controls are displayed and the animation starts to cycle through your scenes.
Press the Pause button to pause the animation.
Press the Pause button to stop the animation.

Note: You can also context-click on a scene tab and select Play Animation to begin an animation

Adding a scene

The Add Scene button (@) allows you to add a new scene to the current file. To add a scene:
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. Select Window > Scenes. The Scenes Manager displays.

. (optional) Type the name of the scene in the 'Name' field. For example, type "Front View" if the scene represents the front view of a building.

. (optional) Press the Tab key. The cursor advances to the Description field.

. (optional) Type a description of the scene in the 'Description’ field. The description could be the address of a building, some detail shown in the scene, and

SO on.

. (optional) Deselect any of the Properties to save that you do not want saved with the scene. Refer to Scene Manager Options for further information.

. Click the Add Scene button (@) to add the scene. A scene tab is added above the Drawing Window. The scene tab has the name of the scene you

assigned in step 2.

Updating a scene

r~
Use the Update Scene button ( =) to update a scene if you have made changes to the scene. To update a scene:

1.
2.

Select the scene you want to update.

Click on the properties, within Properties to save, to store with the scene.

Warning: Each scene has a series of properties that you can store with that scene (Properties to save). Additionally, when you update a scene, you can
choose those properties, of the properties that are stored with the scene, to update (the dialog box that appears when the Update button is clicked). If you
choose to update a property that you are not storing with a scene (using Properties to save), the property will not be updated. Therefore, it is important to
ensure you have all of the properties you want to store with a scene checked prior to updating a scene.

~
3. Click on the Update Scene button ( ®=). An Scene Update dialog box appears.
4.

5. Click on the Update button.

Click on the properties you want to update. Remember, you can only update those properties that you have previously selected to be stored with the scene.

Assigning styles to scenes

You can assign individual styles to each scene in your SketchUp file. To assign a style to a scene:
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. Select the Window > Styles menu item. The Styles Manager is displayed.
. Select a styles collection from the drop-down list, such as 'Assorted Styles.'

Click on a style in the collection. The style is selected and applied to your current model.

. Select Window > Scenes. The Scenes Manager is displayed.

. Click the Add Scene button ( @). A scene is added with the current style.
. Repeat steps 2 to 5 for additional styles and scenes.

Modifying a style assigned to a scene

To modify a style already assigned to a scene:
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. Select Window > Styles. The Styles Manger is displayed.
. Select the In Model styles from the drop-down list. The In Model styles are displayed.

Click on one of the In Model styles to modify.

. Select the Edit tab. The Edit panel is displayed.
. Adjust the style as necessary.
. Click the Update Style with changes button. The style is updated in all scenes.

Details arrow

Click on the arrow in the upper-right portion of the Scene Manager dialog box to show or hide additional options.

Scenes manager options
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Update Scene

™
Use the Update Scene button (®) to update a scene if you have made changes to the scene.

Add Scene button

The Add Scene button (@) allows you to add a new scene to the current file.

Delete Scene button

Use Delete Scene button (@) to delete a scene from the current file. Select the scene in the list of scenes and click the Delete Scene button to delete the scene.

Move Scene Down button

Use the Move Scene Down button ( $ ) to move the currently selected scene down in the list.

Move Scene Up button

Use the Move Scene Up button ( ) ) to move the currently selected scene up in the list.

View options drop-down list

Click on the View options drop-down list to list several options for viewing your scenes in Scenes browser.
Small thumbnails

Click the Small thumbnails menu item (EEEV) to display small thumbnail representations of your scenes.

Large thumbnails

oo
Click the Large thumbnails menu item (907 to display large thumbnail representations of your scenes.

Details

o=
Click on the Details menu item (85 7) to display large thumbnails representations of your scenes along with the scene name, author, and description.

List

Click on the List menu item (= ") to display a list of all scene names.

Refresh
Click on the Refresh menu item to refresh the current list of scenes.

Show/Hide Details button

=]
Use the Show/Hide Details button ( ') to show or hide additional details.

Include in animation
Use the Include in animation checkbox to indicate whether a scene should be used in the animation. Select a scene and select the Include in Animation option to
include the scene in animation. Disable this option for scenes you want to work on but do not want in a animation.

Name
Click in the Name field to name the currently active scene.

Description
Click in the Description field to provide a short description or note for the currently active scene.

Properties to save
The Properties to Save options are used to control the different properties that can be stored with each scene. Properties that are not selected in the Properties to
save section cannot be updated with the Update button.

Camera Location: Selecting the Camera Location checkbox stores the point of view, including the zoom distance and field of view, with the scene.
Hidden Geometry: Use the Hidden Geometry checkbox to store the hidden geometry visibility with the scene.

Visible Layers: Use the Visible Layers checkbox to store the visible layers with the scene.

Active Section Planes: Use the Active Section Planes checkbox to store the active section planes with a scene.

Note: Use different section cuts in successive scenes to create exciting animations with different cross sections of your model.

Style and Fog: Use the Style and Fog checkbox to store the drawing style settings, such as edge rendering and fog, with the scene.

Shadows Settings: Use the Shadows Settings checkbox to store all shadow-related information, including type, time, date, and so on, with the scene.
Axes Location: Use the Axes Location checkbox to store display and position of SketchUp's drawing axes with the scene.

Details menu

Use the Details arrow ( B ) to display the Details menu. The following lists all options found on the details menu in both Microsoft Windows and Mac OS X
versions of SketchUp.

Add Scene
The Add Scene menu item allows you to add a new scene to the current file.

Update Scene
Use the Update Scene menu item to update a scene if you have made changes to the scene.

Delete Scene
Use Delete Scene menu item to delete a scene from the current file. Select the scene in the list of scenes and click the Delete Scene button to delete the scene.

Use Scene Thumbnails

Select the Use Scene Thumbnails to create a thumbnail image from the current scene (the menu item will have a check next to it). Select the User Scene
Thumbnails again to use background Match Photo image for thumbnails (the menu item will not have a check next to it). By default, thumbnails are only created
for scenes that contain background Match Photo images.
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Update Scene Thumbnails
Use the Update Scene Thumbnails to update thumbnail images for the currently selected scene. These images are displayed when either the Small thumbnails or
Large thumbnails option is selected in the View Options drop-down list.

Add Scene with Matched Photo
Use the Add Scene with Matched Photo to match a new photo. Refer to Match Photo: Introduction for further information.

Show/Hide Details
Use the Show/Hide Details menu to show or hide additional details.

Scenes manager

The Scenes Manager is used to control the various features of SketchUp scenes. Activate the Scenes dialog box from the Window menu or from the scene tabs.

The Scenes Manger contains a list of all of the scenes for the model. Scenes in this list are displayed in the order in which they will be displayed when running an
animation. The following image shows the Scenes Manager on Microsoft Windows:
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Each scene has a series of properties that you can store with that scene (Properties to save). Additionally, when you update a scene, you can choose those
properties, of the properties that are stored with the scene, to update (the dialog box that appears when the Update button is clicked). If you choose to update a
property that you are not storing with a scene (using Properties to save), the property will not be updated. Therefore, it is important to ensure you have all of the
properties you want to store with a scene selected prior to updating a scene.

Refer to Scenes manager options for further information.

What can | use Scenes for?

You can use Scenes to save camera views, as well as several additional properties.

For example, open a new model, change the view-move the camera by orbiting, panning, and zooming-and then click "Window" > "Scenes." Click the "+" button
to add a new scene. Change the view by orbiting a little bit. Click the "Scene 1" scene (the "Scene 1" tab at the top). The view is returned to the position and zoom
level determined by "Scene 1."

You can update the properties that are saved on a scene. You can also add new Scenes, and then update each scene with different properties. As you move from
one scene to the next, the view changes smoothly from the one set for the first scene to the one set for the second scene, and the different properties you saved
for each scene are also enabled. You can use this to add a nice animation quality to the display of your model.

To add a new Scene, right-click the "Scene 1" scene, and then click "Add."
You can store several properties with each scene:

The view (camera position, zoom, and field of view).
Shadow settings.

Whether entities are hidden or displayed.

Section planes.

Drawing axes.

Style Display Settings (display styles and edge effects).
Layers.
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Scenes only store properties, not geometry. There's only one instance of the geometry in a model, and all Scenes are simply views of that geometry. If you have a
scene selected and draw some new geometry, you'll see the new geometry on every scene. The only things you can change from scene to scene are the properties
that are stored.

The easiest way to control scene properties is via the Scenes dialog box (open the "Window" menu, and then click "Scenes").

When you add a new scene, it inherits all of the saved properties of the current scene. But if you're on existing scene and make change to any of the scene
properties, you must update the scene in order to save the changes. You can also update other Scenes at the same time to save the same property changes to
those Scenes as well.

An important note: Components don't have Scenes. If you create a model with Scenes and share it in the 3D Warehouse, and then you download that model
directly into a SketchUp model, it comes in as a component. To be able to see and access Scenes, you must open the model in a new instance of SketchUp, so it
opens as a full model rather than as a component in a model:

1. In the 3D Warehouse, click "Download to SketchUp."
2. A message asks, "Load this directly into your SketchUp model?" Click "No."
3. The next message asks, "Do you want to open or save this file?" Click "Open."

For more information about Scenes, open the "Help" menu, and then click "Help Center."
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Generating Scene Thumbnails

You will see this message when using SketchUp 8 to open a SketchUp file that was created with version 7 or earlier. This is a one time process, that you're
welcome to cancel at any time. If you have a lot of textures, this process can take longer.

What should | know about Scene thumbnails?

SketchUp 8 can display a thumbnail preview for all Scenes in a model. There are a few things that are good to know about this feature, especially if you're
working with models created with an older version of SketchUp.

Generating Scene Thumbnails dialog box
You will see this message if you use SketchUp 8 to open a model created with an older version of SketchUp. This is a one time operation that will happen the first
time you open a model. If you're model has a lot of textures, this process can take a while. In which case you have two options:

e Press Cancel.
e Press Cancel and check Don't generate thumbnails for this model.

If you choose Cancel, then this dialog box will appear again the next time you open the SketchUp file. If you choose the second option, then you will have the
option update the scenes later. Review the following sections to learn more.

Automatically updating Scene thumbnails
1. Click Window > Scenes.
2. Right click on the scene that you want automatically updated. You can also hold down the Shift key and click on multiple scenes.
3. Click Use Scene Thumbnails if there is not a check mark next to this option. Otherwise you don't have to make any changes.

Manually updating Scene thumbnails

1. Click Window > Scenes.
2. Right click on the scene that you want manually updated. You can also hold down the Shift key and click on multiple scenes.
3. Click Update Scene Thumbnails.

Scenes and animations

Your SketchUp file can contain one or more scenes. A scene consists of your model and a series of scene-specific settings, such as a specific point of view,
shadow, display setting, and section cut. For example you can have your model on one scene with a morning shadow and on another scene with your model and
a evening shadow. Then, use the animation feature of SketchUp to cycle through the scenes and watch the shadow transition from morning to evening (this is
called a shadow study). Link several scenes together, each with different settings, to form a animated tour of your model. Activate the Scene Manager from the
Window menu to add, delete, and update scenes.

Saving animations

Animation export
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Preferences

What are templates and how do | change the default template?

A template file contains default settings from the Model Info, Style, and Shadow dialog boxes. Templates can also contain base geometry like the person who's
standing in the default SketchUp template. Different templates are geared toward different types of users like architects or geo-modelers, so you'll want to select
a template that's best-suited for the types of models you build. Your selected template will automatically load when you open SketchUp.

There are couple ways you can change the template that SketchUp uses whenever you open a new file:
Select a different template

SketchUp is installed with several templates, including: Architectural - US, Centimeter, Meters, and Millimeters. To change to a different template:

. Open the Window menu (Mac = SketchUp menu).

. Click Preferences.

. In the left pane, click Template.

. In the right pane, select a drawing template.

. Click OK to close the System Preferences dialog box.

. To open a new model using the selected template, open the File menu, and click New.
. The selected template is also used after you close and restart SketchUp.
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Make changes to the default template you are using

. Open the File menu.
. Click Save As.
3. In the Save As dialog box, browse to the SketchUp Templates folder, which is installed by default to:
o SketchUp and SketchUp Pro for PC - C:\Program Files\Google\Google SketchUp #\Resources\en-US\Templates.
o SketchUp and SketchUp Pro for Mac - Macintosh HD/Library/Application Support/Google SketchUp #/SketchUp/Templates.
. Save the template using the existing template name or a new name, for example, "My Template."
. Back in SketchUp, if you saved your changes using a new template name, select that new template (follow the preceding "Select a different template”
procedure).
6. To open a new model using the selected template, open the File menu, and click New.
7. The selected template is also used after you close and restart SketchUp.
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How are preferences saved?

SketchUp Preferences includes settings such as keyboard shortcuts and toolbar position. Preferences are saved for each user account, rather than in the template.
For more information about sharing your preferences, see our Exporting preferences article.

Creating a template

A template file contains default settings from the Model Info dialog box and base geometry. To create a template:

1. Select File > New to start a new SketchUp file.

2. Modify the Model Info settings to fit your particular needs. For example, you might want to set default units and snaps, activate a ground plane, and set a
geographic location.

3. Modify the Preference settings to fit your particular needs.

4. (optionally) Draw any geometry that you want to share among all of your models. For example, you might want all of your models of houses to be created
within the same starting terrain (such as when you are creating models of houses within a housing development).

5. Select File > Save As Template to save the SketchUp file.

6. Enter the template name, description, and filename.

7. (optional) Select the 'Set as default template' checkbox to save this template as the default template (to load every time you load SketchUp).

Note: The template will appear in the Template panel of the Preferences dialog box (Window > Preferences on Microsoft Windows or SketchUp > Preferences on
Mac OS X)

Assigning keyboard shortcuts (Microsoft Windows)

Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a
keyboard shortcut:

1. Select Window > Preferences. The Preferences dialog box is displayed.

2. Click on the Shortcuts item on the left-hand side of the Preferences dialog box. The Shortcuts panel is displayed.

3. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the
Assigned list.
Note: The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some
context menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open
Preferences > Shortcuts to set a keyboard shortcut for Reverse Faces.

4. Type the keyboard shortcut key sequence In the 'Add Shortcut' field. Shortcut keys can consist of any keyboard key, except number keys, with a few
exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Alt. SketchUp will indicate when a key or key
combination cannot be used or is already assigned.

5. Click the + button.

You can have multiple keyboard shortcut combinations for each command. SketchUp will prompt you before allowing you to assign a keyboard shortcut that is
already assigned to another command. Some keys are reserved for use by Microsoft Windows and can not be assigned as a keyboard shortcut.

Note: You can save your shortcuts to a .dat file for copying to other computers. See the Files panel in this topic for more information.

The Measurements toolbar and keyboard shortcuts

Temporary focus is given to the Measurements toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys.
The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements toolbar. Prepend any of these
letters with a number in the Measurements toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example, 7s
would be the correct entry to redefine a segmentation in the Measurements toolbar. However, s7 will activate whatever command is invoked with the letter S as a
keyboard shortcut.
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Note: Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements toolbar.

Assigning keyboard shortcuts (Mac OS X)

Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a
keyboard shortcut:

1. Select SketchUp > Preferences. The Preferences dialog box is displayed.

2. Click on the Shortcuts item on the left-hand side of the Preferences dialog box. The Shortcuts panel is displayed.

3. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the
Key column next to each function.

Note: The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some
context menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open
Preferences > Shortcuts to set a keyboard shortcut for Reverse Faces.

4. Type the keyboard shortcut key sequence in the field below the function list. Shortcut keys can consist of any keyboard key, except number keys, with a
few exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Option, or Command. SketchUp will
indicate when a key or key combination cannot be used or is already assigned.

You can have multiple keyboard shortcut combinations for each command. SketchUp will prompt you before allowing you to assign a keyboard shortcut that is
already assigned to another command. Some keys are reserved for use by Microsoft Windows and can not be assigned as a keyboard shortcut.

Note: You can save your shortcuts to a .dat file for copying to other computers. See the Files panel in this topic for more information.

The Measurements toolbar and keyboard shortcuts

Temporary focus is given to the Measurements toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys.
The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements toolbar. Prepend any of these
letters with a number in the Measurements toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example, 7s
would be the correct entry to redefine a segmentation in the Measurements toolbar. However, s7 will activate whatever command is invoked with the letter S as a
keyboard shortcut.

Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements toolbar.

Exporting preferences, including keyboard shortcuts (Microsoft Windows)

System preferences are automatically saved as you make the changes to items like keyboard shortcuts. However, you can export preferences, including keyboard
shortcuts, for sharing between other copies of SketchUp. To export your preferences:

. Select the Window > Preferences. The Preferences dialog box appears.

. Select the Files item from the left-hand of the Preferences dialog box. The Files panel is displayed.

. Click the Export button. The Export Preferences dialog box is displayed.

. Navigate to the folder where you want to save the file.

. Type the name of the file in the 'File name’ field (Preferences.dat by default).

. Click on the Options button. The Export Preferences Options dialog box appears.

. Select the 'Shortcuts' checkboxes if you do not want to save either shortcuts or File locations respectively.
. Click the OK button.

. Click the Export button. The preferences are saved to your predefined location.
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Importing preferences, including keyboard shortcuts (Microsoft Windows)

You can import preferences, including keyboard shortcuts,that are exported from another copy of SketchUp. To import preferences:

. Select Window > Preferences. The Preferences dialog box appears.

. Select the Files item from the left-hand of the Preferences dialog box. The Files panel is displayed.

. Click the Import button. The Import Preferences dialog box is displayed.

. Navigate to the folder containing the preferences file.

. Select the preferences file.

. Click on the Options button. The Import Preferences Options dialog box appears.

. Select the 'Shortcuts' checkboxes if you do not want to save either shortcuts or File locations respectively.
. Click the OK button.

. Click the Import button. The preferences are imported into SketchUp.
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Resetting keyboard shortcuts

To reset keyboard shortcuts:

1. Select the Preferences menu item from the Window (Microsoft Windows) or SketchUp (Mac OS X) menu. The Preferences dialog box is displayed.
2. Click on the Shortcuts item on the left-hand side of the dialog box. The Shortcuts panel is displayed.
3. Click the Reset All button. Keyboard shortcuts are reset.

Application Preferences dialog box (Mac OS X)

SketchUp's application preferences are used to set various global behaviors for SketchUp. Activate the Preferences from the SketchUp menu.
Applications
Use the Applications preferences panel to identify the application used to open an application for editing image files.

Default Image Editor
Use the Choose button to display the Image Editor Browser. Use the browser to locate an image editor for your image files.

Drawing
Use the Drawing preferences panel to define global mouse (or otherinput device) behavior.

Click Style
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The Click Style options allow you to define how your input device reacts to clicks.

Click-drag-release: Use the Click-drag-release button to force the Line tool to draw by click and holding the mouse button to define the start point of the line,
dragging the mouse to extend the line, and releasing the mouse to establish the end point of the line.

Auto detect:Use the Auto Detect button to use either Click-drag-release and Click-move-click as necessary.

Click-move-click: Use the Click-move-click button to force the Line tool to draw by clicking and releasing the mouse button to define the start point of the line,
moving the mouse to extend the line, and clicking again to establish the end point of the line.

Continue line drawing:Use the Continue line drawing checkbox to force the Line tool to treat an end point as the start point of a new line, saving you the one
extra click required establish a new start point for the second line.

Miscellaneous
The Miscellaneous options define other global mouse behaviors.

Display crosshairs:Use the Display crosshairs checkbox to display a set of colored crosshairs (corresponding to axes colors) when drawing.
Auto-activate paint tool:Use the Auto-activate paint tool checkbox to automatically activate the Paint Bucket tool after you select a color swatch.

Disable pre-pick on Push/Pull Tool: By default, you can select a face with the Select tool, orbit the model (even so that the pre-selected face is hidden), click on
the Push/Pull tool and push/pull anywhere on the screen to push/pull the pre-selected face. This feature allows you to push/pull faces that are normally hard to
select. Check the Disable pre-pick on Push/Pull tool checkbox to disable this pre-pick feature.

Bounding box only
Click the Bounding box only checkbox to toggle between displaying only one bounding box or displaying a bounding box for each component and it's
corresponding edges when selected.

Extensions

Use the Extensions preferences panel to add or remove SketchUp extensions. An extension can be an add-on tool or feature created by SketchUp that is not
necessarily a part of core SketchUp functionality.

Select the checkbox next to the extension that you want to enable in SketchUp. The extension will be available (menu items and optional toolbar) the next time
your run SketchUp.

General
Use the General preferences panel to define global save and settings.

Create backup
Use the Create backup checkbox to automatically create a backup file whenever you save a drawing. The backup file is the previously saved version of the file.
This file will be saved to the same folder as the drawing file. For example, if your drawing is hotel.skp, the backup will be called hotel.skb.

Auto-save
Use the Auto-save checkbox to automatically save changes to your drawing into a temporary file at specific time interval. This temporary file is available on the
file system should SketchUp abnormally exit. Type the auto-save interval, in minutes, into the minutes field.

The temporary file's name will be a combination of the word 'AutoSave' with the original filename, such as AutoSave_hotel.skp. This file is saved in the Autosave
folder under /Library/Application Support/SketchUp/Autosave if the model has never been saved. SketchUp puts the auto save file in the same directory
as the model file.

We strongly recommend you keep the Auto-Save option checked to ensure that your valuable work is retained.

SketchUp checks your model for unrecoverable errors during the auto-save, preventing the overwriting of a good auto-save file. Sketchup will display a dialog
box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. We recommend
you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable
information regarding the unrecoverable errors.

Check model for problems
The Check model for problems options allow you to enable problem checking for your SketchUp models.

Automatically check models for problems: Selecting the Automatically check model for problems checkbox causes SketchUp to check for minor problems with
your model. These problems can occur given the infinite flexibility that SketchUp provides when designing in 3D. Your model is assessed for problems when it is
loaded or saved. We strongly recommend selecting this box to ensure that problems are corrected proactively, allowing your model to perform optimally. You
must manually check for problems using the Fix Problems button in the Statistics panel of the Model Info dialog box if you leave this checkbox deselected.

Automatically fix problems when they are found: Selecting the Automatically fix problems when they are found checkbox causes SketchUp to fix problems
found in your model automatically (without having to display a dialog box). Leave this checkbox deselected if you want SketchUp to display a dialog box (with the
Always fix my models, Fix it now, and Fix it later options) when a problem is found.

Scenes and Styles
The Scenes and Styles options allow you to enable warnings for style changes.

Warn of style change when creating scenes:Use the Warn of style changes when creating scenes if you want to be notified when a style has changed when
adding scenes to your file.

Software Updates
The Software Updates option allows you to automatically check for software updates.

Automatically check for updates: Check the Automatically check for updates checkbox to allow SketchUp to automatically check for updates to the application
when you are connected to the Internet.

OpenGL
Use the OpenGL preferences panel to define how the OpenGL standard should be applied within SketchUp.

Note: You might notice intermittent streaks or small spots of light within face shadows. A minimal amount of these artifacts is to be expected on most systems,
and can vary greatly with the quality of your OpenGL driver.

Caution: Certain OpenGL drivers do not fully support casting shadows on faces.

Caution: SketchUp's Shadow feature can have a severe performance impact on slower computers or those using software rendering.
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OpenGL Settings
The OpenGL Settings allow you to speed up OpenGL drawing.

Use Hardware acceleration: Use the Use Hardware acceleration checkbox to use the hardware acceleration features of a video card. Unfortunately, only a small
percentage of 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be 100% OpenGL
compatible). Most 3d drivers are designed for games, and are rarely tested using other 3D programs. Consequently, numerous incompatibility problems can
occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video card
is not 100% OpenGL compatible and does not support hardware acceleration.

Note: Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your graphics card to
see if it supports hardware acceleration (using the System Preferences on Macintosh OS X).

We cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the
manufacturer of the video card in your system. Therefore, we cannot guarantee that SketchUp will work with hardware acceleration on your system. Refer to the
OpenGL topic for further information.

Use maximum texture size: Selecting the Use maximum texture size checkbox uses the maximum texture size supported by your graphics card. This option
might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised.

Use fast feedback: Selecting the Use fast feedback checkbox increases performance when editing large models. SketchUp runs a test to assess whether your
video card can support this option on startup. SketchUp will activate this option if fast feedback is supported. You can also attempt to use this feature by
selecting the Use Fast Feedback checkbox manually; however you will be warned by SketchUp that enabling this option could cause problems on your system if
fast feedback is not supported.

Shortcuts
Use the Shortcuts preferences panel to define keyboard shortcuts for most SketchUp commands.

Assigning keyboard shortcuts
Keyboard shortcuts can dramatically speed up your drawing by allowing you to change tools while keeping the mouse cursor near the drawing area. To assign a
keyboard shortcut:

1. Select the command to which you will assign a keyboard shortcut (within the Function list). Existing keyboard shortcuts for this command will display in the
Key column.

Note: The list of commands available in the Shortcuts panel is dynamically generated and includes all menu items and active context menu items. Some context
menu items become active only after performing another task. For example, select a face to activate the Reverse Faces command and then open Preferences >
Shortcuts to set a keyboard shortcut for Reverse Faces.

2. Type the keyboard shortcut key sequence in the text field at the bottom of the panel. Shortcut keys can consist of any keyboard key, except number keys,
with a few exceptions. Any key that can be used as a shortcut can also be assigned a modifier key like Shift, Control, or Option. SketchUp will indicate
when a key or key combination cannot be used or is already assigned.

SketchUp will prompt you before allowing you to assign a keyboard shortcut that is already assigned to another command. Some keys are reserved for use by
Mac OS X and can not be assigned as a keyboard shortcut.

Note: Keyboard shortcuts are saved to Home/Library/Application Support/SketchUp/Shortcuts.plist. You can copy this file to other users or computers.

The Measurements toolbar and keyboard shortcuts

Temporary focus is given to the Measurements toolbar when you type a number while in the drawing area. Therefore, numbers cannot be used as shortcut keys.
The letters S, R, X, and the symbols / and * can be used within keyboard shortcuts and as you enter values in the Measurements toolbar. Add a prefix to any of

these letters with a number in the Measurements toolbar to ensure that a command with a corresponding keyboard shortcut letter is not invoked. For example,

7s would be the correct entry to redefine a segmentation in the Measurements toolbar. However, s7 will activate whatever command is invoked with the letter S

as a keyboard shortcut.

Do not use the spacebar or backspace keys as keyboard shortcuts to avoid conflict with values entered in the Measurements toolbar.

Template

Use the Template preferences panel to designate a SketchUp file that you would want to use as a template for all of your subsequent models.
Workspace

Use the Workspace preferences panel to make changes to your SketchUp workspace.

Tool Palette
SketchUp has two differently sized tool pallets. The large tool buttons are easier for some users to see and use (they provide larger areas to click with your
mouse) and are easier to use with a pen and tablet. Smaller buttons save screen space, allowing a larger drawing area.

Use large tool buttons: Use on the Use large tool buttons checkbox to toggle between large and small tool buttons.

Main Window
The Main Window options allow you to set the behavior for the main SketchUp window.

Cascade main windows: Select the Cascade main windows checkbox to place newly created drawing windows lightly below and to the right (cascaded) of the
previous drawing window. This feature is useful if you want to see all of your drawing window title bars. Newly created drawing windows will appear directly on
top of each other when this option is not enabled.

Save current window size:Click on the Save current window size button to save the window size for the currently active drawing window as the default size for
SketchUp.

Reset Workspace Button
Use the Reset Workspace button to reset SketchUp to its default configuration (all dialog boxes are closed).

Application Preferences dialog box (Microsoft Windows)

SketchUp's application preferences are used to set various global behaviors for SketchUp. Activate the Preferences from the Window menu.
Applications

Use the Applications preferences panel to identify the application used to open an application for editing image files.
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Default Image Editor
Use on the Choose button to display the Image Editor Browser. Use the browser to locate an image editor for your image files.

Compatibility
Use the Compatibility preferences panel to identify component and group highlighting and mouse wheel settings.

Bounding box only
Use the Bounding box only checkbox to toggle between displaying only one bounding box or displaying a bounding box for each component and it's
corresponding edges when selected.

Invert
Use the Invert checkbox to change SketchUp scroll wheel behavior to match Google Earth scroll wheel behavior (rolling forward zooms out, rolling backward
zooms in).

Drawing
Use the Drawing preferences panel to define global mouse (or other input device) behavior.

Click Style
The Click Style options allows you to define how your input device reacts to clicks.

Click-drag-release: Use the Click-drag-release button to force the Line tool to draw by click and holding the mouse button to define the start point of the line,
dragging the mouse to extend the line, and releasing the mouse to establish the end point of the line.

Auto detect: Use the Auto detect button to use either Click-drag-release and Click-move-click as necessary.

Click-move-click:Use the Click-move-click button to force the Line tool to draw by clicking and releasing the mouse button to define the start point of the line,
moving the mouse to extend the line, and clicking again to establish the end point of the line.

Continue line drawing:Use the Continue line drawing checkbox to force the Line tool to treat an end point as the start point of a new line, saving you one extra
click required establish a new start point for the second line.

Miscellaneous
The Miscellaneous options define other global mouse behaviors.

Display crosshairs:Use the Display crosshairs checkbox to display a set of colored crosshairs (corresponding to axes colors) when drawing.

Disable pre-pick on Push/Pull Tool: By default, you can select a face with the Select tool, orbit the model (even so that the pre-selected face is hidden), click on
the Push/Pull tool and push/pull anywhere on the screen to push/pull the pre-selected face. This feature allows you to push/pull faces that are normally hard to
select. Check the Disable pre-pick on Push/Pull tool checkbox to disable this pre-pick feature.

Extensions

Use the Extensions preferences panel to add or remove SketchUp extensions. An extension can be an add-on tool or feature created by SketchUp that is not
necessarily a part of core SketchUp functionality.

Select the checkbox next to the extension that you want to enable in SketchUp. The extension will be available (menu items and optional toolbar) the next time
your run SketchUp.

Files
The Files preferences panel defines various locations for files used by SketchUp (such as the default location for Components and Materials).

Models
Use the Models field to define the default location for all of your models. SketchUp uses this location as the starting point for all open and save file operations.

Components
Use the Components field to define the default location used when you open or create a collection using the Components Browser.

Materials
Use the Materials field to define the default location used when you open or create a collection using the Materials Browser.

Styles
Use the Styles field to define the default location used when you open or create a collection using the Styles Browser.

Texture images
Use the Texture images field to define the default location for all images that can be used as a texture. SketchUp uses this location as the starting point for all
File > Insert > Image as Texture operations.

Watermark images
Use the Watermark images field to define the default location for all images that can be used as a watermark.

Export models
Use the Export models field to define the default location for all models that are exported. SketchUp uses this location as the starting point for all File > Export >
3D Model operations.

General

Use the General preferences panel to define global save and settings.

Saving

Create backup: Use the Create backup checkbox to automatically create a backup file whenever you save a drawing. The backup file is the previously saved

version of the file. This file will be saved to the same folder as the drawing file. For example, if your drawing is hotel.skp, the backup will be called hotel.skb.

Auto-save:Use the Auto-save checkbox to automatically save changes to your drawing into a temporary file at a specific time interval. This temporary file is
available on the file system should SketchUp abnormally exit. Type the auto-save interval, in minutes, into the minutes field.

The temporary file's name will be a combination of the word 'AutoSave' with the original filename, such as AutoSave_hotel.skp. This file is saved in the directory
where the original .skp file exists.

Warning: We strongly recommend you keep the Auto-Save option selected to ensure that your valuable work is retained.

SketchUp checks your model for unrecoverable errors during the auto-save, preventing the overwriting of a good auto-save file. Sketchup will display a dialog
box in the rare case that unrecoverable errors are found in your model. This dialog box contains the option to quit SketchUp and send a report. We recommend

you click on the quit SketchUp and send report button to terminate SketchUp and preserve your previously valid auto-save file. This report contains valuable
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information regarding the unrecoverable errors.

Check model for problems
The Check Model for Problems options allow you to enable problem checking for your SketchUp models.

Automatically check models for problems: Selecting the Automatically check model for problems checkbox checks for minor problems with your model. These
problems can occur given the infinite flexibility that SketchUp provides when designing in 3D. Your model is assessed for problems when it is loaded or saved.
We strongly recommends selecting this box to ensure that problems are corrected proactively, allowing your model to perform optimally. You must manually
check for problems using the Fix Problems button in the Statistics panel of the Model Info dialog box if you leave this checkbox deselected.

Automatically fix problems when they are found: Check the Automatically fix problems when they are found checkbox to have SketchUp fix problems found in
your model automatically (without having to display a dialog box). Leave this checkbox deselected if you want SketchUp to display a dialog box (with the Always
fix my models, Fix it now, and Fix it later options) when a problem is found.

Scenes and Styles
The Scenes and Styles options allow you to enable warnings for style changes.

Warn of style changes when creating scenes:Use the Warn of style changes when creating scenes if you want to be notified when a style has changed when
adding scenes to your file.

Software Updates
The Software Updates option allows you to automatically check for software updates.

Automatically check for updates: Check the Automatically check for updates checkbox to allow SketchUp to automatically check for updates to the application
when you are connected to the Internet.

OpenGL
Use the OpenGL preferences panel to define how the OpenGL standard should be applied within SketchUp.

Note: You might notice intermittent streaks or small spots of light within face shadows. A minimal amount of these artifacts is to be expected on most systems,
and can vary greatly with the quality of your OpenGL driver.

Warning: Certain OpenGL drivers do not fully support casting shadows on faces.

Warning: SketchUp's Shadow feature can have a severe performance impact on slower computers or those using software rendering.

OpenGL Settings
The OpenGL Settings allow you to speed up OpenGL drawing.

Use hardware acceleration: Use the Use Hardware acceleration checkbox to use the hardware acceleration features of a video card. Unfortunately, only a small
percentage of 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be 100% OpenGL
compatible). Most 3d drivers are designed for games, and are rarely tested using other 3D programs. Consequently, numerous incompatibility problems can
occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video card
is not 100% OpenGL compatible and does not support hardware acceleration.

Note: Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your graphics card to
see if it supports hardware acceleration (using the Control Panel on Microsoft Windows.

We cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the
manufacturer of the video card in your system. Therefore, We cannot guarantee that SketchUp will work with hardware acceleration on your system. Refer to the
OpenGL topic for further information.

Use maximum texture size: Selecting the Use maximum texture size checkbox uses the maximum texture size supported by your graphics card. This option
might result in a slowing of SketchUp unless your graphics card and computer can handle what is advertised.

Note: This option only affects textures and images on the screen (not export or print quality).

Use fast feedback: Selecting the Use fast feedback checkbox increases performance when editing large models. SketchUp runs a test to assess whether your
video card can support this option on startup. SketchUp will activate this option if fast feedback is supported. You can also attempt to use this feature by
selecting the Use Fast Feedback checkbox manually; however you will be warned by SketchUp that enabling this option could cause problems on your system if
fast feedback is not supported.

We strongly recommends that you set your driver's anti-aliasing setting to application controlled (which is normally the default setting for most graphic card
drivers) to ensure that fast feedback functions properly. It is possible that you will see rendering anomalies, such as blurring of the model, when using fast
feedback under a non-application controlled setting.

Capabilities

The capabilities table lists one or more different graphic card settings combinations that might work well within SketchUp. These combinations were selected by
SketchUp, on execution, from a large list of settings combinations supported by your graphics card. SketchUp defaults to the most basic of these combinations to
ensure your models will be rendered properly. Choose a different combination if you want to alter your graphics capabilities within SketchUp.

Anti-Alias: SketchUp generally defaults to a combination with a zero anti-alias value. Higher anti-alias values, such as 2x or 4x, can create smoother looking
lines in SketchUp. However, you might experience some flickering and reduced rendering performance if a higher anti-alias value is selected.

Details button: Use the Details button to view details about your video card.
Shortcuts
Use the Shortcuts preferences panel to define keyboard shortcuts for most SketchUp commands.

Filter field
Type a phrase in the Filter to list shortcuts of a specific type.

Function list
The Function list contains all of the functions that can be assigned a keyboard shortcut.

Add Shortcut field
Type a keyboard shortcut, to be assigned to the currently selected function, in the Add Shortcut field.

+ button
Use the + button to add the keyboard shortcut in the Add Shortcut field to the currently selected function.

Assigned field
The Assigned field contains a list of keyboard shortcuts assigned to the currently selected function.
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- button
Use the - button to remove the currently selected keyboard shortcut (in the Assigned field) from the list of shortcuts assigned to a function.

Reset All button
Use the Reset All button to reset all keyboard shortcuts to their factory defaults.

Import button
Use the Import button to import a keyboard shortcuts file. Refer to Importing Preferences, Including Keyboard Shortcuts for more information.

Export button
Use the Export button to export current keyboard shortcuts as a keyboard shortcuts file. Refer to Exporting Preferences, Including Keyboard Shortcuts for more
information.

Template
Use the Template preferences panel to designate a SketchUp file that you would want to use as a template for all of your subsequent models.

Default Drawing Template drop-down list
The Default Drawing DrawingTemplateTemplate drop-down list contains a list of all of the templates available in SketchUp.

Browse button
Use the Browse button to browse for a template. The Browse for Template dialog box is displayed. Locate and select a template using this dialog box.

Workspace
Use the Workspace preferences panel to make changes to your SketchUp workspace.

Tool Palette
SketchUp has two differently sized toolbars. The large tool buttons are easier for some users to see and use (they provide larger areas to click with your mouse)
and are easier to use with a pen and tablet. Smaller buttons save screen space, allowing a larger drawing area.

Use large tool buttons: Use the Use large tool buttons checkbox to toggle between large and small tool buttons.

Reset Workspace Button
Use the Reset Workspace button to reset SketchUp to its default configuration (all dialog boxes are closed).

Automatically loading a template

You can load a template SketchUp file manually using File > Open every time you want to create a model. Or, you can identify a file as a template using the
Template section of the Preferences dialog box to load the template automatically when you run SketchUp:

1. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The Preferences dialog box is displayed.

2. Click on the Templates item on the left-hand side of the Preferences dialog box. The Template panel is displayed.

3. Select a drawing template from the drop-down list to select one of the SketchUp default templates. Or, optionally, click the Browse button to find a
template that you have created.

4. Click the OK button to close the Preferences dialog box. The selected template is sued after you close and restart SketchUp.
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Entity Info Dialog Box

Entity info

Select an entity and either context-click on the entity or select Window > Entity Info to view and change the entities attributes. All of the Entity Info dialog box
fields for all entities in SketchUp follow.

Note: Some of these items are only visible when the details arrow in the upper right-hand corner is pointing up.
Align to screen

The Align to screen button allows Dimension entities to rotate as you orbit the model (always face the camera).
Align to dimension

The Align to dimension button to allows dimension text to align vertically to the dimension line instead of the camera. As you orbit your model, the text will
remain vertically aligned with the dimension lines.

This Entity Info dialog box item is available for the Dimension entity.

Above
The Above menu item places the dimension text above the dimension line.

Centered
The Centered menu item places the dimension text in the center of the dimension line.

Outside
The Outside menu places the dimension text on the opposite side of the dimension line from the dimensioned points.

Text position
The Text position options allow dimension text to horizontally to the dimension line.
This Entity Info dialog box item is available for the Dimension entity.

Outside start
The Outside start menu item places the dimension text at the start of the dimension line.

Centered
The Outside Start menu item places the dimension text at the center of the dimension line.

Outside end
The Outside end menu item places the dimension text at the end of the dimension line.

Endpoints

Select the end point style for all of your end points from the 'Endpoints' drop-down list. These styles are None, Slash, Dot, Closed and Open.

This Entity Info dialog box item is available for the Dimension entity.

Area

The Area field displays the area of the selected entity. Use the Area > Selection context menu item to calculate the area of multiple selected entities.
This dialog box item is available for the Face entity.

Arrow

The Arrow drop-down list contains a list of arrowheads permitted for the selected Text entity.

This Entity Info dialog box item is available for the Text and Dimension entities.

Cast shadows

The Cast Shadows menu item allows the entity to cast a shadow.

This Entity Info dialog box item is available for the Arc, Circle, Component, Curve, Face, Group, Image, Line, Polygon, and Surface entities.
Definition Name

The Definition Name field can contain the name of the component definition.

This Entity Info dialog box item is available for the Component entity.

Font

The Font button is used to select a new font for the selected Text or Dimension entity.

This Entity Info dialog box item is available for the Text and Dimension entities.

Hidden

The Hidden check box is used to hide or unhide the entity. Hidden entities are displayed in a ghosted pattern, allowing you to select them, if View > Show Hidden
Geometry is enabled.

This Entity Info dialog box item is available for all entities.
Layer
The Layer field displays the layer of the currently selected entity. Select a new layer to move the entity to that layer.

This Entity Info dialog box item is available for the all entities.
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Leader

The Leader drop-down list contains a list of leader-types permitted for the selected Text entity.
This Entity Info dialog box item is available for the Text entity.

Length

The Length field displays the length of the currently selected entity.

This Entity Info dialog box item is available for the Arc, Circle, Curve, Line, and Polygon entities.
Locked

The Locked check box is used to lock the component so that it cannot be moved or edited. However, additional copies of the component can be dragged into the
work area from the Components Browser.

Deselect the Locked check box to unlock the component so it can be edited.
This Entity Info dialog box item is available for the Component and Group entities.
Material

The Material swatch displays the material used on the currently selected entity. The default material for an entity is represented by a gray/blue box. There are
two default material swatches for faces and surfaces because faces and surfaces have both a front and a back side. The left swatch represents the front-side
material. The right swatch represents the back-side material.

This Entity Info dialog box item is available for the 3D Polyline, Arc, Circle, Component, Curve, Dimension, Face, Group, Line, Polygon, Surface, and Text entities.
Name

The Name displays the name of the currently selected component instance or group. Image entities also have an un-editable name field in the dialog box.
This Entity Info dialog box item is available for the Component, Group, and Image entities.

Radius

This Radius field displays the radius of the selected entity. Type a new value in this field to change the radius of the entity.

This Entity Info dialog box item is available for the Arc, Circle, and Polygon entities.

Receive Shadows

The Receive Shadows menu item allows the component to receive a shadows cast by other entities.

This Entity Info dialog box item is available for the Component, Face, Group, Image, and Surface entities.

Segments

The Segments field displays the number of segments in the selected entity. Type a new value in this field to change the number of segments for the entity.
Note: Arc segmentation can only be changed when the Arc entity is part of 2 dimensional geometry (not part of a curved surface).

This Entity Info dialog box item is available for the Arc, Circle, Curve, and Polygon entities

Size in pixels (Microsoft Windows) or Size (Mac OS X)

The Size in pixels (Microsoft Windows) or Size (Mac OS X) field displays the pixel dimensions of the currently selected image.

This Entity Info dialog box item is available for the Image entity.

Soft

The Soft option is used to render the edge as a soft edge.

This Entity Info dialog box item is available for the Line entity.

Smooth

The Smooth option is used to render the faces connected to the edge with a varying tonal value.

This Entity Info dialog box item is available for the Line entity.

Text

The Text field contains the text string for the selected Text entity. Click in this field to modify the text. Click in the drawing area to update your changes.
This Entity Info dialog box item is available for the Text entity and Dimension entities.

Width and Height

The Width and Height fields display the dimensions of the currently selected image. Type in a new width or height to proportionally rescale the Image entity. Or,
click on the lock icon to rescale the Image entity's width and height independently (non-proportional scale).

This Entity Info dialog box item is available for the Image entity.

Entity info dialog box

The Entity Info dialog box displays information about selected entities, and allows you to view and change their properties. This dialog box is context-sensitive,
and will contain different options as you select different entities in your model. Activate the Entity Info dialog box from either the Window menu or through a
context menu. The following image shows the Entity Info dialog box on Microsoft Windows:
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Layers Manager

Layers Manager

The Layers Manager is used to apply and manage layers in your model. Activate the Layers Manager from the Window menu. The following image shows the
Layers Manager on Microsoft Windows:
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The Layers Manager displays all the layers and their associated visibility in the model. Every model has one layer, called Layer0, which will be visible the first time
you activate the Layers dialog box.

Note: You cannot delete Layer0. Entities that reside on LayerO always inherit their visibility from the layer of the components/groups that contain them. This
makes layer 0 work like the default drawing layer. If you use any other layer as a drawing layer, all the entities that were created on that layer will become
invisible when you hide that layer. This is not the case when hiding layer 0. Any entities that are on layer 0, but inside a group or component that is on another
layer, will remain visible when you hide layer 0.

Remember, layers in SketchUp do not work exactly like layers in 2 dimensional programs. Namely, entities drawn with one layer appear in all layers in SketchUp.

Layers Manager options

Add

Use the Add button to create additional layers. Enter the layer name (or press Enter on Microsoft Windows or Return on Mac OS X to accept the default name).
Each new layer has a different color to help you distinguish layers.

Delete

Select a layer and use the Delete button to delete a layer. You will be prompted to move entities on the deleted layer to another layer (the default or current layer)
if there are entities unique to that layer.

Name

The Name column lists all the layers, by name, in the drawing. The current layer has a check next to its name. Check the box next to a layer name to make it the
current layer. Click on the name of a layer to edit the name of the layer.

Use the Name column header to sort the layer alphabetically. Click on the Name column again will reverse the order. You can select a multiple layers by dragging.
You can also press the Ctrl key and click on layer names to selectively pick layers or press the Shift key and click to select a series of contiguous layers.

Visible

Use Visible checkbox to toggle the visibility of a layer. Click on the Visible column header to sort layers by visibility. Click again on the Visible column header to
reverse the order. A hidden layer becomes automatically visible when you select the layer.

Color

The color column displays a color associated with each layer. Click on a layer and select a new color to change the color of the layer. Click on the Color column
header to sort layers by color. Click again on the Color column heading to reverse the order.

Details menu

Click on the right arrow next to the Delete button to open the details pop-up menu. This menu allows you to perform additional Layers Manager-related
functions.

Select All

Use the Select All menu item to select all layers in the list of layers.

Purge

Use the Purge menu item to delete all unused layers (layers without any geometry).
Color by Layer

Use the Color by Layer menu item to apply materials to geometry on a per layer basis using the color associated with the layer. Ensure shaded or shaded with
Textures display is turned on to view materials.

Does SketchUp support layers?

First things first: by default, a SketchUp model has one layer, Layer O (zero), which is the base layer. You can't delete or rename Layer 0, and you should always
draw your individual entities on Layer 0 and leave them there.

The main difference you'll notice is that entities associated with different layers in SketchUp still intersect each other. For this reason, it's almost always best to
draw all your individual entities on Layer 0 and leave them there. Then, if you want to use layers to organize your model, you can turn individual entities into
groups or components, and then associate different layers with those groups or components. To add additional layers:

1. Open the "Window" menu.
2. Click "Layers."
3. In the "Layers" dialog box, click "+" button
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5

6.

. Optionally, you can rename a layer (other than Layer 0).
. Optionally, you can delete a layer (other than Layer 0). If the layer you are deleting isn't empty, a message asks if you want to move its contents to another

layer or delete the contents.
Optionally, you can make another layer active by clicking its option button. When you draw individual entities, they are always drawn on the active layer, so

you should typically have Layer O selected, unless you need to hide it, in which case, you need to select a different layer.

Important note: Groups and components are also entities, and, just like with individual entities, you control their layer properties in the Entity Info
dialog box. To try to keep things clear, this article refers to individual entities (things like edges and faces) versus groups and components. To try to
make things even clearer, since groups and components behave the same with respect to layers, only groups are mentioned from now on in this
article. Finally, the idea of drawing individual entities on Layer 0 and leaving them there is so important that this article doesn't even address the
option of associating other layers with individual entities. If you want to experiment with that, you'll need to take along your own search and rescue

team!

Notice the way this is phrased: you associate layers with groups, rather than moving groups to layers. This is because a layer is actually a property of a group,
and you associate a layer with a group by selecting it in the group's Entity Info dialog box.

Once you have associated layers with groups in a model, you can use the layers to control the visibility of those groups. In this way you can easily turn off or on
the visibility of various parts of your model, for example, you could make all of your wall and roof entities different groups, associate layers with those groups,

and then hide those layers so as to display just the floor plan in the model.

To control the visibility of layers:

1.
2.
3.

In SketchUp open the "Window" menu.

Click "Layers."
Click the check box in the "Visible" column: when it has a check mark, the layer is visible; when it is clear, the layer is hidden.

Note: The active layer is indicated by its option button being selected. You can't hide the active layer, but you can select another layer, and then hide the
original one.

Additional notes about layers:

.

.

Be happy! Always draw your entities on Layer 0 and leave them there. (Did we say that already?)
Controlling visibility versus isolating geometry. It's important to note again that layers control only visibility. You can't isolate geometry (make it
independent of other geometry) by associating different layers with it; you can only control whether it is visible or hidden by making the layer that is
associated with it visible or hidden. The way to make selected SketchUp geometry independent is to make it into a group or component.
Keeping track of layers with color. When you are associating layers with groups, you can make it easier to keep track of the layers by turning on layer
colors:

1. Open the "Window" menu.

2. Click "Layers."

3. In the Layers dialog box, open the options menu, and then select "Color by Layer."

4. If you are following the advice to draw all individual entities on Layer 0, and then leave them there, all individual entities will have the color of Layer

0. All groups or components will have the color of the layer they are on.

5. If you select the Paint tool, Color by Layer is automatically turned off.
Entities within groups. If you draw some entities on Layer 0, make them a group, and then associate another layer with the group, the entities within the

group remain associated with the original layer. However, the group controls the visibility of the entities. If you hide the layer that is associated with a
group, all of the entities within the group are hidden. Also, if you use Color by Layer, the color is controlled by the layer that is associated with a group or
component.

Color by Layer with groups that are nested within other groups. If you have Layer 0 associated with a group, and then nest that group inside another
group, the Layer 0 group will inherit the layer color of the topmost group. If you have a layer other than 0 associated with a group, then that group inherits
and keeps that layer's color, even if you nest it with another group and associate a different layer with the topmost group.
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Shadows Dialog Box

Details arrow

Click on the arrow in the upper-right portion of the Scene Manager dialog box to show or hide additional Entity Info details.

Shadows settings dialog box

The Shadows dialog box is used to control SketchUp's Shadows feature, including display, time and date, and site location and orientation. You can also use the
Shadows toolbar control to control shadows. Activate the Shadow Settings dialog box from the Window menu. The following image contains a screen shot of the
Shadows Settings dialog box on Microsoft Windows:
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Note: Ensure you have set the proper location for your model set through the Location panel of the Model Info dialog box for accurate shadow casting.
Note: Daylight savings time is not factored into shadow calculations.

Shadow options

SketchUp contains a variety Shadow setting options allowing you to manipulate the use of shadows within your model.

Display shadows button

Use the Display shadows button (‘) to toggle between displaying and not displaying shadows within your model.
Time Zone drop-down list

Select a time zone form the Time Zone drop-down list to identify your location for accurate shadows.

Time slider

Use Time slider to adjust the time of day used by SketchUp to determine the location of the sun for shadow casting. The slider adjusts the time from sunrise to
sunset, with 12:00 noon in the middle of the slider. Type a time into the time text field to set a precise time.

Date slider

Use the Date slider to adjust the day of the year used by SketchUp to determine the location of the sun for shadow casting. The slider adjusts the date from
January 1st to December 31st. Type a date into the date text field to set a precise day. You can specify the date in numerical form (11/8).

Light slider

Use the Light slider to control the intensity of the light in the model. (it lightens or darkens light). This option effectively lightens and darkens illuminated
surfaces.

Dark slider

Use the Dark slider to control the intensity of light in the model. This option (it lightens or darkens shadows). This option effectively lightens and darkens the
areas under shade and shadows.

Use sun for shading check box
Click the Use sun for shading check box to use the sun to shade parts of the model while not actually casting shows.
On faces checkbox

Use the On faces checkbox to enable casting of Face shadows. This feature makes intensive use of your 3D graphics hardware and can cause performance
degradation.

On Ground checkbox
Use the On ground checkbox to enable the casting of shadows on the ground plane (the red/green plane).
From edges checkbox

Use the From edges checkbox to enable the casting of shadows from edges that are not associated with a face.

Enabling shadows

The SketchUp Shadows feature is designed to give you a general idea of how the sun and shadows relate to your model during the course of a day and
throughout the year. The calculations are based on the location (latitude and longitude, directional orientation of the model, and an associated time zone). The
time is not adjusted for Daylight Saving Time. You can enable shadows based on location data captured from the Add Location dialog box or by entering data
directly into the Geo-location panel of the Model Info dialog box.

Enabling shadows using location data from the Add Location dialog box

Use the Add Location dialog box to set location and directional orientation for models that represent real-world structures. To enable shadows using the Add
Location dialog box:

1. Add the location where you want your 3D model to appear. Refer to Adding a Location for further information. SketchUp is calibrated to the same latitude,
longitude, and time zone as the location you choose in the Add Location dialog box. These coordinates appear in SketchUp's Geo-location panel of the

210



Model Info dialog box (Model Info > Geo-location).

Note: The time zone in SketchUp is set based on the coordinates of the image. Because some time zones lines zigzag rather dramatically, the time zone for
some locations may inaccurate by up to one hour (sometimes longer).

2. Select Window > Shadows. The Shadows Settings dialog box appears.
3. Click on 'display shadows' to display shadows for your model.
4. Manipulate shadows using the controls in the Shadows Settings dialog box.

Enabling shadows using manually input data

Use the Location section of the Model Info dialog box to manually input location information. To enable shadows using manual input data:

1. Select Window > Model Info. The Model Info dialog box appears.
2. Select Geo-location on the left-hand side of the Model Info dialog box. The Geo-location panel appears.
3. Click on the Set Manual Location button.
4. Enter a country in the 'Country' field.
5. Enter a location (city) in the 'Location' field.
6. Enter the latitude in the 'Latitude’ field.
7. Enter the longitude in the 'Longitude’ field.
8. Click the OK button.
9. Select Window > Shadows. The Shadows Settings dialog box appears.
10. Click on 'display shadows' to display shadows for your model.
11. Manipulate shadows using the controls in the Shadows Settings dialog box.

Note: You cannot change the color of shadows.
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Fog Dialog Box

Fog options

There are a few options in the Fog dialog box for configuring fog.

Display Fog

Selecting the Display Fog checkbox displays fog in the drawing area. Deselecting the Display Fog checkbox hides fog.
Fog sliders

The left-most fog slider determines where you want the fog to start relative to the camera (your view). Fog can begin right in front of the camera which is zero on
the scale or further away from the camera. Move the left-most slider to the right to start fog somewhere beyond the camera.

The right-most slider determines where you want the fog to be at 100% strength (known as zero visibility). Move the right-most slider to the left to establish 100
percent strength closer to the camera (your view). Move the right-most slider all the way to the left to have zero visibility right in front of the camera and
extending out to infinity (you wont actually be able to see your model at all and at any distance).

Use Background Color

Selecting the Use background color checkbox uses the currently configured background color as the fog color. Refer to the Background Panel section of the Styles
Browser topic for further information on setting the background color.

Deselecting the Use background color and clicking on the color swatch selects a different color to be used as the fog color.

Note: Use the OpenGL panel in the Application Preferences dialog box to set hardware acceleration before using fog.

Fog dialog box

Fog is primarily used as a special effect during presentations. Use the Fog menu item within the Window menu to display the Fog dialog box. The following image
shows a screenshot of the Fog dialog box on Microsoft Windows:
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The following image shows a screenshot of the Fog dialog box on Mac OS X:
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Setting fog
Use the Fog dialog box to apply Fog-like effects to your model. To apply Fog:

1. Select Window > Fog. The Fog dialog box appears.
2. Select the 'Enable Fog' checkbox. Fog might appear around your model (depending on your view of the model and the settings of the fog sliders).
3. Adjust the sliders.

Note: Fog sliders will move automatically when you change your point of view, such as when you zoom in or zoom out. As with real fog, the geometry will
become more clear as you zoom closer to it, and less clear as you move away.
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Model settings and managers
Model Info dialog box

The Model Info dialog box allows you to configure a number of different settings specific to your current SketchUp model. Activate the Model Info dialog box
from the Window menu.

The Model Info dialog box contains several panels, including the Dimensions panel for setting global dimensions and the Units panel for setting units to be used
in your model.

Animation

The Animation panel allows you to set properties for animations. The following image shows the Animation panel of the Model Info dialog box on Microsoft
Windows:
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The following image shows the Animation panel of the Model Info dialog box on Mac OS X:
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Scene Transitions
The Scene Transitions section of the Animation panel allows you to determine the amount of time it takes to transition from one scene in the animation to
another scene.

Enable scene transitions:Use the enable scene transitions checkbox to enable scene transitions.
Seconds: Enter the number of seconds that will transpire before the next transition changes to another scene.

Scene Delay
The Scene Delay section of the Animation panel allows you to determine the amount of time an animation will spend on each scene before transition to another
scene.

Seconds: Enter the number of seconds that should transpire before the transition begins to another scene.
Components

The Components panel allows you to modify the visual appearance of your model while editing groups and components. SketchUp allows you to fade or hide
other similar components or fade or hide the rest of the model to make it easier to concentrate on modifications to the edited component. The following image
shows the Components panel of the Model Info dialog box on Microsoft Windows:
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The following image shows the Components panel of the Model Info dialog box on Mac OS X:
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Component/Group Editing
The Component/Group Editing portion of the Components panel allows you to define how geometry outside a component appears when editing a component.

Fade similar components:Sliding the Fade similar components slider controls the degree of fading of other visible instances of the component you are editing.
Use the Hide checkbox to toggle the display of components similar to the one you are editing.

Fade rest of model:Sliding the Fade rest of model slider controls the fading of geometry unrelated to the group or component you are editing. Use tggfé-ﬁde



check box to toggle the display of the rest of the model while editing a component or group.

Show component axes:Components contain their own axes. Use the Show component axes checkbox to display component axes.

Credits

The Credits panel allows you to view contributors toward the current model. This panel also allows the current users to claim credit toward the current model.

Model Authors
The Model Authors portion of the Credits panel displays the currently logged in user. User's must log in using their Google Account (GAIA account) to claim credit
toward a model.

Claim Credit button: Use the Claim Credit button to claim credit on the currently selected model.

Component Authors
The Component Authors portion of the Credits panel displays the list of contributors toward the current model.

Dimensions

The Dimensions panel allows you to change the appearance and behavior of Dimension entities in your model. The following image shows the Dimensions panel
of the Model Info dialog box on Microsoft Windows:
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The following image shows the Dimensions panel of the Model Info dialog box on Mac OS X:
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Text
The Text portion of the Dimensions panel allows you to select the font used by Dimension entities in the drawing area.

Fonts: Use the Fonts button to select the font to be used for all Dimension entities in SketchUp. Use the font color button to choose a font color for Dimension
entities.

Leader Lines
The Leader Lines portion of the Dimensions panel allows you to choose an end point style for your leader lines.

Endpoints: Select the end point style for all of your end points from the Endpoints drop-down list. These styles are None, Slash, Dot, Closed Arrow and Open
Arrow.
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Dimension

The Dimension portion of the Dimensions panel contains default display options for Dimension entities.
Align to screen: Use the Align to screen button to allow Dimension entities to rotate as you orbit the model (always face the camera).

Align to dimension line: Use the Align to dimension line button to allow Dimension entities to align to the dimension line instead of the camera. As you orbit
your model, the text will remain aligned with the dimension lines.

Select all dimensions:Use the Select all dimensions button to select all dimension entities in the model.
Update selected dimensions:Use Update selected dimensions to update the currently selected entities with the currently selected dimension settings.

Expert dimension settings
Use the Expert dimension settings button to display the Expert Dimension Settings dialog box.

Hide when foreshortened:Use the Hide when foreshortened checkbox to allow Dimension entities to hide when they become foreshortened. Slide the slider to
set the threshold angle that will cause Dimension entities to become hidden.

Hide when too small: As your view moves further away from your model, dimensions appear smaller and text remains the same size. This behavior can result in
an unclear Dimension text. Use the Hide when too small checkbox to automatically hide dimensions when they are hard to read. Slide the slider to s&%tﬁle size



that will cause Dimension entities to be hidden.

Highlight Non-Associated Dimensions:Use the Highlight non-associated dimensions checkbox to assign a color to dimensions that are not associated with
entities in your model. Non-associated dimensions are usually the result of erasing an entity that was used to calculate a dimension, such as an edge.

File

The File panel allows you to configure settings related to your SketchUp model's file, including the location of the file (on your file system), size, date of last
modification, and version of SketchUp used for last modification. The following image shows the Files panel of the Model Info dialog box on Microsoft Windows:
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The following image shows the Files panel of the Model Info dialog box on Mac OS X:
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General
The General portion of the File panel contains default file options for the current model. The Description field is the only field that is editable within the General
section.

Location: The Location field contains the location of the model's file on the file system (if it has been saved).
Version: The Version field contains the version of SketchUp last used to modify the model.

Size: The Size field contains the Size, in kilobytes, of the current SketchUp model's file.

Description: Click in the Description field to enter a description for your model.

Redefine thumbnail on Save:Use the Redefine thumbnail on save checkbox to save the current view of the model as the thumbnail representation of the model.
This thumbnail is shown when browsing through models when locating a file to open (Microsoft Windows).

Alignment
The Alignment portion of the File panel allow you to determine the alignment of the model when loaded and used as a component.

Note: These options are also displayed when you create a component from a selection set within SketchUp. However, the options presented during component
creation pertain to components that are already within a model while the options in the Model Info dialog box pertain to a model file that can be loaded as a
component in another model.

Glue to:Select a menu item from the Glue to menu to identify the surfaces where your file can be placed. For example, a model of a door would only be glued to
surfaces in the horizontal planes.

Cut opening:Use the Cut opening checkbox to cause your model to able to penetrate a face, thus creating an opening, when used as a component. The model
will cut the face to which it is attached at the model's perimeter.

Always face camera:Use the Always face camera checkbox to treat the model as though it were a 2D component by forcing the model to always face forward
when loaded as a component. This option increases performance by eliminating the need to render the component as a 3D form.

Shadows face sun:This option is only available when the Always face camera option is enabled. Selecting the Shadows face sun checkbox causes shadows to be
cast from the components' current position as though the components were facing the sun. The shadow shape does not change as the component rotates to face
the camera. This option works best with components that have narrow bases (such as trees). This option does not work well with components that have wide
bases (such as people in mid stride).

Note: Ensure the component's axis is positioned at the bottom center of the component for best results.
Deselect this option to cause the shadow to be cast from the component's current position. The size of the shadow changes based on view point.
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Models intended for Google Earth contain geographical information identifying their location in the world. The Geo-location panel allows you to view and specify
a location for your model.

The following image shows the Geo-location panel of the Model Info dialog box on Microsoft Windows:
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@ This model is accurately geo-ocated

Country: USA
Location: Boulder (CO)
Latitude: 40.0455N
Longitude: 105.2809W

Clear Location | I Add More Imagery... |

Advanced Settings

Set Manual Location...

The following image shows the Geo-location panel of the Model Info dialog box on Mac OS X:
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Geographic Location
The Geographic Location portion of the Location panel allows you to assign a geographic location to your model.

Add Location button: Use the Add Location button to display the Add Location dialog box for selecting a location for your model.

Clear Location button: Use the Clear Location button to remove the location from your model. This option is only available for a model that has geographical
information.

Add More Imagery button: Use the Add More Imagery button to display the Add Location dialog box allowing you to choose additionaly imagery adjacent to
your location to add to the model. Refer to the Adding a Location for further information.

Advanced Settings

The Advanced Settings panel allows you set a manual location for your model.
Rendering

The Rendering panel allows you to enable anti-aliased textures.

Use Anti-Aliased Textures
Use the Use Anti-Aliased Textures checkbox to attempt to improve performance and quality of textures.

Statistics
The Statistics panel allows you to troubleshoot performance issues in SketchUp. This panel displays information about the type and number of drawing elements

in your model and allows you to perform verifications on your model. The following image shows the Statistics panel of the Model Info dialog box on Microsoft
Windows:
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The following image shows the Statistics panel of the Model Info dialog box on Mac OS X:
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Entire model and Only components

The Entire model and Only components options in the drop-down list box allow you to toggle between displaying statistics for your entire model and displaying
statistics related only to components. The Components option is useful for generating a tally of the number of certain components used in your model (such as
the number of a particular part in an assembly).

Show nested components
Use the Show nested components checkbox to include individual elements within placed components in the statistics totals.

Purge Unused
Use the Purge Unused button to remove any unused components, materials, image objects, layers, and other extraneous information from your file.

Fix Problems
Use the Fix Problems button to find minor issues with your SketchUp model due to the infinite flexibility that SketchUp provides when designing in 3D. Use the
Fix Problems button to scan your model, and report and fix any problems. This option checks for several cases, including:

Faces bounded by properly connected edges.
Vertices of faces are on the same plane.

Edges bounding a face are in the same component.
Faces do not have zero area size.

Start and end points of an edge are not the same.

Note: Problem checking is also performed automatically (if turned on within the General panel of the Application Preferences dialog box) when a file is loaded,
manually saved, or automatically saved (using the SketchUp auto-save feature). Refer to the Save menu item in the File menu or the auto-save feature in the
General panel of the Application Preferences dialog box for further information.

Text

The Text panel allows you to change the appearance and behavior of Text entities in your model. The following image shows the Text panel of the Model Info
dialog box on Microsoft Windows:
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The following image shows the Text panel of the Model Info dialog box on Mac OS X:
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Screen Text
Screen text is text that is not attached, using a leader line and arrow, to a specific piece of geometry. The Screen Text portion of the Text panel allows you to
select the font used by screen text in the drawing area.

Fonts: Use the Fonts button to define the font to be used for all screen text in SketchUp. The Font dialog box, containing the font, font style, and size for your
dimensions font, is invoked.

Text color swatch:Click on the text color swatch to select the default display color for any unpainted screen text (those painted with the default material).
Select all screen text:Use the Select all screen text to select all screen text in the drawing area.

Leader Text
Leader text is text that is attached, using a leader line and arrow, to a specific piece of geometry. The Leader Text portion of the Text panel allows you to select
the font used by leader text in the drawing area.

Fonts:Use the Fonts button to define the font to be used for all leader text in SketchUp. The Font dialog box, containing the font, font style, and size for your
dimensions font, is invoked.

Leader text color swatch:Click on the leader text color swatch to select the default display color for any unpainted leader text (those painted with the default
material).

Select all leader text: Use the Select all leader text to select leader text in the drawing area.

Leader Lines
The Leader Lines options allow you to identify the type of leader line used with Text. Text might or might not have leader lines.

End Point:Use the End Point drop-down menu to select the end point type for the leader line. Choose between None, Dot, Closed Arrow, and Open Arrow.

Leader:Use the Leader drop-down menu to select between View Based and Pushpin leader types. A View Based leader will always retain its 2D screen orientation.
A Pushpin leader is aligned in 3D space, and rotates with your model as you change your view.

Text

-

Update selected text:Use the Update selected text button to apply the current settings to any selected Text entities.
Units
The Units panel is allows you to set defaults for linear and angular unit measurements.

Note: You can override the default units using the Measurements toolbar to work in different units simultaneously.

The following image shows the Units panel of the Model Info dialog box on Microsoft Windows:
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The following image shows the Units panel of the Model Info dialog box on Mac OS X:
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Length Units
The Length Units section of the Units panel allows you to set the default units for your model.

Format:Use the Format drop-down menu to set the type of units displayed for measurements, dimensions, and within the Measurements toolbar. Architectural
displays as feet and inches. Decimal displays decimal units, including inches, feet, millimeters, centimeters, and meters. Engineering displays feet and decimal
units of feet, and fractional units display only fractional inches.

Note: Fractional units are primarily used by wood workers in the United States.

Precision:Use the Precision drop-down menu to set the precision for displaying units. Architectural unit precision can be set from 1" to 1/64". Decin’éqllémit



precision can be set in numbers of decimal places beyond zero for any of these units. SketchUp users working in Metric should use the decimal unit setting.
Engineering unit precision can be set in decimal places beyond zero.

Enable length snapping: Use the Enable length snapping checkbox to snap lines and other entities to the specified sized increments. Length snaps can be
overridden by entering exact values into the Measurements toolbar. Type the snap length in the text field to have SketchUp snap to specific increments when
drawing.

Note: SketchUp does not have a grid snap option similar to other CAD applications.

Display units format: Use the Display units format checkbox to display unit markers, such as the double quotes (") for inches. This option is only available when
the format is set to Decimal.

Force Display of 0":Use the Force display of 0" checkbox to display 0" in architectural units when there are no inches in the measurement. Ordinarily, inches
would be suppressed in this case. For example, a measurement of three feet in length would read as 3'0" with this setting enabled.

Angle Units
The Angle Units portion of the Units panel allow you to define how units are displayed for angled measurements

Precision:Use the Precision drop-down list to set the use of decimal degree units to either a level of precision of 0 (no decimal places) or 0.0 (one decimal place)
for greater accuracy.

Enable angle snapping:Use the Enable angle snapping checkbox to enable snapping to the specified increment while using the Protractor or Rotate tool. Move
your cursor inside the protractor to snap to the specified increment while using these tools. You will see tick marks corresponding to your snap angle on the
Protractor.

Snap angle:Use the Snap angle drop-down list to choose the snap increment for angular measurements and rotations.

Instructor

The Instructor dialog box displays information related to the currently selected tool. Click on a tool in the toolbar or menu to view information about that tool in
the instructor. Click on links in the instructor to navigate to sections in the online SketchUp User's Guide.

Instructor E]

h ~
-4
Eraser Tool
Tool Operation
Modifier Keys
Advanced Operations
v
< >

Choose Color dialog box (Microsoft Windows)

The Choose Color dialog box contains a variety of different color controls that combine to give you a versatile mechanism for experimenting with color in your
SketchUp models.

You can activate the Choose Color dialog box by clicking on the Front color and Back color buttons in the Edit tab of the Styles Browser.

Color Wheel v

%] B

Cancel

Color picker menu

SketchUp allows you to choose between four color pickers: Color Wheel, HLS, HSB, and RGB. Click on the color picker that you want to use in the drop-down
menu within the Choose Color dialog box.
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Active Color Well

The Active Color Well, which is below the Color Picker menu, contains the current color selection.

The contents of the Active Color Well are maintained as you switch between pickers, allowing you to use different pickers to create your colors.
Color picker types

SketchUp contains four color Picker types, used to select materials that do not have texture (just color).

Note: Ensure that the Shaded or Shaded with Textures display style is selected to see the colors that you have applied to entities.

Color wheel
The color wheel arranges color hue radially around the wheel, with the highest saturation at the outer edge of the wheel. Sliding the value slider, to the right of
the wheel, up or down changes the brightness of the color.

To use the Color Wheel, select the color you want by clicking your mouse over that color in the wheel. You can also click and drag the cursor around the Color
Wheel to quickly browse through many different colors which will dynamically appear in the Active Color Well.

HSB (hue, saturation & brightness) and HLS (Hue, Light, and Saturation)
The HSB and HLS color pickers allow you to pick colors from the HSB (hue saturation and brightness) color range. HSB often gives you a more intuitive color
model for selecting desaturated colors.

Adjust the sliders for hue, saturation and brightness until you see the color you want in the active color well.

Sometimes it is easier to mix desaturated colors using the HSB or HLS Color Picker in conjunction with one of the other color pickers. Switch to another color
picker to make your rough color selection, then switch back to the HSB or HLS color picker to fine tune your color.

RGB (red, green and blue)

The RGB Color Picker allows you to select colors from the RGB (red, green and blue) color range. RGB colors are traditionally used when modeling color on a
computer screen and represent the closest approximation of the actual range of colors recognizable by the human eye. RGB has a wide color gamut and is one of
the most effective color spaces to use in SketchUp.

Slide the sliders left and right for each of the component colors (red, green and blue) to create the color that you want to use.

You can type in exact numerical values for red, green or blue in the value boxes to the right of the sliders if you want to precisely match a color that you have
specified elsewhere.

Match Photo dialog box

The Match Photo dialog box controls are used to help you create accurate 3D models from photos and to accurately place models in a photo's context. This
dialog box is only relevant during matching. Activate the Match Photo dialog box from the Window menu. The following image contains a screen shot of the
Match Photo dialog box on Microsoft Windows:
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Done

New Matched Photo button

Click on the New Matched Photo button to start a new matching.

Edit Matched Photo button

Click on the Edit Matched Photo button to reenter the matching mode. This button is only active in a Sketch-Over-Image mode.

Model checkbox

Check the Model checkbox to display the model. Uncheck the Model checkbox to hide the model. This option is also available in sketch-over-image mode.
Project textures from photo button

Click on the Project textures from photo button to automatically project the photo as a texture onto your model.

Grid On/Auto radio buttons

Check the On radio button to continuously display the axes grid. Check the Auto radio button to only show the grid when manipulating one of the matching
controls.

Style buttons

Click on the Style buttons to change the style of the grid. Grid styles are used to set the grid to best complement a specific type of photo. The left-most style is
used for photos usually taken indoors where walls, ceiling, and floor of a room meet at a corner (the origin is usually at the bottom corner where the walls,
ceiling, and floor meet). The middle style is used for photos taken from a vantage point where you are looking down on the building or structure (the origin
would be at the top corner of the building where roof and walls meet). Finally, the right-most style is used for photos taken from a vantage point where you are
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standing on the ground (the origin would be the bottom corner where the walls and ground meet).

Planes buttons

Click on the Planes buttons to toggle the display of grid lines on a particular plane. The Red/Green button toggles grid lines in the red and green planes. The Red
and Blue button toggles grid lines in the red and blue planes. Finally, the Green/Blue button toggles grid lines in the green and blue planes.

Spacing field

The spacing field is used to set the scale of your model before you start sketching over the image. Enter a value in the spacing text-entry box to change the size
of grid spacing to represent some multiple of the overall structure size. Then, drag the axes lines to line grid squares up with your image.
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Soften Edges Dialog Box
Soften Edges dialog box

SketchUp's edges can be softened and smoothed to achieve a real-world appearance. Edges are automatically hidden when softened. Softened edges can also be
smoothed rendering the adjoining faces with a smooth tonal gradient. The following series of images contains a column (lower part of each image) that is first
softened (middle column) and then smoothed (right-most column).

Note: Softened edges are hidden automatically (but still exist in your model). Edges that are currently not visible will be displayed, along with any explicitly
hidden geometry, when you enable the Hidden Geometry menu item on the View menu.
Triple-click on geometry to ensure you have hidden and unhidden geometry selected before performing a soften or smooth operation.

The Soften Edges dialog box allows you to automatically apply or remove softness and smoothing effects to the edges in your model. Activate the Soften Edges
dialog box from the Window menu. The following image contains a screen shot of the Soften/Smooth Edge dialog box on Microsoft Windows:
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There are a several components to achieving a desired result using soften and smoothing effects. Namely, detailed geometry require additional facets (such as a
column having many small sides) to achieve a clean soften or smooth effect. However, additional detail can affect the computer's performance. Conversely,
adding detail to portions of a model that will be seen at a distance is likely a waste of the computer's resources. A good strategy for creating useful models is to
try to use the least amount of geometry in conjunction with soften or smoothing effect to achieve the desired result (whether it be a detailed close-up or a
panoramic).

Soften Edges options

SketchUp contains a few Soften Edges options allowing you to manipulate the use of softening within your model.

Note: Edges that are shared by three or more faces cannot be softened. The following image shows an edge shared by three faces.

Angle between normals slider

Use Angle between normals slider to set the maximum size of all angles that will be smoothed or softened. The higher the setting, the more angles you are likely
to smooth or soften with a smooth or soften command. Consequently, the higher the setting the more performance might degrade.

Smooth normals checkbox

Selecting the Smooth normals checkbox smoothes any edges, essentially spreading color and texture over edges, to make the edges appear smooth.
Soften coplanar checkbox

Selecting the Soften coplanar checkbox softens edges, essentially deleting edges, between coplanar surfaces.

Create a three dimensional multi-sided polygon (with more than 5 sides) and experiment with these options to become familiar with softening and smoothing
models. For example, create a 6-sided polygon, expand the polygon using the Push/Pull tool, select the entire 3D polygon, click on Smooth Normals, and move
the Angle Between Normals to 61 degrees. Notice that each edge of the polygon looks smooth because the angle between each normal is 60 degrees and,
therefore, can be smoothed. Now move the slider to 59 degrees. Notice that the sides no longer look smoothed because the Angle Between Normals only
operates on angles below or equal to 59 degrees. Experiment further by turning on the Soften Coplanar option to see edges appear and disappear.
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Entities

Entities intro
This section of the user's guide covers the various entities used to construct a model in SketchUp. These entities include faces, arcs, dimensions, and lines.

Entities are covered in alphabetical order.

Image entities

Image entities are essentially special groups consisting of a face with an applied bitmap image material. Image Objects can be moved, rotated and scaled. They
can also be stretched horizontally or vertically, but they cannot be made non-rectangular. Import Images using the File > Import > 2D Graphic menu item.

Image formats

SketchUp supports the following formats for import as an Image Object: JPEG, PNG, PDF (Mac OS X), PICT (Mac OS X), PSD (Mac OS X), EPS, SGI (Mac OS X), TGA
(Microsoft Windows), BMP (Microsoft Windows), and TIFF. Some formats may be more appropriate than others for certain types of images and applications.

Image proportions

By default, Image Objects retain the proportions of the file from which they are derived. While inserting an image, you can hold down the Shift key to de-
constrain the proportions. You can also use the Scale tool to alter the image object's proportions after it is placed.

Inserting image entities

Images can be added to SketchUp models in one of two ways. First, you can use File > Import which will open a File Open dialog allowing you to navigate to the
file you want. Alternately, you can simply drag and drop from the File Explorer (Microsoft Windows) or Finder (Mac OS X) directly into your drawing area.

Note: Image Objects can also be inserted as textures (File > Import). For additional information on using images as textures, see the Texture Positioning topic.
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Group Entities

Group entities

Groups are entities that can hold other entities. Groups are commonly used to combine several entities as a single entity for the purposes of performing a quick
operation with the combination (such as a copy). Use the Make Group menu item from the Edit menu to create a group from the currently selected entities.

Editing a Group
Exploding a Group

Applying Materials to Groups

Creating a group
Groups are useful for combining entities to perform a quick operation such as copy or move operations. To create a group:

. Select the Select tool. The will change to an arrow.

. Click and hold the mouse button a short distance away from the entities you want to select to start a selection box.

. Drag the mouse to the opposite corner of the selection starting point.

. Release the mouse button when all of the elements are either partially included (left-to-right selection) or fully included (right-to-left selection) in the
selection box.

AWN R

N

5. Select the Edit > Make Group. Alternatively, context-click on the currently selected entities and select Make Group from the context menu. The geometry
you selected appears grouped within a highlighted bounding box.

Note: The Make Group operation disconnects any geometry that was connected to the grouped geometry prior to placing the geometry in the group. The
disconnected geometry is maintained outside of the group's context.

Note: You can make group hierarchies by grouping other Group entities within a group. Additionally, you can mix your hierarchies by including components and
groups within other components and groups.

Note: You can ungroup grouped entities by context-clicking on the group and then selecting the Explode menu item.

Editing a group

Groups can be opened for editing, placing you in the Group's context. To edit a group:

1. Select the Edit > Group > Edit Group to edit the group. Alternatively, context-click on the currently selected group and select Edit Group from the context
menu. An edit bounding box will surround the group and entities exterior to the group will turn grey.

Double-click on the group to edit the group.

2. Make changes to entities within the group. Any changes while in the group's context only affects the Group entity. You can, however, perform inference
alignments to geometry outside of the group while you are editing the group.

3. Select the Edit > Close Group / Component to end the edit session. Alternatively, context-click on the currently selected group's bounding box and select
Close Group from the context menu.

Click outside of the group to close the Group.
Applying materials to groups
Any geometry inside a group that is painted with the default material will be painted when you paint an unexploded group. Therefore, you can have entities

within a group painted individually while other elements painted using the material assigned to the entire group. The following image contains four cars all
enclosed in groups. The tires, bumper, and windshield have been painted black when editing the group.
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Each entire Group entity was then painted after being edited, turning each of the faces with the default material to the color applied on the group (green, blue,
red, and yellow from left to right):

Exploding (Ungrouping) a Group
You can explode (ungroup) a Group entity to break it back into its original entities. To explode a group:

1. Select the "Select Tool." The will change to an arrow.

2. Select the group you want to explode.

3. Select the "Edit > Group > Explode." Alternatively, context- click on the currently selected group and select "Explode" from the context menu. The Group
will be split back into its entities.

Elements within groups that were placed adjacent to other geometry might become joined to elements exterior to the group when the group is exploded.
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Surface Entities

Surface entities

Surface entities are a number of faces joined together to give the impression of roundness (using soft edges). Although the individual planar faces that make up a
curved face set are still separate entities, they can act like a single group when selected or painted.

There are three types of surfaces, though the Entity Info dialog box will recognize each as just a Surface entity:

L]
L]
.

Arc surface. An arc surface is generated when a face with an Arc entity has one or more of its edges extruded (usually with the Push/Pull tool).

Cylindrical surface. A cylindrical surface is similar to an arc surface, but is generated when a circular face is extruded to form a cylinder.

Polyface surface. A polyface surface is generated when a face with a Polyline Curve entity has one or more of its edges extruded (usually with the Push/Pull
tool). You can also create one manually by softening edges with the Erase tool or using the Soften/Smooth Control. Polyface surfaces do not have special
editable properties, but respond to tool operations as a single entity.

The following image contains the three types of surfaces, an arc surface, cylindrical surface, and polyface surface, from left to right.

Creating an arc surface

As mentioned previously, arc surfaces are extruded faces with one or more arc edges. To draw an arc surface:

. Select the Arc tool. The cursor changes to a pencil with an arc.
. Click to place the starting point of your arc.

Click again to place the ending point of your arc.

. Or, optionally type in values for the chord length, bulge distance, radius, and number of segments in the Measurements toolbar.

Click again to set the bulge distance.

. Select the Line tool. The cursor changes to a pencil.

. Click at one end of the arc set the starting point of your line.

. Click at the other end of the arc to set the ending point of your line. This step completes a face consisting of an arc and a straight line.

. Select the Push/Pull tool. The cursor will change to a 3D rectangle with an up arrow.

. Click on the face.

. Move the cursor up to create an arc curve in the positive direction or move the cursor down to expand the arc curve in the negative direction.
. Click again when the arc curve has reached the desired size. The vertical curved surface is an arc surface.

Creating a cylindrical surface

As mentioned previously, cylindrical surfaces are extruded circles. To draw a cylindrical surface:

1.
2.
3.

8.

Select the Circle tool. The cursor changes to a pencil with a circle.

Click to place the center point of the circle.

Move the mouse out from the center point to define the radius of your circle. As you do so, the radius value is displayed dynamically in the Measurements
toolbar and can be specified by typing in a length value followed by pressing the Enter (Microsoft Windows) or Return (Mac OS X) key. You can also specify
the segmentation for the circle in the Measurements toolbar.

. Click a second time to finish the circle.

. Select the Push/Pull tool. The cursor will change to a 3D rectangle with an up arrow.
. Click on the face
. Move the cursor up to create cylinder in the positive direction or move the cursor down to expand the cylinder in the negative direction.

Click again when the cylinder has reached the desired size. The vertical surface is a cylindrical surface.

Creating a polyface surface

As mentioned previously, polyface surfaces are extruded faces with one or more polyline curve edges. To draw a polyface surface:

. Select the Freehand tool. The cursor will change to a pencil with a polyline curve.
. Click and hold to place the starting point of your polyline curve.

Drag the cursor to draw a polyline curve. Do not close the curve.

. Release the mouse button to stop drawing.
. Select the Line tool. The cursor changes to a pencil.

Click at one end of the polyline curve to set the starting point of your line.

. Click at the other end of the polyline curve to set the ending point of your line. This step completes a face consisting of an arc and a straight line.
. Select the Push/Pull tool. The cursor will change to a 3D rectangle with an up arrow.
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11.

. Click on the face
. Move the cursor up to create the polyface surface in the positive direction or move the cursor down the expand the polyface surface in the negative

direction.
Click again when the polyface surface has reached the desired size. The vertical curved surface is an polyface surface.
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Importing

How should | prepare a CAD file for import into SketchUp?

What version of DWG/DXF files should | import into SketchUp? When SketchUp imports an AutoCAD file, it strips the information to its basic geometric
components. Because of this, regardless of AutoCAD file format (2010, 2007, etc...), the end result is essentially the same. To maximize compatibility, however,
we suggest importing AutoCAD files that are in R13 format.

You may not need to do anything special, but performing a little preparation often helps make the imported data more efficient.

SketchUp automatically discards any entities in the imported CAD file that have no 3D relevance, for example, text, dimensioning, hatching, logos, and so on.
However, SketchUp won't discard the layers holding these entities, so you may want to delete those layers from the CAD file prior to import, or you can easily
delete them all in SketchUp after import by opening the Layers browser (Window > Layers) and using the Purge command on the flyout menu, which purges all
unused layers.

When geometry is many miles or kilometers away from the origin (0,0) in SketchUp, you can experience performance problems. Because of this, if you are
importing, for example, Autodesk AutoCAD DWG files such as civil site plans in order to work with the contour lines, if the graphic or geometry is far away from
the origin, it is helpful to move it close to the origin before importing into SketchUp. Alternatively, clear the SketchUp Preserve drawing origin option when
importing (File > Import > Options > Scale).

CAD imports are generally successful when the file size 15MB or less. Larger file sizes may fail upon import.

AutoCAD objects are not directly supported, but there is a way you can use them. Examples of these objects are doors, windows, stairs, and contour lines created
in created in the Autodesk Architectural Desktop or Autodesk Land Desktop. In order to make the entities in these objects available for use, you can explode
them in the Desktop application. The first explode results in a block entity. A second explode results in polylines. Block entities are imported into SketchUp as
components, which can also be exploded in SketchUp. An alternative is to use the File > Export to AutoCAD command in the Desktop application. If the Desktop
application is in plan view prior to export, this command creates 2D line work for SketchUp to import; if it is in a 3D view, it creates 3D faces for SketchUp to
import.

Here are a couple suggestions for handling CAD graphics after you have imported them into SketchUp:

e For imported data that won't be used for 3D extrusion, but that you need to view or show to others, such as property lines, parking lot markers, and so on:
The goal with this type of data is to have it available, but to prevent it from impacting performance. To accomplish this, you need to isolate this data so
SketchUp doesn't need to use its Face Finder functionality to analyze all of the points that make up this data. You can do this by selecting all these entities
and creating a component from them (this is easiest to accomplish if these entities are all on their own layer). Be sure to use the Replace selection with
component option when you create the component.

e For imported data that will be used for 3D extrusion: As long as the imported edges are connected endpoint to endpoint, all you have to do is trace one
edge from endpoint to endpoint, and then SketchUp's Face Finder creates the face whose perimeter is defined by the edges connected to that edge.

Importing an Adobe lllustrator File

@ This is a Pro only feature.
SketchUp can import Adobe lllustrator files in the for of AutoCAD Drawing (.dwg) or AutoCAD Interchange (.dxf) file formats. To Import an Adobe Illustrator file:

. Export the Adobe lllustrator file as either a .dwg or .dxf file from Adobe Illustrator.

. Run SketchUp.

. Select File > Import. The Open dialog box appears.

. Navigate to the .dwg or .dxf file.

. Click the Open (Microsoft Windows) or Import (Mac OS X) button. The file is imported.
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Note: You might want to reduce the number of anchor points that define curves in Adobe lllustrator to reduce the number of segments that are created from the
curves when the file is imported into SketchUp. File size can increase dramatically if you import geometry that contains a lot of line segments within curves
(especially if you push/pull the faces formed by the segments). Try to balance how many anchor points you think you should include in your Adobe lllustrator
curved lines by taking into consideration the distance at which the curved lines will be viewed in the SketchUp model.
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CAD (DWG/DXF) import
Importing CAD files at the correct scale

@ This is a Pro only feature.

Apply the appropriate scale when importing a CAD file, such as an AutoCAD Drawing (.dwg) or AutoCAD Interchange File (.dxf). To import a CAD file at the
correct scale:

. Select the File > Import. The Open dialog box appears.

. Select the type of file to open from the 'Files of type' (Microsoft Windows) or 'Format’ (Mac OS X) drop-down list.
. Click the Options button. The import options for the specific CAD file type appears.

Select the appropriate scale from the Units drop-down list.

. Click the OK button.

. Click the Open button. The CAD file is imported.

OUVThWNKE

Reducing DWG or DXF import file size

@ This is a Pro only feature.

Try to keep the size of imported files to a minimum. Importing very large CAD files can take a long time because each CAD element must be analyzed and
converted into a SketchUp entity. Also, once imported, a complex CAD file can slow SketchUp's performance because lines and faces in SketchUp have a lot more
'intelligence' than their CAD equivalents.

Strategies for Minimizing CAD File Size

SketchUp models can be designed to be as accurate as models in CAD. However, SketchUp is not designed for the same type of line-intensive drawings done in
CAD software. Therefore, it is a good idea to clean up and import only the CAD content that is absolutely necessary into SketchUp.

Another strategy is to keep different levels of detail in separate CAD files. For example, one imported CAD file can contain site plan information, another can
have a floor plan, and a final file can have a specific detail.

Importing 3D DWG or DXF files

@ This is a Pro only feature.
To import a 3D DWG or DXF model file:

1. Click File > Import. The Open dialog box is displayed.

2. (optional) Click on the Options button to modify the import options, such as units, for the incoming file. See 'Import Options' section for further
information.

3. Click OK to import the file. The Import Results dialog box will appear containing details of the imported model.
Note: It can take several minutes to import a large file because SketchUp's native geometry is very different from most CAD software and the conversion
process is calculation-intensive.

4. Click OK in the Import Results dialog box. The model will appear in the drawing area at the origin.
Note: The imported model's entities will be enclosed within a group if geometry existed in the drawing area prior to importing the model.

5. (optional) Click on the Zoom Extents tool to locate the imported model if it is not currently displayed in your drawing area.
DWG/DXF Supported CAD Elements

@D This is a Pro only feature.

SketchUp must translate the elements within a CAD file into SketchUp entities when importing a CAD file. Supported CAD elements include lines, arcs, circles,
polylines, faces, entities with thickness, 3D faces, and nested blocks. CAD layers are also supported.

SketchUp does not support AutoCAD regions, XREFs, hatching, dimensions, text, and proprietary ADT or ARX objects. These CAD elements will be ignored on
import.

You can change any unsupported elements into primitive CAD drawing elements, within your CAD application, if you need to import these elements into
SketchUp. For example, you can explode ADT walls and extrusions in Autodesk Architectural Desktop so they will import as faces in SketchUp. Some elements
might need to be exploded multiple times in your CAD package to be translated into SketchUp entities.

3D Model (DWG/DXF) Import

@ This is a Pro only feature.

SketchUp allows you to import 3D models, such as DWG and DXF CAD files, for placement within your model. Import a file using the Import menu item in the File
menu.

Note: Google is a member of the OpenDWG Alliance, allowing SketchUp to offer the most reliable DWG file translation available.
The Import AutoCAD DWG/DXF Options dialog box

@ This is a Pro only feature.

Some CAD files might contain non-standard units, coplanar faces, or inconsistently oriented faces. You can force SketchUp to automatically analyze and repair
these issues during the import process.

Geometry
The Geometry section of the AutoCAD DWG/DXF Import Options dialog box contains options to configure the appearance of the exported VRML file.
Merge Coplanar Faces

Planes can import into SketchUp with triangulated lines. Removing these lines manually can be tedious. The Merge coplanar faces option is used to have
SketchUp automatically remove these lines.
229



Orient Faces Consistently
The Orient faces consistently option is used to analyze the direction of imported faces and orient these faces so that they are uniform in direction.
Scale

Some CAD formats, such as DXF, save data in generic units. The Scale section of the AutoCAD DWG/DXF Import Options dialog box contains options to configure
the units for the imported file.

Units
Select the unit type used in the original CAD file to import geometry at the correct scale.

Warning: SketchUp only recognizes faces of .001 square inches and larger. It is possible to create very small faces on import if you select millimeters as your
SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units
used in the original file. Resize the model as necessary after it is imported.

Preserve Drawing Origin

The Preserve drawing origin option is used to define where the DWG/DXF file will be placed when it is inserted into a SketchUp file. Check this box if you want to
place the DWG/DXF file at the origin, as originally defined in the DWG/DXF file. Do not check this box if you want the DWG/DXF file to be placed near the
SketchUp origin.

DWG/DXF import plug-in

As you may know, the DWG/DXF importer isn't available in SketchUp 7.1. Please note that this functionality continues to be offered in SketchUp Pro.

For those of you who depend on this feature, you can download this optional plug-in for Windows or Mac that enables the DWG/DXF importer. This plug-in will
only be available for a limited time, and it will not be supported in our next major release.

You may also consider downloading the SketchUp Pro trial, which allows you to try all of the features of SketchUp Pro including LayOut and Style Builder. You can
learn more about the differences between SketchUp and SketchUp Pro on our site.
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COLLADA (DAE) import
Importing COLLADA (DAE) Files

To import a COLLADA (DAE) file:

. File > Import. The Open dialog box is displayed.

. Locate the file you want to import

. Click OK in the Import Results dialog box. The model will appear in the drawing area at the origin.

. (optional) Click on the Zoom Extents tool to locate the imported model if it is not currently displayed in your drawing area.

3D Model COLLADA (DAE) Import

SketchUp allows you to import COLLADA (DAE) files. Import a DAE file using the Import menu item in the File menu.

The COLLADA (DAE) Import Options dialog box

The COLLADA (DAE) Import Options dialog box contains options for importing DAE Files.
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Validate COLLADA file

The Validate Collada files option checks to see if the file is a valid COLLADA 1.4.1 file. You will receive a warning and be asked if you want to proceed with the
import if the file is not a valid COLLADA file.

Warning: Importing an invalid COLLADA file can yield unexpected results.
Merge Coplanar Faces

Some 3D modeling tools only support triangular faces. If a model is triangulated, edges have been added to break complex faces into collections of triangles.
These edges can be tedious to remove manually. The Merge coplanar faces option is used to automatically remove edges shared by coplanar faces with the same
material.
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DEM import
Importing DEM files

To import a DEM file:
1. File > Import. The Open dialog box is displayed.

Warning: You must add the ".dem’ file extension to your DEM files to open these files. Additionally, you can select any file with the ".ddf' extension from your
directory to open DDF files.

e (optional) Click on the Options button to modify the import options, such as points, for the incoming file. See the following Import Options section for further
information.

e Click OK to import the file. The Import Results dialog box will appear containing details of the imported model.

Note: The file import time corresponds to the number of maximum points defined in the Import Options dialog box: the greater number of maximum points, the
longer it takes the file to load.

e Click OK in the Import Results dialog box. The model will appear in the drawing area at the origin.
Note: The imported model's entities will be enclosed within a component.

* (optional) Click on the Zoom Extents tool to locate the imported model if it is not currently displayed in your drawing area.

3D Model (DEM) import

SketchUp allows you to import a digital elevation models (DEM) containing point data relating to terrain elevations. Unfortunately, there is not a single
standardized file format for digital elevation models. However, SketchUp supports the following two important file formats: USGS DEM and spatial data transfer
standard (SDTS).

The USGS DEM file format is an ASCII format for storing geographical information. These files can have an extension of '.dem." You will have to add the ".dem'
extension to your USGS DEM files if they do not have this extension.

SDTS is a complex geographical data format. SDTS models usually consist of 20 or more files, all with the extension of ".ddf," stored in a single directory. You can
select any of the "*.ddf" files in a SDTS directory to import the entire set of files.

Import a USGS DEM or SDTS file using the Import menu item in the File menu.

DEM Import Options dialog box

DEM files can contain thousands of points yielding a very detailed, yet very slow, SketchUp model. The CAD files might contain non-standard units, coplanar
faces, or inconsistently oriented faces. You can force SketchUp to automatically analyze and repair these issues during the import process.

Points and faces

The Points and faces fields are used to identify the number of points, and subsequent faces, that will be created upon import. The fewer the points and
subsequent faces, the better the performance in SketchUp. However, the fewer the points and subsequent faces, the lesser the detail of the imported model.

Note: (2 * points) + 1 = approximate number of faces created upon import.
Generate gradient texture

The Generate gradient texture field is used to apply a gradient texture to the imported DEM model. This texture will be darker in lower areas of the model and
lighter in high areas.
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3DS import
Importing 3DS files

To import a 3DS model file:

. Click File > Import. The Open dialog box is displayed.
. Select the type of file to import from the 'Files of type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button to modify the import options for the incoming file. See the following Import Options section for further information.
. Click OK to import the file.
Note: It can take several minutes to import a large file because SketchUp's native geometry is very different from most CAD software and the conversion
process is calculation-intensive.
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5. Click OK in the Import Results dialog box. The model will appear in the drawing area at the origin.
6. (optional) Click on the Zoom Extents tool to locate the imported model if it is not currently displayed in your drawing area.

3DS Model (3DS) Import

SketchUp allows you to import 3D Studio (3DS) files. Import a file using the Import menu item in the File menu.

3DS import options dialog box

Geometry
Merge Coplanar Faces

Planes can import into SketchUp with triangulated lines. Removing these lines manually can be tedious. The Merge coplanar faces option is used to have
SketchUp automatically remove these lines.

Scale
Units

The Units drop-down list is used to import 3DS geometry at the correct scale. A 3DS file has a field which indicates its units value. Sometimes this value is
explicitly set in the 3DS file (such as millimeters) and sometimes it is missing and set to a generic value. The Model Units list item will import your 3DS file with
the unit value it finds in your 3DS file. SketchUp will import your file using inches if a units value is not set in the 3DS file. SketchUp will import your 3DS file at
the unit you choose if you pick anything other than Model Units.

For example, a face that is 1cm x 1cm will be imported into SketchUp as 1cm x 1cm if your 3DS file has its units value set to centimeters and you select Model
Units in this drop-down list. A 1cm x 1cm face will import into SketchUp with dimensions of lin x lin if you choose inches in the drop-down list.

Warning: SketchUp only recognizes faces of .001 square inches and larger. It is possible to have very small faces on import if you select millimeters as your
SketchUp units but the model was originally intended to be displayed in feet. Therefore, use a large unit type, such as feet or meters, if you do not know the units
used in the original file. Resize the model as necessary after it is imported.
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2D image import

Importing large images

The maximum size of an image that can be imported into SketchUp is 1024 pixels wide by 1024 pixels high. SketchUp will automatically downsize files larger
than the 1024 pixels by 1024 pixels using a medium quality sampling mechanism. For better quality results, downsize a larger image before import into
SketchUp using a photo editing program like Adobe Photoshop (one that supports bicubic resampling) and save the file as a high-quality JPEG file.

Additionally, crop any images to include only the portion of the image to be used if the image will be used as a texture in SketchUp (to minimize impact on file
size in SketchUp).

Importing 2D graphic files

To import a 2D graphic file:

. Click File > Import. The Open dialog box is displayed.

. Locate the file you want to import

. Click OK to import the file. The image will appear in the drawing area. Your cursor, which will be an arrow, will be anchored to one of the image's corners.
. Click anywhere in the drawing area to anchor the point of the image held by the cursor.

Drag your mouse away from the anchor point to increase the size of the image.

. Click again to finish placing your image.
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Importing 2D graphics as textures

To import a 2D graphic file as a texture:

1. Click File > Import. The Import dialog box is displayed.

2. Locate the file you want to import

3. Click the 'Use As Texture' check box if you want your image to be used as a texture upon import (this will require you to paint the image on a an existing

surface). See the following 'Importing 2D graphics as textures' section for additional information.

4. Click OK to import the file. The image will appear in the drawing area. Your cursor, which will be the paint bucket, will be anchored to one of the image's
corners. The paint bucket cursor only appears when the image is over a surface where it can be painted.

. Click on a surface to anchor the point of the image held by the cursor.

6. Drag your mouse away from the anchor point to increase the size of the image on the face.

. Click again to paint your image on the face. The image will repeat, if necessary, to fill the entire face. A thumbnail of the image appears in the Materials
browser's Colors (Microsoft Windows) or In Model (Mac OS X) section to indicate that the image is a texture. Refer to the Paint Bucket tool for additional
information on working with textures.
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2D Graphic Import

SketchUp allows you to import 2D raster images, including JPEG and BMP, for placement within your model Import a file using the Import menu item in the File
menu.

Importing 2D graphics as textures

Image file size versus quality

When you add an Image Object to your scene, the image file it is based on becomes embedded in your SketchUp document. This allows you to send your
SketchUp files to others without any data loss through misplaced linked files, but it also means that your files can quickly balloon to unwieldy sizes. When
inserting images, try to keep file size as small as possible:

Resolution

Resolution can have a large impact on image size. Try to use only as much resolution as you need, and no more. You may sometimes find that even a pixilated,
low resolution file can be sufficient to provide the information you need from a photograph, sketch, or drawing. You can also cut down on image file size by
converting your images to grayscale before inserting them into SketchUp.

Also, the resolution of Image Objects is limited to the largest texture that OpenGL can handle. For most systems this limit is 1024 x 1024 pixels. This should be
sufficient for most purposes, but if higher resolution is required, you can always stitch together multiple Image Objects.

Image file compression

Another way to minimize file size is to use compressed file formats such as JPEG and PNG. These take up far less space both on disk and inside a SketchUp file.
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Exporting
Export Options dialog box (Mac OS X)

@ This is a Pro only feature.

The Export Options dialog box contains options for exporting 2D PDF and EPS Files.

Image size

The Image Size section of the PDF/EPS Export Options dialog box contains size options for your model.
Match view size

Match view size option is used to force width and height to correspond to the "screen dimensions" of the graphic window (the width and height values end up
being the horizontal and vertical pixel counts divided by 72 ppi). Checking this option grays out Width, Height, In Image, and In Model. The values in In Image
and In Model are not guaranteed to be valid.

Unchecking this option allows you to control the output size by adjusting Width, Height, In Image, and In Model values.
Aspect ratio button (chain link)

When this button is linked, the height and width aspect ratio is automatically maintained.

When the button is unlinked (broken), the height and width can be maintained separately.

Width/Height

The width and height fields are used to enter a custom width and height for the output image. Note that these options correspond to the dimensions of the
graphic window, not the model extents. If the Aspect ratio button is broken, the width and height can be modified independently and the model scale is adjusted
accordingly.

Image scale
The Image scale section of the PDF/EPS Export Options dialog box contains scaling options for your model.
In Image/In Model

In Image/In Model fields are used to specify absolute scale your output. The first measurement, labeled In Image, is the measurement of the exported geometry.
The second measurement, labeled In Model, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter 1 inch In
Model equals 4 feet In Image.

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable this scale option.

Line quality
The Line quality section contains a setting for exported line weights.
Line weight

This option is used to apply a weight to all profile lines, or lines that have space behind them as they are displayed.
3D Model Export

@ This is a Pro only feature.

SketchUp allows you to export your models as Kaydara (FBX) files. Export a FBX file using the Export > 3D Model menu item in the File menu.
The Export Options dialog box

@ This is a Pro only feature.

The Export Options dialog box contains options for exporting Epix files.

Image Size

The Image Size section of the Export Options dialog box contains size and scaling options for your model.
Use View Size

The Use View Size option is used to set your output to the exact dimensions of your SketchUp drawing area.
Width/Height

The width and height fields are used to enter a custom page size for your file.

Tip: SketchUp cannot export Epix files with compression enabled. Re-saving your file in Piranesi can reduce file size considerably.

Resolution (Mac OS X)

The Resolution drop-down list is used to select the resolution for the exported image. For viewing images on the screen, 72-96 pixels/inch is adequate. For
printing, you might want to increase the resolution to 150-300 pixels/inch. Remember, high resolution images take longer to generate.

EPIX

The EPIX section of the Export Options dialog box contains options for the contents of the exported file.

Export Edges

The Export Edges check box is used to maintain the edge rendering style from the drawing area when saving your drawings as an Epix file.

Note: Edges will not appear in your Epix file if edges are disabled in your style.
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Export Textures

The Export Textures check box is used to maintain textures from the drawing area when saving your drawings as an Epix file.

Note: The Export Textures option is only applicable when materials have been assigned to faces and SketchUp is in the Shaded with Textures display setting.
Export Ground Plane

The Export Ground Plane check box is used to create a ground plane in the Epix file without explicitly modeling a ground in SketchUp.
Exporting Epix files

@ This is a Pro only feature.
To export an Epix file:

. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.

Select File > Export > 2D Graphic. The Export 2D Graphic dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the Epix export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The Export Options dialog box is displayed.

. (optional) Adjust the options in the Export Options dialog box dialog box.

. (optional) Click the OK button.

. Click the Export button.

Note: SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.

Note: Your display must be set to 32-bit color in order to correctly export Epix files (Microsoft Windows).
2D graphic (Epix) export

@ This is a Pro only feature.

Piranesi is a painting application that enables you to create stunning renderings from your SketchUp models. For more information, please visit the Piranesi web
site.

SketchUp allows you to export your models as Epix files for use in Piranesi. Export an Epix file using the Export > 2D Graphic menu item in the File menu.
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AutoCAD (DWG/DXF) export
3D Model (DWG/DXF) Export

@ This is a Pro only feature.

SketchUp can export 3D geometry to several AutoCAD formats: DWG r12, DWG r13, DWG r14, DWG r2000, DWG r2004, DXF r12, DXF r13, DXF r14, DXF r2000,
and DXF r2004. SketchUp uses the industry standard OpenDWG Alliance file import/export model libraries to ensure maximum possible compatibility with
AutoCAD. Export a file from the File menu.

AutoCAD Export Options dialog box (Mac OS X)

@ This is a Pro only feature.

The AutoCAD Export Options dialog box contains options for exporting AutoCAD files.

Geometry

The Geometry section of the Export Options dialog box contains the various entities that can be exported into your DWG/DXF file.

SketchUp can export faces, edges (wires), dimensions, text, or guides in any combination.

@ This is a Pro only feature.

The AutoCAD Export Options dialog box contains options for exporting AutoCAD files.

AutoCAD Version

The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.
Export

The Export section of the AutoCAD Export Options dialog box contains the various entities that can be exported into your DWG/DXF file.

SketchUp can export faces, edges (wires), dimensions, text, or guides in any combination.
3D DWG/DXF export details

@ This is a Pro only feature.
The 3D DWG and DXF export is used to export SketchUp files for use in other CAD programs such as AutoCAD. The following details apply to this export:

e Faces in SketchUp are exported as a triangulated polyface mesh with interior splframe hidden lines (if applicable). This conversion helps to simulate the
appearance of your native SketchUp file, even when all exported faces are triangular.

e SketchUp uses the current units set in the Units Panel of the Model Info dialog box as a reference for translation to a DWG or DXF file. For example, if the
current unit setting is Decimal and Meters, SketchUp will export the DWG file accordingly. AutoCAD must be set to decimal for the units to translate
correctly as meters.

e When exporting, duplicate line entities will not be created on top of a p-line entity.

Exporting 3DDWG or DXF files

@ This is a Pro only feature.
To export a 3D DWG or DXF file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.
. Select the export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The AutoCAD Export Options dialog box is displayed.

. (optional) Adjust the options in the AutoCAD Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.

Exporting 2D DWG or DXF Files

NoOuUVuhwWNR

@ This is a Pro only feature.
To export a 2D DWG or DXF graphic file:

. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.

. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box is displayed (Microsoft Windows).

Enter a file name for the exported file in the 'File' name (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the DWG or DXF export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.

. (optional) Click on the Options button. The DWG/DXF Hidden Line Options dialog box is displayed.

. (optional) Adjust the options in the DWG/DXF Hidden Line Options (Microsoft Windows) or Export Options (Mac OS X) dialog box.
. (optional) Click the OK button.

. Click the Export button.

PNV A WN

Note: SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.
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COLLADA (DAE) export
Exporting COLLADA (DAE) Files

To export a COLLADA (DAE) file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the DAE export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The DAE Export Options dialog box is displayed.

. (optional) Adjust the options in the DAE Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.

The COLLADA (DAE) Export Options dialog box

The Export COLLADA (DAE) Options dialog box contains options for exporting DAE (COLLADA) files.
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Geometry
The Geometry section of the DAE Export Options Dialog box is used to identify the geometry that will be exported.

Export Two-Sided Faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the
resulting DAE file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always
render, and materials applied to front and back faces are preserved. When this option is selected, SketchUp will weld the vertices of the front faces together and
the vertices of the back faces together.

Export Edges
The Export Edges checkbox is used to maintain the appearance of a model with edges visible. Note that stand-alone edges are always exported.

Triangulate All Faces
Some 3D modeling tools only support triangular faces. The Triangulate All Faces checkbox is used to break all surfaces into triangles instead of multi-sided
faces.

Export Only Selection Set
The Export Only Selection Set checkbox is used to export the currently selected geometry in the drawing area. The entire SketchUp model is exported when there
is no selection in the drawing area or when this checkbox is not selected.

Export Hidden Geometry
The Export Hidden Geometry checkbox is used to export hidden geometry within the SketchUp model.

Preserve Component Hierarchies
The Preserve Component Hierarchies option preserves the full component hierarchy and component instancing in the exported .dae file. The component
hierarchy will be flattened and component instances will become unique objects if this option is not checked.

Materials
The Materials section of the DAE Export Options Dialog box is used to identify how materials will be exported.

Export Texture Maps
Select the Export Texture Maps checkbox to export textures with your DAE file.

Use "Color By Layer" Materials
The Use "Color by Layer" Materials checkbox is used to assign materials to geometry based on your model's layer assignments in SketchUp. Check this checkbox
to export materials based on layers, such as when exporting to other rendering applications.

Note: The Export Texture Maps and Use "Color By Layer" Materials options are mutually exclusive.
Credits
The Credits section of the DAE Export Options Dialog box is used to identify treatment of credits associated with the model.

Preserve Credits
The Preserve Credits checkbox keeps SketchUp model attribution credits with the DAE file. This is useful when uploading a DAE file to the 3Dwarehouse.

3D Model Collada (DAE) Import and Export

SketchUp allows you to import and export Collada (DAE) files. Collada files are XML files with a .dae extension which stands for "Digital Asset Exchange."” Collada
is typically the file format used to transfer data between digital content creation (DCC) tools such as SketchUp and Maya, 3ds Max, and Rhino. A more complete
list of DCC tools can be found at:

http://www.ogre3d.org/wiki/index.php/DCC_Tools

Note: SketchUp supports the Collada 1.4 specification and schema.

3D Model COLLADA (DAE) Export

SketchUp allows you to export your models as COLLADA (DAE) files. Export a DAE file using the Export > 3D Model menu item in the File menu.

SketchUp Items Not Exported
A SketchUp file might not look identical in another program when exported as a COLLADA file because COLLADA does not support certain SketchUp features. The
following SketchUp features are not exported:

Matched photos

Guide lines and guide points
Coordinate lines

Rendering options

Shadows

Text

Section planes
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Section cuts

Scenes

Dimensions

Material pushpin locations
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Note: SketchUp supports the COLLADA 1.4 specification and schema.
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3DS Export
3DS Export Options dialog box

@ This is a Pro only feature.

The 3DS Export Options dialog box contains options for exporting 3DS files.

Geometry

The Geometry section of the 3DS Export Options dialog box contains options for determining how geometry will be represented in a 3DS file.
Export (Full hierarchy)

The Export (Full hierarchy) option is used to create meshes for each top level nested component and group and, additionally, meshes for non-grouped entities
based on the connection of faces. These meshes will be organized based on where they fit in the component and group hierarchy. This option allows you (using a
tree view in AutoDesk 3DS Max, for example) to select individual components and groups with all their children and each connected face set as separate meshes.
This option preserves the name of the component or group using the following rule for components: if an instance name exists, that name will be used; if an
instance name does not exist, the definition name will be used.

Export (By layer)

The Export (By layer) option is used to create separate meshes based on a combination of how faces are connected and what layer (from SketchUp) they are on.
All faces that are connected and are on the same layer will be grouped together in separate meshes. These meshes will then be organized based on the layer to
which they belong. This option allows you (using a tree view in AutoDesk 3DS Max, for example) to select all objects on a layer using the organization scheme
and then to drill down and select individual meshes within that layer. No hierarchy will be created with this option.

Export (By material)

The Export (By material) option is used to create separate meshes based on a combination of how faces are connected and what material they have. All faces that
are connected and have the same material will be grouped together in separate meshes. These meshes will then be organized based on their materials. This
option allows you (using a tree view in AutoDesk 3DS Max, for example) to select all objects with the same material using the organization scheme and then to
drill down and select individual meshes having that material. No hierarchy will be created with this option.

Export (Single Object)

The Export (Single object) item is used to export your SketchUp model as a single 3DS mesh. This single mesh will be simple to select and manipulate once
imported into another application. Because there is a limitation in the 3DS format that meshes can only have 65,536 vertices and faces, if this limit is exceeded,
more than one mesh will be created with emphasis on keeping the number of meshes to the minimum amount necessary.

Export only current selection

The Export only current selection checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection.
Additionally, the entire model is exported when this checkbox is not checked.

Export two-sided faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the
resulting 3DS file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always
render, and materials applied to front and back faces are preserved. When this option is selected, SketchUp will weld the vertices of the front faces together and
the vertices of the back faces together according to the logic for texture mapping and welding outlined in the following Export texture maps option.

Export standalone edges

Standalone line entities (lines not connected to any faces) are somewhat unique to SketchUp and not supported by many other 3D programs or the 3DS format.
The Export standalone edges check box creates very thin rectangles that appear as standalone lines in the 3DS files. Unfortunately, this option can result in
invalid texture coordinates requiring UV mapping to be re-applied before the scene is rendered. Also, certain exported standalone edge geometries can create
invalid 3DS files altogether. The VRML format may better suit your needs if you need to export standalone edges.

Materials
Export Texture Maps

The Export texture maps checkbox is used to assign texture maps to 3DS materials whenever the corresponding SketchUp material uses a texture image. The
3DS format allows only one UV mapping coordinate per vertex, meaning you can not have a different UV mapping on two faces that share the same vertex. Given
this limitation of the 3DS format, a tradeoff between preserving texture coordinates and welding geometry is sometimes necessary and reflected in the following
two sub-options: Favor Preserving texture coordinates and Favor Welding Vertices.

Favor (Preserving Texture Coordinates)

When the Preserving texture coordinates option is selected, and UV mappings are different, the exporter breaks up geometry so that each coplanar group of
polygons has its own set of vertices. In this case, vertices will not be welded together and no smoothing of faces will be evident. If UV mappings are identical,
vertices will be welded.

Note: Use this option if the preservation of textures is of most importance.

Favor (Welding Vertices)
When the Welding Vertices option is selected, the exporter will weld together vertices which will keep your geometry intact and allow smoothing to be preserved.
However, when two faces share the same vertex but have different UV mappings, this option will only allow one of the texture mappings to be preserved.

Warning: Use this option if the preservation of smoothing and welding is of most importance.

Use 'Color by Layer' Materials

The 3DS file format does not support layers directly. The Use 'Color by Layer' Materials checkbox is used to assign 3DS materials based on your model's layer
assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.

Cameras
Generate Cameras From Scenes

The Generate Cameras from Scenes checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The
current SketchUp view is exported with the name 'Default Camera,’ and other Scene camera definitions are output using their Scene Name.
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Units

The units drop-down list is used to determine the unit size in the 3DS output.
3DS known issues and limitations

@D This is a Pro only feature.

If you're receiving an error message, SketchUp SDK error: An error has occurred resulting in an invalid output file ... See this forum thread for additional
details.

2 Sided Faces

Faces are only visible from the front in some programs while both sides of a face are always visible in SketchUp. These two-sided faces can appear to be missing
in other applications if not facing the correct direction. You an manually reorient your faces in SketchUp using the Reverse command or the Orient Faces
command to make face directions uniform for a given set of connected geometry.

Additionally, you can use the 'Export two-sided' checkbox to correct this issue.
Flipped Textures

Textures and materials exported with the two-sided/geometry checkbox can appear flipped in certain applications (such as, Maya version 6.0 and 6.5). A 3DS
mesh does not store any normal data so normals must be computed by the target system. Some importers might compute the normals incorrectly resulting in the
appearance of flipped textures.

Texture Map Names

The 3DS format was designed in an era when DOS-based systems were prevalent. Therefore, 3DS is not capable of storing texture filenames that exceed the 8.3
DOS character limit. This issue can be a limitation to anyone who uses modern OS filename capabilities to manage large, complex projects or file libraries.

SketchUp creates unique names for each texture by adding unique suffixes to file names. For example, a file named 'corrugated metal.jpg' will be described in
the 3DS file as 'corrugat.jpg". Any other files that use the same first six letters is truncated and the suffix "01," 02," and so on, are added.

Visibility
Only entities that are currently visible in SketchUp are output to the 3DS file. Rendering display options are not taken into account, which means that faces are
output even if SketchUp is in wireframe mode. Faces are not output, however, if they are hidden or if they reside on a layer that is hidden.

Multiple Cameras

3DS format can not store an orthographic camera. This format will be simulated through a perspective camera with a very small field of view or a very large lens
length. The eye point will be moved as far away as is possible to yield the same width and height of the projection plane. Certain applications might have
problems with a small field of view. For example, Maya does not read the field of view at all and only lets it become as small as 2.5.

Layers

The 3DS format does not support layers. Any layers you assign in SketchUp will be lost. The DWG format might be a better solution if you need layers to export.
Alternately, you can export with the 'Color by Layer materials' option enabled, which might allow you to easily select and organize geometry in your model based
on SketchUp layers once your model is imported into another application.

Units

SketchUp exports 3DS files at the units specified in the 3DS export options dialog box. This setting can affect the way geometry is described within the 3DS file.
For example, a 1 meter cube in SketchUp will export to 3DS with sides of length 1 when units are set to meters. If you change the export units to centimeters, the
same cube will export to 3DS with a length of 100.

The 3DS format contains extra information that indicates the original units using a scale factor. This information allows an application that reads 3DS to
automatically adjust the size of 3DS models to the correct 'real world' size.

Unfortunately, many applications ignore this extra unit scale information meaning that the centimeter cube imports as 100 times larger than the 1 meter cube,
instead of at the same size. Worse, it is not always clear in which unit 3DS files are saved, resulting in considerable trial and error. In these cases, the best work-
around is simply to export files at the units setting expected by the 3DS importing application.

3D Model (3DS) export

@ This is a Pro only feature.

The 3DS format is native to the original DOS-based 3D Studio modeling and animation application. Although obsolete in many ways, the 3DS format is still widely
used and offers a direct way to export simpler SketchUp models into a wide range of 3D modeling packages. Because 3DS preserves material assignments,
texture mapping, and camera position, it can often allow ideas generated in SketchUp to be transferred with greater fidelity than formats designed for CAD.

Exporting 3DS files

@ This is a Pro only feature.
To export a 3DS file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the 3DS export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The 3DS Export Options dialog box is displayed.

. (optional) Adjust the options in the 3DS Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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Preparing a 3DS file for export

@ This is a Pro only feature.

Every face in SketchUp has a front and back side. Ensure the front of each face is facing out before exporting a model to the 3DS format.
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. Select the Window > Styles. The Styles Browser is displayed.

. Click the Edit tab. The Edit panel is displayed.

. Click the Face settings button. The face settings portion of the Edit panel is displayed.

. Note the Front color. You will want to turn all of the faces in your model so that the front of the face is showing.

Select View > Face Style.

. Select the Monochrome face style.

. Select all of the back faces that are displayed.

. Context-click on one of the selected faces. The context menu for a Face entity is displayed.
. Select the Reverse Faces menu item. All of the selected faces are reversed.

. Save the file as a 3DS file.
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KMZ export
3D Model (KMZ) Export

The KMZ format is a zipped form of Google Earth's proprietary Keyhole Markup Language (KML). These files can contain location data (latitude and longitude)
along with other information (such as SketchUp geometry).

The KMZ Export Options Dialog Box

The KMZ Export Options dialog box contains options for exporting KMZ files.
Geometry
The Geometry section of the KMZ Export Options Dialog box is used to identify the geometry that will be exported.

Export Hidden Geometry
The Export Hidden Geometry checkbox is used to export hidden geometry within the SketchUp model.

Credits
The Credits section of the KMZ Export Options Dialog box is used to identify treatment of credits associated with the model.

Preserve Credits
The Preserve Credits checkbox keeps SketchUp model attribution credits with the KMZ file. This is useful when uploding a KMZ file to the 3Dwarehouse.

Exporting KMZ files

To export a KMZ file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the KMZ export type from the 'Export type' (Microsoft Windows) or 'Format’' (Mac OS X) drop-down list.
. Click the Export button.
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OBJ export
OBJ Export Options dialog box

@ This is a Pro only feature.

The OBJ Export Options dialog box contains options for exporting OBJ files.
Geometry

Export only current selection

The Export only current selection checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no selection.
Additionally, the entire model is exported when this checkbox is not checked.

Triangulate all faces
The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.
Export two-sided faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the
resulting OB]J file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always
render, and materials applied to front and back faces are preserved.

Export edges

The Export edges checkbox is used to write SketchUp line entities as OBJ line entities. Edges are ignored when this checkbox is not checked. Usually this
checkbox is not checked because most applications will ignore edges on import.

Materials

The Materials section of OBJ Export Options Dialog box is used to identify how materials will be exported.
Export texture maps

Check the Export texture maps checkbox to export textures with your OB]J file.

Scale

The Scale section OBJ Export Options Dialog box is used to identify the scale used in the OBJ output.
Swap YZ coordinates (Y is up)

The Swap YZ coordinates check box is used to output the model with the vertical direction as Y. This orientation is the default orientation for some applications,
such as Maya. Do not check this box if you want your model to be output with the Z axis in the vertical direction, such as when using 3D Studio Max.

Units

The units drop-down list is used to determine the unit size in the OBJ output. The Model Units setting is used to select the units that are being used in SketchUp.
OBJ export known issues and limitations

@ This is a Pro only feature.

OBJ file names

OB files do not support spaces in their filenames. SketchUp will replace any space with an underscore () when the file is saved.
Triangulation errors

SketchUp will export one face entity as one polygon in an OB file. This ratio of faces to polygons can create some problems for some OBJ importers (polygons
might appear missing or reversed). Use the Triangulate faces option to create additional polygons for importers that seem to have problems with the OBJ file
exported from SketchUp. Additionally, you can import the OBJ file into an application that does not have problems with the SketchUp faces-to-polygons ratio and
then export that file as another file type to be used in the less-qualified application.

Flat set hierarchy

The OBJ output supports a flat set membership hierarchy meaning that the format identifies which objects belong to any set. This output does not support a tree
hierarchy because it cannot identify if one particular set is actually a component of another set. This limitation is a limitation of the OBJ format.

NURBS
SketchUp does not output nurbs or any of the advanced OB]J entities. SketchUp outputs polygon faces only.
Maya and PNG or JPG files (Mac OS X)

PNG and JPG images included in an OBJ do not always appear in Maya. This issue appears to occur due to a Maya bug on the Macintosh platform.
3D Model (OBJ) Export

@ This is a Pro only feature.

The OBJ file format is a 3D file format created by Wavefront for use in their Advanced VisualizerFdé product. These files text-based and support free-form and
polygonal geometry. An additional '.mtl' file describes materials defined in the ".obj' file.

Exporting OBJ files

@ This is a Pro only feature.
To export an OB file:

1. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows). 244
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. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the OBJ export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The OBJ Export Options dialog box is displayed.

. (optional) Adjust the options in the OBJ Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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FBX export
The FBX Export Options dialog box

@ This is a Pro only feature.

The XSI Export Options dialog box contains options for exporting XSl Files.

Geometry

The Geometry section of the FBX Export Options dialog box is used to identify the geometry that will be exported.
Export only current selection

The Export only current selection only checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no
selection. Additionally, the entire model is exported when this checkbox is not checked.

Triangulate all faces
The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.
Export two-sided faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the
resulting XSl file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always
render, and materials applied to front and back faces are preserved.

Materials

The Materials section of the FBX Export Options dialog box is used to identify how materials will be exported.
Export texture maps

Check the Export texture maps checkbox to export textures with your FBX file.

Scale

The Scale section of the FBX Export Options dialog box is used to identify the scale used in the F BX output.
Swap YX coordinates (Y is up)

Units

The units drop-down list is used to determine the unit size in the FBX output.
Exporting FBX files

@ This is a Pro only feature.
To export a FBX model file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the FBX export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The FBX Export Options dialog box is displayed.

. (optional) Adjust the options in the FBX Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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XSI export
The XSI Export Options dialog box

@ This is a Pro only feature.

The XSI Export Options dialog box contains options for exporting XSl files.

Geometry

The Geometry section of the FBX Export Options dialog box is used to identify the geometry that will be exported.
Export only current selection

The Export only current selection only checkbox is used to export the currently selected geometry. The entire SketchUp model is exported when there is no
selection. Additionally, the entire model is exported when this checkbox is not checked.

Triangulate all faces

The Triangulate all faces checkbox is used to break the output into triangles instead of multi-sided faces.

Export two-sided faces

The Export two-sided faces checkbox is used to export faces twice, once for the front and once for the back. This option doubles the number of polygons in the
resulting XSl file and can slow down rendering. However, this option ensures that your model will appear more like it appears in SketchUp. Both faces will always
render, and materials applied to front and back faces are preserved.

Materials

The Materials section of the XSI Export Options dialog box is used to identify how materials will be exported.

Export texture maps

Check the Export texture maps checkbox to export textures with your XSl file.

Scale

The Scale section XSI Export Options dialog box is used to identify the scale used in the XSI output.

Swap YX coordinates (Y is up)

The Swap YZ coordinates check box is used to output the model with the vertical direction as Y. This orientation is the default orientation for some applications,
such as Maya. Do not check this box if you want your model to be output with the Z axis in the vertical direction.

Units

The Units drop-down list is used to determine the unit size in the OBJ output.
3D Model (XSI) Export

@ This is a Pro only feature.

SketchUp allows you to export your models as Soft Image (XSI) files. Export a XSl file using the Export > 3D Model menu item in the File menu.
Exporting XSl files

@ This is a Pro only feature.
To export a XSI model file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the XSI export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The XSI Export Options dialog box is displayed.

. (optional) Adjust the options in the XSI Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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VRML export
3D Model (VRML) Export

@ This is a Pro only feature.

VRML 2.0 (Virtual Reality Modeling Language) is a 3D scene/object description format often used to exchange data between 3D applications and to publish 3D
information to the web. VRML files can store SketchUp geometry in the form of edges, faces, groups, materials and textures, transparency, camera views, and
lights.

Exporting VRML Files

@ This is a Pro only feature.
To export a VRML file:

. Select File > Export > 3D Model. The Export Model dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the VRML export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.
. (optional) Click on the Options button. The VRML Export Options dialog box is displayed.

. (optional) Adjust the options in the VRML Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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The VRML Export Options dialog box (Microsoft Windows)

@ This is a Pro only feature.

The VRML Export Options dialog box contains options for exporting VRML files.

Appearance

The Appearance section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.
Output texture maps

If enabled, SketchUp will export texture information to the VRML file. When disabled, it will export colors only. When publishing VRML files to the web, you may
want to edit the files so that textures read from the relative location rather than from your local hard drive. Also, VRML texture and material names cannot have
blanks, so SketchUp will use the underscore character instead.

Ignore back of face materials

The Ignore back of face materials checkbox is used to export both front and back faces with the front material. SketchUp exports VRML files with double faces so
that files will be viewable from any viewpoint.

Output Edges
The Output Edges check box exports displayed edges as VRML edge entities.
Use 'color by layer' materials

The VRML file format does not support layers directly. The Use 'color by layer' materials checkbox is used to assign VRML materials based on your model's layer
assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.

Use VRML standard orientation

The Use VRML standard orientation checkbox is used to export a file that conforms to the VRML standard. The VRML standard considers the XZ plane to be
horizontal the ground plane) whereas SketchUp considers the XY plane to be the ground plane.

Generate cameras

The Generate cameras checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The current SketchUp
view is exported with the name 'Default Camera,' and other Scene camera definitions are output using their Scene Name.

Allow mirrored components
The Allow mirrored components check box is used to export components that have been mirrored or resized so they are an opposite of the original component.
Check for material overrides

The Check for material overrides check box is used to determine if any of the faces, edges, or components within this component contain references to the
default material or default layer.

VRML Export Options dialog box (Mac OS X)

@ This is a Pro only feature.

The VRML Export Options dialog box contains options for exporting VRML files.

Geometry

The Geometry section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.
Use VRML standard orientation

The Use VRML standard orientation checkbox is used to export a file that conforms to the VRML standard. The VRML standard considers the XZ plane to be
horizontal the ground plane) whereas SketchUp considers the XY plane to be the ground plane.

Allow mirrored components
The Allow mirrored components check box is used to export components that have been mirrored or resized so they are an opposite of the original component.
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Output edges

The Output edges check box exports displayed edges as VRML edge entities.

Materials

The Materials section of the VRML Export Options dialog box contains options to configure the appearance of the exported VRML file.
Ignore back of face materials

The Ignore back of face materials checkbox is used to export both front and back faces with the front material. SketchUp exports VRML files with double faces so
that files will be viewable from any viewpoint.

Check for material overrides

The Check for material overrides check box is used to determine if any of the faces, edges, or components within this component contain references to the
default material or default layer.

Output texture maps

If enabled, SketchUp will export texture information to the VRML file. When disabled, it will export colors only. When publishing VRML files to the web, you may
want to edit the files so that textures read from the relative location rather than from your local hard drive. Also, VRML texture and material names cannot have
blanks, so SketchUp will use the underscore character instead.

Use 'color by layer' materials

The VRML file format does not support layers directly. The Use 'color by layer' materials checkbox is used to assign VRML materials based on your model's layer
assignments in SketchUp. Check this checkbox to export materials based on layers, such as when exporting to other rendering applications.

Cameras
The Cameras section of the VRML Export Options dialog box contains an option to generate cameras for the exported VRML file.
Generate cameras from Scenes

The Generate cameras from Scenes checkbox is used to create a camera for the default view as well as any SketchUp Scenes which have been defined. The current
SketchUp view is exported with the name 'Default Camera,’ and other Scene camera definitions are output using their Scene Name.
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2D export

Export Image Options dialog box

The Export Image Options dialog box contains options for exporting raster image files.
Image Size

Use View Size

The Use view size is used to set your output to a 1:1 (real world) scale.

Width/Height

The Width and Height fields are used to control the size of image as measured in pixels or specific units. Click on the chain icon to the right of the text fields to
lock the aspect ratio of the export (Mac OS X).

Resolution (Mac OS X)

The Resolution drop-down list is used to select the resolution for the exported image. For viewing images on the screen, 72-96 pixels/inch is adequate. For
printing, you might want to increase the resolution to 150-300 pixels/inch. Remember, high resolution images take longer to generate.

Rendering

Anti-Alias

When enabled, SketchUp will smooth the exported image. This method can take longer, but it helps to reduce jagged lines and pixilated artifacts in images.
JPEG Compression

The slider bar for a JPEG export is used to define the level of JPEG compression quality. The level of quality becomes lesser and the file size is smaller as the slider
is moved to the left. Conversely, the level of quality becomes higher and the file size is larger if the slider is moved to the right.

2D Graphic Export (Microsoft Windows)

SketchUp allows you to export 2D raster image files in JPEG, BMP, TIFF, and PNG raster file formats. Export a file using the Export > 2D Graphic menu item in the
File menu.

Note: Shadows cannot be saved with a 3D model. None of the 2D vector output formats support rendering features such as shadows, textures, or transparency.
The only export formats that will represent shadows as seen on your display are pixel-based raster images and animations.

SketchUp allows you to export 2D raster image files in JPEG, TIFF, PNG, and Epix formats. Export a file using the Export > 2D Graphic menu item in the File
menu.

Note: Shadows cannot be saved with a 3D model. None of the 2D vector output formats support rendering features such as shadows, textures, or transparency.
The only export formats that will represent shadows as seen on your display are pixel-based raster images and animations.

Exporting a Raster Image

To export a 2D graphic file:

1. Manipulate the view of the model so that it appears as you would like it to appear in the exported file. SketchUp will export the model view as it is currently
displayed, including display style, edge rendering, shadows, and point of view.

. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box is displayed (Microsoft Windows).

Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.

. Click the Export button.

. (optional) Click the Options button. The 'Export Image Options' dialog box is displayed.

. (optional) Adjust the options in the Export Image Options dialog box.

. (optional) Click the OK button.

. Click the OK button.
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PDF/EPS export
PDF/EPS Hidden Line Options dialog box (Microsoft Windows)

@ This is a Pro only feature.

The PDF/EPS Hidden Options dialog box contains options for exporting 2D PDF and EPS Files.

Drawing size

The Drawing size section of the PDF/EPS Hidden Options dialog box contains size and scaling options for your model.
Full Scale (1:1)

Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

Width/Height

The width and height fields are used to enter a custom page size for your file.

In Hidden-Line Output/In SketchUp

In Hidden-Line Output/In SketchUp fields are used to scale your model for export. The first measurement, labeled In Hidden-Line Output, is the measurement of
the exported geometry. The second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" =
1', simply enter 1 inch In SketchUp equals 4 feet In Hidden Line Output.

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable this scale option.

Profile lines
The Profile Lines section of the PDF/EPS Hidden Options dialog box contains options for exporting profile lines.
Show profiles

The Show profiles option exports any lines that are displayed in profile as thicker lines in the 2D vector file. All lines are output normally, without profile
thickness, when this option is disabled (regardless of the screen display).

Match screen display (auto width)

The Match screen display (auto width) automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp drawing
area. This option is only available when Show profiles is checked.

Width

The Width fields are used to specify an exact width for the profile lines. This option is only available when 'Show Profiles' is checked and 'Match screen display
(auto width)' is unchecked.

Section lines

The Section Lines section of the DWG/DXF Hidden Options dialog box contains options for exporting section lines.
Specify section line width

The Specify section line width option is used to adjust settings for Section Slice lines that are output.

Match screen display (auto width)

The Match screen display (auto width) automatically sets the width of section lines by matching the output to the proportions you see in the SketchUp drawing
area. This option is only available when 'Specify section line width' is checked.

Width

The Width fields are used to specify an exact width for the section lines. This option is only available when 'Specify section line width' is checked and 'Match
screen display (auto width)' is unchecked.

Extension Lines
The Extension Lines section of the PDF/EPS Hidden Options dialog box contains options for exporting extension lines.
Extend edges

Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extension lines. The Extend edges option is used to
toggle the export of line extensions.

Match screen display (auto width)

The Match screen display (auto width) automatically sets the width of extension lines by matching the output to the proportions you see in the SketchUp drawing
area. This option is only available when Extend edges is checked.

Width

The Width fields are used to specify an exact width for the extension lines. This option is only available when 'Extend edges' is checked and 'Match screen display
(auto width)" is unchecked.

Always prompt for hidden line options

The Always prompt for hidden line options is used to automatically display the Hidden Line Options dialog box when you export a 2D PDF or EPS file.
Map Windows fonts to PDF base fonts

This option is used to select PDF fonts that correspond to the Windows fonts used in the model.

Defaults

The Defaults button is used to return the items in the Hidden Line Options dialog box to the default settings.
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2D Graphic (PDF/EPS) Export

@ This is a Pro only feature.

SketchUp allows you to export your models as 2D vector drawings, including PDF and EPS. Export a file using the Export > 2D Graphic menu item in the File
menu.

2D PDF/EPS Export Details

@ This is a Pro only feature.

The PDF and EPS export is used to export vector SketchUp files for use in other vector-based editing programs like Adobe lIllustrator.

Warning: Some graphic features of SketchUp, including textures, shadows, smooth shading, backgrounds, and transparency, cannot be exported to PDF and EPS.
Text and Dimensions

SketchUp will attempt to output text annotation and notes to your 2D drawing. Please note the following limitations:

e Text and dimension entities that are obscured (partially or totally) by other geometry in the SketchUp drawing area export on top of the geometry.
e Text and dimension entities that are partially clipped by the edges of the SketchUp drawing area are not exported.
e Certain fonts may not export exactly.

Exporting PDF or EPS files

@ This is a Pro only feature.
To export a 2D PDF or EPS graphic file:

. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.

. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box is displayed.

. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. (optional) Click on the Options button. The PDF/EPS Hidden Line Options dialog box (Microsoft Windows) or Export 2D Graphic dialog box (Mac OS X) is
displayed.

. Select EPS File (*.eps) or PDF File (*.pdf) from the Format drop-down dialog box.

. (optional) Click on the Options button. The Export Options dialog box is displayed.

. Adjust the export options. Refer to the PDF/EPS Hidden Line Options dialog box (Microsoft Windows) or Export 2D Graphic dialog box (Mac OS X) for
further information.

. (optional) Click the OK button.

. Click the Export button.
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Note: SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.
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2D DWG/DXF export
DWG/DXF Export Options dialog box (Mac)

@ This is a Pro only feature.

The DWG/DXF Export Options dialog box contains options for exporting 2D DWG and DXF Files.

Drawing Scale & Size

The Drawing Scale & Size section of the DWG/DXF Hidden Options dialog box contains scaling options for your model.
Full Scale (1:1)

The Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

In Drawing/In Model

The In Drawing/In Model fields are used to scale your model for export. The first measurement, labeled In the Model, is the measurement of the exported
geometry. The second measurement, labeled In Drawing, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter
1 inch In Model equals 4 feet In Drawing.

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable this scale option.

Width/Height

The width and height fields are used to enter a custom page size for your file.

Profile Lines

The Profile Lines section of the DWG/DXF Hidden Options dialog box contains options for exporting profile lines.
None

The None option is used to export profile lines at standard width.

Polylines with width

The Polylines with width option is used to export profile lines as AutoCAD polyline entities.

Wide line entities

The Wide line entities option is used to export profile lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG
files.

Separate on a layer

The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen
weight or quickly change the line width of all profile lines in a separate CAD or lllustration program.

Note: The Separate on a layer option creates a single additional layer for profile edges. SketchUp Layer assignments do not translate directly when exporting 2D
hidden line vectors.

Width

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and
Automatic is unchecked.

Automatic

The Automatic option is used to set the width of profile lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only
available when Polylines with width is checked.

Section Lines

The Section Lines section of the Export Options dialog box contains options for exporting section lines.
None

The None option is used to export section slice lines at standard width.

Polylines with width

The Polylines with option is used to export section slice lines as AutoCAD polyline entities.

Wide line entities

The Wide line entities option is used to export section slice lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later
DWG files.

Separate on a layer

The Separate on a layer option is used to output section slice lines onto their own layer. This option is useful if you would like to plot section slice lines using a
different pen weight or quickly change the line width of all section slice lines in a separate CAD or lllustration program.

Note: The Separate on a layer option creates a single additional layer for section slice edges. SketchUp Layer assignments do not translate directly when
exporting 2D hidden line vectors.
Width

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and
Automatic is unchecked.
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Automatic

The Automatic option is used to set the width of section slice lines by matching the output to the proportions you see in the SketchUp drawing area. This option
is only available when 'Polylines with width' is checked.

Edge Extensions
The Edge Extensions section of the Export Options dialog box contains options for exporting extension lines.
Show extensions

Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extensions. The show extensions option is used to
toggle the export of line extensions.

Length

The Length field is used to specify an exact length for line extensions. This option is only available when 'Show extensions' is checked and 'Automatic’ is
unchecked.

Automatic

The Automatic option is used to set the length of extension lines by matching the output to the proportions you see in the SketchUp drawing area. This option is
only available when Show extensions is checked.

DWG/DXF Hidden Line Options dialog box (Microsoft Windows)

@ This is a Pro only feature.

The DWG/DXF Hidden Line Option dialog box contains options for exporting 2D DWG and DXF Files.

Drawing Scale & Size

The Drawing Scale & Size section of the DWG/DXF Hidden Options dialog box contains scaling options for your model.

Full Scale (1:1)

The Full Scale (1:1) option is used to set your output to a 1:1 (real world) scale.

In Drawing/In Model

The In Drawing/In Model fields are used to scale your model for export. The first measurement, labeled In the Model, is the measurement of the exported
geometry. The second measurement, labeled In Drawing, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter
1 inch 'In Model' equals 4 feet 'In Drawing."'

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable this scale option.

Width/Height

The width and height fields are used to enter a custom page size for your file.

AutoCAD Version

The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.

Profile Lines

The Profile Lines section of the DWG/DXF Hidden Option dialog box contains options for exporting profile lines.

None

The None option is used to export profile lines at standard width.

Polylines with width

The Polylines with width option is used to export profile lines as AutoCAD polyline entities.

Wide line entities

The Wide line entities option is used to export profile lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later DWG
files.

Separate on a layer

The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen
weight or quickly change the line width of all profile lines in a separate CAD or Illustration program.

Warning: The Separate on a layer option creates a single additional layer for profile edges. SketchUp layer assignments do not translate directly when exporting
2D hidden line vectors.
Width

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and
Automatic is unchecked.

Automatic

The Automatic option is used to set the width of profile lines by matching the output to the proportions you see in the SketchUp drawing area. This option is only
available when 'Polylines with width' is checked.

Section Lines
The Section Lines section of the DWG/DXF Hidden Options dialog box contains options for exporting section lines.

None
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The None option is used to export section slice lines at standard width.

Polylines with width

The Polylines with option is used to export section slice lines as AutoCAD polyline entities.
Wide line entities

The Wide line entities option is used to export section slice lines as AutoCAD wide line entities. This option is only available when saving AutoCAD 2000 or later
DWG files.

Separate on a layer

The Separate on a layer option is used to output section slice lines onto their own layer. This option is useful if you would like to plot section slice lines using a
different pen weight or quickly change the line width of all section slice lines in a separate CAD or lllustration program.

Note: The Separate on a layer option creates a single additional layer for section slice edges. SketchUp Layer assignments do not translate directly when
exporting 2D hidden line vectors.
Width

The Width field is used to specify an exact width for the Polylines with width option. This option is only available when Polylines with width is checked and
Automatic is unchecked.

Automatic

The Automatic option is used to set the width of section slice lines by matching the output to the proportions you see in the SketchUp drawing area. This option
is only available when 'Polylines with width' is checked.

Extension Lines
The Extension Lines section of the DWG/DXF Hidden Options dialog box contains options for exporting extension lines.
Show extensions

Some CAD applications might have problems recognizing endpoints and intersections of lines with SketchUp extensions. The show extensions option is used to
toggle the export of line extensions.

Length

The Length field is used to specify an exact length for line extensions. This option is only available when 'Show extensions' is checked and 'Automatic' is
unchecked.

Automatic

The Automatic option is used to set the length of extension lines by matching the output to the proportions you see in the SketchUp drawing area. This option is
only available when Show extensions is checked.

Always Prompt for Hidden Line Options
The Always Prompt for Hidden Line Options is used to automatically display the Hidden Line Options dialog box when you export a 2D DWG or DXF file.
Defaults

The Defaults button is used to return the items in the Hidden Line Options dialog box to the default settings.
2D Graphic (DWG/DXF) Export

@ This is a Pro only feature.

SketchUp allows you to export your models as 2D vector drawings, including DWG and DXF. Export a file using the Export > 2D Graphic menu item in the File
menu.

Exporting 2D DWG or DXF Files

@D This is a Pro only feature.
To export a 2D DWG or DXF graphic file:

. Manipulate the view of the model so that it appears as you would like it to appear in the exported file.

. Select File > Export > 2D Graphic. The Export 2D Graphic dialog box is displayed (Microsoft Windows).

. Enter a file name for the exported file in the 'File' name (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the DWG or DXF export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.

. (optional) Click on the Options button. The DWG/DXF Hidden Line Options dialog box is displayed.

. (optional) Adjust the options in the DWG/DXF Hidden Line Options (Microsoft Windows) or Export Options (Mac OS X) dialog box.
. (optional) Click the OK button.

. Click the Export button.
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Note: SketchUp exports the model using the current point of view with the exception of unsupported features such as textures and shadows.
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Section slice export
Section Slice Export

@ This is a Pro only feature.

SketchUp can save the active Section Slice as its own 2D file in the DWG and DXF formats. As with all vector information, section slice export has the advantage of
preciseness. Export a section slice using the Export > Section Slice menu item in the File menu.

Exporting Section Slices

@ This is a Pro only feature.
To export a section slice:

. Double-click on the Section Plane entity whose section slice you want to export.

. Select File > Export > Section Slice. The Export 2D Section Slice dialog box is displayed (Microsoft Windows).
. Enter a file name for the exported file in the 'File name' (Microsoft Windows) or 'Save As' (Mac OS X) field.

. Select the export type from the 'Export type' (Microsoft Windows) or 'Format' (Mac OS X) drop-down list.

. (optional) Click on the Options button. The Section Slice Export Options dialog box is displayed.

. (optional) Adjust the options in the Section Slice Export Options dialog box.

. (optional) Click the OK button.

. Click the Export button.
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2D Section Slice Options dialog box (Microsoft Windows)

@D This is a Pro only feature.

The 2D Section Slice Export Options dialog box contains options for exporting 2D section slice files.
Projection

The Projection section contains options for selecting the type of exported file.

True section (orthographic)

This option outputs the section slice as a true orthographic drawing. This is useful for creating templates for CD drawings or any other time you want to generate
accurate, measurable slices.

Screen projection (WYSIWG)

This projects the section cut as you see it on your SketchUp screen, including any perspective distortion. This is most useful for diagrams that need not be
measured.

Drawing scale & size

The Drawing scale and size section of the Section Slide Export Options dialog box contains options to configure the scale and size of the exported section slice.
Full Scale (1:1)

Select Full Scale (1:1) to output your section slice to CAD at a true 1:1 scale.

Width/Height

These values represent the overall dimensions of the slice output, and will update depending on the slice being exported and its scale.

In Drawing/In Model

These controls allow you to specify a certain drawing scale, and follow architectural conventions. The first measurement, labeled 'In Drawing' is the measurement
of the exported geometry. The second measurement, labeled 'In Model' is the actual measurement of the object in real scale.

For example, for a scale of 1/4" = 1', simply enter 1 inch in the output equals 4 feet in SketchUp.

Note: You cannot export a perspective screen projection to scale. Also, even if the view is a paraline projection, only faces whose normals are perpendicular to
the view angle will be measurable.

AutoCAD version

The AutoCAD section of the AutoCAD DWG/DXF Export Options dialog box is used to select the version of exported DWG/DXF file.

Section lines

The Section lines section of the Section Slice Export Options dialog box contains options to configure the section cut lines of the exported section slice.
None

Outputs section slice lines at normal width.

Polylines with width

Select the Polylines with width option to output lines as polyline entities.

Wide line entities

Select the Wide line entities to output lines as wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.
Separate on a layer

The Separate on a layer option is used to output profile lines onto their own layer. This option is useful if you would like to plot profile lines using a different pen
weight or quickly change the line width of all profile lines in a separate CAD or lllustration program.

Note: The Separate on a layer option creates a single additional layer for profile edges. SketchUp Layer assignments do not translate directly when exporting 2D
hidden line vectors.
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Width/Automatic

When enabled, this automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp display. If disabled, you can
specify an exact width.

Always Prompt for Hidden Line Options

When enabled, the options dialog will come up each time you output a section slice. When disabled, SketchUp will use whatever options were used the last time
by default.

2D Section Slice Options dialog box (Mac OS X)

@ This is a Pro only feature.

The 2D Section Slice Export Options dialog box contains options for exporting 2D section slice files.

Width/Height

These values represent the overall dimensions of the slice output, and will update depending on the slice being exported and its scale.
Drawing scale

The Drawing scale section of the Section Slice Export Options dialog box contains options to configure the scale of the exported section slice.
Full Scale (1:1)

Use the Full Scale (1:1) option to output your section slice to CAD at a true 1:1 scale.

In Drawing/In Model

These controls allow you to specify a certain drawing scale, and follow architectural conventions. The first measurement, labeled 'In Drawing' is the measurement
of the exported geometry. The second measurement, labeled 'In Model' is the actual measurement of the object in real scale.

For example, for a scale of 1/4" = 1', simply enter 1 inch in the output equals 4 feet in SketchUp.

Note: You can't export a perspective screen projection to scale. Also, even if the view is a paraline projection, only faces whose normals are perpendicular to the
view angle will be measurable.

Section lines

The Section lines section of the Section Slice Export Options dialog box contains options to configure the section cut lines of the exported section slice.
None

Outputs section slice lines at normal width.

Polylines with width

Use the Polylines with width option to output lines as polyline entities.

Wide line entities

Use the Wide line entities option to output lines as wide line entities. This option is only available when saving AutoCAD 2000 or later DWG files.
Automatic/Width

When enabled, this automatically sets the width of profile lines by matching the output to the proportions you see in the SketchUp display. If disabled, you can
specify an exact width.

Projection
The Projection section contains options for selecting the type of exported file.
True section (orthographic)

This option outputs the section slice as a true orthographic drawing. This is useful for creating templates for CD drawings or any other time you want to generate
accurate, measurable slices.

Screen projection (WYSIWG)

This projects the section cut as you see it on your SketchUp screen, including any perspective distortion. This is most useful for diagrams that need not be
measured.
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Animation export
Animation export

@ This is a Pro only feature

You can export animations as video animation files or as series of image file, one file for each frame per second of your presentation. Export an animation using
the Export > Animation menu item in the File menu.

Tip: Use the Animation Export feature when you need to provide a presentation of your model to a client who does not have SketchUp or the SketchUp viewer. Or,
export a video animation for post-processing in another presentation software package. Use SketchUp for simple presentations or when the customer has the
SketchUp viewer.

Animation types

SketchUp supports both single video animation file export (in the form of an Audio Video Interleave or AVI on Microsoft Windows and QuickTime on Mac OS X)
and multiple image file export.

Single video file animations

SketchUp allows you to export animation as a single video animation file (Audio Video Interleave or AVI on Microsoft Windows and QuickTime on Mac OS X).
These files can be played using any compatible software video player or incorporated into a professional presentation using additional software presentation
tools. SketchUp utilizes special third-party software called codecs (compressor/decompressor) to create these files. The following image shows the process of
video compression on Microsoft Windows:
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Each codec included with SketchUp implements a compression technique designed for a specific medium such as Web video, Email, or CD-ROM.
Multiple Image File Animations

SketchUp also allows you to export an animation as a series of progressive image files. The number of files exported depends on the frame rate for the
presentation. For example, a 5 minute presentation exported at 10 frames per-second will yield 3000 files (60 seconds x 5 minutes x 10 frames per-second).
Multiple image file animations are typically generated to use as input into video animation software products for post-processing.

The Animation Export Options dialog box (Mac OS X)

The Animation Export Options dialog box contains options for exporting Animation files.

Settings

The settings section of the Animation Export Options dialog box contains options for controlling resolution and frame size for the video animation.
Format

The Format drop-down list is used to select the combination of resolution, frame rate, and codec based on your particular output medium (Web, CD ROM, Email,
and so on). For example, the suggested combination of settings for streaming a video over the Web is 160x120 resolution at 10 frames per second using the
Sorenson codec.

Select Custom from the Format drop-down list configure your own custom
Width/Height

The Width and Height fields are used to control the frame size of the animation, as measured in pixels. The smaller the width and height values, the smaller the
overall size, in kilobytes, the video animation file.

Tip: Computer screens can handle resolutions of 1024x768 pixels and above. However, 640x480 pixels is considered a full-size video. Typical videos are created
at an even lower frame size. For example, 320x240 is yields acceptable data rates for CD-ROM, and transfers acceptably to videotape while 240x180 is
acceptable for Web streaming. Values larger than 640x480 are not recommended unless specifically require such as when creating Full Quality Digital Video
similar to that of professional videographers.

Note: Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame size, the larger the resulting video
animation file. Large video animation files can slow down your computer resulting in skipping.

Aspect Ratio Lock

The Aspect Ratio Lock icon is used to maintain a fixed proportion of video at any frame size. Click on this lock to use a nonproportional frame size in your video
animation.
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Frame Rate

The Frame Rate drop-down list is used to select the number of frames of animation per second (fps) of time in the presentation. The more frames per-second,
the smoother the video animation. However, doubling the frame rate generally doubles the rendering time as well as the final size of the video. A setting between
8 and 10 is considered the minimum required to produce smooth movement in your video animation. You might consider using a frame rate of 3 frames per-
second while testing video animation export.

Note: There are frame rate requirements for certain mediums, such as 29.97 fps for television in the United States, 25 fps for television in Europe, 24 fps for film,
and so on.

Note: Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame rate, the larger the resulting video
animation file. Large video animation files can slow down your computer resulting in skipping.

Loop to Starting Scene

The Loop to Starting Scene option is used to generate an additional video segment that animates from the last scene of your presentation to the first (forming a
continuous loop of video).

Expert

Click the Expert button to launch the Compression Settings dialog box. This dialog box allows you to modify the settings used by a specific codec.
Rendering

The rendering section of the Animation Export Options dialog box contains options for rendering your video animation.

Anti-Alias

The Anti-Alias option is used to smooth the exported image. This option can increase the export time, but helps to reduce jagged lines and pixilated artifacts in
images.

Transparent Background

The Transparent Background option is used to save the animation with a transparent background to aid in compositing. However, not all codecs are capable of
storing transparency.

The Animation Export Options dialog box (Microsoft Windows)

The Animation Export Options dialog box contains options for exporting Animation files.
Width/Height

The Width and Height fields are used to control the frame size of the animation, as measured in pixels. The smaller the width and height values, the smaller the
overall size, in kilobytes, the video animation file.

Tip: Computer screens can handle resolutions of 1024x768 pixels and above. However, 640x480 pixels is considered a full-size video. Typical videos are created
at an even lower frame size. For example, 320x240 is yields acceptable data rates for CD-ROM, and transfers acceptably to videotape while 240x180 is
acceptable for Web streaming. Values larger than 640x480 are not recommended unless specifically require such as when creating Full Quality Digital Video
similar to that of professional videographers.

Note: Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame size, the larger the resulting video
animation file. Large video animation files can slow down your computer resulting in skipping.

Aspect Ratio Lock

The Aspect Ratio Lock icon is used to maintain a fixed proportion of video at any frame size. Click on this lock to use a nonproportional frame size in your video
animation.

Frame Rate

The Frame Rate drop-down list is used to select the number of frames of animation per second (fps) of time in the presentation. The more frames per-second,
the smoother the video animation. However, doubling the frame rate generally doubles the rendering time as well as the final size of the video. A setting between
8 and 10 is considered the minimum required for to produce smooth movement in your video animation. You might consider using a frame rate of 3 frames per-
second while testing video animation export.

Note: There are frame rate requirements for certain mediums, such as 29.97 fps for television in the United States, 25 fps for television in Europe, 24 fps for film,
and so on.

Note: Most personal computers can transfer 5 to 7 megabytes of data per second from the hard drive. The larger the frame rate, the larger the resulting video
animation file. Large video animation files can slow down your computer resulting in skipping.

Loop to Starting Scene

The Loop to Starting Scene option is used to generate an additional video segment that animates from the last scene of your presentation to the first (forming a
continuous loop of video).

Anti-Alias

The Anti-Alias option is used to smooth the exported image. This option can increase the export time, but helps to reduce jagged lines and pixilated artifacts in
images.

Codec

The Codec option is used to specify which codec, or compression plug-in, to apply to your video animation.

Play When Finished

The Play When Finished option is used to start your default video player and play exported video animation file after it has been created.
Always Prompt for Animation Options

The Always Prompt for Animation Options option is used to display the Animation Export Options dialog box every time a video animation is created.

Exporting an animation

Animation files can be used to present your model without the need for SketchUp. Or, you import your files into another presentation or animation product to
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further enhance your animations. To Export an animation as an animation file (or series of image files):

1. Select the File > Export > Animation menu item. The Export Animation dialog box is displayed.
2. Select the export type from the 'Export type' drop-down list.
3. Enter the name for the exported file or series of files. The animation exporter will combine this name with a sequencing number for each image file that is

created as part of a multiple image file animation. For example, if you export a 1 minute presentation called mypres.jpg, at 10 frames per-second, you will
get 600 files, each named mypres0001.jpg, mypres0002.jpg, mypress0003.jpg all the way to mypress0600.jpg.

4. Click on the Options button. The Animation Export Options dialog box is displayed. The following image contains the Animation Export Options dialog
box on Microsoft Windows:

Settings
Width: |320
} % 43 =
Height: |240
Frame Rate: |10 v frames/second
[V Loop to starting page
I Play when finished
Codec: Cinepak Codec by Radius
Rendering
IV Antiglias
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oK Cancel Defaults

The following image contains the Animation Export Options dialog box on Mac OS X:

Export Options

Settings
Format: | Full Quality DV 3]
Width: 720 2 :
Height: 480 3
Frame Rate. | 29.97 19 fps
 Loop To Starting Page
{ Expert... )
Rendering

gAnn alias

— Transparent Background

! Cancel ) @

5. Modify animation export options as necessary. See Animation Export Options in this topic for further information.
6. Click on the Export button to export the presentation as an animation.

Refer to Creating an Animation for further information
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Printing
Printing (Microsoft Windows)

SketchUp allows you to print your designs using any Windows-compatible printing device. You can also print to scale and span a print across multiple sheets,
allowing you to output a large drawing from a standard printer. Printing is a three-step process:

1. Select the paper size for your printer using File > Print Setup.
2. Configure the output size and preview your output using File > Print Preview.
3. Print your model using File > Print.

Printing (Mac OS X)

SketchUp allows you to print your designs using any Mac OS X-compatible printing device. Printing is a four-step process:

. Select the paper size for your printer using File > Page Setup.

. Configure your model size printing using File > Document Setup.
. Preview your output using File > Print > Preview.

. Print your model using File > Print.
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Tip: Select the File > Print menu item to print using paper size and model size defaults.

Printing to scale

To print to scale (Windows):

. Select Camera > Parallel Projection. The check mark next to the Perspective menu item should disappear and SketchUp will enter paraline mode.
. Select the Camera > Standard Views. The Standard views submenu is displayed.

. Select a view. The drawing area changes to the view.

. Select the File > Print. The Print dialog box appears.

. Uncheck the 'Fit to page' checkbox. The Page size fields appear active.

. Set the scale using the Scale fields.

. Click the OK button. The model prints to scale.
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To print to scale (Mac):

. Select Camera > Parallel Projection. The check mark next to the Perspective menu item should disappear and SketchUp will enter paraline mode.
. Select the Camera > Standard Views. The Standard views submenu is displayed.

Select a view. The drawing area changes to the view.

. Select File > Document Setup. The Document Setup dialog box appears.

. Uncheck the 'Fit View to Page' checkbox. The Print Scale fields appear active.

. Set the scale using the Print Scale fields.

. Click the OK button.

. Select File > Print. The Print dialog box appears.

. Click the Print button. The model prints.

The Page Setup dialog box (Mac OS X)
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The Page Setup dialog box is used to set paper size and orientation specific to your printer. This dialog box is the same as all standard Page Setup dialog boxes
found in OS X applications. Select File > Page Setup to invoke the Page Setup dialog box.

Settings

The Settings drop-down list of the Page Setup dialog box contains a list of settings panels to appear in the Page Setup dialog box..
Page Attributes

The Page Attributes panel contains primary configuration settings for the Page Setup dialog box. Its settings are defined below in detail.
Custom paper size

The Custom paper size panel allows you to define custom paper sizes not currently configured for your selected printer.

Warning: You can define a paper size that your printer is not capable of using.

Summary

The Summary panel contains a summary of all current page attributes. You can use this panel to troubleshoot difficult print jobs, or to verify all the current page
attributes in one quick view.

Format for

The Format for drop-down list of the Page Setup dialog box is used to select a specific printer and printer settings. Select the printer to use from the Name drop-
down list.

Note: The Any Printer setting is a generic printer description that should set up a print job for any printer available. Use this setting if you are preparing a PDF file
for printing on a printer that is not configured on your system.

Paper Size

The Paper Size section of the Page Setup dialog box is used to select the paper size used for your output.

Orientation

The Orientation section of the Page Setup dialog box is used to select the orientation (landscape or portrait) for your output.
Scale

The Scale section of the of the Page Setup dialog box is used to override any SketchUp-specific scale settings.
The Print Preview and Print dialog boxes (Microsoft Windows)
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The Print Preview and Print dialog boxes contain the same series of options. The only difference is that the Print Preview dialog box outputs your model to the
screen instead of to a printer. Items configured in one of these dialog boxes automatically appear in the other dialog box. Select File > Print Preview or File >
Print to invoke the Print Preview and Print dialog boxes.
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The Print Preview and Print dialog boxes contain several printing options to consider when printing a SketchUp model.
Printer

The Printer section of the Print dialog box is used to select a specific printer and printer settings. Select the printer to use from the 'Name' drop-down list. Click
on the 'Properties' button to configure the printer for printing (the properties dialog box is different for each printer-type).

Tabbed page print range

The Tabbed print range section of the Print dialog box is used to choose between printing the model in the current draw area, or printing all models on all scenes
in the file.

Copies

The Copies section of the Print dialog box is used to select the number of copies to print. Click the 'collate’ button if you want each copy to be collate (instead of
printing several page ones, then several page twos, and so on).

Print size

The Print size section of the Print dialog box is used to adjust the physical size of your output.

Fit to page

The Fit to page option is used to size the model to fit on a single sheet of paper. This option must be disabled in to specify a different size or scale.
Page size

The Page size fields are used to enter a custom page size for your output.

Scale

The Scale fields are used to scale your model for printing. The first measurement, labeled In the Model, is the measurement of the exported geometry. The
second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1', simply enter 1 inch In the
Printout equals 4 feet In SketchUp.

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable the scale option.

Note: Even though paraline projection is used to get an output that is to scale, not all angles will be measurable to a scale. This issue is the result of SketchUp
using foreshortening, or a technique of shortening lines to create a 3D effect on a 2D medium such as paper.

Use model extents

The Use model extents option is used to print only the model as viewed using the Zoom Extents tool. This option might discard any surrounding empty
background.

Tiled sheet print range

If the current scale is larger than the paper size of your printer or plotter, the entire model can be printed by printing on several pieces of paper. These pieces of
paper can then be taped together to create the final scaled model. For example, tiling lets you print proofs of a large model, such as a B size (11" x 17"), on a
printer that uses a smaller paper size, such as an A size (8.5" x 11"). Tiling also lets you print banners that are made up of multiple pages.

Tiling is available when you use the Scale fields to scale a model to be larger than the current paper size available in your printer.

You can also print selected page tiles within the set by entering a page number range in the Pages from fields. Page tiles are numbered top to bottom beginning
at the top left of the drawing page.

You can display a preview of tile Pages using Print Preview in the File menu.

Printing large tiled output can be taxing on your computers resources.

Print quality

You can expedite the printing of print jobs and rough drafts by selecting the appropriate print quality.
Draft

The Draft setting is used to produces quick images (usually output has jagged lines).

Standard

The Standard setting is used to produce output with a the optimum balance of speed and quality.
High definition

The High Definition setting is used to produce high-quality output.
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Ultrahigh definition

The Ultrahigh definition setting is used to produce the highest-quality output. This setting can slow down your system, but is best for measured drawings or
ultra-fine prints.

Large format

The Large format setting produces images that are optimized for large format output or that are meant to be viewed from several feet away. Resolution and line
weights are set accordingly. This setting is useful for plotters and tiled sheets.

2D section slice only
The 2D section slice only option is used to output only the section slice outlines in your model (if present).
Use High Accuracy HLR

The Use High Accuracy HLR option is used to send the model information to the printer as vector information.

The Print dialog box (Mac OS X)

The Print dialog box is used to send your output to a printer, PDF file, or Fax. This dialog box is the same as all standard Print dialog boxes found in OS X
applications. Select File > Print to invoke the Print dialog box.

Settings

The Settings drop-down list displays various settings panels within the Print dialog box. The settings drop-down list is in the middle of the Print dialog box and
normally displays the 'Copies & Pages' settings.

The Copies and Pages Print dialog box panel
The Copies and Pages Print dialog box panel is used to control the number of copies and tiled output.
Copies

The Copies section of the Print dialog box is used to select the number of copies to print. Click the 'collate’ button if you want each copy to be collate (instead of
printing several page ones, then several page twos, and so on).

Pages

The Pages section of the Print dialog box is used to print selected page tiles within a set of tiled pages by entering a page number range in the Pages from fields.
Page tiles are numbered top to bottom beginning at the top left of the drawing page.

The Layout Print dialog box panel

The Layout Print dialog box panel is used to select the orientation (landscape or portrait) for your output.
The Scheduler Print dialog box panel

The Scheduler Print dialog box panel is used schedule the printing of your model for a later time.

The Paper Handling Print dialog box panel

The Paper Handling Print dialog box panel is used alternate between printing odd or even numbered pages.
The Color Sync Print dialog box panel

The Color Sync Print dialog box panel is used perform color conversion (if supported by your printer) and filters to your output.
The Paper Feed Print dialog box panel

The Paper Feed Print dialog box panel is used select the tray that contains the paper you want to use.

The SketchUp Print dialog box panel

There are a few SketchUp-specific settings in the Print dialog box that you can access by selecting SketchUp from the 'Settings' drop-down list in the middle of
the dialog box.

You can expedite the printing of print jobs and rough drafts by selecting the appropriate print quality.
Draft

The Draft setting is used to produces quick images (usually output has jagged lines).

Standard

The Standard setting is used to produce output with a the optimum balance of speed and quality.
High

The High setting is used to produce high-quality output.

Extra High

The Extra High Definition setting is used to produce the highest-quality output. This setting can slow down your system, but is best for measured drawings or
ultra-fine prints.

Vector Printing
The Vector Printing option is used to send the model information to the printer as vector information.
The Summary Print dialog box panel

The Summary Print dialog box panel contains a summary of all current page attributes. You can use this panel to troubleshoot difficult print jobs, or to verify all
the current page attributes in one quick view.

The Document Setup dialog box (Mac OS X)
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The Document Setup dialog box is used to configure settings specific to the current SketchUp model. Use Document Setup to set the print size, print scale and to
preview the number of pages required to print your drawing. Select File > Document Setup to invoke the Page Setup dialog box.

Print size

The Print size section of the Document Setup dialog box is used to determine the size of the page size for your output.

Fit view to page

The Fit view to page option is used to size the model to fit on a single sheet of paper. This option must be disabled in to specify a different size or scale.
Width/Height

The width and height fields are used to enter a custom page size for your output. If you define a size larger than the page size you selected in Page Setup,
SketchUp will print your drawing on multiple pages (tiles) that you can affix together manually after printing.

SketchUp will calculate the number of pages required to print your drawing at that size automatically, and display it below.

Print scale

The Scale section of the of the Page Setup dialog box is used to override any SketchUp-specific scale settings.

In Drawing/In Model

The In Drawing/In Model fields are used to scale your model for printing. The first measurement, labeled In the Model, is the measurement of the exported
geometry. The second measurement, labeled In SketchUp, is the actual measurement of the object in real scale. For example, for a scale of 1/4" = 1, simply

enter 1 inch In Drawing equals 4 feet In Model.

Note: It is not possible to print a perspective image to scale. Ensure perspective is disabled and you are using one of the Standard Views in the Camera >
Standard submenu, to enable the scale option.

Note: Even though paraline projection is used to get an output that is to scale, not all angles will be measurable to a scale. This issue is the result of SketchUp
using foreshortening, or a technique of shortening lines to create a 3D effect on a 2D medium such as paper.

Pages required (section tiling)

If the current scale is larger than the paper size of your printer or plotter, the entire model can be printed by printing on several pieces of paper. These pieces of
paper can then be taped together to create the final scaled model. For example, tiling lets you print proofs of a large model, such as a B size (11" x 17"), on a
printer that uses a smaller paper size, such as an A size (8.5" x 11"). Tiling also lets you print banners that are made up of multiple pages.

Tiling is available when you use the Scale fields to scale a model to be larger than the current paper size available in your printer.

You can display a preview of tile pages by clicking on the Preview button at the bottom of the Print dialog box.

The Print Setup dialog box (Microsoft Windows)

The Print Setup dialog box is used to select and configure your printer and final output orientation. Select File > Print Setup to invoke the Print Setup dialog box.
Printer

The Printer section of the Print Setup dialog box is used to select a specific printer and printer settings. Select the printer to use from the 'Name' drop-down list.
Click on the 'Properties' button to configure the printer for printing (the properties dialog box is different for each printer-type).

Paper

The Paper section of the Print Setup dialog box is used to select the paper size used for your output.

Size

The Size drop-down list contains different paper sizes that are supported by your printer. Select the paper size that you want to use from this list.
Location

The Location drop-down list contains different trays in your printer. Select the tray that contains the paper you want to use.

Orientation

The Orientation section is used to select the orientation (landscape or portrait) for your output.
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Common tasks

Using the Credits feature

Overview

In SketchUp, you can use the Credits feature to associate a model with yourself, and you can see who else has contributed to a model. Please note that you will
need a Google Account to use the Credits feature. If you claimed the credit for a model and upload the model to the 3D Warehouse, anyone who downloads the
model will see your Google Account Nickname in the Contributors section along with the name of the model.

Claiming Credit

. Click the Google Account button in the lower left-hand corner, denoted by the letter G.

. If you aren't signed in yet, you'll be prompted to sign in to your Google Account.

. Once you're signed in, you'll see a 'SketchUp is requesting permission' dialog. Click Allow access to continue.
. Click Window > Model info > Credits. This will open the Credits window.

. Your user name will appear in the 'Model authors' section. Click Claim Credit.
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Note: This feature is not a Digital Rights Management (DRM)-type feature, just a simple attribution. We do not enforce any usage restrictions based on credits.

Ensuring edge alignment to axes

There are two methods to ensure your edges align to axes: change the cursor to the axes colors or change your edges to the axes colors.
Changing cursor to axes colors

One method for ensuring your edges are aligned to axes is to change the cursor so that it displays cross hairs that are the colors of the axes while drawing. To
change the cursor to axes colors:

1. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The Preferences dialog box is displayed.
2. Select the In Drawing item on the left-hand side of the Preferences dialog box. The Drawing panel is displayed.

3. Click the 'Display cross hairs' checkbox.

4. Click the OK button to close the Preferences dialog box. The cursor will display cross hairs that are the color of the axes.

Changing edges to axes colors

A second method for ensuring your edges are aligned to axes is to temporarily change the colors of your edges to reflect their alignment to one of the axis. To
change edge colors to reflect axes colors:

. Select Window > Styles. The Styles Browser is displayed.

. Select In Model from the drop-down list of styles libraries. The styles in your model appear.

. Click on the Edit tab. One of the edit panels appears.

. Click on the Edge Settings icon. The Edge Setting panel appears.

. Select By axis from the Color drop-down list. The colors of the edges in your model change to reflect their alignment to the axes.
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Copying geometry

There are two ways to copy geometry in SketchUp:

1. Use the Copy and Paste commands to copy geometry.
2. Use the Move tool if you want to create one or more copies of a piece of geometry at specified distance intervals from the original piece of geometry.

Creating a 2-Point Perspective

Select Camera > Two-Point Perspective to achieve a 2-point perspective view of your model. You will be placed in the Pan tool to pan around your model.

Warning: Orbiting will move a model out of 2-point perspective.

Dividing lines or arcs into equal segments

To divide a line or arc into equal segments:

1. Context-click on the entity to invoke the entity's context menu

2. Select Divide. A string of red dots appears along the line segment.

3. Drag the cursor back and forth along the length of the entity to increase or decrease the number of divisions. A tooltip displays the number and length of
segments that will be created if you pause briefly on the entity.

Note: The number of divisions is also displayed in the Measurements toolbar. Type in the number of desired segments followed by pressing the Enter
(Microsoft Windows) or Return (Mac OS X) key to manually divide the entity.

4. Click again to divide the entity. The entity will be broken into separate segments.
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This menu item is available for the 3D Polyline, Circle, Line, and Polygon entities.

Drawing accurate angled lines

Drawing accurate angled lines is a two-step process. To draw accurate angled lines, please follow these steps:

1. Use the Protractor tool to create a Guide Line entity at some angle.
2. Use the Line tool to trace over the Guide Line entity and create the line.

Drawing engraved text

To draw text that appears engraved:

. Select the 3D text.
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. Draw a large rectangular surface.
. Select Tools > 3D Text. The Place 3D Text dialog box appears.
. Enter the desired text in the text field.

. Check the 'Extruded' check box.

Type a negative value in the 'Extruded’ field.
. Click the Place button. A cursor appears with the text.
. Click on the rectangular surface. The text is placed on the surface as a group.

Flipping or mirroring geometry

A flip operation refers to making a mirror of your geometry. A mirror is creating a mirrored copy of your geometry.

Flipping geometry

Flipping is useful when you want to create an exact mirror of your geometry. You can flip geometry by:

1. Selecting the geometry to be flipped.

. Context-clicking on the geometry. The context menu is displayed.

2
3. Selecting the Flip Along context menu item.
4

. Choosing the direction or axis for the flip. The following image shows the geometry before the flip operation.

The following image shows the geometry after the flip operation.
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. Context-click on the 3D text. The context menu for the group is displayed.
. Select the Explode menu item. The 3D text explodes into its individual geometry.
. Select the face of each letter and press the Delete key on your keyboard. The face is removed and the letter appears to be engraved.
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Note: You can also use the Scale tool to flip or mirror geometry.

Mirroring Geometry

The process for mirroring geometry is essentially the same process as for flipping, but you are creating an additional copy. Mirroring allows you to create one
half of a model and then duplicate and mirror that half to create the rest of the model. For example, you could create the left-side of a model of a car and then
duplicate and mirror that side to create the right-side of the car. The process to mirror geometry follows:

1. Select the geometry to be mirrored. The following image shows the left-side of a car.

. Make a copy of the geometry

. Paste the copy.

. Context-click on the geometry. The context menu is displayed.

. Select the Flip Along context menu item.

. Choose the direction or axis for the flip. The following image shows the left-side of the car and copy of the left-side of the car that has been flipped.
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Note: You can also use the Scale tool to flip or mirror geometry.

Installing Ruby plugins

Place Ruby plugins into the Plugins folder to execute them when you restart SketchUp. The Plugins folder on Microsoft Windows is at:
C:\Program Files\Google\Google SketchUp 8\Plugins

The Plugins folder on Mac OS X is at:

/Library/Application Support/Google SketchUp 8/SketchUp/Plugins

Remapping mouse buttons

You can only control the directory you roll the scroll wheel to zoom in and out in SketchUp. By default, you roll the scroll wheel up to zoom in and down to zoom
out. To change scroll wheel mapping:
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1. Select Window > Preferences. The Preferences dialog box is displayed.

2. Select the Compatibility item in the left-hand side of the Preferences dialog box. The Compatibility panel is displayed.
3. Check the 'Invert' checkbox.

Warning: Some mouse drivers or configuration utilities make it possible to map mouse buttons to various functions or keystroke assignments. You should make

these kinds of changes carefully because SketchUp makes extensive use of the mouse buttons in combination with various modifier keys (Ctrl, Alt, Shift), and you
could easily lose functionality by remapping the mouse buttons.

Creating an image igloo

Building Maker buildings imported into SketchUp as .SKP files containing one scene for each image used to create the the building. SketchUp's Image Igloo

feature allows you to easily navigate between these images and use them in conjunction with Match Photo to further detail your model. To create and navigate an
image igloo:

1. Open your Building Maker model in SketchUp. The model opens containing a scene for each of the images used to create the model.
2. Select Camera > Image Igloo. Each of the images associated with the model appears hovering over the model, forming an igloo over the model. Each
photo appears at the angle from which the original photo was taken. Each photo also contains the name of its associated scene.

3. Use the right and left arrow keys to navigate between images (and scenes). Navigate to the image you want to use to detail your model. The currently
selected image is has a magenta colored border. The image with a blue colored border is the scene that was active when you chose image igloo menu item.

Note: Alternatively, hold down the middle mouse button to rotate the image igloo. The currently selected image is shown in magenta.

4. Press the Enter key. SketchUp enters the sketching mode of Match Photo using the currently selected image.
5. Add detail to the model. Refer to Creating a 3D model to match a photo for further information on using the Match Photo sketching mode.

Using Street View images to photo texture buildings

SketchUp allows you to capture images from Street View to texture the buildings you are creating for Google Earth. This feature is specifically useful when Street
View images are available for the exterior walls of a building in Google Maps. To capture a Street View image and apply it to a building's exterior wall:

1. Locate a building in Google Maps (maps.google.com) that you want to model. This building must have Street View images for one or more exterior wall.
The following image contains Street View image of two restaurants in Boulder, Colorado:
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Note: Visit http://maps.google.com/help/maps/streetview/ for further information about Street View.

2. Model the building in SketchUp. Refer to Placing a SketchUp model in Google Earth for information on how to create a model for Google Earth. The
following image contains a basic model of this two restaurants:

3. Click on one of the building's exterior walls (choose a wall that has a corresponding image in Street View).

4. Click the Add Photo Textures button (¥ ). The Photo Textures window appears.

5. Navigate (in the Photo Texture window) so you are facing the image of the exterior wall that you have selected in SketchUp. The following image shows the
Photo Texture window with the image of front of the two restaurants:
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. Click the Select Region button. The image in the Street View window fades. A smaller area, the same shape as the wall chosen in Sketchup, appears. This
shape represents the portion of the Street View image that you will use to photo texture your building. This shape has four pins. You must position these
pins around the portion of the Street View photo that you want to use to texture the wall chosen in SketchUp. The following image shows the faded Street
View image with a rectangular shape representing the area of the image that will be used to texture your building in SketchUp:

. Click and hold the left mouse button on one of the pins, such as the upper-left pin.
. Move the mouse cursor (pin) to a position in the Street View image that represents a corner of your wall, such as the upper-left corner.

Release the left mouse button. The following image shows the upper-left pin placed at the upper-left corner of the Street View image of the two
restaurants:

O o N
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10. Repeat steps 7-9 for the remaining three pins. The following image shows all four pins placed on all four corners of the Street View image of the two
restaurants. The area that is within the four pins represents the portion of the image that will be applied to selected face in SketchUp.

N

11. Click the Grab button to grab the selected portion of the Street View image and apply it as a texture to your building in SketchUp. The following image
shows your building in SketchUp with the Street View image:

12. (optional) Further adjust your image using the Texture Position tool. Refer to the Texture Position tool for further information.
13. Repeat Steps 3-12 for other sides of the building where you have Street View images. The following image shows a finished building with two Street View
images applied to exterior walls:
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Installing Ruby Plugins

SketchUp 8 and .rbz files
The latest version of SketchUp 8 allows you to install zipped Ruby files (.rbz) from within the product. If your plugin has a standard (.zip) extension, then you can
just change the extension name from .zip to .rbz.

To install a SketchUp 8 Ruby plugin script with the .rbz format:

1. We recommend logging into your computer as an admin before installing any Ruby scripts. This will make the installation go more smoothly and ensure
that files get installed in the proper places.

. Select Window > Preferences (Microsoft Windows) or SketchUp > Preferences (Mac OS X). The Preferences dialog box is displayed.

. Click on Extensions. The Extensions panel is displayed.

. Click on the Install Extension button. The Open dialog box is displayed.

. Locate the Ruby zip file to install (.rbz).

. Click on the Open button. The Ruby plugin appears in the list of extensions.

OV hWN

Older versions of SketchUp and .rb files
If you're using an older version of SketchUp or you have a file with the .rb extension, you can install the plugin by placing the Ruby script file into the appropriate
folder, and then restarting SketchUp.
Windows - the default location is:
e SketchUp and SketchUp Pro: C:\Program Files\Google\Google SketchUp #\Plugins.
Mac OS X - the default location is:
[YOUR USER NAME]/Library/Application Support/Google SketchUp #/SketchUp/plugins

Tip: you may need to create your plugins folder in the SketchUp folder. To do so click File > New folder in your Finder window. If you prefer, you can also save
your plugins to the same location under your Macintosh HD (Macintosh HD/Library/Application Support/Google SketchUp #/SketchUp/plugins).
However, plugins in this location may be removed in an uninstall.

Once you have restarted SketchUp, you should see that the script's commands have been added to the appropriate menus. You can also run the script using the
Ruby Console (open the "Windows" menu, and then click Ruby Console).

Adding a background to your model

SketchUp allows you add image files to your model and position those images such that they act as a background. For example, you can have a single image
placed vertically behind a house so that you can study what will be seen from certain angles within the house.
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Drawing Specific shapes

Drawing a bowl

Advanced tasks, such as drawing a bowl or sphere, require experience with several SketchUp tools and features. You should be competent with the following
tools and features before attempting to draw a bowl:

The Circle tool

The Follow-Me tool
The Offset tool
The Line tool

The Eraser tool
Inference

One common way to draw a bowl is:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the side of the bowl. The size of this circle does not matter.

2. Move the cursor to the origin. The cursor should snap to the origin.
3. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.

¥

4. Press and hold the Shift key to lock the Circle tool in the green or red inference direction.
5. Draw a circle perpendicular to the circle on the ground plane whose radius represents the radius of the outside of your bowl.

6. Use the Offset tool to create an offset of this second circle. The offset distance represents the bowl thickness.
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7. Use the Line tool to divide the second circle in half.

8. Use the Eraser tool to erase the top half of the second circle. You are creating the profile of the bowl.

9. Use the Eraser too to erase the face that represents the inside of the bowl. The profile of the bowl is complete.
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10. Select the edge of the circle on the ground plane. This is your path.
11. Select the Follow-Me tool.
12. Click on the profile of the bowl. A bowl is created.

13. Remove the circle on the ground plane.

Drawing a cone

Advanced tasks, such as drawing a cone or sphere, require experience with several SketchUp tools and features. You should be competent with the following
tools and features before attempting to draw a cone:

The Circle tool

The Move tool

The Push/Pull tool
The Follow-Me tool
The Line tool
Inference

Drawing a cone by resizing a cylinder face
One common way to draw a cone is:

1. Draw a circle on the ground plane at the origin. This circle will represent the base of the cone.

2. Use the Push/Pull tool to create a cylinder at the height of your cone.
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3. Select the Move tool.

4. Place the cursor at the edge of the top of the cylinder.

5. Move the cursor around the edge until you find one of the cardinal points (a point that is aligned with the red or green axis). The edge of the circle will not
highlight when the cursor is on a cardinal point. Cardinal points act as resize handles.

6. Click the mouse button when the cursor is over a cardinal point on the edge of the top of the cylinder.

7. Move the cursor toward the center of the cylinder. A cone begins to take shape.

Drawing a cone using the Follow-Me tool
One common way to draw a cone is:

1. Draw a circle on the ground plane at the origin. This circle will represent the base of the cone.

. Use the Orbit tool to orbit so that your view is looking over the top of the circle (not directly down on the circle).

. Use the Line tool to draw a line up the blue axis from middle of the circle to the height of your cone.

. Use the Line tool to draw a line from the top of the previous line to the edge of the circle. This line will form the second line of a triangle.
. Use the Line tool to join the last line to the bottom of the first line, creating a solid triangular face.

v WN

6. Select the edge of the circle on the ground plane. This is your path.
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7. Select the Follow-Me tool.
8. Click on the solid triangular face. A cone is created.

Note: The bottom face of the cone is eliminated when you use the Follow Me tool to create a cone. Draw a line from endpoint to endpoint of any segment
along the circumference of the cone's base to recreate the bottom face.

Drawing an ellipse

There are multiple ways to draw things in SketchUp. One common way to draw an ellipse is:

. Draw a circle with the Circle tool.

. Select the Scale tool. The cursor will change to a box within another box.

. Click on the circle. Scaling grips will appear around the circle.

. Click and hold one of the grips in the middle of one of the bounding box edges (not one of the corner grips).
. Move the cursor away from the center of the circle. The circle will form an ellipse.

U WN

Drawing an inner tube

Advanced tasks, such as drawing a cone or inner tube, require experience with several SketchUp tools and features. You should be competent with the following
tools and features before attempting to draw an inner tube:

The Circle tool

The Select tool
The Follow-Me tool
Inference

One common way to draw a inner tube is:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the sphere. The size of this circle does not matter.

3. Select the Circle tool.
4. Move the cursor to the origin. The cursor should snap to the origin.
5. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.
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. Hold the Shift key to lock the Circle tool to lock the inference direction.
. While holding the Shift key, draw a circle, whose diameter will be the diameter of your inner tube, perpendicular to the first circle. This circle is the profile

of the inner tube.

N O

e

9. Select the Follow-Me tool.
10. Click on the profile of the inner tube. An inner tube is created.

Drawing a pyramid (creating a pyramidal hipped roof)

Advanced tasks, such as drawing a cone or pyramid, require experience with several SketchUp tools and features. You should be competent with the following
tools and features before attempting to draw a pyramid:

The Rectangle tool
The Move tool
The Line tool
Inference

One common way to draw a pyramid is:

1. Use the Rectangle tool to draw a square. SketchUp's inference engine displays a dashed diagonal line and the word 'square' when your rectangle is a
square. This square will be the base of your pyramid.

2. Use the Line tool to draw two diagonal lines across the square (from corner to the opposite corner).

278



3. Select the Move tool.
4. Hover the cursor over the mid point of the diagonal line. The tooltip should say 'endpoint.’

5. Click the mouse button.
6. Move the cursor up in the blue direction to the desired height.

Drawing a sphere

Advanced tasks, such as drawing a cone or sphere, require experience with several SketchUp tools and features. You should be competent with the following
tools and features before attempting to draw a sphere:

The Circle tool

The Select tool

The Follow-Me tool
The Eraser tool
Inference

One way to draw a sphere is to use the following steps:

1. Draw a circle on the ground plane at the origin. This circle will be used as a path used to draw the sphere. The size of this circle does not matter.

2. Move the cursor to the origin. The cursor should snap to the origin.
3. Move the cursor up the blue axis (above the circle on the ground plane). The cursor should turn green or red.
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4. Press and hold the Shift key to lock the Circle tool in the green or red inference direction.
5. Draw a circle, smaller than the first, perpendicular to the circle on the ground plane (this represents the profile of the sphere).

6. Select the edge of the circle on the ground plane. This is your path.
7. Select the Follow-Me tool.
8. Click on the profile of the sphere. A sphere is created.

9. Remove the circle on the ground plane.
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Technical Reference

Codec Lists

SketchUp's animation export feature uses codecs (COmpressor/DECompressor) to create the appropriately sized video depending on your needs. Codecs differ in
their intended use, compression method, and handling pictures and sound. If you plan to edit your video, you might want to choose a codec that provides higher
quality at the expense of file size and compatibility. Conversely, if you plan to email your video or play it off a CD, you might want to select a codec that provides
lower data rates at the expense of quality. Some codecs are also designed specifically for a certain device, such as a digital video camera.

You can also choose to create uncompressed video by not using a codec. However, a large uncompressed animation file might require a fast system and very
large amounts of disk space.

Microsoft Windows codecs
Following is an explanation of codecs that are included with SketchUp.
Cinepak Codec by Radius

This is the default codec for SketchUp. Although not as advanced as modern codecs, videos compressed using Cinepack will work reliably on any platform, play
smoothly from CD-ROM, and will provide good file size compression. Cinepak is asymmetrical and lossy.

Intel Indeo Video R3.2

This codec was designed for video playback from CD-ROM discs. It is comparable in quality to the Cinepak codec, but Cinepack is preferable due to wider
support.

Microsoft Video 1
This codec originally shipped with Video for Windows (Windows 3.1) and is low quality and rarely used today.
Intel Indeo Video 4.5

This is a lossy codec that provides good compatibility, speed, and flexibility with average image quality. Advanced features include a quick compression option,
keyframe control, transparency, and the ability to adapt to the available bandwidth. (Access to some of these requires software available separately from Intel.)

Intel Indeo Video 5.10

This is a lossy codec that provides good compatibility, speed, and flexibility with average image quality. Advanced features include a quick compression option,
keyframe control, transparency, and the ability to adapt to the available bandwidth. (Access to some of these requires software available separately from Intel.)

Full Frames Uncompressed

This option allows you to export your animation without any compression.
Mac OS X codecs

Animation

This codec works well for images that use large areas of solid colors, and is great for SketchUp images that have no textures or background gradients. It is lossy,
but a compression setting of 100% is lossless.

Apple H.263

H.263 is a QuickTime codec designed for video conferencing at low data rates and may not be suitable for general-purpose video.
Apple Pixlet Video

Apple VC H.263

This codec is a modified version of H.263 for iChat

Cinepak

This is the default codec for SketchUp. Although not as advanced as modern codecs, videos compressed using Cinepack will work reliably on any platform, play
smoothly from CD-ROM, and will provide decent file size compression. Cinepak is asymmetrical and lossy.

Component video

This codec provides relatively little compression, which means files can get large. It's useful for archiving, or temporarily storing video.
DV - PAL

Used by PAL digital video hardware such as camcorders.

Graphics

This provides a high quality, 8-bit color image that can work well with SketchUp output. The compression ratio is low, however, which means that it might not be
well suited to playback from CD-ROM or the web.

H.261

H.263 is a codec designed for video conferencing at low data rates and may not be suitable for general-purpose video. The H.263 requires half the bandwidth to
achieve the same video quality as in the H.261.

JPEG 2000

Motion JPEG A and Motion JPEG B

These codecs are designed for many video-capture cards, which provide hardware acceleration for JPEG compression.
MPEG-4 Video

MPEG-4 is the new worldwide standard for interactive multimedia creation, delivery, and playback for the Internet. The MPEG-4 video codec is designed to
provide the highest quality across a wide array of data rates over the Internet.

None
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This option allows you to export your animation without any compression.
Photo - JPEG

The Photo JPEG codec is built into QuickTime and implements the Joint Photographic Experts Group ISO version 9R9 algorithm for image compression. This codec
is generally used for storage of still images, but can also be used for editing and storage of high-quality video files.

Planar RGB

This is similar to the Animation codec in that it is effective for images that use large areas of solid colors.

PNG

The PNG codec implements the lossless PNG compression - decompression algorithm used by many Web browsers.
Sorenson Video

This is a very good codec for general video, and is great for playback from CD-ROM the web. It is similar to Cinepak, but provides better picture quality and
smaller file sizes at the cost of lightly longer compression times. It also supports dynamic playback that automatically adjusts to available bandwidth and CPU
resources.

Sorenson Video 3

Makes improvements over Sorenson Video in the form of higher quality video and better data compression.
TGA

The TGA codec implements the lossless TGA compression - decompression algorithm.

TIFF

The TIFF codec implements the lossless PNG compression - decompression algorithm.

Video

This provides high-quality playback from hard disk and moderate quality playback from CD-ROM. It supports both spatial and temporal compression of 16-bit
video. Data can be re-compressed or recompiled later for higher compression ratios with minimal or no quality degradation.

Raster File Formats

Raster images are made up of individual square colored pixels that, when combined, form some image. SketchUp supports several different raster image formats,
each of which has its own particular advantages and should be selected depending on the task you want to perform.

JPEG (Joint Photographic Experts Group)

JPEG image files enjoy wide support across many applications, computer platforms, and digital cameras. The most prominent feature of JPEG is its compression
scheme, which can reduce file size to a fraction of other formats. This compression scheme makes the JPEG format particularly useful for sending images, such as
digital photographs, using email or for viewing on the world wide web.

Tip: Consider using JPEG if your image contains lots of textured areas or fine detail.

JPEG compression works so well because it analyzes an image, divides it into blocks, and then discards the information which the human eye does not readily
perceive. However, this high-level of compression yields a lower image quality and therefore, sometimes resulting in blocky patterns of color referred to as
artifacts. JPEG images are referred to as lossy because data is actually lost during the compression process and an uncompressed JPEG file will never be identical
to the original file.

The previous image shows the artifacts resulting from JPEG compression (in the right-most portion of the image).
Fortunately, you can adjust the amount of JPEG compression to suit your needs using the File > Export > 2D Graphic Options > Image Quality slider bar.

Tip: Resaving a JPEG image multiple times can result in compounded artifacts. Work with original raster images in a non-lossy format, such as PNG, before saving
to JPEG for final output.

PNG (Portable Network Graphics)

The PNG format was developed for transferring images efficiently over the world wide web without data loss. Like JPEG, PNG does use compression, but it is a
non-lossy variety that is free from artifacts.

Tip: Consider using PNG for models that have large areas of solid, uniform, colors (such as non-textured SketchUp models).

TIFF (Tagged Image File Format)

The TIFF file format is often used to exchanged files between applications and computer platforms (Mac and Personal Computers). There are a large number of
variations to the TIFF format available, and therefore TIFF might not be as universally accessible as other formats such as PNG and JPEG. SketchUp supports as
wide a range of TIFF formats as possible, and you should test compatibility with other applications before exporting to TIFF file. 1-bit raster files, or TIFF files
with gif encoding, are not compatible with SketchUp.

Also, while formats such as PNG and JPEG are viewable by any web browser and can therefore be sent to virtually any other person with good chance of success,
TIFF files may require additional software to be viewed on some systems. TIFF is primarily used for high-resolution printing from desktop publishing
applications.
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Note: SketchUp does not support TIFF files at 1 bit per pixel. Images compressed using RLE will expand to uncompressed sizes once imported into SketchUp.

BMP (Bitmap)

The BMP file format was created for Microsoft Windows operating systems primarily as the format used for the Microsoft Windows clipboard and for viewing
(especially as wallpaper). BMP does not use compression. Therefore, BMP can be useful for creating temporary files to be further modified in other applications.
However, BMP tends to create very large files that are not suitable for archive, web, and email use.

Epix

Epix is the native format of Piranesi which is an architectural painting application designed to work with images generated from 3D models. See Piranesi Epix
Export for more information.

BugSplat (Microsoft Windows)

BugSplat (www.bugsplatsoftware.com) is a 3rd party software application that is integrated in SketchUp for Microsoft Windows 2000, XP, and Vista to help
improve the quality of the product. BugSplat helps us troubleshoot unrecoverable SketchUp errors or crashes. BugSplat provides a mechanism for Microsoft
Windows users to send information about all crashes to SketchUp for troubleshooting.

How Does it Work?

In the rare event that SketchUp crashes you will see a dialog, similar to Microsoft Window's crash report dialog. This dialog will give you the option to send us the
information regarding the crash. Here is what is collected if you decide to send us the information:

e Your version of the SketchUp executable.

e Your language setting, such as English.

e A'stack trace' of the bug allowing us to see the exact line of code where SketchUp crashed.
e A list of SketchUp code dependencies.

e (optional) Your name and email address.

e (optional) A description of what you were doing before the crash.

Note: If you happen to look at the BugSplat Software website, you will see a security statement that is aimed at assuring clients of BugSplat - in this case
SketchUp - that the information on our crashes (e.g., how many we have, and so on) will be protected. The above information is all that we are collecting.

Edge Splitting Behavior (SketchUp 6 versus SketchUp 7)

SketchUp 7 edge splitting behavior increases productivity over the overlapping edge behavior in SketchUp 6.

Overlapping Lines in SketchUp 6

Edges or lines that overlapped in SketchUp 6 did not split at the intersection point, often requiring you to retrace lines or use the Intersect with Model feature to
manually split them. For example, draw a simple 2D window by creating a square and then drawing two single lines. Draw one line from the middle of the top

edge to the middle of the bottom edge. Draw a second line from the middle of the left edge to the middle of the right edge. This shape, in SketchUp 6, yields ten
edges and two faces:
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If you want four faces, one for each pane of glass, you must retrace the four segments that make up lines 9 and 10 into four individual edges.

Q

Edge Splitting in SketchUp 7

Overlapping edges are automatically split in SketchUp 7. Therefore, drawing a 2D window using the process explained previously automatically yields 12 lines
and four faces:
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@ @ Additional Examples

Following are some additional examples of overlapping line treatment between SketchUp 6 and SketchUp 7.

Overlapping Circles in SketchUp 6

Overlapping circle shapes in SketchUp 6 results in two faces:
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Overlapping Circles in SketchUp 7

Overlapping circle shapes in SketchUp 7 results in three faces (edges split where they intersect):

Overlapping Lines Forming a Star in SketchUp 6

Overlapping lines forming a star in SketchUp 6 results in no faces:

X

Overlapping Lines Forming a Star in SketchUp 7

Overlapping lines forming a star in SketchUp 7 results in six faces:

o

2D vector file formats

AN
' :

2D vector file formats have advantages over bitmap image export in that they produce drawings that are resolution independent and can be easily imported and
modified in many other programs. These file formats are useful for creating a set of 2D construction documents, plotting a perspective in a large format, or for
import into vector illustration software for further refinement.

EPS

Encapsulated PostScript format is based on PostScript, a graphics description language developed by Adobe as a standard way for graphics programs and print
devices to communicate. EPS is widely used in the graphic design and publishing industries.

PDF

Adobe—r« Portable Document Format (PDF) is the open standard for worldwide electronic document distribution. PDF preserves all the fonts, formatting, graphics,
and color of the source document, regardless of the application and platform used to create the document. Also, PDF files are compact and can be shared,
viewed, navigated, and printed exactly as intended by anyone with free Adobe Acrobat—« Reader—r« software.

Warning: Some graphic features of SketchUp, including textures, shadows, smooth shading, backgrounds, and transparency, cannot be exported to PDF and EPS.

DWG (AutoCAD Drawing File)
DWG was created by AutoDesk as the file format for their AutoCAD program. There are many different versions of DWG, including DWG r12, r2000, and r2004.
DXF (Data Exchange File)

DXF is a 2D graphics file format supported by most all Macintosh and PC-based CAD applications. DXF was created by AutoDesk as the method for exchanging
CAD data between their AutoCAD application and other CAD applications.

The Anatomy of an Epix File

The native file format of Piranesi is referred to as an Epix (Extended Pixel) file. In addition to storing the actual rendered image, Epix embed additional
information from the original 3D model. This information allows Piranesi's paint tools to intelligently render the image. There are three 'channels' of an Epix file:

RGB
The first, known as the RGB Channel, contains the color of each pixel. This is the same data typically stored in other raster image formats. (In fact, Epix files are
readable in most image editors as TIFF files.)

Depth
The second, known as the Depth Channel, stores the distance of each pixel from the eye point. This information helps Piranesi understand the surface topology
under the image and allows it to apply textures, scale objects, lock orientation, and many other capabilities dependent on the 3D surfaces of your model.

Material
The third, a Material Channel stores the material for each pixel. This lets you paint one part of your rendering loosely without having to worry about painting
another by mistake.

In General, Piranesi expects a flat shaded, non-textured Epix file. Some of the rendering modes in SketchUp, such as Wireframe and Hidden Line, don't really
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work well for Piranesi and are disabled during export in favor of shaded output.

Other features of SketchUp, such as edges and textures, are also different from that which Piranesi expects, yet may be desirable in many cases. While adding
support for Epix files in SketchUp, we have tried to adhere to Piranesi's expectations whenever possible while retaining enough flexibility to accommodate the
varying needs of different artists and renderers.

SketchUp Ruby API and Console

SketchUp contains a Ruby application programming interface (API) for users who are familiar with (or want to learn) Ruby scripting and want to extend the
functionality of SketchUp. This interface allows users to create tools, menu items, and other plugins, such as automated component generators, to be included in
the menus within SketchUp. In addition to the API, SketchUp also includes a Ruby console which is an environment where you can experiment with Ruby
commands or methods.

For additional information on the Ruby programming language, visit www.rubycentral.com.

To learn more about the SketchUp Ruby API, visit our Ruby API Code Site. This site contains an FAQ, tutorials, documentation, and the SketchUp Developers
Forum.

Currently, SketchUp does not offer technical support for the Ruby Application Programmers Interface (API) or for any Ruby plugins created by third parties. We
encourage posting Ruby API questions to our SketchUp Developers Forum. General Ruby information may be obtained at http://www.ruby-lang.org.

We reserve the right to change this policy at any time.

SketchUp and OpenGL

3D applications, such as SketchUp, require abundant system resources. Aside from having a fast CPU and large amounts of RAM, your video card and video card
drivers must be 100% OpenGL compliant.

What is OpenGL?

OpenGL is the industry-standard, used in numerous software applications and games, to draw 3D geometry. Most Microsoft Windows and Apple OS X operating
systems come with a software-based OpenGL driver. However, these drivers rely heavily on the CPU to perform the rendering calculations of OpenGL (a task that
is not done efficiently by most CPUs).

Many video card manufacturers have also built cards that support the OpenGL standard. These cards perform the rendering calculations using a specialized chip
called the Graphics Processing Unit or GPU (instead of relying on the CPU). These chips significantly enhance OpenGL performance upward of 3000 percent. This
performance enhancement is known as Hardware Acceleration.

Hardware Acceleration
SketchUp will take advantage of hardware acceleration if your computer has a 100% OpenGL compatible video card.

Tip: If the Use Hardware Acceleration option is not available in SketchUp, verify that the control panel settings for your video card's device driver has hardware
acceleration enabled (Microsoft Windows).

Unfortunately, only some 3D drivers in the consumer video card market are 100% OpenGL compatible and can use this feature (though many cards claim to be
100% OpenGL compatible). Most 3d drivers are designed for games, and are often not tested using other 3D programs. Consequently, incompatibility problems
can occur requiring a fix from the video card manufacturer. Disable this option if you are having problems with the 3D rendering of your models or if your video
card is not 100% OpenGL compatible and does not support hardware acceleration.

Note: Hardware Acceleration might only be available on your system for certain resolutions and color depths. Check the system settings for your video card to
see if it supports hardware acceleration (using the Control Panel on Microsoft Windows or System Preferences on Macintosh OS X).

Note: We strongly recommend that you set your display colors to a 32-bit color depth (using Control panel > Display Properties) to ensure that your SketchUp
model will render accurately when using hardware acceleration (Microsoft Windows).

We cannot control the quality of the OpenGL driver on your computer system. Video card device drivers are proprietary and are maintained solely by the
manufacturer of the video card in your system. Therefore, we cannot guarantee that SketchUp will work with hardware acceleration on your system.

Compatibility Issues

OpenGL incompatibility is a significant system configuration issue leading to problems with SketchUp. Difficulties with Sketchup tools, performance, and
rendering (such as mysterious graphics appearing on your screen) are usually the result of a video card not fully supporting OpenGL (despite claims by the
manufacturer), an out-of-date video card driver, or incompatibility with 32-bit color depth. A temporary solution is to disable hardware acceleration in SketchUp
while troubleshooting the problem.

Consult the Video Card Compatibility section of the Readme file (in the SketchUp installation directory) for additional details regarding compatibility issues for
specific video cards.

Loading an offline crash report

If a crash occurs when you are not connected to the Internet, BugSplat displays a dialog box indicating that a zip file has been created on your local hard drive.
This dialog box will also indicate the name and location of the zip file (normally AtLastCrashMMDDYY_HHMMSS.zip in your Windows temporary directory).Go to
http://www.bugsplatsoftware.com/post/post_form.php and follow the instructions on the Web page to send this file to BugSplat Software when you reconnect to
the Internet. Or email the zip file to SketchUp directly by contacting technical support at http://sketchup.google.com/support/bin/request.py.

Tech Glossary

A
Angular Rotation Value - The value in the Measurements toolbar that is displayed when measuring an angle with the Protractor tool.
Autofold - The process of skewing, distorting, or folding geometry by selecting a specific point on an edge or face and moving the points. See also Sticky.

Axonometric - Meaning 'measurable from the axes.' An axonometric projection is a view of a model in which lines appear parallel in both 3 dimensional and 2
dimensional space, and lines have a length that is to some scale, (for example 1" in SketchUp = 1" in the real world).

B
C

CAD - See Computer Assisted Design
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Camera - A software implementation of the user's point of view. See also 'Point of View.'

Camera angle - See 'Point of View.'

Camera tool - A software tool used to alter the user's point of view of a SketchUp model.

Chord length - The distance between the starting point and the ending point of an Arc entity.

Component entity - An entity that contains other entities. Components are models that are saved as SketchUp files for reuse in other SketchUp files.

Components browser - The Components browser is used to instance Component entities from component definitions, including those components that you
create and a variety of pre-built components that you can use in your models.

Component definition - The blueprint that defines the appearance and behavior of all component instances. Component definitions are created and stored in the
Components browser either as part of a component collection or when you create a component.

Component instance - An instance of a component definition, such as an a single instance of an office chair component. You can have multiple component
instances from the same component definition.

Component collection - A series of related component definitions, such as a component collection of doors or windows.

Computer Aided Design - Software used for precision design. CAD is traditionally rigid and is often used for creating construction documents from which you
would create the actual item you are designing.

Guide tools - tools used to create construction geometry and prepare physical documentation.

Context - An isolated realm that separates geometry within from anything outside. When you start a SketchUp model you are working within the model context.
When you make a group or component you are essentially creating other contexts inside of the model context. When you edit groups or components you are in
the group or component context. Certain commands or operations, such as the Unhide All command, scaling using the Measure tool, and placing active Section
Planes, are limited to a particular context. Additionally, when you create and select other entities, you are essentially in the entity's context.

Context menu - A menu of menu items or commands available in a particular context, such as when a line or component is selected.

Cutting behavior - The ability of component entities to cut holes in faces. The component's cutting behavior is established when the component is initially
created.

Cutting plane - A plane defining the exact location where the component will cut into a face.

Coplanar - Refers to entities that exist in the same plane.

Curved face set - A series of faces joined to make up a curved surface, such as a tube or arch.

D

Dialog Stack - dialog boxes arranged such that they form a stack.

Distort - Twisting out of natural shape.

Drawing area - The area within the drawing window where you create your model. See also 'Drawing window.'

Default material - A material assigned to all newly created faces. The default material is different for the front and back of faces.
Drawing tool - A software tool used to create entities and geometry from scratch.

Drawing window - The entire application window for SketchUp. The Drawing Window contains menus, toolbars, the status bar, and the drawing area. See also
'Drawing area.'

E

Edge-based modeling - A form of modeling in which a surface is automatically created for 3 intersecting coplanar edges.

Edge entity - Edges bound faces within geometry. The term edge and line are used interchangeably.

Entity - The smallest graphical building blocks in SketchUp. Entities are used to create geometry which, in turn, is used to create models.
Extrude - The action of thrusting out or growing a form.

Extrusion -A from that has been extruded. See 'Extrude.'

F

Functional terrain - Terrain that has no portion of itself bending back upon itself creating overhangs, underhangs or caves.

Face entity - A planer entity bounded by 3 or more intersecting coplanar edges or lines.

Face shadows - Shadows projected onto horizontal faces by vertical faces based on the sun's angle in the sky.

G

Geometry - The combination of 3 or more entities. Geometry in SketchUp usually refers to an indistinguishable portion of a component or model.

Georeferencing - The process of establishing an image or model's physical location in the real world. A relationship between an image or model and its real world
coordinates.

Ground plane - A flat or level surface representing the ground. In SketchUp, the ground plane is represented by the exact location of the red and green axes.

Group entity - An entity that contains other entities. Groups are commonly used to combine several entities into a single entity for the purposes of performing a
quick operation, such as a copy and paste.

Gluing behavior - The ability of component entities to align to faces in a specific orientation. The component's gluing behavior is established when the
component is initially created.

Ground shadows - Shadows projected onto the ground plane by vertical faces based on the sun's angle in the sky.
H
Healing - The concept of joining two faces by erasing, or 'healing' a line that intersects a face. Creating one face from two.
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Inference - The identification of relationships between entities in the drawing area. These relationships are pointed out to the user by the inferencing engine and
can be used as references for drawing in 3D space.

Inference engine - Functionality built into SketchUp to locate or infer points from other points in your model, such as the center of a circle, the midpoint of a line,
a line that is perpendicular to the ground plane, a point on a face, a point on an edge, and so on. The inference engine notifies you of these points by using both

color indicators and on-screen messages indicating the location of the cursor as you draw an entity. For example, SketchUp displays the string 'From Point' when
the line you are drawing is in plane with another point.

Insertion point - The point where the cursor will grab and insert the component in to a model from the Components browser.

Instance - see 'Component instance.’'

Intersection - The concept of splitting faces and edges to create additional independent faces and edges by intersecting the face or edge with a line.
J

K

L

Layer - Layers are used to control the visibility of geometry within large models. A SketchUp layer is an attribute with a name, such as 'Layer0,' 'Layer9,’ or
'Chairs.' Elements can be assigned different layers.

Layers manager - A dialog box used to apply and manage layers in your model.
M
Manager - A dialog box used to store and manipulate a specific aspect of SketchUp functionality such as scenes, components, or materials.

Material - Software-simulated paints that have both color and texture attributes. For example, a brick material might contain the color of red and a rough
appearance or texture similar to real brick.

Modal dialog box - A dialog box that temporarily prohibits the user's interaction with the application. Modal dialog boxes usually require the user to perform
some action prior to returning to normal application use.

Model - The contents of a SketchUp file. See also 'Component.’

Modification tool - A software tool used to modify existing entities or geometry.

Modeless dialog box - A dialog box that does not prohibit the user's interaction with the application. See also 'Modal dialog box."

Move Point - The point where you click on the entity with the Move tool.

N

(o}

One-Point Perspective - In central perspective or one point perspective there is only one vanishing point (vp), which is located straight in front of the viewer: it is
the vanishing point for the direction of view. This is not determined by our view, but the flat faces and tunnel walls of all objects within view. All lines drawn in

the blue axes are exactly perpendicular to the ground plane and all of the lines drawn in the red and green axes are exactly perpendicular to the blue axes when
viewing a 2 or 3 dimensional drawing viewed in one point perspective.

Origin - The point where the drawing axes intersect or 'originate.'

Organic shape - Geometry or models that have a hand-made or custom appearance.
P

Pan - A camera movement in which the camera turns side to side.

Paraline - See 'Axonometric.'

Perspective - A distortion of the camera angle such that it represents the model as though you were standing at a fixed position and looking at it without moving
(certain items appear closer while other items appear to be far away; entities are not to scale).

Plane - A flat or level surface.

Point of view - The user's view of the model.

Polygon mesh - A surface comprised of polygons, each derived from irregularly spaced points.

POV - see 'Point of view.'

Principal tools - Tools that tend to be used most often in SketchUp.

Pulling - The process of reshaping your model by shrinking a portion of your model back toward its starting point along a single axis.
Pushing - The process of reshaping a your model by expanding a portion away from its starting point and along a single axis.
Q

R

Ruby console - An environment where you can experiment with Ruby commands or methods.

Ruby script - A small program, written in the Ruby programming language, that adds functionality to SketchUp.

Ruby Programming Language - An object oriented scripting language.

S

Sandbox - Surfaces created with the From Scratch and From Contours tools are referred to as sandboxes because like sand in a sandbox, these surfaces can be
sculpted using a special set of tools called sandbox tools. Other terms for sandbox are terrain or Triangulated Irregular Network (TIN).

Scene - Similar to a slide in presentation software, a scene consists of your model and a series of scene-specific settings, such as a specific point of view,
shadow, display setting, and section cut. Scene can be combined to form animations in SketchUp.

Score - A thin slice allowing for folding.
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Section Cut effect - The result of slicing through your model to see inside and optionally modify its inner working.

Section plane - Special entities that are used to control the selection, placement, orientation, direction, of the section slice.

Section slice - The edges created by the intersection of geometry at a section plane.

Segment - A segment is a single line that, when combined, form an arc, circle, or polygon. The more segments an entity has, the smoother it appears.
Skew - To place at an angle.

Solid - any 3d model (component or group) that has a finite closed volume. A SketchUp solid must be watertight, or manifold, meaning it cannot have any leaks,
missing faces, or faces that do not meet at an edge.

Split - The concept of creating two faces from one by dividing the face with a line.

Stickiness - Entities are said to be 'sticky' in that when connected to another entity, moving one entity might move or alter the another, attached, entity. See also
Autofold.

Surface - A series of joined faces.
T

Three-point perspective - In three-point perspective there are three vanishing points (vp), allowing you to construct a form in any orientation. Three-point
perspective is usually used to represent three dimensions in a three-dimensional medium such as SketchUp.

Tilt - A camera movement in which the camera tilts up or down.
TIN - See 'Triangulated Irregular Network.'

Triangulated Irregular Network - A surface comprised of triangles, each derived from irregularly spaced points. This surface is also referred to as a sandbox and
mesh.

Triangulation - The orientation of triangles in a TIN (horizontal or vertical). See also 'Triangulated Irregular Network.'

Two-point perspective - In two-point perspective there are two vanishing points (vp), which are located to the left and right of the viewer. Two-point perspective
is usually used to represent three dimensions on a two-dimensional medium. All lines drawn in the blue axes are exactly perpendicular to the ground plane when
viewing a 3 dimensional drawing viewed in 2 point perspective.

U

Y

Measurements toolbar - The Measurements toolbar displays dimensional information while you draw. You can also enter values into the Measurements toolbar to
manipulate the selected entity.

w
Walkthrough tools - tools used to view your model as through walking around and in your model
X

X-ray mode - A display setting whereby all faces have an applied global transparency. X-ray mode is useful for seeing, and sometimes editing, the inner
workings of your model

Y
z
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